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Welcome

Welcome to Fusion for Mac, Linux and Windows!

Fusion is the world’s most advanced compositing software for visual effects artists,
broadcast and motion graphic designers and 3D animators. With over 30 years of
development, Fusion has been used on over 1000 major Hollywood blockbuster
feature films! Fusion features an easy and powerful node based interface so you
can construct complex effects simply by connecting various types of processing
together. That's super easy and extremely fast! You get a massive range of features
and effects included, so you can create exciting broadcast graphics, television

commercials, dramatic title sequences and even major feature film visual effects!

Fusion Studio customers can also use DaVinci Resolve Studio to get a complete set of
editing, advanced color correction and professional Fairlight audio post production
tools. Clips in the DaVinci Resolve timeline can be shared with Fusion so you can
collaborate on your complex compositions within your VFX team and then render
the result back directly into the DaVinci Resolve timeline. We hope you enjoy reading

this manual and we can’t wait to see the work you produce with Fusion.

The Fusion Engineering Team

Tt

Grant Petty
CEO Blackmagic Design
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Introduction
to Compositing
in Fusion

This introduction is designed explicitly to help users who are new to
Fusion get started learning this exceptionally powerful environment
for creating and editing visual effects and motion graphics

right from within DaVinci Resolve or using the stand-alone

Fusion Studio application.

This documentation covers both the Fusion Page inside DaVinci Resolve and the
stand-alone Fusion Studio application.
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What Is Fusion?

Blackmagic Design Fusion is powerful 2D and 3D visual effects compositing software with over

thirty years of evolution serving the motion picture and broadcast industry, creating effects seen in
countless films and television series. It is available as a stand-alone application as well as a page within
DaVinci Resolve.

In its purest form, Fusion is a collection of image-processing engines called nodes. These nodes
represent effects like blurs and color correctors, as well as images, 3D models, and spline masks.
Similar to effects you may be familiar with, each node includes a set of parameters that can be
adjusted and animated over time. Stringing different nodes together in a graphical user interface
called a node tree allows you to create sophisticated visual effects. The nodes, node trees, and all
settings you create are saved in a document called a Composition, or “comp” for short.

Merged right into DaVinci Resolve, the Fusion page makes it possible to jump immediately from
editing right into compositing, with no need to export media, relink files, or launch another application
to get your work done. Now everything you need lives right inside DaVinci Resolve.

The Fusion page in DaVinci Resolve, showing viewers, the Node Editor, and the Inspector

How Do | Use the Fusion Page?

The relationship between the Edit page and the Fusion page is similar to the relationship between the
Edit page and the Color page. Each clip can have a grade applied to it in the Color page, and similarly
every clip can have a composition applied to it in the Fusion page.

If you use the Fusion page to create any kind of effect or composite, a badge appears on that clip in
the Timeline to show that clip has a composition applied to it.
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Clips with Fusion page
compositions have a Fusion
badge to the right of the name.

To create an effect in the Fusion page of DaVinci Resolve, you need only park the playhead over a clip
in the Edit or Cut page and then click the Fusion page button. Your clip is immediately available as a
Medialn node in the Fusion page, ready for you to add a variety of stylistic effects. You can paint out
an unwanted blemish or feature, build a quick composite to add graphics or text, or accomplish any
other visual effect you can imagine, built from the Fusion page’s toolkit of effects.

Alternatively, in DaVinci Resolve, you have the option of editing together all the clips you want to use,
superimposing and lining up every piece of media you'll need with the correct timing, before selecting
them and creating a Fusion clip. A Fusion clip functions as a single item in the Edit or Cut page timeline,
but once in the Fusion page, each piece of media you've assembled is revealed in a fully built Fusion

composition, ready for you to start adding nodes to customize for whatever effect you need to create.

Whichever way you want to work, all this happens on the very same timeline as editing, grading, and
audio post, for a seamless back and forth as you edit, refine, and finish your projects.

How Do Fusion Effects Differ from Edit Page Effects?

When using DaVinci Resolve, you can create numerous effects in the Edit page. Transitions, fades,
superimpositions, over-the-shoulder picture-in-picture effects, time remapping, and lower third

titles are some of the effects that can be quickly and more efficiently created in the Edit or Cut page
timeline. However, the Fusion page’s node-based interface lets you go deep into the details of a
composition to create sophisticated 2D and 3D effects with precise control and endless customization.
Effects that include more than two or three layers can be much more manageable in Fusion. Green or
blue screen composites, sky replacements, and object removal are all effects better suited for Fusion’s
more advanced toolset.

How Do Fusion Effects Differ from Color Page Effects?

The Color page in DaVinci Resolve can also handle some visual effects work. Effects that blur the line
between color grading and finishing can be very fast and intuitive in the Color Page, especially for
people already familiar with the Color page toolset. Beauty work and small image repairs can make
efficient use of the Color page's straightforward Tracking tool, Face Refinement, and Patch Replacer
effects. However, when it comes to more challenging blue/green screen compositing, the tools built
around Fusion's powerful Delta keyer are more capable of handling these shots. Integrating 3D
objects into live-action scenes, split-screen effects, motion graphics, and precise keyframing are all
better suited to the Fusion page.
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Creating visual effects with the stand-alone Fusion Studio software begins with opening Fusion,
creating a new composition, importing some clips via Loader nodes, and building out your composite
with effects. Just like the Fusion Page in DaVinci Resolve, you add effects using different nodes from
the Effects Library, and you combine multiple layers of imagery using Merge nodes. Once you've
created the desired result, add a Saver node to the end of the tree of nodes you've created to render
your final result.

Rendering Out Your Final Result

Unlike the Fusion Page in DaVinci Resolve, which renders directly back into the Edit or Cut page
timeline, the final step in Fusion Studio is to render the finished effect to disk as a movie file or image
sequence. The last node in every node tree is a Saver node. Saver nodes configure the output file
format and render the file to disk. You can use as many Saver nodes in a composite as you need. For
instance, you might use multiple Saver nodes to render out intermediate areas of a composite or to
output a composite in multiple formats.

In addition to the kinds of robust compositing, paint, rotoscoping, and keying effects you'd expect
from a fully-featured 2D compositing environment, Fusion offers much more.

3D Compositing

Fusion has powerful 3D nodes that include extruded 3D text, simple geometry, and the ability to
import 3D models. Once you've assembled a 3D scene, you can add cameras, lighting, and material
shaders, and then render the result with depth-of-field effects and auxiliary channels to integrate with
more conventional layers of 2D compositing, for a sophisticated blending of 3D and 2D operations in
the very same node tree.

A 3D scene with textured 3D text, created entirely within Fusion

Particles

Fusion also has an extensive set of nodes for creating particle systems that have been used in
major motion pictures, with particle generators capable of spawning other generators, 3D particle
generation, complex simulation behaviors that interact with 3D objects, and endless options for
experimentation and customization. You can create particle system simulations for VFX or more
abstract particle effects for motion graphics.
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A 3D particle system, also created entirely within Fusion

Text

The Text tools in Fusion are exceptional, giving you layout and animation options in both 2D and 3D.
Furthermore, within DaVinci Resolve, these Text tools have been incorporated into the Edit and Cut
pages as Fusion Titles. These title templates are compositions saved from Fusion as macros with
published controls that are visible in the Edit or Cut page Inspector for easy customization, even if
you're working with people who don't know Fusion.

A multi-layered text composite integrating video clips and Fusion-generated elements

And Lots More

The list goes on. With Stereo and VR adjustment nodes, Planar Tracking, Deep Pixel nodes for
re-compositing rendered 3D scenes using Auxiliary Channel data, powerful Masking and Rotoscoping
nodes, and Warping effects, Fusion is an impressively featured environment for building worlds, fixing
problems, and flying multi-layered motion graphics animations through your programs.

Introduction to Compositing in Fusion
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That depends on what you want to do, but honestly it's not so bad with this PDF at your side, helping
guide the way. It's worth repeating that this Fusion documentation was developed specifically to help
users who've never before worked with Fusion learn the core concepts needed to perform the basics,
in preparation for learning the rest of the application on your own.

Fusion is a deep, production-driven product that's had decades of development, so its feature set is
deep and comprehensive. You won't learn it in an hour, but much of what you'll find won't be so very

different from other compositing applications you may have used. And if you've familiarized yourself
with the node-based grading workflow of the DaVinci Resolve Color page, you've already got a leg up

on understanding the central operational concept of compositing in Fusion.

Introduction to Compositing in Fusion 1"



Exploring the
Fusion Interface

This chapter provides an orientation on the Fusion user interface,

providing a quick tour of what tools are available, where to find

things, and how the different panels fit together to help you build

and refine compositions in this powerful node-based environment.
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The Fusion User Interface

If you open up everything at once, Fusion is divided into four principal regions designed to help

you make fast work of node-based compositing. The viewer(s) are at the top, the work area is at

the bottom, the Inspector is at the right, and the Effects Library is the area found at the left. In

DaVinci Resolve's Fusion page, the Effects Library shares space with the Media Pool. All these panels
work together to let you add effects, paint to correct issues, create motion graphics or title sequences,
or build sophisticated 3D and multi-layered composites.

The Fusion user interface shown completely

However, Fusion doesn't have to be that complicated, and in truth, you can work very nicely with only
the viewer, Node Editor, and Inspector open for a simplified experience.

Exploring the Fusion Interface 13
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A simplified set of Fusion controls for everyday working

You probably won't see the term “the work area” used much, in favor of the specific panels within the
work area that you'll be using. Still, the area referred to as the work area is the region at the bottom
half of the Fusion user interface, within which you can expose the three main panels used to construct
compositions and edit animations in Fusion. These are the Node Editor, the Spline Editor, and the
Keyframes Editor. By default, the Node Editor is the first thing you'll see, and the main area you'll be
working within, but it can sit side-by-side with the Spline Editor and Keyframes Editor as necessary.
You can make more horizontal room on your display for these three panels by putting the Effects
Library and Inspector into a half-height mode, if necessary.

EREEEEEE BEEE

The work area showing the Node Editor, the Spline Editor, and the Keyframes Editor

Interface Toolbar

At the very top of Fusion is a toolbar with buttons that let you show and hide different parts of

the user interface (UI). Buttons with labels identify which parts of the UI can be shown or hidden.

In DaVinci Resolve's Fusion page, if you right-click anywhere within this toolbar, you have the option of
displaying this bar with or without text labels.

Greenscreen Example "} Spline @ Keyframes tada 3§ Inspector

The Ul toolbar of the Fusion page

Exploring the Fusion Interface
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Greenscreen Example

o2 Nodes -3 spiine 4 Kevrames  )§ Inspector

The UI toolbar of Fusion Studio

These buttons are as follows, from left to right:

— Media Pool/Effects Library Full Height: Lets you set the area used by the Media Pool
(DaVinci Resolve only) and/or Effects Library to take up the full height of your display, giving you

more area for browsing at the expense of a narrower Node Editor and viewer area. At half-height,
the Media Pool/Templates/Effects Library are restricted to the top half of the Ul along with
the viewers (you can only show one at a time), and the Node Editor takes up the full width of
your display.

— Media Pool: (DaVinci Resolve only): Shows and hides the Media Pool, from which you can drag
additional clips into the Node Editor to use them in your Fusion page composition.

— Effects Library: Opens or hides the repository of all node tools available to use in Fusion.
From here, you can click nodes to add them after the currently selected node in the Node Editor, or
you can drag and drop nodes to any part of the node tree you like.

— Clips: (DaVinci Resolve only): Opens and closes the Thumbnail timeline, which lets you
navigate your program, create and manage multiple versions of compositions, and reset the
current composition.

— Nodes: Opens and closes the Node Editor, where you build and edit your compositions.

— Console (Fusion Studio only): The Console is a window in which you can see the error, log, script,
and input messages that may explain something Fusion is trying to do in greater detail. The
Console is also where you can read FusionScript outputs, or input FusionScripts directly.

— Spline: Opens and closes the Spline Editor, where you can edit the curves that interpolate
keyframe animations to customize and perfect their timing. Each keyframed parameter appears
hierarchically within the effect in which it appears in a list to the left.

— Keyframes: Opens and closes the Keyframes Editor, which shows each clip and effects node in
your Fusion composition as a layer. You can use the Keyframes Editor to edit and adjust the timing
of keyframes that have been added to various effects in your composition. You can also use the
Keyframes Editor to slide the relative timing of clips that have been added to Fusion, as well as
to trim their In and Out points. A spreadsheet can be shown and hidden within which you can
numerically edit keyframe values for selected effects.

— Metadata (DaVinci Resolve only): Hides or shows the Metadata Editor, which lets you read and
edit the available clip and project metadata associated with any piece of media within a composite.

— Inspector: Shows or hides the Inspector, which shows you all the editable parameters and controls
that correspond to selected nodes in the Node Editor. You can show the parameters for multiple
nodes at once, and even pin the parameters of nodes you need to continue editing so that they're
displayed even if those nodes aren’t selected.

— Inspector Height: Lets you open the Inspector to be half height (the height of the viewer area)
or full height (the height of your entire display). Half height allows more room for the Node Editor,
Spline Editor, and/or Keyframes Editor, but full height lets you simultaneously edit more node
parameters or have enough room to display the parameters of multiple nodes at once.

Exploring the Fusion Interface 15



Whenever you click somewhere on the Fusion interface using the pointer or using a keyboard
shortcut to “select” a particular panel, you give that panel of the user interface “focus.” A panel with
focus captures specific keyboard shortcuts to do something within that panel, as opposed to doing
something elsewhere in the interface.

To make it easier to keep track of which panel has focus, a highlight appears at the top edge of
whichever panel has focus. In DaVinci Resolve, you must turn on “Show focus indicators in the
User Interface” in the UI Settings panel of the User Preferences to see the highlight.

Master ; 87% 00:00:04:03

v Master

The focus indicator shown at the top edge of the Media
Pool, shown next to a viewer that doesn’t have focus

Viewers

The viewer area displays either one or two viewers at the top of the Fusion page, and this is
determined via the Viewer button at the far right of the Viewer title bar. Each viewer can show a single
node’s output from anywhere in the node tree. You assign which node is displayed in which viewer.
This makes it easy to load separate nodes into each viewer for comparison. For example, you can

load a Keyer node into the left viewer and the final composite into the right viewer, so you can see the
image you're adjusting and the final result at the same time.

UFO
PRESENCE!
ALIEN ABDUCTION!

Dual viewers let you edit an upstream node in one while seeing
its effect on the overall composition in the other.

Ordinarily, each viewer shows 2D nodes from your composition as a single image. However,

when you're viewing a 3D node, you have the option to set that viewer to one of several 3D views.

A perspective view gives you a repositionable stage on which to arrange the elements of the

world you're creating. Alternatively, a quad view lets you see your composition from four angles,
making it easier to arrange and edit objects and layers within the XYZ axes of the 3D space in which
you're working.

Exploring the Fusion Interface
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Loading a 3D node into a viewer switches on a Perspective view

TIP: In Perspective view, you can hold down the middle and right mouse buttons, then drag
in the viewer to pivot the view around the center of the world. All other methods of navigating

viewers work the same.

The viewers have a variety of capabilities you can use to compare and evaluate images. This section
provides a short overview of viewer capabilities to get you started.

There are standardized methods of zooming into and panning around viewers when you need
a closer look at the situation. These methods also work with the Node Editor, Spline Editor, and
Keyframes Editor.

Methods of panning viewers:
— Middle-click and drag to pan around the viewer.
— Hold down Shift and Command and drag the viewer to pan.

— Drag with two fingers on a track pad to pan.

Methods of scaling viewers:

— Click a viewer, and press the equals key (=) to zoom in, and the minus key (-) to zoom out.

— Press the middle and left mouse buttons simultaneously and drag left or right to resize the viewer.
— Hold down the Command key and use your pointer’s scroll control to zoom in and out of the viewer.

— Hold down the middle mouse button, and then click the left mouse button to zoom in, or click the

right button to zoom out. The scaling uses a fixed amount, centered on the position of the cursor.
— Click a viewer and press Command-1 to resize the image in the viewer to 100 percent.

— Click a viewer and press Command-2 to resize the image in the viewer to 200 percent.

Exploring the Fusion Interface
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— Click a viewer and press F to reset the image in the viewer to fit the viewer.
— Click the Scale viewer menu and choose Fit or a percentage.

— Right-click on a viewer and choose an option from the Scale submenu of the contextual menu.
This includes a Custom Scale command that lets you type your own scale percentage.

— Hold down the Command key and drag with two fingers on a track pad to zoom in and out
of the viewer.

Methods of spinning 3D viewers:

— In 3D Perspective view, hold down the middle and right mouse button, then drag to
spin the stage around.

— In 3D Perspective view, hold down the Shift key and drag with two fingers on a track pad to
spin the stage around.

When you first open the Fusion page in DaVinci Resolve, the output of the current empty composition
(the MediaOut1 node) is usually showing in viewer 2. If you're in Dual-viewer mode, viewer 1 remains
empty until you assign a node to one of them.

When using Fusion Studio, nothing is loaded into either of the viewers until you assign a node to
one of them.

To load specific nodes into specific viewers:

— Hover the pointer over a node, and click one of two buttons that appear at the bottom
left of the node.

— Click once to select a node, and press 1 (for the left viewer) or 2 (for the right viewer).
— Right-click a node and choose View On > None/Left View/Right View in the contextual menu.

— Right-click the control header of a node in the Inspector, and choose View On > None/Left View/
Right View from the contextual menu.

— Drag a node and drop it over the viewer you'd like to load it into (this is great for tablet users).

When a node is being viewed, a View Indicator button appears at the bottom left. This is the same
control that appears when you hover the pointer over a node. Not only does this control let you know
which nodes are loaded into which viewer, but they also expose little round buttons for switching
between viewers.

p  Transform1 (Xf) |m

Viewer assignment buttons at
the bottom of nodes indicate
when they're being viewed.
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To clear an image from a viewer, click in the viewer to make it active; a thin red highlight is displayed at
the top of the active viewer. With the viewer active, press the " (accent) key. This key is usually found to
the left of the 1 key on U.S. keyboards. The fastest way to remove all the images from all the viewers is
to make sure none of the viewers is the active panel, and then press the Tilde key.

You can also select the node that is currently showing in the viewer, and press the viewer number
again (1 or 2 respectively) to clear the viewer.

A series of buttons and pop-up menus in the viewer's title bar provides several quick ways of
customizing the viewer display.

MediaOut1

Controls in the viewer title bar

— Zoom menu: Lets you zoom in on the image in the viewer to get a closer look, or zoom out to get
more room around the edges of the frame for rotoscoping or positioning different layers. Choose
Fit to automatically fit the overall image to the available dimensions of the viewer.

— Split Wipe button and A/B Buffer menu: You can actually load two nodes into a single viewer
using that viewer's A/B buffers by choosing a buffer from the menu and loading a node into the
viewer. Turning on the Split Wipe button (press Forward Slash) shows a split wipe between the
two buffers, which can be dragged left or right via the handle of the onscreen control, or rotated
by dragging anywhere on the dividing line on the onscreen control. Alternatively, you can switch
between each full-screen buffer to compare them (or to dismiss a split-screen) by pressing Comma
(A buffer) and Period (B buffer).

— SubView type: (These aren't available in 3D viewers.) Clicking the icon itself enables or disables
the current “SubView” option you've selected, while using the menu lets you choose which SubView
is enabled. This menu serves one of two purposes. When displaying ordinary 2D nodes, it lets
you open up SubViews, which are viewer “accessories” within a little pane that can be used to
evaluate images in different ways. These include an Image Navigator (for navigating when zoomed
far into an image), Magnifier, 2D viewer (a mini-view of the image), 3D Histogram scope, Color
Inspector, Histogram scope, Image Info tooltip, Metadata tooltip, Vectorscope, or Waveform scope.
The Swap option (Shift-V) lets you switch what's displayed in the viewer with what'’s being displayed
in the Accessory pane. When displaying 3D nodes, this button lets you have access to an additional
mini 3D viewer.

— Node name: The name of the currently viewed node is displayed at the center of the
viewer's title bar.

— ROI controls: Clicking the icon itself enables or disables Rol (Region of Interest) limiting in the
viewer, while using the menu lets you choose the region of the Rol. Rol lets you define the region
of the viewer in which pixels actually need to be updated. When a node renders, it intersects
the current Rol with the current Domain of Definition (DoD) to determine what pixels should be
affected. When enabled, you can position a rectangle to restrict rendering to a small region of the
image, which can significantly speed up performance when you're working on very high resolution

Exploring the Fusion Interface
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or complex compositions. Auto (the default) sets the region to whatever is visible at the current
zoom/pan level in the viewer. Choosing Set lets you draw a custom region within the frame by
dragging a rectangle that defaults to the size of the viewer, which is resizable by dragging the
corners or sides of the onscreen control. Choosing Lock prevents changes from being made to the

current Rol. Choosing Reset resets the Rol to the whole viewer.

Color controls: Lets you choose which color and/or image channels to display in the viewer.
Clicking the icon itself toggles between Color (RGB) and Alpha, the two most common things you
want to see (pressing C or A also toggles between Color and Alpha). Opening the menu displays
every possible channel that can be displayed for the currently viewed node, commonly including
RGB, Red, Green, Blue, and Alpha (available from the keyboard by pressing R, G, B, or A). For certain
media and nodes, additional auxiliary channels are available to be viewed, including Z-depth,
Object ID, Material ID, XYZ Normals, and so on.

Viewer LUT: Clicking the icon itself toggles LUT (LookUp Table) display on or off, while the menu
lets you choose which of the many available color space conversions to apply to the viewer. The

top options let you choose Fusion controls that can be customized via the Edit item at the top of
this menu. The rest of this menu shows all LUTs installed in the LUT directory to use for viewing.

By default, when using DaVinci Resolve, the viewers in the Fusion page show you the image prior
to any grading done in the Color page, since the Fusion page comes before the Color page in

the DaVinci Resolve image processing pipeline. When you're working on clips that have been
converted to linear color space for compositing, it is desirable to composite and make adjustments
to the image relative to a normalized version of the image that appears close to what the final will
be. Enabling the LUT display lets you do this as a preview, without permanently applying color
adjustments to the image.

Option menu: This menu contains various settings that pertain to the viewers in Fusion.
When drawing or adjusting a polyline mask or spline, the control points
will snap to pixel locations.
Toggles whatever onscreen controls are visible for the currently selected node.
Provides all the settings for the Region of Interest in the viewer.

This option uses a smoother bilinear interpolated resizing method when zooming
into an image in the viewer; otherwise, scaling uses the nearest neighbor method and shows
noticeable aliasing artifacts. However, this is more useful when you zoom in at a pixel level since
there is no interpolation.

Overrides the auto aspect correction when using formats with
non-square pixels.
Toggles a checkerboard underlay that makes it easy to see
areas of transparency.
Allows for the visualization of brightness values outside of the normal
viewing range, particularly when working with floating-point images or auxiliary channels.
Exposes a simple pair of Gain and Gamma sliders that let you adjust the

viewer's brightness.

Used to properly display spherical imagery in a variety of formats, selectable
from this submenu.

Used to properly display stereoscopic imagery in a variety of formats,

selectable from this submenu.
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Time Ruler and Transport Controls

The Time Ruler, located beneath the viewer area, is based on the total duration of the composition.
What it represents depends on which version of Fusion you're using:

— For DaVinci Resolve users, the duration displayed in the Time Ruler range depends on what's
currently selected in the Edit or Cut page timeline.

— In Fusion Studio, the Time Ruler depends on the Global Start and End values set in the Fusion
Studio Preferences > Defaults.

The transport controls under the Time Ruler include playback controls, audio monitoring, as well as
number fields for the composition duration and playback range. Additional controls enable motion
blur and proxy settings.

If you've selected a single clip in the Edit or Cut page Timeline, then the global range shown in the
Time Ruler is based on the total source duration for that clip. You cannot move the playhead outside
the global range. The yellow lines, called the render range, identify the current In and Out points for
the clip and are the only frames visible in the Fusion page. All frames outside of this range constitute
the unused head and tail handles of that source clip.

The Time Ruler displaying ranges for a clip in the
Timeline via yellow marks (the playhead is red)

If you've created a Fusion clip or a compound clip, then the “working range” reflects the entire
duration of that clip.

The Time Ruler displaying ranges for a Fusion clip in the Timeline

Render Range

The render range determines the range of frames that are visible in the Fusion page and that are used
for interactive playback, disk caches, and previews. Frames outside the default render range are not
visible in the Fusion page and are not rendered or played.

You can modify the duration of the render range for preview and playback only. Making the range
shorter or longer does not trim the clip in the Edit or Cut page Timelines.

You can change the render range in the Time Ruler by doing one of the following:
— Hold down the Command key and drag a new range within the Time Ruler.
— Drag either the start or end yellow line to modify the start or end of the range.

— Right-click within the Time Ruler and choose Set Render Range from the contextual menu.
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— Enter new ranges in the Range In and Out fields to the left of the transport controls.

— Drag a node from the Node Editor to the Time Ruler to set the range to the duration of that node.
You can return the render range to the In and Out points of the timeline clip by

doing one of the following.

— Right-click within the Time Ruler and choose Auto Render Range.

— Click back in the Edit or Cut page, and then return to the Fusion page.

The Time Ruler, located beneath the viewer area, displays two different frame ranges: one for the
entire composition, called the global range, and the other called the render range, which determines
what to render and what to cache in memory for previews. The global start and end range takes up
the entire Time Ruler and sets the total duration of a composition. You cannot move the playhead

outside the global range.

The Time Ruler displaying ranges for a clip in the Timeline via yellow marks (the playhead is red)

Global Start and End Range

The global start and end range is simply the total duration of the current composition.

You can change the global range by doing one of the following:

— To change the global range for all new compositions, choose Fusion Studio > Preferences on
macQOS or File > Preferences on Windows or Linux. In the Global and Default Settings panel, enter a

new range in the Global range fields.

— To change the Global range for the current composition, enter a new range in the Global Start and
End fields to the left of the transport controls.

— Dragging a node from the Node Editor to the Time Ruler automatically sets the Global and Render
Range to the extent of the node.

Render Range

The render range determines the range of frames used for interactive playback, disk caches, and
previews. Frames outside the render range are not rendered or played, although you can still drag the
playhead to these frames to see the unused frames.

To preview or render a specific range of a composition, you can modify the render range in a

variety of ways.

You can set the render range in the Time Ruler by doing one of the following:
— Hold down the Command key and drag a new range within the Time Ruler.

— Right-click within the Time Ruler and choose Set Render Range from the contextual menu to set the

Render Range based on the selected Node's duration.
— Enter new ranges in the Range In and Out fields to the left of the transport controls.

— Drag a node from the Node Editor to the Time Ruler to set the range to the duration of that node.
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A red playhead within the Time Ruler indicates the currently viewed frame. Clicking anywhere within
the Time Ruler jumps the playhead to that frame, and dragging within the Time Ruler drags the
playhead within the available duration of that clip or composition.

A two-handled gray scroll bar lets you zoom into the range shown by the Time Ruler, which is useful

if you're using a very large Global range such that the Render range is a tiny sliver in the Time Ruler.
Dragging the left or right handles of this bar zooms relative to the opposite handle, enlarging the
width of each displayed frame. Once you've zoomed in, you can drag the scroll bar left or right to scroll
through the composition.

TIP: Holding the middle mouse button and dragging in the Time Ruler lets you scroll the
visible range.

The Transport Controls in DaVinci Resolve’s Fusion page include buttons that control playback as
well as time fields on the left side for setting the render range and the current time on the right side.
Additional controls are available in the right-click menu.

Controlling Playback

There are six transport controls underneath the Time Ruler in the Fusion page. These buttons include
Composition First Frame, Play Reverse, Stop, Play Forward, Composition Last Frame, and Loop.

The Fusion page controls for playback

Navigation Shortcuts

Many standard transport control keyboard shortcuts you may be familiar with work in Fusion, but
some are specific to Fusion’s particular needs.

To move the playhead in the Time Ruler using the keyboard, do one of the following:

— Spacebar: Toggles forward playback on and off.

— JKL: Basic JKL playback is supported, including J to play backward, K to stop, and L to play forward.
— Back Arrow: Moves 1 frame backward.

— Forward Arrow: Moves 1 frame forward.

— Shift-Back Arrow: Moves to the clip’s Global Start frame.

— Shift-Forward Arrow: Moves to the clip's Global End frame.

— Command-Back Arrow: Jumps to the Render Range In point.

— Command-Forward Arrow: Jumps to the Render Range Out point.
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Real-Time Playback Not Guaranteed

Because many of the effects you can create in the Fusion page are processor-intensive, there is
no guarantee of real-time playback at your project’s full frame rate unless you've cached your
composition first (discussed later).

Frame Increment Options

Right-clicking either the Play Reverse or Play Forward buttons opens a contextual menu. This menu
contains options to set a frame increment value, which lets you use a keyboard shortcut to move the
playhead in sub-frame or multi-frame increments.

Moving the playhead in multi-frame increments can be useful when rotoscoping. Moving the playhead
in sub-frame increments can be useful when rotoscoping or inspecting interlaced frames one field at

a time (0.5 of a frame).

Right-click the Play Forward or Play
Backward buttons to choose a frame
increment in which to move the playhead.

Looping Options
The Loop button can be toggled to enable or disable looping during playback. You can right-click this
button to choose the looping method that's used:

— Playback Loop: The playhead plays to the end of the Time Ruler and starts from the
beginning again.

— Ping-pong Loop: When the playhead reaches the end of the Time Ruler, playback reverses
until the playhead reaches the beginning of the Time Ruler, and then continues to ping-pong
back and forth.

Render Range Fields

The two time fields on the left side of the transport controls are used to modify the Render Range.
You can enter time values in frames, or click and drag inside the fields to modify the In and Out of the

render range for previews and caching.
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25.0

The Render Start and
Render End time fields

Playing a composition in DaVinci Resolve’s Fusion page will play the audio from the Edit or Cut page
Timeline. You can choose to hear the audio or mute it using the Audio toolbar button to the left of the
transport controls. The audio waveforms are displayed in the Keyframes Editor to assist in the timing
of your animations.

TIP: If the Mute button is enabled on any Timeline tracks, audio from those tracks will not be
heard in Fusion.

For Fusion Studio, audio can be loaded using the Loader node’s Audio tab. The audio functionality is
included in Fusion Studio for scratch track (aligning effects to audio and clip timing) purposes. Final
renders should almost always be performed without audio. Audio can be heard if it is brought in
through a Loader node.

To hear the audio from a specific Loader node:

— Right-click over the Speaker icon and choose the file name that contains the audio
you want to hear.

Audio Toolbar Button

The Audio button in the toolbar is a toggle that can be used to enable or mute audio playback
associated with the clip. Additionally, right-clicking this button displays a contextual menu that can be
used to select a Medialn node in the Fusion page or an external WAV file in Fusion Studio.

The Current Time Field

The Current Time field at the right of the transport controls displays the frame number for the
playhead position, which corresponds to the frame seen in the viewer. Clicking and dragging in this
field scrubs the playhead position back and forth. However, you can also enter time values into this
field to move the playhead by specific amounts.

When setting ranges and entering frame numbers to move to a specific frame, numbers can be
entered in sub-frame increments. You can set a range to be -145.6 to 451.75 or set the playhead to
115.22. This can be very helpful when animating parameters because you can set keyframes where
they actually need to occur, rather than on a frame boundary, so you get more natural animation.
Having sub-frame time lets you use time remapping nodes or just scale keyframes in the Spline view
and maintain precision.
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The Fusion Page Viewer Quality and Proxy Options

Right-clicking anywhere in the transport control area other than over the Play Forward/Play Reverse
buttons lets you turn on and off Fusion quality controls. You can either enable high-quality playback at
the expense of more significant processing times or enter various proxy modes that temporarily lower
the display quality of your composition to speed processing as you work.

Rendering for final output is always done at the highest quality, regardless of these settings.

High Quality

As you build a composition, often the quality of the displayed image is less important than the
speed at which you can work. The High Quality setting gives you the option to either display
images with faster interactivity or at final render quality. When you turn off High Quality, complex
and time-consuming operations such as area sampling, anti-aliasing, and interpolation are skipped
to render the image to the viewer more quickly. Enabling High Quality forces a full-quality render to
the viewer that's identical to what is output during final delivery.

Motion Blur

The Motion Blur button is a global setting. Turning off Motion Blur temporarily disables motion blur
throughout the composition, regardless of any individual nodes for which it's enabled. This can
significantly speed up renders to the viewer. Individual nodes must first have motion blur enabled
before this button has any effect.

Proxy

The Proxy setting is a draft mode used to speed processing while you're building your composite.
Turning on Proxy reduces the resolution of the images that are rendered to the viewer, speeding
render times by causing only one out of every x pixels to be processed, rather than processing
every pixel. The value of x is decided by adjusting a slider in the Proxy section in the Fusion >
Fusion Settings > General panel.

Auto Proxy

The Auto Proxy setting is a draft mode used to speed processing while you're building your
composite. Turning on Auto Proxy reduces the resolution of the image while you click and drag to
adjust a parameter. Once you release that control, the image snaps back to its original resolution.
This lets you adjust processor-intensive operations more smoothly, without the wait for every
frame to render at full quality causing jerkiness. You can set the auto proxy ratio by adjusting a
slider in the Proxy section of the Fusion > Fusion Settings > General panel.

Selective Updates

When working in Fusion, only the tools needed to display the images in the viewer are updated.
The Selective Update options select the mode used during previews and final renders.

The options are available in the Proxy section of the Fusion > Fusion Settings > General panel. The
three options are:

— Update All (All): Forces all the nodes in the current node tree to render. This is primarily used
when you want to update all the thumbnails displayed in the Node Editor.

— Selective (Some): Causes only nodes that directly contribute to the current image to be
rendered. So named because only selective nodes are rendered. This is the default setting.

— No Update (None): Prevents rendering altogether, which can be handy for making many
changes to a slow-to-render composition.
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The transport controls in Fusion Studio include buttons to control playback, time fields on the left
side for setting the global range and render range, and a Render button to initiate rendering of the
composite. There are also controls on the right side for proxy and motion blur. The time field on the
far right is used for the current time.

Fusion Studio transport controls

Controlling Playback

There are eight transport controls underneath the Time Ruler in Fusion Studio. These buttons include
Composition First Frame, Step Backward, Play Reverse, Stop, Play Forward, Step Forward, Composition
Last Frame, and Loop.

Fusion Studio transport controls

Navigation Shortcuts

Many standard transport control keyboard shortcuts you may be familiar with work in Fusion, but
there are some keyboard shortcuts specific to Fusion’s particular needs.

To move the playhead in the Time Ruler using the keyboard, do one of the following:

— Spacebar: Toggles forward playback on and off.

— JKL: Basic JKL playback is supported, including J to play backward, K to stop, and L to play forward.
— Back Arrow: Moves 1 frame backward.

— Forward Arrow: Moves 1 frame forward.

— Shift-Back Arrow: Moves to the clip’s Global End frame.

— Shift-Forward Arrow: Moves to the clip’s Global Start frame.

— Command-Back Arrow: Jumps to the Render Range In point.

— Command-Forward Arrow: Jumps to the Render Range Out point.

Real-Time Playback Not Guaranteed

Because many of the effects you can create in the Fusion page are processor-intensive, there is no
guarantee of real-time playback at your project’s full frame rate, unless you've cached your composition
first. For more information, see the “Fusion RAM Cache for Playback” section later in this chapter.

Frame Increment Options

Right-clicking the Step Backward, Play Reverse, Play Forward, or Step Forward buttons opens a drop-
down menu with options to set a frame increment value. Selecting a frame number from the menu
lets you move the playhead in sub-frame or multi-frame increments whenever you use a keyboard
shortcut or press the Step Forward/Backward buttons.
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Moving the playhead in multi-frame increments can be useful when rotoscoping. Moving the playhead
in sub-frame increments can be useful when rotoscoping or inspecting interlaced frames one field at

a time (0.5 of a frame).

Right-click the Step Forward or Step
Backward buttons to choose a frame
increment in which to move the playhead.

Looping Options
The Loop button can be toggled to enable or disable looping during playback. You can right-click this
button to choose the looping method that's used:

— Playback Loop: The playhead plays to the end of the Time Ruler and starts from the
beginning again.

— Ping-pong Loop: When the playhead reaches the end of the Time Ruler, playback
reverses until the playhead reaches the beginning of the Time Ruler, and then continues to

ping-pong back and forth.

Range Fields

The four time fields on the left side of the transport controls are used to quickly modify the global

range and render range in Fusion Studio.

175.0 (250.0) <»

Global Time Fields to the left of the transport controls

Audio

The Audio button is a toggle that mutes or enables any audio associated with the clip. Additionally,
right-clicking on this button displays a drop-down menu that can be used to select a WAV file, which
can be played along with the composition, and to assign an offset to the audio playback.
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Render

Clicking the Render button in the transport controls displays the composition’s Render Settings dialog.
This dialog is used to configure the render options and initiate rendering of any Saver nodes in the
composition. Shift-clicking on the button skips the dialog, using default render values (full resolution,

high quality, motion blur enabled).

The Current Time

The Current Time field at the right of the transport controls shows the frame at the position of the
playhead, which corresponds to the frame seen in the viewer. However, you can also enter time values
into this field to move the playhead by specific amounts.

When setting ranges and entering frame numbers to move to a specific frame, numbers can be
entered in sub-frame increments. You can set a range to be -145.6 to 451.75 or set the playhead

to 115.22. This can be very helpful when animating parameters because you can set keyframes where
they actually need to occur, rather than on a frame boundary, so you get more natural animation.
Having sub-frame time lets you use time remapping nodes or just scale keyframes in the Spline view

and maintain precision.

NOTE: Many fields in Fusion can evaluate mathematical expressions that you type into them.
For example, typing 2 + 4 into most fields results in the value 6.0 being entered. Because
Feet + Frames uses the + symbol as a separator symbol rather than a mathematical symbol,
the Current Time field will not correctly evaluate mathematical expressions that use the

+ symbol, even when the display format is set to Frames mode.

Fusion Studio Viewer Quality and Proxy Options

Five buttons along the right side of the transport controls let you either enable high-quality playback
at the expense of greater processing times, or enter various proxy modes that temporarily lower the

display quality in order to speed processing as you work.

Rendering for final output is always done at the highest quality, regardless of these settings.

Some

Five buttons control the viewer quality,
motion blur, proxy options, and image-
processing update settings.

HiQ

As you build a composition, often the quality of the displayed image is less important than the
speed at which you can work. The High Quality setting gives you the option to either display
images with faster interactivity or at final render quality. When you turn off High Quality, complex
and time-consuming operations such as area sampling, anti-aliasing, and interpolation are skipped
to render the image to the viewer more quickly. Enabling High Quality forces a full-quality render to

the viewer that's identical to what will be output during final delivery.
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MB

The Motion Blur button is a global setting. Turning off Motion Blur temporarily disables motion blur
throughout the composition, regardless of any individual nodes for which it's enabled. This can
significantly speed up renders to the viewer. Individual nodes must first have motion blur enabled

before this button has any effect.

Prx

A draft mode to speed processing while you're building your composite. Turning on Proxy reduces
the resolution of the images that are rendered to the viewer, speeding render times by causing
only one out of every x pixels to be processed, rather than processing every pixel. The value of x
is decided by adjusting a slider in the General panel of the Fusion Preferences, found under the
Fusion menu on macOS or the File menu on Windows and Linux.

Aprx

A draft mode to speed processing while you're building your composite. Turning on Auto Proxy
reduces the resolution of the image while you click and drag to adjust a parameter. Once you
release that control, the image snaps back to its original resolution. This lets you adjust processor-
intensive operations more smoothly, without the wait for every frame to render at full quality
causing jerkiness. You can set the auto proxy ratio by adjusting a slider in the General panel of
the Fusion Preferences, found under the Fusion menu on macQOS or the File menu on Windows

and Linux.

Selective Updates

The last of the five buttons on the right of the transport controls is a three-way toggle that
determines when nodes update images in the viewer. By default, when working in Fusion, any node
needed to display the image in the viewer is updated. The Selective Update button can change this
behavior during previews and final renders.

The three options are:

— Update All (All): Forces all the nodes in the current node tree to render. This is primarily used
when you want to update all the thumbnails displayed in the Node Editor.

— Selective (Some): Causes only nodes that directly contribute to the current image to be
rendered. So named because only selective nodes are rendered. This is the default setting.

— No Update (None): Prevents rendering altogether, which can be handy for making a lot of

changes to a slow-to-render composition.

The options are also available in the Fusion Preferences General panel.

By default, all time fields and markers in Fusion count in frames, but you can also set the time display

to SMPTE timecode or Feet + Frames.

To change the time display format:

Choose Fusion > Fusion Settings in DaVinci Resolve, choose Fusion Studio > Preferences in Fusion
Studio on macQOS, or choose File > Preferences in Fusion Studio on Windows or Linux.

When the Fusion settings dialog opens, select the Defaults panel and choose a Timecode option.
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Select the Frame Format panel. If you're using timecode, choose a frame rate and turn on the
“has fields” checkbox if your project is interlaced. If you're using feet and frames, set the Film Size
value to match the number of frames found in a foot of film in the format used in your project.

Click Save.

When you select a node with keyframed parameters, those keyframes appear in the Time Ruler as
little white tic marks, letting you navigate among and edit keyframes without having to open the
Keyframes Editor or Spline Editor to see them.

The Time Ruler displaying keyframe marks

To move the playhead in the Time Ruler among keyframes:
— Press Option-Left Bracket ([) to jump to the next keyframe to the left.
— Press Option-Right Bracket (]) to jump to the next keyframe to the right.

When assembling a node tree, all image processing operations are rendered live to display the final
result in the viewers. However, as each frame is rendered, and especially as you initiate playback
forward or backward, these images are automatically stored to a RAM cache as they're processed so
you can replay those frames in real time. The actual frame rate achieved during playback is displayed
in the Status bar at the bottom of the Fusion window during playback. Of course, when you play
beyond the cached area of the Time Ruler, uncached frames need to be rendered before being added
to the cache.

Priority is given to caching nodes that are currently being displayed, based on which nodes are loaded
to which viewers. However, other nodes may also be cached, depending on available memory and on
how processor-intensive those nodes happen to be, among other factors.

Memory Limits of the RAM Cache

There is a single setting in DaVinci Resolve for limiting the RAM used for caching. This setting is
located in the DaVinci Resolve Preferences Memory and GPU panel.

— Limit Fusion Memory Cache To: This slider sets the maximum amount of RAM that Fusion
can access for caching. It is a subset of the RAM allocated to DaVinci Resolve. You can assign a
maximum of 75% to Fusion from DaVinci Resolve's total RAM allocation. When not using the Fusion
page, the RAM is released for other pages in DaVinci Resolve.
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There are two settings in Fusion Studio for limiting the RAM used for caching. These settings are
located in the Preferences Memory panel.

— Limit Caching To: This slider sets the maximum amount of RAM used for caching. The 60% default
setting on a 32-GB system limits the cache to 19.2 GB. The maximum amount you can assign to
Fusion Studio is limited to 80% of the total system memory. This leaves a minimum amount of
memory for other applications and the operating system.

— Leave at least # MBytes: This number field further limits caching in cases where the system'’s
available free RAM drops below the entered value. For instance, setting this to 200 MB attempts
to keep 200 MB of RAM free for the OS or other applications. Setting the number field to 0 allows
Fusion Studio to use the full amount of RAM specified by the Limit Caching To setting, ignoring
other apps.

When the size of the cache reaches the Fusion Caching/Memory Limits setting found in the Memory
panel of the Preferences, then lower-priority cache frames are automatically discarded to make room
for new caching. You can keep track of the RAM cache usage via a percentage indicator on the far
right of the Status bar at the bottom of the Fusion window.

Displaying Cached Frames

All cached frames for the currently viewed node are indicated by a green line at the bottom of the
Time Ruler. Any green section of the Time Ruler should play back in real time.

The green lines indicate frames that have been cached for playback.

Temporarily Preserving the Cache When Changing
Quality or Proxy Settings

If you toggle the composition’s quality settings or proxy options, the cache is not immediately
discarded. The green line instead turns red to let you know the cache is being preserved and can be
used again when you go back to the original level of quality or disable proxy mode. However, if you
play through those frames at the new quality or proxy settings, this preserved cache is overwritten
with a new cache at the current quality or proxy setting.

Ared line indicates that cached frames from a different
quality or proxy setting are being preserved.

There's one exception to this, however. When you cache frames at the High Quality setting, and you
then turn off High Quality, the green frames won't turn red. Instead, the High Quality cached frames
are used even though the HiQ setting has been disabled.
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Toolbar

The toolbar, located underneath the Time Ruler, contains buttons that let you quickly add commonly
used nodes to the Node Editor. Clicking any of these buttons adds that node after the currently
selected node in the node tree, or adds an unconnected instance of that node if no nodes are
selected. The Toolbar can be customized and saved for specific tasks.

The toolbar has buttons for adding commonly used nodes to the Node Editor.

The default toolbar is divided into sections that group commonly used nodes together. As you hover
the pointer over any button, a tooltip shows you that node’s name.

— Loader/Saver nodes (Fusion Studio Only): The Loader node is the primary node used to
select and load clips from the hard drive. The Saver node is used to write or render your
composition to disk.

— Generator/Title/Paint nodes: The Background and FastNoise generators are commonly used to
create all kinds of effects, and the Title generator is obviously a ubiquitous tool, as is Paint.

— Color/Blur nodes: ColorCorrector, ColorCurves, HueCurves, and BrightnessContrast are the four
most commonly used color adjustment nodes, while the Blur node is ubiquitous.

— Compositing/Transform nodes: The Merge node is the primary node used to composite one
image against another. ChannelBooleans and MatteControl are both essential for reassigning
channels from one node to another. Resize alters the resolution of the image, permanently altering
the available resolution, while Transform applies pan/tilt/rotate/zoom effects in a resolution-
independent fashion that traces back to the original resolution available to the source image.

— Mask nodes: Rectangle, Ellipse, Polygon, and BSpline mask nodes let you create shapes to use for
rotoscoping, creating garbage masks, or other uses.

— Particle system nodes: Three particle nodes let you create complete particle systems when you
click them from left to right. pEmitter emits particles in 3D space, while pMerge lets you merge
multiple emitters and particle effects to create more complex systems. pRender renders a 2D
result that can be composited against other 2D images.

— 3D nodes: Seven 3D nodes let you build sophisticated 3D scenes. These nodes auto attach to one
another to create a quick 3D template when you click from left to right. ImagePlane3D lets you
connect 2D stills and movies for compositing into 3D scenes. Shape3D lets you create geometric
primitives of different kinds. Text3D lets you build 3D text objects. Merge3D lets you composite
multiple 3D image planes, primitive shapes, and 3D text together to create complex scenes, while
Camera3D lets you frame the scene in whatever ways you like. SpotLight lets you light the scenes
in different ways and Renderer3D renders the final scene and outputs 2D images and auxiliary
channels that can be used to composite 3D output against other 2D layers.

When you're first learning to use Fusion, these nodes are really all you need to build most common

composites. Once you've become a more advanced user, you'll still find that these are truly the most
common operations you'll use.
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You can add and remove tools from the Fusion toolbar and then save the custom toolbar as a preset.
New tools can be added by dragging them from the Effects Library or the Node Editor, and dividers
can be added to group tool sets together.

To create a new toolbar, do the following:

Right click in an empty area of the toolbar and choose Customize > Create Toolbar from the

contextual menu.

Enter a name for the toolbar in the dialog box, and click OK.

To rearrange the tools in the toolbar, do the following:
Create a new custom toolbar or select an existing custom toolbar.

Drag a node in the toolbar to a new location.

To add a tool to the toolbar:
Create a new custom toolbar or select an existing custom toolbar.
Do one of the following:
— Drag a node from the Effects Library to the location on the toolbar where you want it added.

— Drag a node from the Node Editor to the location on the toolbar where you want it added.

To add a divider to a toolbar, do the following:
Create a new custom toolbar or select an existing custom toolbar.
Right-click over any tool and choose Customize > Add Divider. A divider is added to the right
of the tool.
To remove a tool from a toolbar, do the following:
Create a new custom toolbar or select an existing custom toolbar.

Right-click over any tool and choose Remove [name of tool].

To remove a group of tools between two dividers, do the following:
Create a new custom toolbar or select an existing custom toolbar.

Right-click over any tool in a group and choose Remove Group.

To prevent a custom toolbar from being modified:

Right-click over the toolbar and choose Lock from the contextual menu.

To switch between toolbars:

Right-click over the toolbar and choose the custom toolbar name or choose Default to return to
Fusion’s default toolbar.

To rename a custom toolbar, do the following:
Right-click over the toolbar and choose the name of the custom toolbar you want to rename.
Right-click over the toolbar again and choose Customize > Rename [toolbar name].

Enter a new name for the toolbar.
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To delete a custom toolbar, do the following:
Right-click over the toolbar and choose the name of the custom toolbar you want to delete.

Right-click over the toolbar again and choose Customize > Remove [toolbar name].

TIP: Adding and deleting tools from a custom toolbar is not undoable. If you are creating a

complex toolset, make a new custom toolbar based on your current toolbar in between major

changes and work off that. That way if you make an error, you can revert back to the last
known good toolbar. Once you have the final toolbar the way you want it, you can go back
and remove all the interim custom toolbars you made.

Node Editor

The Node Editor is the heart of Fusion because it's where you build the tree of nodes that makes up
each composition. Each node you add to the node tree adds a specific operation that creates one
effect, whether it's blurring the image, adjusting color, painting strokes, drawing and adding a mask,
extracting a key, creating text, or compositing two images into one.
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The Node Editor displaying a node tree creating a composition

You can think of each node as a layer in an effects stack, except that you have the freedom to route
image data in any direction to branch and merge different segments of your composite in completely
nonlinear ways. This makes it easy to build complex effects, but it also makes it easy to see what's
happening, since the node tree doubles as a flowchart that clearly shows you everything that's
happening, once you learn to read it.
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Depending on your mood, there are a few ways you can add nodes from the Effects Library to your
composition. For most of these methods, if there’s a single selected node in the Node Editor, new
nodes are automatically added after it, but if there are no selected nodes or multiple selected nodes,
then new nodes are added as disconnected from anything else.

Methods of adding nodes include:

— Click a button in the toolbar.

— Open the Effects Library, find the node you want in the relevant category, and click once on a node
you'd like to add.

— Right-click on a node and choose Insert Tool from the drop-down menu to add it after the node
you've right-clicked on. Or, you can right-click on the background of the Node Editor to use that
submenu to add a disconnected node.

— Press Shift-Spacebar to open a Select Tool dialog, type characters corresponding to the name of
the node you're looking for, and press the Return key (or click OK) when it's found. Once you learn

this method, it'll probably become one of your most frequently used ways of adding nodes.

Select Tool

xture Transform (3TT)

Tracker (Tra)

The Select Tool dialog lets you find any
node quickly if you know its name.

Removing nodes is as simple as selecting one or more nodes, and then pressing the Delete or

Backspace keys.
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Each node displays small colored connections around the edges. One or more arrows represent
inputs, and the square connection represents the tool's processed output, of which there is always
only one. If you hover the pointer over any of a node’s inputs or output, the name of that input or
output immediately appears in the Status bar. If you wait for a few more moments, a floating tooltip
displays the same name right over the node.

Each node has inputs and outputs that are “wired together” using connections. The inputs are
represented by arrows that indicate the flow of image data from one node to the next, as each node
applies its effect and feeds the result (via the square output) to the next node in the tree. In this way,
you can quickly build complex results from a series of relatively simple operations.

Medialn1 (MI) i Blur1 (Blur, Blur) — MediaOut1 (MO) ]

Three nodes connected together

You can connect a single node’s output to the inputs of multiple nodes (called “branching”).

Medialn1 (MI) S Blurl (Blur, Blur) ™

\ 4 v
ColorCurvest (CCv) g

One node branching to two to split the image to two operations

You can then composite images together by connecting the output from multiple nodes to certain
nodes such as the Merge node that combines multiple inputs into a single output.

Text2 (Text+ Tut+) g, Mergel (Merge, Mrg) m

Text1 (Text+, Txt¥) m—"

Two nodes being merged together into one to create a composite
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By default, new nodes are added from left to right in the Node Editor, but they can also flow from top
to bottom, right to left, bottom to top, or in all directions simultaneously. Connections automatically
reorient themselves along all four sides of each node to maintain the cleanest possible presentation

as you rearrange other connected nodes.

Medialn1 (M)
]

Medialn3 (M1)

v v
> DeltaKeyer! (DK)

[} e
: |
» Polygont (Ply) ¢ w—, BrightnessContrast1 ZDepthMatteGroup v
= » » Imageplane304 (3im)
[ ]

v v v .
» ImagePlane3D1 (3Im) w—p  Displace3D1 (3D) m » Merge3D1 (3Mg) m » Renderer3Dl (3Rn) g, MediaOutl (MO) g

» Camera3di @Cm) <

v
Medialn2 (MI) m——» ImagePlane3D2 (3Im) w/ A

Nodes can be oriented in any direction; the input arrows let you follow the flow of image data.

As your Node tree gets larger, parts inevitably go offscreen. When a portion of the node tree is
offscreen, a resizable Navigator pane appears in the upper-right corner. The Navigator is a miniature
representation of the entire node tree that you can drag within to pan to different parts of your
composition quickly. You can resize the navigator using a handle in the lower-left corner, and you can
choose to show or hide the Navigator by pressing the V key, or by right-clicking the Node Editor to
access the Options submenu of the contextual menu.

The Navigator pane for accessing offscreen parameters or tools

There are other standard methods of panning and zooming around the Node Editor.
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Methods of navigating the Node Editor:

— Middle-click and drag to pan around the Node Editor.

— Hold down Shift and Command and drag the Node Editor to pan.

— Press the Middle and Left mouse buttons simultaneously and drag to resize the Node Editor.

— Hold down the Command key, and use your mouse’s scroll control to resize the Node Editor.

— Right-click the Node Editor and choose an option from the Scale submenu of the contextual menu.
— Press Command-1 to reset the Node Editor to its default size.

— Drag two fingers on a track pad to pan.

— Hold the Command key down and drag two fingers on a track pad to resize the Node Editor.

Alternative Node View Layout presets located in the Fusion page allow for positioning the Node Editor
vertically, either alongside the Inspector, or along the left side of the screen. This can be very helpful
when animating in the Spline Editor or Keyframes Editor.

When in the Fusion page, you can choose the layouts from Workspace > Layout Presets. Choosing a
vertical layout allows the node tree to flow from top to bottom, leaving much more room along the
lower half of the screen for the Spline Editor or Keyframes Editor.

The Mid Flow Vertical layout preset used with the Vertical Flow direction setting.

When using the vertical layouts, enabling the Flow > Build Direction > Vertical option in the Fusion
settings will cause all new Node trees to build vertically, leaving maximum room for Fusion’s
animation tools.

You can then save alternative layouts based on these two vertical presets using the Workspace >
Layout Presets submenu.
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When you want to return to the default horizontal Node Editor layout, just choose Workspace > Layout
Presets > Fusion Presets > Default.

These Layout options are not available in Fusion Studio, however, you can use the Floating Frame to
position the Node Editor wherever you like.

As you work, it's important to keep the node trees that you create tidy to facilitate a clear
understanding of what's happening. Fortunately, the Fusion Node Editor provides a variety of
methods and options to help you with this, found within the Options and Arrange Tools submenus of
the Node Editor contextual menu.

Status Bar

The Status bar in the lower-left corner of the Fusion window shows you a variety of up-to-date
information about things you're selecting and what's happening in Fusion. For example, hovering the
pointer over a node displays information about that node in the Status bar. Additionally, the currently
achieved frame rate appears whenever you initiate playback, and the percentage of the RAM cache
that's used appears at all times. Other information, updates, and warnings appear in this area

as you work.

BAND
Medialn1 (Media In, M)
Imitter1 pTurbulencel
Domain: HiQ
Image: (0, 0) - (1920, 1080)
DoD: (0, 0) - (1920, 1080)

Frame Size (1920, 1080) . M

Pixel Aspect 1:1 r " ImagePlane3D2
Depth 16bit float (GPU) —_—

Data: (0, 0) - (1920, 1080

The Status bar under the Node Editor showing you information about a node
under the pointer, as well as a popup box with even more relevant info.

Occasionally the Status bar will display a badge to let you know there’'s a message in the console you
might be interested in. The message could be a log, script message, or error.

A notification that there’s a message in the Console
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Effects Library

The Effects Library in Fusion shows all the nodes and effects available in Fusion, including third-party
OFX plugins, if installed. If you are using DaVinci Resolve, Resolve FX also appear in the OFX category.
While the toolbar shows many of the most common nodes you'll use in any composite, the Effects
Library contains every single tool available in Fusion, organized by category, with each node ready to
be quickly added to the Node Editor. Suffice it to say that there are many, many more nodes available
in the Effects Library than on the toolbar, spanning a wide range of uses.

Shaders

Transform

The Effects Library with Tools open The Templates section of the Effects Library

The hierarchical category browser of the Effects Library is divided into several sections depending

on whether you are using Fusion Studio or the Fusion page within DaVinci Resolve. The Tools section
is the most often used since it contains every node that represents an elemental image-processing
operation in Fusion. Hovering the pointer over a specific tool will reveal a tool-tip explaining its
functionality at the bottom right of the DaVinci Resolve interface. The OpenFX section contains third-
party plugins, and if you are using the Fusion page, it also contains ResolveFX, which are included
with DaVinci Resolve. A third section, only visible when using the Fusion page in DaVinci Resolve, is the
Templates section. The Template section contains a variety of additional content including templates
for Lens Flares, Backgrounds, Generators, Particle Systems, Shaders (for texturing 3D objects), and
other resources for use in your composites.

The Effects Library’s list can be made full height or half height using a button at the far left of
the UI toolbar.
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The Inspector

The Inspector is a panel on the right side of the Fusion window that you use to display and manipulate
the parameters of one or more selected nodes. When a node is selected in the Node Editor, its
parameters and settings appear in the Inspector.

Inspector

Polygon4

Gaussian

Inspector

Perturb1

0.05293

Alternate

The Inspector shows parameters from The Modifier panel
one or more selected nodes. showing a Perturb modifier

The Fusion Inspector is divided into two panels. The Tools panel is the main panel that shows you

the parameters of selected nodes. The Modifiers panel shows optional extensions to the standard
parameters of a tool. In the following image, a Perturb modifier has been added to a parameter to add
random animation to that parameter, and the controls found on the Modifier panel let you customize
what kind of randomness is being added.

Other nodes display node-specific items here. For example, Paint nodes show each brush
stroke as an individual set of controls in the Modifiers panel, available for further editing
or animating.

A cluster of controls appears at the top of every node’s controls in the Inspector.

Camera3D1

Common Inspector controls
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Set Color: A pop-up menu that lets you assign one of 16 colors to a node, overriding a
node’s own color.

Versions: Clicking Versions reveals another toolbar with six buttons. Each button can
hold an individual set of adjustments for that node that you can use to store multiple
versions of an effect.

Pin: The Inspector is also capable of simultaneously displaying all parameters for
multiple nodes you've selected in the Node Editor. Furthermore, a Pin button in the
title bar of each node’s parameters lets you “pin” that node’s parameters into the
Inspector so that they remain there even when that node is deselected, which is
valuable for key nodes that you need to adjust even while inspecting other nodes of

your composition.

Lock: Locks that node so that no changes can be made to it.

Reset: Resets all parameters within that node.

Many nodes expose multiple tabs’ worth of controls in the Inspector, seen as icons at the top of the
parameter section for each node. Click any tab to expose that set of controls.

GroundPlane

= ;
+

Controls Material Transform Settings

Nodes with several tabs’ worth of parameters

Keyframes Editor

The Keyframes Editor displays each node in the current composition as a stack of layers within a
miniature timeline. The order of the layers is largely irrelevant as the order and flow of connections
in the node tree dictate the order of image-processing operations. You use the Keyframes Editor to
trim, extend, or slide Loader, Medialn, and effects nodes, or to adjust the timing of keyframes, which
appear superimposed over each effect node unless you open them up into their editable track.
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| MOVEMENT!

Medialn1

The Keyframes Editor is used to adjust the timing of clips, effects, and keyframes.

At the top, a series of zoom and framing controls let you adjust the work area containing the layers.

These controls let you manipulate the Keyframes Editor view.

A Horizontal zoom control lets you scale the size of the editor.
— A Zoom to Fit button fits the width of all layers to the current width of the Keyframes Editor.

— A Zoom to Rect tool lets you draw a rectangle to define an area of the Keyframes
Editor to zoom into.

— A Sort pop-up menu lets you sort or filter the tracks in various ways.

— An Option menu provides access to many other ways of filtering tracks and
controlling visible options.

Atimeline ruler provides a time reference, as well as a place in which you can scrub the playhead.

At the left, a track header contains the name of each layer, as well as controls governing that layer.
— Alock button lets you prevent a particular layer from being changed.

— Nodes that have been keyframed have a disclosure control, which when opened displays a
keyframe track for each animated parameter.

In the middle, the actual editing area displays all layers and keyframe tracks available in the
current composition.

At the bottom-left, Time Stretch and Spreadsheet mode controls provide additional ways
to manipulate keyframes.
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At the bottom right, the Time/TOffset/TScale drop-down menu and value fields let you numerically
alter the position of selected keyframes either absolutely, relatively, or based on their distance from
the playhead.

Each Loader or Medialn node that represents a clip used in a composition is represented as a layer

in this miniature timeline. You can edit a layer’s In or Out points by positioning the pointer over the
beginning or end of a segment and using the resize cursor to drag that point to a new location. You
can slide a layer by dragging it to the left or right, to better line up with the timing of other elements in
your composition.

The Keyframes Editor also lets you adjust the timing of elements that you've added from directly

within Fusion.

Each effect node also appears as a layer, just like clips. You can resize the In and Out points of an
effect layer, and slide the entire layer forward or backward in time, just like a Loader or Medialn
layers. If you trim an effect layer to be shorter than the duration of the composition, the effect cuts in
at whichever frame the layer begins, and cuts out after the last frame of that layer, just like a clip on

a timeline.

When you've animated an effect by adding keyframes to a parameter in the Inspector, the Keyframes
Editor is used to edit the timing of keyframes easily. By default, all keyframes applied to parameters
within a particular node’s layer appear superimposed in one flat track over the top of that layer.

To edit keyframes, you can click the disclosure control to the left of any animated layer’'s name in the
track header, which opens up keyframe tracks for every keyframed parameter within that layer.

Keyframe tracks exposed

Keyframe Editing Essentials

Here's a short list of keyframe editing methods that will get you started.

Methods of adjusting keyframes:

— You can click on a single keyframe to select it.

— You can drag a bounding box over a series of keyframes to select them all.
— You can drag keyframes left and right to reposition them in time.

— You can right-click one or more selected keyframes and use commands from the drop-down menu
to change keyframe interpolation, copy/paste keyframes, or even create new keyframes.

— You can Command-drag one or more selected keyframes to drag a duplicate of them to another
position in the keyframe track.
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To change the position of a keyframe using the toolbar, do one of the following:
— Select a keyframe, and then enter a new frame number in the Time Edit box.

— Choose T Offset from the Time Editor pop-up, select one or more keyframes, and enter a
frame offset.

— Choose T Scale from the Time Editor pop-up, select one or more keyframes, and enter a multiplier
added to the current playhead frame position. For instance, if the playhead is on frame 10 and the
keyframe is on frame 30, entering the TScale value of 2 will position the keyframe on frame 50. The
distance between the playhead and original keyframe is 20, so (20 x 2) = 40, which is then added to
the playhead position.

Time Stretching Keyframes

If you select a range of keyframes in a keyframe track, you can turn on the Time Stretch tool to show

a box used to squeeze and stretch the entire range of keyframes relative to one another. The Time
Stretcher changes the overall timing of a sequence of keyframes without losing the relative timing
from one keyframe to the next. Alternatively, you can turn on Time Stretch and draw a bounding box
around the keyframes you want to adjust to create a time-stretching boundary that way. Click the Time
Stretch tool again to turn it off.

Merge2

Center : Path1 : Displacement

Time stretching keyframes

The Keyframe Spreadsheet

If you turn on the Spreadsheet and then click on the name of a layer in the keyframe track, the
numeric time position and value (or values if it's a multi-dimensional parameter) of each keyframe
appear as entries in the cells of the Spreadsheet. Each column represents one keyframe, while each
row represents a single aspect of each keyframe.

Center : Path1 : Displacement

Editing keyframes in the Spreadsheet
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For example, if you're animating a motion path, then the “Key Frame” row shows the frame each
keyframe is positioned at, and the “Path1Displacement” row shows the position along the path at each
keyframe. If you change the Key Frame value of any keyframe, you'll move that keyframe to a new
frame of the Timeline.

Spline Editor

The Spline Editor provides a more detailed environment for editing the timing, value, and interpolation
of keyframes. Using control points at each keyframe connected by splines (also called curves), you

can adjust how animated values change over time. The Spline Editor has four main areas: the Zoom
and Framing controls at the top, the Parameter list at the left, the Graph Editor in the middle, and the
toolbar at the bottom.

spline

v  pTurbulencel

v st

The Spline Editor is divided into the Zoom controls at top,
Parameter list at left, Graph Editor, and toolbar.

At the top, a series of Zoom and Framing controls let you adjust the work area containing the curves.

— Vertical and horizontal zoom controls let you scale the size of the editor.
— A Zoom to Fit button fits the width of all curves to the current width of the Spline Editor.

— A Zoom to Rect tool lets you draw a rectangle to define an area of the Spline Editor to zoom into.

A Timeline ruler provides a time reference, as well as a place in which you can scrub the playhead.

The Parameter list at the left is where you decide which splines are visible in the Graph view. By
default, the Parameter list shows every parameter of every node in a hierarchical list. Checkboxes
beside each name are used to show or hide the curves for different keyframed parameters. Color

controls let you customize each spline’s tint to make splines easier to see in a crowded situation.

The Graph view that takes up most of this panel shows the animation spline along two axes. The
horizontal axis represents time, and the vertical axis represents the spline’s value. Selected control
points show their values in the edit fields at the bottom of the graph.

Lastly, the toolbar at the bottom of the Spline Editor provides controls to set control point
interpolation, spline looping, or choose Spline editing tools for different purposes.

Exploring the Fusion Interface

47




Before you start editing splines to customize or create animation, you need to choose which
parameter’s splines you want to work on.

To show every parameter in every node:

— Click the Splines Editor Option menu and choose Expose All Controls. Toggle this control off again
to go back to viewing what you were looking at before.

To show splines for the currently selected node:

— Click the Splines Editor Option menu and choose Show Only Selected Tool.

The Spline Editor is a deep and sophisticated environment for keyframe and spline editing
and retiming, but the following overview will get you started using this tool for creating and

refining animation.

To select one or more control points:
— Click any control point to select it.
— Command-click multiple control points to select them.

— Drag a bounding box around multiple control points to select them as a group.

To edit control points and splines:
— Click anywhere on a spline to add a control point.
— Drag one or more selected control points to reshape the spline.

— Shift-drag a control point to constrain its motion vertically or horizontally.

To edit Bézier curves:
— Select any control point to make its Bézier handles visible, and drag the Bézier handles.

— Command-drag a Bézier handle to break the angle between the left and right handles.

To delete control points:

— Select one or more control points and press the Delete or Backspace key.

The Spline Editor toolbar at the bottom contains a mix of control point interpolation buttons, Spline
loop modes, and Spline editing tools.

Control Point Interpolation

The first six buttons let you adjust the interpolation of one or more selected control points.

Control point interpolation controls
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Smooth: Creates automatically adjusted Bézier curves to create smoothly
interpolating animation.

Linear: Creates linear interpolation between control points.

Invert: Inverts the vertical position of non-animated LUT splines. This does not operate
on animation splines.

Step In: For each keyframe, creates sudden changes in value at the next keyframe
to the right. Similar to a hold keyframe in After Effects® or a static keyframe in the
DaVinci Resolve Color page.

Step Out: Creates sudden changes in value at every keyframe for which there's a change
in value at the next keyframe to the right. Similar to a hold keyframe in After Effects or a
static keyframe in the DaVinci Resolve Color page.

Reverse: Reverses the horizontal position of selected keyframes in time, so the keyframes
are backward.

Spline Loop Modes

The next three buttons let you set up spline looping after the last control point on a parameter’s

spline, enabling a limited pattern of keyframes to animate over a far longer duration. Only the control

points you've selected are looped.

Spline Loop modes

Set Loop: Repeats the same pattern of keyframes over and over.

Set Ping Pong: Repeats a reversed set of the selected keyframes and then a duplicate set
of the selected keyframes to create a more seamless pattern of animation.

Set Relative: Repeats the same pattern of selected keyframes but with the values of
each repeated pattern of keyframes being incremented or decremented by the trend of
all keyframes in the selection. This results in a loop of keyframes where the value either
steadily increases or decreases with each subsequent loop.
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Spline Editing Tools

The next five buttons provide specialized Spline editing tools.

Click Append: Click once to select this tool and click again to de-select it. This tool
lets you add or adjust keyframes and spline segments (sections of splines between
two keyframes), depending on the keyframe mode you're in. With Smooth or Linear
keyframes, clicking anywhere above or below a spline segment adds a new keyframe
to the segment at the location where you clicked. With Step In or Step Out keyframes,
clicking anywhere above or below a line segment moves that segment to where
you've clicked.

Time Stretch: If you select a range of keyframes, you can turn on the Time Stretch tool
to show a box you can use to squeeze and stretch the entire range of keyframes relative
to one another, to change the overall timing of a sequence of keyframes without losing
the relative timing from one keyframe to the next. Alternatively, you can turn on Time
Stretch and draw a bounding box around the keyframes you want to adjust to create a
time-stretching boundary that way. Click Time Stretch a second time to turn it off.

Shape Box: Turn on the Shape Box to draw a bounding box around a group of control
points you want to adjust in order to horizontally squish and stretch (using the top/
bottom/left/right handles), corner pin (using the corner handles), move (dragging on the
box boundary), or corner stretch (Command-drag the corner handles).

Show Key Markers: Turning on this control shows keyframes in the top ruler that
correspond to the frame at which each visible control point appears. The colors of these
keyframes correspond to the color of the control points they're indicating.

Thumbnail Timeline in
the Fusion Page

In the Fusion page of DaVinci Resolve, the Thumbnail timeline (hidden by default) can be opened by

clicking the Clips button in the Ul toolbar and appears underneath the Node Editor when it's open.

The Thumbnail timeline shows every clip in the current Timeline, giving you a way to navigate from

one clip to another. Each thumbnail has a pop-up menu for creating and switching among multiple

versions of compositions, and resetting the current composition, when necessary.
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The Thumbnail timeline lets you navigate the Timeline and manage versions of compositions.

Right-clicking on any thumbnail exposes a contextual menu.

3:42:02:22 % 19:27:19:01

The contextual menu for the Thumbnail timeline

To open another clip:

— Click any thumbnail to jump to that clip's composition. The current clip is outlined in orange.

To navigate the Thumbnail timeline:
— Middle-click and drag the Timeline left or right to scroll through the clips in the Timeline.

— Click and drag the slider at the bottom of the Thumbnail timeline to scroll through the
clips in the Timeline.

To create and manage versions of compositions:

— To create a new version of a composition: Right-click the current thumbnail, and choose Create
New Composition from the contextual menu.

— To load a different composition: Right-click the current thumbnail, and choose “NameOfVersion”
> Load from the contextual menu.

— To delete a composition: Right-click the current thumbnail, and choose “NameOfVersion” > Delete
from the contextual menu.

— To rename a composition: Right-click the current thumbnail, and choose “NameOfVersion"” >
Rename from the contextual menu.

To reset the current composition:

— Right-click the current thumbnail, and choose Reset Current Composition from the
contextual menu.

To change how thumbnails are identified:

— Double-click the area underneath any thumbnail to toggle among clip format, clip name, and the
composition version name.
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The Media Pool in the Fusion Page

In DaVinci Resolve's Fusion page, the Media Pool continues to serve its purpose as the repository
of all media you've imported into your project. This makes it easy to add additional clips to your
compositions simply by dragging the clip you want from the Media Pool into the Node Editor.

The media you add appears as a new Medialn node in your composition, ready to be integrated into
your node tree however you need it.

Pirate Dailies

The Media Pool in Thumbnail mode showing video clips

TIP: If you drag one or more clips from the Media Pool onto a connection line between two
nodes in the Node Editor, the clips are automatically connected to that line via enough Merge
nodes to connect them all.

For more information on using the myriad features of the Media Pool, see Chapter 18, “Adding and
Organizing Media with the Media Pool,” in DaVinci Resolve Reference manual.

If you find yourself in the Fusion page and you need to quickly import a few clips for immediate use,
you can do so in a couple of different ways.

To add media by dragging one or more clips from the Finder to
the Fusion page Media Pool (macOS only):

Select one or more clips in the Finder.

Drag those clips into the Media Pool of DaVinci Resolve, or to a bin in the Bin list. Those clips are

added to the Media Pool of your project.
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To use the Import Media command in the Fusion page Media Pool:
With the Fusion page open, right-click anywhere in the Media Pool, and choose Import Media.

Use the Import dialog to select one or more clips to import, and click Open. Those clips are added
to the Media Pool of your project.

For more information on importing media using the myriad features of the Media page,
see Chapter 18, "Adding and Organizing Media with the Media Pool,” in DaVinci Resolve
Reference manual.

Bins in Fusion Studio

Bins in Fusion Studio are similar to the Media Pool in DaVinci Resolve. Bins are organizational panels
that provide an easy way of accessing commonly used tools, settings, macros, compositions, and
media content. They can keep all your custom content and resources close at hand, so you can use
them without searching through your hard drives. Bins can also be shared over a network to improve
a collaborative workflow with other Fusion Studio artists.

[N
> Library on localhost

The Bins window

To open the Bins window:

— Choose File > Bins from the menu bar.

Similar to the Media Pool in DaVinci Resolve, when adding an item to the Fusion bins, a link is created

between the item on disk and the bins. Fusion does not copy the file into its own cache or hard drive
space. The file remains in its original format and in its original location.
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The Bins window is actually a separate application used to save content you may want to reuse at a
later time. The Bins window is separated into two panels. The sidebar on the left is a bin list where
items are placed into categories, while the panel on the right displays the selected bin’s content.

\E Library on localhost
& :

The Bin list sidebar

The Bin list organizes content into bins or folders using a hierarchical List view. These folders can be
organized to suit your workflow, but standard folders are provided for Clips, Compositions, Favorites,
Settings, and Tools. Parent folders contain subfolders that hold the content. For instance, the Tools bin
is a parent folder to all the categories of tools. To access subfolders, click the disclosure arrow to the
left of the parent folder’s name.

When you select a bin from the bin list, the contents of the folder are displayed in the Contents panel

as thumbnail icons.

The Bins icon view

A toolbar along the bottom of the bin provides access to organization, playback, and editing controls.

Exploring the Fusion Interface

54




The Bins toolbar

— New Folder: Creates a new folder in the current window.

— New Reel: Creates an empty reel that can contain multiple clips edited together into a timeline.
— New Clip: Opens a dialog to link a new media file into a bin.

— Studio Player: Opens a playback viewer for a selected clip.

— Icon/List view: This button toggles between showing contents of a bin in thumbnail view
and list view.

— Checkerboard: Shows a checkerboard pattern in a clip thumbnail to signify transparency.

— Thumbnail size: Provides a few preset sizes for thumbnail icons.

Right-clicking in any area of the bin window displays a pop-up menu to access most of a bin's features.
Right-clicking on an item in a bin shows the same menu with additional options for renaming, playing,
or deleting the item.

Selecting a clip in a bin and clicking the Studio Player button or double-clicking the clip opens the
Studio Player. The Studio Player can be used to view clips, view metadata, and add notes.

The Bin Studio Player

For more information on Bins, see “Bins in Fusion Studio.”
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The Console

The Console is a window in which you can see the error, log, script, and input messages that may
explain something Fusion is trying to do in greater detail. The Console is also where you can read
FusionScript outputs, or input FusionScripts directly. In DaVinci Resolve, the Console is available by
choosing Workspace > Console or choosing View > Console in Fusion Studio. There is also a Console
button in the Fusion Studio User Interface toolbar.

Occasionally the Status bar displays a badge to let you know there’s a message in the Console you
might be interested in.

Fusion Build: Apr

The Console window

A toolbar at the top of the Console contains controls governing what the Console shows. At the

top left, the Clear Screen button clears the contents of the Console. The next four buttons toggle

the visibility of error messages, log messages, script messages, and input echoing. Showing only a
particular kind of message can help you find what you're looking for when you're under the gun at
3:00 in the morning. The next three buttons let you choose the input script language. Lua 5.1 is the
default and is installed with Fusion. Python 2.x and Python 3.x require that you install the appropriate
Python environment on your computer. Because scripts in the Console are executed immediately, you
can switch between input languages at any time.

At the bottom of the Console is an Entry field. You can type scripting commands here for execution in
the current comp context. Scripts are entered one line at a time, and are executed immediately. For

more information on scripting, see the Fusion Scripting Manual.
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Customizing Fusion

This section explains how you can customize Fusion to accommodate whatever workflow
you're pursuing.

Fusion has its own settings window, accessible by choosing Fusion > Fusion Settings in

DaVinci Resolve, or in Fusion Studio by choosing Fusion > Preferences on macOS or File > Preferences
on Windows or Linux. This window has a variety of options for customizing the Fusion experience.
For more information, see Chapter 13, “Preferences,” in the Fusion Reference Manual or Chapter 75 in

the DaVinci Resolve Reference Manual.

(@ @& Fusion Settings

General

The Fusion Settings window set to the General panel

Saving Fusion Layouts

It is possible to customize the layout and configuration of panels to suit the size of the desktop and

monitor, or to match personal preferences.

In DaVinci Resolve, configure and resize the panels you want displayed and then:

— Choose Workspace > Layout Presets > Save Layout Presets.

Exploring the Fusion Interface 57




In Fusion Studio, configure and resize the panels you want displayed and then:

— Click the Grab Document Layout button in the Preferences > Layout panel to save the layout for all
new Compositions.

— Click the Grab Program Layout button to remember the size and position of any floating views,
and enable the Create Floating Views checkbox to automatically create the floating windows when
Fusion restarts.

The Ul toolbar at the top of the screen lets you open panels you need and hide those you don't. It's
the simplest way to create a layout for your particular needs at the moment.

Greenscreen Example “juSpine & Keyframes tadat 3% Inspector

The Ul toolbar of the Fusion page

You can change the overall size of each panel using preset configurations, or you can adjust them
manually. The viewers and Work panel are inverse of each other. The more space used to display the
Work panel, the less space available for the viewers. To resize a panel, manually drag anywhere along
the raised border surrounding the edges of the panel.

Dragging the edge between
two viewers to resize it

Fusion Studio includes a Floating Frame window that can be used to house any panel.

To place a panel in the Floating Frame, do the following:
In Fusion Studio, choose Window > New Floating Frame.

Right-click in the Floating Frame and choose the panel from Add View submenu.

When using multiple monitors, you can choose to have floating panels spread across your displays for

greater flexibility.
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Fusion Keyboard Remapping

When using the Fusion page, functions and tools can be mapped to hot keys on your keyboard by
choosing DaVinci Resolve > Keyboard Customization. In the Commands column of the Keyboard
Customization window, select Panels > Fusion Page.

For more information on using the Keyboard Customization window, see Chapter 4, “System and User
Preferences,” in DaVinci Resolve Reference manual.

Fusion Studio Keyboard Remapping

When using Fusion Studio, functions and tools can be mapped to hot keys on your keyboard by
choosing Views > Customize Hotkeys.

The Fusion Hotkey Manager dialog is divided into two sections. The left is where you select the
functional area where you want to assign a keyboard shortcut. The right side displays the keyboard
shortcut if one exists. You can use the New button at the bottom of the dialog to add a new
keyboard shortcut.

Edit Hotkey

Merge 3D

The Fusion Studio Hotkey Manager window

For instance, if you want to add a shortcut for a specific node:

Open the Keyboard Hotkey Manager.
Select Views > Effect from the Target area of the Hotkey Manager.
Below the Key/Action area, click the New button to create a new keyboard shortcut for the Node.

In the Edit Hotkey window, click the Tools disclosure arrow, and then select Blur to display all the
Blur-related nodes.

Select Glow in the Action panel.

At the top of the Edit Hotkey window, type G as the shortcut for the Glow node, and then click OK.
Glow and the G hotkey will now appear in the Key/Action area on the right.

Click OK to close the Hotkey Manager.

Click in the Node Editor and press G to add a Glow node.
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Undo and Redo

Undo and Redo commands let you back out of steps you've taken or commands you've executed and
reapply them if you change your mind. Fusion is capable of undoing the entire history of things you've
done since creating or opening a particular project. When you close a project, its entire undo history
is purged. The next time you begin work on a project, its undo history starts anew.

There is no practical limit to the number of steps that are undoable (although there may be a limit to

what you can remember).

To simply undo or redo changes you’'ve made one at a time:
— Choose Edit > Undo (Command-Z) to undo the previous change.

— Choose Edit > Redo (Shift-Command-Z) to redo to the next change.
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Getting Clips

into Fusion

This chapter details the various ways you can move clips

into Fusion as you build your compositions.
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Preparing Compositions
in the Fusion Page

Ordinarily, clips come into the Fusion page from the Edit or Cut page Timeline as either a single clip,

or as multiple layers contained within a Fusion clip. You can also add clips to a composition directly
from DaVinci Resolve’'s Media Pool. How clips find their way into a Fusion composition can determine
how they function within that composition and what resolution that composition outputs to the rest of

DaVinci Resolve.

Positioning the playhead over a clip in the Edit page or Cut page Timeline and clicking the Fusion
page button causes that clip to appear in the Fusion page as a single Medialn node connected to a
MediaOut node. Only the topmost visible clip is taken into Fusion. Clips that aren't visible because
they're on lower tracks with clips above them are ignored, unless you disable the clips or tracks that
appear above. These very simple default compositions are referred to unofficially in this manual as

“single-clip compositions.”

The Medialn node represents the image that's fed to the Fusion page for further work, and the
MediaOut node represents the final output that's fed onward to the Color page for grading.

Medialn1 e MediaOut1

The default node tree that appears when you first open
the Fusion page while the playhead is parked on a clip.

This initial node structure makes it easy to quickly use the Fusion page to create relatively simple
effects using the procedural flexibility of node-based compositing.

For example, if you have a clip that's an establishing shot, with no camera motion, that needs some
fast paint to cover up a bit of garbage in the background, you can open the Fusion page, add a Paint

node, and use the Clone mode of the Stroke tool to paint it out quickly.

Mediain1 m—p Paintl - MediaOut1 [

A simple paint effect applied to a shot with no camera motion.

TIP: The resolution of a single clip brought into Fusion via the Edit or Cut page Timeline is the

resolution of the source clip, not the Timeline resolution.
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Once you've finished, simply go back to the Edit or Cut page and continue editing, because the

entire Fusion composition is encapsulated within that clip, similarly to how grades in the Color page
are also encapsulated within a clip. However you slip, slide, ripple, roll, or resize that clip, the Fusion
effects you've created and the Color page grades you've made follow that clip’s journey through your

edited Timeline.

TIP: While you'll likely want to do all the compositing for a greenscreen style effect in the
Fusion page, it's also possible to add a keyer, such as the excellent DeltaKeyer node, between
the Medialn and MediaOut nodes, all by itself. When you pull a key this way, the alpha channel
is added to the MediaOut node, so your clip on the Edit page has transparency, letting you
add a background clip on a lower track of your Edit page Timeline.

How Nodes Are Named
While the documentation refers to nodes by their reqular name, such as “Medialn,” the actual names
of nodes in the Fusion Node Editor have a number appended to them, to indicate which node is which

when you have multiple instances of a particular type of node.

For situations where you know you're creating a more ambitious composited effect that requires
multiple layers edited together with very specific timings, you can create a “Fusion clip” right from the
Timeline. For example, if you have a foreground greenscreen clip, a background clip, and an additional
graphic clip, you can stack them all on the Timeline as superimposed clips. You can then use the Edit
page slip and slide features to align their timings so they work together as necessary. You can also
edit multiple consecutive clips together that you want to use in a composition as a series of clips. Once
that's done, you can select every clip in the stack to create a Fusion clip, so you can easily use all these

superimposed layers within a Fusion composite.

To create a Fusion clip:
Edit all the clips you want to use in the Edit page Timeline.
Select all clips you want to be in the same composite at once.
Right-click one of the selected clips and choose New Fusion Clip from the contextual menu.

A new clip, named “Fusion Clip X" (where X is an automatically incrementing number) appears in the

currently selected bin of the Media Pool and in the Timeline to replace the previously selected clips.

With the playhead parked over that clip, open the Fusion page to see the new arrangement of

those clips in the Fusion page Node Editor.

Getting Clips into Fusion 63




01:00:00:00

vz Video3
= O

Video 1

= O

€2 Depasitphotas [77195177-77195177)_original,jpg
Al Audio 1

01:00:00:00

V3 Video3
= O

Video 1

B O

Al Audio 1

A stack of clips to use in a composite (Top), and turning that stack
into a Fusion clip in the Edit page (Bottom).

The nice thing about creating a Fusion clip is that every superimposed clip in a stack is automatically
connected into a cascading series of Merge nodes that create the desired arrangement of clips. Note
that whatever clips were in the bottom of the stack in the Edit page appear at the top of the Node
Editor in the Fusion page, but the arrangement of background and foreground input connections is
appropriate to recreate the same compositional order.

Medialn1

Medialn2

Medialn3 - MediaOut1 ]

The initial node tree of the three clips we turned into a Fusion clip.
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TIP: Fusion clips change the working resolution of the individual clips to match the Timeline
resolution. For instance, if two 4K clips are stacked one on top of the other in an HD Timeline,
creating a Fusion clip resizes the clips to HD. The full resolution of the individual 4K clips is not
available in Fusion. To maintain the full resolution of course clips, bring only one clip into the
Fusion composition from the Edit or Cut page Timeline, and then bring other clips into the
Fusion composition using the Media Pool.

There is a newer powerful way of applying Fusion composites to your clips called a “Referenced
Composition.” This method allows you to reuse your work across multiple clips or even timelines.

You create a referenced composition on the Edit page by selecting a single clip, or a stack of clips,
and then select “Create Referenced Composition” from the contextual menu. This generates a Fusion
Referenced Composition in the Media Pool. You can enter the Fusion page to start compositing or

double-click the Referenced Composition in the Media Pool to open it.

Referenced comps can be linked to other clips in any timeline by selecting the referenced comp,
then right-clicking the target clip and selecting “Link to Referenced Composition.” Any changes
you make are applied across all connected clips because they are all “referred” or "linked” to

the same composition.

Referenced Compositions are an effective and secure way to keep your work backed up and
organized, as they live in the Media Pool and will persist even if the original referenced clip is deleted
from the timeline.

Creating and Managing Referenced Compositions

To create a Referenced Composition:

Select one or more timeline clips that are “stacked” on tracks in an Edit window timeline (clips have

to overlap in time at least partially).
Right-click and select “Create Referenced Fusion Composition.”

The new reference composition, associated with the top selected clip, now appears in the
Media Pool.

You can open the referenced composition in the Fusion page by double-clicking on it in the
Media Pool. Media nodes match the relative locations of the source track clip arrangement in the
Edit timeline.

The contents of the video track are treated as a source, allowing creative manipulation of clips before

they're passed on to Fusion for compositing.

You can right-click on a referenced composition in the Media Pool and choose the Usage option to
view and navigate to its target linked clips.

You can duplicate your referenced composition for iteration purposes.

In the example below we create a simple reference composition out of three clips, replacing a logo
on a truck.
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Creating a reference composition by selecting multiple overlapping clips, and
then Create Referenced Composition from the contextual menu.

Final Truck_ S...

The Reference Composition
thumbnail in the Media Pool

Double-clicking on the Reference Node brings us into Fusion, where we add some Corner Positioner
nodes to line up the green stripe and logos to fit.

Medialn1

Medialn2 - CornerPasitioner1

MediaOut1

Medialn3 B ——— CornerPositioner1_1
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Now that we have the referenced composition set, we can easily change the logo, just by performing
a replace edit with the new logo to V3 in the timeline. The new logo is automatically applied in the

Fusion comp with the same settings.

01:00:00:00

Medialn2 m—p  CornerPositioner1

MediaOut1

Medialn3 B —— e ——— CornerPositioner1_1

Adding Additional Referenced Clips

Once you've established a referenced composition, you can add clip(s) that can use the referenced
composition to affect the other clips.

To add clip references to a referenced composition:
Select the referenced composition that you want to refer to another clip.
Select a target clip in the timeline, right click and choose “Link to Referenced Composition.”

Add other clips, one a time if you wish, including clips from other timelines.
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Referenced Composition Behaviors and Rules
There are some additional behaviors and rules to be aware of when using referenced compositions.
— Referenced compositions maintain the original source resolution of your clips.

— When selecting multiple clips, ensure that the clips have some overlap with the top selected clip.
Without this overlap, the context menu action to create a referenced composition across layers is
not available.

— When creating a project composition from multiple overlapping clips, a single composition

associated with the top selected clip is created.

— The referenced composition features additional Media In nodes (one per track). Media In 1 refers to
the top selected clip. Subsequent Media In nodes reference timeline tracks (layers) below the top clip.

— Removing a timeline clip will not remove the associated composition.

— When you edit the contents in a referenced composition’s track, the corresponding Media In

refreshes to automatically to show the new clips, edits, effects, and transitions.

From the timeline clip’s context menu, you can:

To reset the composition. This affects all referenced clips.
To remove the composition reference from the selected clip.
This retains the composition in the Media Pool, but the clip effect is cleared. Useful if you want to
link to another referenced composition.

To find the reference composition the clip is a part of
in the Media Pool.

NOTE: Clips of differing frame rates or clips with speed changes are not supported in
referenced compositions.

The Generator category of the Edit page Effects Library has a Fusion Composition generator. It's
useful for creating an empty placeholder in the Timeline that you later want to work on in the Fusion
page to create a more fully-featured Fusion composition.

To create a blank Fusion clip in the Edit page:
Open the Effects Library, and select the Effects category.
Edit a Fusion Composition clip into the Timeline in whichever way is most convenient.

You can drag a Fusion Composition clip into the Timeline, which will result in a clip that's the
length of the “Standard generator duration” preference, which is 5 seconds by default.
You can set In and Out points in the Timeline, and drag the Fusion Composition clip onto any

of the editing overlays of the Timeline viewer to perform that sort of edit to insert, overwrite,
“place on top,” or ripple overwrite it into a specific place in the Timeline, for a specific duration.

A new clip named “Fusion Composition” appears in the Timeline. It initially displays only black in the
Timeline viewer, since it's a blank composition with no contents.

With the playhead parked over that clip, open the Fusion page. Since this composition is blank,
there's only a single MediaOut node in the Node Editor. At this point, you can add whatever media,
generators, and other effects you require.
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You can create an empty Fusion Composition clip in any bin in the Media Pool without creating a
Timeline. This method can be useful for creating motion graphics or titles when there is no Timeline or
when you plan on using the clip in multiple Timelines.

To create a blank Fusion Composition clip in a bin:

Select the bin in the Media Pool where you want to save the Fusion Composition.

Right click in an empty area of the bin and choose New Fusion Composition.

In the New Fusion Composition clip dialog, enter a Name for the clip, a duration, and a frame rate,
and then click Create.

The clip will appear in the bin. To open it in Fusion, do one of the following:
— Double-click the Fusion Composition

— Right-click over the Fusion Composition clip and choose Open in Fusion Page

To reset a Fusion clip back to its initial default state, right-click on the Fusion clip in the Edit page
Timeline, and select Reset Fusion Composition. You can select multiple Fusion clips and reset
them at once.

Specific Fusion transitions are available in the Edit page Effects Library. You can use these transitions
to bring two clips and the transition between them into the Fusion Page. These transitions can then be
modified and saved back to the Edit page Timelines or saved as a new, reusable Fusion Transition that
appears in the Edit Page Effects llbrary.

To apply and open a Fusion Transition:
Open the Effects Library, and select the Video Transitions category.

Scroll to the bottom of the transition list and drag one of the Fusion Transitions onto a cut in

the Timeline.

Right-click over the Fusion Transition in the Timeline and choose Open in Fusion Page.

The Fusion page opens with two Medialn nodes representing the two sides of the transitions.

The Medialn nodes connect to a cross dissolve or a group of nodes used to create the transition. At
this point, you can modify the transition using masks or other nodes and return to the Edit page to
see the results.
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A Noise Dissolve Transition opened in the Fusion page.

To learn about creating custom Fusion Transitions that appear in the Effects Library, see Chapter 6,
“Node Groups, Macros, and Fusion Templates.” in the Fusion Reference Manual or Chapter 68 in the
DaVinci Resolve Reference Manual.

You can open the Media Pool on the Fusion page and drag clips directly to the Node Editor to add
them to your node tree.

When you add a clip by dragging it into an empty area of the Node Editor, it becomes another Medialn
node, disconnected, that's ready for you to merge into your current composite in any one of a
variety of ways.

Medialn1 m—p Paintl

Medialni m—» Painti

Medialn2

Dragging a clip from the Media Pool (Top),
and dropping it onto your composition (Bottom).
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TIP: Dragging a clip from the Media Pool on top of a connection line between two other
nodes in the Node Editor adds that clip as the foreground clip to a Merge node.

When you add additional clips from the Media Pool, those clips becomes a part of the composition,
similar to how Ext Matte nodes you add to the Color page Node Editor become part of that
clip’s grade.

Audio with Media Pool Clips

Audio from a clip brought in through the Media Pool is muted by default. Hearing the audio from a
Media Pool clip is a two step process.

To hear audio from a clip brought in through the Media Pool, do the following:
Select the clip in the Node Editor.
In the Inspector, click the Audio tab and select the clip name from the Audio Track
drop-down menu.
Right-click the speaker icon in the toolbar, then choose the Medialn for the Media Pool
clip to solo its audio.

You can now use the speaker icon contextual menu to switch back and forth between all the
Medialn nodes.

Complex Fusion Compositions can have multiple Medialn nodes to keep track of. It is possible to find
the exact clip in the Media Pool assigned to a Medialn node by selecting it, and then choosing Clip >
Find Clip in Media Pool (Option-F).

You also have the option of dragging clips from the file system directly into the Node Editor. When you
do this, they'll be added to the currently selected bin of the Media Pool automatically. So, if you have
a library of stock animated background textures and you've just found the one you want to use using
your file system’s search tools, you can simply drag it straight into the Node Editor to use it right away.

Using Medialn Nodes

The Medialn nodes in the Fusion Page are the foundation of every composition you create. This
section provides more detail about the controls available for adjusting Medialn and Loader nodes.

Medialn nodes have one Effects mask input and one output. In the case of the Effects mask input,
connecting a mask node such as a Polygon or B-Spline node creates an alpha channel in the
Medialn node.
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TIP: If you connect a mask node without any shapes drawn, that mask outputs full
transparency, with the result that the image output by the Medialn node is uselessly blank.
If you want to rotoscope over a Medialn node, first create a disconnected mask node, and
with the mask node selected (exposing its controls in the Inspector) and the Medialn node
loaded into the viewer, draw your mask. Once the shape you're drawing has been closed, you
can connect the mask node to the Medialn node’s input, and you're good to go.

Which Inspector options are available for Medialn nodes of your composition depends on how you
imported the media.

Medialn Node Parameters for Clips in a Timeline

When you create a composition using clips from the Edit page Timeline, the Medialn nodes for those
clips display fewer parameters than those imported directly from the Media Pool, because the timing
of clips that have already been edited into a Timeline is already set.

Madifiers
Medialn1

Clip Name KFC 4

Image Audio
Process Mode Full Frames
MedialD
Layer 0
> Source Color Space

> Source Gamma Space

The Inspector Image tab
parameters for a clip from the Timeline

Image Tab
— Clip Name: Displays the name of that clip.

— Process Mode: Lets you choose whether the clip represented by that node will be processed as
Full Frames, or via one of the specified interlaced methods.

— Media Source: Selects where the media is linked from, allowing you to access Edit track composite
results.

— Timeline: Links the clip from the Edit Timeline (default)

— Background: In cases where the clip is composited over another clip in the Edit Timeline, the
background clip is loaded instead.

— Media Pool: Links the clip directly from the Media Pool, bypassing the Edit Timeline.
— Layer: In the case of Photoshop PSD files, this selects the layer of the PSD file to use.
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Source Color Space

The Color Space Type menu sets the color space of the media to help achieve a linear workflow. Unlike
the Gamut tool, this doesn't perform any actual color space conversion but rather adds the source
space data into the metadata, if that metadata doesn't already exist. The metadata can then be used
downstream by a Gamut tool with the From Image option, or in a Saver if explicit output spaces are
defined there.

— Auto: Passes along any metadata that might be in the incoming image.

— Space: Allows the user to set the color space from a variety of options.

Source Gamma Space

The Curve Type menu automatically determines or allows you to choose the Gamma setting for the
image and allows the option to remove the Gamma curve to help achieve a linear workflow.

— Auto: Passes along any metadata that might be in the incoming image.

— Space: Allows you to choose a specific setting from a Gamma Space drop-down menu, while a
visual graph lets you see a representation of the gamma setting you've selected.

— Log: Similar to the Log-Lin node, this option reveals specific log-encoded gamma profiles so that
you can select the one that matches your content. A visual graph shows a representation of the
log setting you've selected. When Cineon is selected from the Log Type menu, additional Lock
RGB, Level, Soft Clip, Film Stock Gamma, Conversion Gamma, and Conversion table options are
presented to finesse the gamma output.

— Remove Curve: Depending on the selected gamma space or on the gamma space found in Auto
mode, the associated gamma curve is removed from the material, effectively converting it to
outputin a linear color space.

— Pre-Divide/Post-Mujltiply: Lets you convert “straight” alpha channels into pre-multiplied alpha
channels, when necessary.

TIP: All content in the DaVinci Resolve Fusion page is processed using 32-bit floating-point bit
depth, regardless of the content’s actual bit depth.

Audio Tab

The Inspector for the Medialn node contains an Audio tab, where you can choose to solo the audio
from the clip or hear all the audio tracks in the Timeline.

Medialn1

Clip Name

AudioTrack  Timeline Audio [Timeline 1]

Sound Offset 0.0

v AudioCache

The Medialn Audio tab
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The Audio tab in the Medialn node is used to select the track for playback, slip the audio timing, and
reset the audio cache

If the audio is out of sync when playing back in Fusion, the Audio tab’s Sound Offset wheel allows you
to slip the audio in subframe frame increments. The slipped audio is only modified in the Fusion page.
All other pages retain the original audio placement.

Purging the Audio Cache

The audio and its settings are cached for faster performance. If you change which audio tracks you
want to play back in Fusion, or you use the Sound Offset wheel to slip the audio tracks, you need
to purge the audio cache. Also, if you return to the Edit, Cut, or Fairlight page and modify the audio
levels, you need to purge the audio cache.

To purge the audio cache after any change to the audio playback:

— Click the Purge Audio Cache button in the Inspector.
The audio will be updated when you next play back the composition.

Aligning Clips from the Media Pool

When you add a clip from the Media Pool or your file system directly into a composition, the resulting
Medialn node has more options than clips from the Edit page Timeline. These additional options make
it easier to align the Media Pool clips with other clips from the Edit or Cut page Timeline. You can also
trim clips, hold the first or last frame for a longer duration than the original media, and reverse or loop
the clip to get more range for your composition.

Inspector

Medialn3

0

Full Frames

The Inspector parameters for a
clip imported from the Media Pool.

Below is a list of controls that are added beyond the controls that appear when a clip is added from
the Edit or Cut page Timeline.

— Global In/Out: Use this control to specify the position of this node within the composition. For
instance, when the clip is added to the comp from the Media Pool, it is added at frame 0. However,
the Medialn node from the Edit page Timeline may not start until a much later frame, based on
where it is edited into the Timeline. Use Global In to specify the frame on which that the clip starts

Getting Clips into Fusion

74




so that it aligned with media from the Edit page Timeline. It is easiest to view and change the
alignment of different clips in the comp while viewing the Keyframes Editor.

To slide the clip in time or align it to other clips without changing its length, place the mouse
pointer in the middle of the range control and drag it to the new location, or enter the value

manually in the Global In value control.

If the Global In and Out values are decreased to the point where the range between the In and Out
values is smaller than the n number of available frames in the clip, Fusion automatically trims the

clip by adjusting the Clip Time range control. If the Global In/Out values are increased to the point
where the range between the In and Out values is larger than the number of available frames in
the clip, Fusion automatically lengthens the clip by adjusting the Hold First/Last Frame controls.
Extended frames are visually represented in the range control by changing the color of the held
frames to purple in the control.

— Trim: The Trim range control is used to trim frames from the start or end of a clip. Adjust the Trim
In to remove frames from the start and set Trim Out to specify the last frame of the clip. The values

used here are offsets. A value of 5 in Trim In would use the 5th frame in the sequence as the start,
ignoring the first four frames. A Trim Out value of 95 would stop loading frames after the 95th.

— Hold First Frame/Hold Last Frame: The Hold First Frame and Hold Last Frame controls will hold
the first or last frame of the clip for the specified amount of frames. Held frames are included in a
loop if the footage is looped.

— Reverse: Select this checkbox to reverse the footage so that the last frame is played first and the

first frame is played last.

— Loop: Select this checkbox to loop the footage until the end of the project. Any lengthening of the
clip using Hold First/Last Frame or shortening using Trim In/Out is included in the looped clip.

Using Loader and Saver Nodes
in the Fusion Page

The Loader and Saver nodes in Fusion Page are specifically used for workflows that center around
multi-channel EXR files. OpenEXR media can contain high-quality floating-point image data, multiple
matte channels, as well as auxiliary channels rendered from 3D software. The Loader node lets you
add OpenEXR files to a composition directly from the file system, retaining all the channels that are
embedded within that file. Saver nodes enable you to render either all or part of a composition as EXR
files directly to disk, bypassing the DaVinci Resolve Deliver page.

To import a multi-channel EXR image sequence into the Fusion page:
Open the Fusion page.
Open the Effects Library, and select the Tools > 1/0 category, and click the Loader node.

In the OS navigation window that opens, select the EXR image sequence you want to import, and
click Open.

A Loader node linked to the EXR file will appear in the Fusion page, although a clip will not appear
in the Media Pool.
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Loader Node Parameters

The image tab of Loader nodes shares parameters with Medialn nodes, as described previously in
this chapter. However, when using a Loader node for EXR files, the Format tab selectively enables and
disables the use of specific auxiliary channels contained in the file.

Inspector
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The Format tab in a Loader node
Inspector displays Aux channels in EXR files.

Outputting Images Using Saver Nodes

Saver nodes render OpenEXR image sequences to disk directly from the Fusion page. Saver nodes
can be added to any branch of a node tree, allowing you to export one or more subsets of nodes

in a composition. You can add as many Saver nodes as you like to whichever branches of your
composition’s node tree you need to output, to export multiple parts of a composition. For example,
if a particular composition is made up of one branch of nodes working together to create a complex
background, and another branch of nodes creating a foreground character with transparency,

you could export the background and foreground branches as separate OpenEXR files using two

Saver nodes.

To do this, simply create a Saver node after any set of nodes you want to output, and then open the
Inspector and click Browse to choose a name and location for the rendered result.
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When naming the file, you must add the .exr file extension. Fusion sets the output format accordingly.
A four-digit frame number is automatically added before the filename extension. However, you can
specify the frame padding by adding several zeroes to indicate the number of digits. For example,
000 signifies 001.

Once the Saver node is set up, output one or more Saver nodes, and choose Fusion > Render
All Savers.

Inspector

Sawver2: No Clip

The Inspector parameters for a Saver node.

Manual Disk Caching Using Loader and Saver Nodes

The Loader and Saver nodes in the Fusion page are also useful for optimizing extremely complex
and processor-intensive compositions. For example, you can render out specific branches of a node
tree that no longer require frequent adjustment to OpenEXR via a Saver node, then reimport the
result to take the place of the original branch of nodes in order to improve the performance of your
composition. Used this way, Loader and Saver nodes provide a bulletproof manual workflow for
caching using media files that will never be automatically purged unless you specifically delete them.
As long as you retain the original branch of nodes, you can always readjust and re-render these
manually cached parts of a composition, if necessary.

Importing Universal
Scene Descriptor (usp) Files

The Universal Scene Descriptor USD framework is a set of open standards for describing, composing,
and simulating a 3D environment. The USD file format is more than just a simple format - it's an open
source 3D scene description used for creating and sharing 3D content across various applications.

DaVinci Resolve and Fusion can import USD (.usdc, .usdz, and .usda) 3D information including
geometry, lighting, cameras, materials, and animation. A new collection of USD tools has been added
to Fusion, allowing users to manipulate, re-light, and render these USD files.
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The USD Loader allows you to import USD files and adjust its options.

Inspector

uLoader3_4

i §

Controls  Settings

Filename /Volumes/DaVinci Media/USDAnimz

Time Scale

Frame Offset

The uLoader node

To Import a USD file:
Add a uLoader tool to your Fusion Composition.

Select the USD file you want to load in the File Browser. If you wish to change this file in the future,
you can do so in the uLoader Inspector without disrupting your node tree.

Connect the output of the uLoader to a uMerge tool.
Connect any other USD tools, like uCamera or any of the uLights, to manipulate the scene.
Connect the output of the uMerge tool to a uRenderer.

Connect the output of the uRenderer to the MediaOut tool.

uCameral

v

/p uRenderer1 S| MediaOut1

/

uLoader1 —_— uMerge1

A

A very simple USD import node tree

Users can load MaterialX files (mtlx) from the the USD Loader and use the uReplaceMaterial tool to
assign imported materials to a nominated USD object to achieve a desired look.
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The Scene Tree window uses an intuitive visual hierarchy to represent USD scenes. The tree is
activated by pressing the Pick button in the Prim Selection box in certain USD tools.

uVisibility1

K |

Controls

v Prim Selection

Selected Prims  /UVISIDility1/uLoader1/0Object674

Invert Prim Selection

¥ Visible

The Prim Selection Pick button

uVisibility1: Select prims

Cancel

The USD Scene Tree dialog

Users can select, filter, isolate, and choose elements in a USD asset to focus on logical components
and make targeted adjustments.
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Preparing Compositions
in Fusion Studio

The next few sections in this chapter cover preparing a project and adding clips into a composition
when using Fusion Studio. The term composition, or comp, is used to refer to the Fusion project

file. By default, opening the Fusion Studio application creates a new empty composition when it's
launched. A composition can contain single frames, image sequences, or movie files at various
resolutions and bit depths. Knowing which files you can load in, how to set up a composition to handle
them, and finally, reading those files in are the first steps in beginning to composite.

Opening, Closing, and Saving Compositions

As soon as you open Fusion Studio, a new empty composition is created. If necessary, you can also
create or open multiple compositions at once. Each additional composition is opened as a tab to the
main Fusion Studio window.

Compaosition3

-I:I:E: Nodes

Three compositions opened as tabs in Fusion Studio.

To create a second new composition:

— Choose File > New.

To open an existing composition, do one of the following:
— Choose File > Open.
— Choose File > Open Recent, and choose from the list of recently opened comps.

— Drag a composition file from an OS file browser into the tabbed composition area at the top of the
Fusion Studio window.

— Double-click on a composition file in the OS file browser.

The following methods can be used to close the current composition:
— Choose File > Close from the menu at the top of the Fusion window.

— Click the Close X icon on the right of the composition’s tab.

If the composition has unsaved changes, a dialog box appears allowing you to save before closing.

TIP: Compositions that have unsaved changes will display an asterisk (*) next to the
composition’s name in the Fusion Studio title bar and in the composition’s tab.

To save the current composition, you can do the following:
— Choose File > Save and enter a name if the comp has yet to be named.

— Choose File > Save As to save under a new name.
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— Choose File > Save Version to save the current composition with an added three-digit version
number at the end of the name. Each time you save a version, the number automatically

increments and the comp file is saved in the same location as the first version.

Auto Save
Auto save automatically saves the composition to a temporary file at preset intervals. Auto saves help

to protect you from loss of work due to power loss, software issues, or accidental closure.

To enable auto save for new compositions, choose Fusion Studio > Preferences, and then locate Global
> General > Auto Save in the Preferences dialog.

An auto-save file does not overwrite the current composition in the file system. A file with the same
name is created in the same folder as the composition but with the extension .autosave instead of
.comp. Unsaved compositions will place the autosave file in the default folder specified by the Comp:
path in the Paths panel of the Global Preferences.

If an auto-save file is present when Fusion Studio loads a composition, a dialog will appear asking to
load the auto-saved or original version of the composition.

The Composition File Format

Composition files are saved as readable plain text files. Using plain text files to describe a
composition makes it easier to integrate Fusion into structured, visual effects pipeline and asset
management solutions.

Composition files can be opened and edited using any standard text editing program. However, it is
never a good idea to open the file using a word processor, such as Microsoft Word or Apple Pages,
as these will generally save additional formatting information which will make the composition
unreadable to Fusion.

Importing and Exporting a Composition from DaVinci Resolve

Although the compositions created in DaVinci Resolve’s Fusion page are saved in the DaVinci Resolve
project library as .drp project files, you can import and export Fusion composition files when in the
Fusion page. This makes it very easy to share Fusion compositions between the different applications.

To export a Fusion composition from DaVinci Resolve:
From within DaVinci Resolve, switch to the Fusion page with the composition you want to export.
Choose File > Export Fusion Composition.

A Save dialog appears in which you can enter a name and location from the exported
Fusion composition.

A .comp extension is added to the end of the filename. Only the node tree created in the Fusion page
is exported. Clips not added to the Node Editor will not appear in the Fusion Studio bins. ResolveFX
added to the comp will also not translate from the Fusion page to Fusion Studio.

Medialn nodes from DaVinci Resolve are automatically converted to Loader nodes, and if the file path
remains identical, the media is automatically relinked.

MediaOut nodes are converted to Saver nodes.

The return trip can also be performed, saving a composition file from Fusion Studio and importing it
into the Fusion page within DaVinci Resolve.
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To import a composition from Fusion Studio into the Fusion page within DaVinci Resolve:
From within Fusion Studio, open the composition you want to move into the Fusion page.

From within DaVinci Resolve, switch to the Fusion page with an empty composition.
The composition you import will completely replace the existing composition in the Fusion page
Node Editor.

Choose File > Import Fusion Composition.
In the Open dialog, navigate to the Fusion comp and click Open.

The new comp is loaded into the Node Editor, replacing the previously existing composition.

TIP: To keep an existing comp in the Fusion page and merge a new comp from Fusion Studio,
open Fusion Studio, select all the nodes in the Node Editor, and press Command-C to copy the
selected nodes. Then, open DaVinci Resolve and switch the Fusion page with the composition
you want, click in an empty location in the Node Editor, and press Command-V to paste the
Fusion Studio nodes. Proceed to connect the pasted node tree into the existing one using a
Merge or Merge 3D node.

Source media can come in a variety of formats, including HD, UHD, and 4K or larger. Often you will
have different formats within a single comp. Each format has different properties, from resolution to
color depth and gamma curve. Fusion can mix and match material of different formats together in a
single composite, but it is important to note how Fusion Studio configures and combines materials of
different formats when loading and merging them together.

When you open Fusion Studio, an empty composition is created. The first thing you do when
starting on a new composition is to set the preferences to match the intended final output format.
The preferences are organized into separate groups: one for global preferences, and one for the

preferences of the currently opened composition.

L - Preferences

Frame Format

17777775

Frame Format preferences for images generated in Fusion.
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Although the final output resolution is determined in the Node Editor, the Frame Format preferences
are used to determine the default resolution used for new Creator tools (i.e., text, background,
fractals, etc.), aspect ratio, as well as the frame rate used for playback.

If the same frame format is used day after day, the global Frame Format preferences should match the
most commonly used footage. For example, on a project where the majority of the source content will
be 1080p high definition, it makes sense to set up the global preferences to match the frame format of
the HD source content you typically use.

To set up the default Frame Format for new compositions, do the following:
Choose Fusion Studio > Preferences.
Click the Global and Default Settings disclosure triangle in the sidebar to open the Globals group.

Select the Frame Format category to display its options.

When you set options in the Global Frame Format category, they determine the default frame format
for any new composition you create. They do not affect existing compositions or the composition
currently open. If you want to make changes to existing compositions, you must open the comp. You
can then select the Frame Format controls listed under the comp’s name in the sidebar.

For more information on preferences, see Chapter 13, “Preferences,” in the Fusion Reference Manual or
Chapter 75 in the DaVinci Resolve Reference Manual.

Once the Frame Format preferences are set, you usually begin to create a composite by reading in
source media. When Fusion reads in media, it doesn't convert or move the original files; it simply reads
the files in place, from whichever storage volume they're on. You are always dealing with the original
source files in their original location.

Source media is read into a comp using a Loader tool. Although there are other tools within Fusion
Studio that you can use to generate images like gradients, fractals, or text, each stillimage, image
sequence, or movie file must be added to your comp using a Loader tool.

Loader and Saver tools are
used to add media to Fusion
Studio and render it out.

To add media to your comp, do one of the following:

— Click Effects to open the Effects Library, and then select Tools > I/0 > Loader.
— Click the Loader icon in the toolbar.

— Right-click over the Node Editor, and then choose Add Tool > 1/0 > Loader.

— Drag a file from an OS file browser window into the Node Editor.
If multiple files are dragged into the Node Editor, a separate Loader is added for each file. However,

if you drag a single frame from an image sequence, the entire series of the image sequence is read
into the comp using one Loader, as long as the numbers are sequential.
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To add only one frame of an image sequence to your comp:
— Hold Shift while you drag a single frame from an image sequence into the Node Editor.

This comes in handy when you want to read in photographs from a digital camera that are
numbered sequentially.

A Loader represents any clip, image file, or graphic that you bring into Fusion. However, other types of
media can also be brought into Fusion Studio. Photoshop PSD files, SVG splines, and 3D models in the
Alembic, FBX, and OBJ format can be imported using the File > Import menu.

TIP: Using File >Import > Footage creates a new composition along with a Loader node for
the footage. The selected media is automatically used for the name of the composition.

For more information about the Loader node, see Chapter 42, “I/0 Nodes,” in the Fusion Reference
Manual or Chapter 104 in the DaVinci Resolve Reference Manual.

When you add a clip into a composition, the resulting Loader node is added at frame 0 of the
composition. However, the vital portion of the clip you are interested in may not start until a few
frames or even seconds later. To ensure you can align the timing of each piece of media, each

Loader includes timing and trimming options in the Inspector. You can also hold the first or last frame
for a longer duration than the original media, and reverse or loop the clip to get more range for

your composition.

At the top of the Inspector are the Global In and Global Out settings. This range slider determines
when in your composition the clip begins and ends. It is the equivalent of sliding a clip along a track in
a Timeline. The Hold First Frame and Hold Last Frame dials at the bottom of the Inspector allow you to
freeze frames in case the clip is shorter than the composition’s global time.

Inspector

Use the Global In/Out range slider to slide a clip in time
to have it appear at the correct time in a comp.

Below the filename in the Inspector is a Trim In and Out range slider. This range slider determines
the start frame and end frame of the clip. Dragging the Trim In will remove frames from the start of
the clip, and dragging the Trim Out will remove frames from the end of the clip.

Although you may remove frames from the start of a clip, the Global In always determines where

in time the clip begins in your comp. For instance, if the Loader has a Global In starting on frame 0,
and you trim the clip to start on frame 10, then frame 10 of the source clip will appear at the comp’s
starting point on frame 0.
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Nolumes/RUGGED BACK UP/R16 FL

Use the Trim In/Out to remove unnecessary
frames from the start or end of a clip.

Instead of using the Inspector to adjust timing, it is visually more obvious if you use the Keyframes
Editor. For more information on the Keyframes Editor and adjusting a clip’s time, see Chapter 9,
"Animating in Fusion’s Keyframes Editor,” in the Fusion Reference Manual or Chapter 71 in the

DaVinci Resolve Reference Manual.

Loader nodes have one Effects mask input and one output. In the case of the Effects mask input,
connecting a mask node such as a Polygon or B-Spline node automatically creates an alpha channel in
the Loader node.

TIP: If you connect a Mask node without any shapes drawn, that mask outputs full
transparency, so the result is that the image output by the Medialn node is blank. If you want
to rotoscope over a Medialn node, first create a disconnected Mask node, and with the Mask
node selected and the Media In node loaded into the viewer, draw your mask. Once the shape
you're drawing has been closed, connect the Mask node to the Medialn node’s input, and

you're good to go.

Using Proxies for Better Performance

For increased performance, you can do one of two things:

— Generate smaller media files and write them to disk using Optimized Media in DaVinci Resolve

— Render out proxy files using Saver nodes in Fusion Studio
Both applications also allow you to generate proxies on-the-fly without rendering new files to
disk using the Proxy and Auto Proxy options in the transport controls area.

To enable the Proxy and Auto Proxy options, you can do one of two things, depending on the version

of Fusion you are using:

— In the Fusion page, right-click the empty area behind the transport controls to enable the

Proxy option.
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Proxy and Auto Proxy options in the
transport controls right-click menu.

— In Fusion Studio, click the Proxy (Prx) button in the transport area to enable the usage of proxies.

The Proxy option reduces the resolution of the images as you view and work with them. Instead of
displaying every pixel, the Proxy option processes one out of every x pixels interactively. In Fusion
Studio, the value of x is determined by right-clicking the Prx button and selecting a proxy ratio from
the drop-down menu. For instance, choosing 5 from the menu sets the ratio at 5:1. In the Fusion
page, the proxy ratio is set by choosing Fusion > Fusion Settings and setting the Proxy slider in the
General panel.

iQ ) (M8 J(Pryg (aen!Sama
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The Proxy menu sets the ratio for
skipping pixels when processing.

The Auto Proxy button enables Fusion to interactively degrade the image only while adjustments are
made. The image returns to normal resolution when the control is released. Similar to the Prx button
in Fusion Studio, you can set the Auto Proxy ratio by right-clicking the APrx button and choosing a

ratio from the menu.

When a Loader node is selected, the Inspector includes a Proxy Filename field where you can specify
a clip that will be loaded when the Proxy mode is enabled. This allows smaller versions of the image
to be loaded to speed up file I/0 from disk and processing. This is particularly useful when working
with high resolution files like EXR that might be stored on a remote server. Lower resolution versions
of the elements can be stored locally, reducing network bandwidth, interactive render times, and

memory usage.

The proxy clip that you create must have the same number of frames as the original clip, and if using
image sequences, the sequence numbers for the clip must start and end on the same frame numbers.
If the proxies are the same format as the original files, the proxies will use the same format options in

the Inspector as the originals.
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When using Fusion Studio, rather than right-clicking over the Proxy button to set the proxy quality,
you can preset the standard and Auto Proxy quality in the Fusion Preferences window. The General
pane in the Preferences window includes sliders for both standard Proxy files and Auto Proxy files.
These sliders designate the default ratio used to create proxies when the Proxy and Auto Proxy modes
are turned on. These settings do not affect the final render quality.

TIP: Even though the proxies are being processed smaller than their original size, the viewers
scale the images so they refer to original resolutions.

File Format Options

The Fusion interface in DaVinci Resolve and Fusion Studio display specific options for various file
formats in slightly different ways. Where Fusion Studio displays most file-specific options in the
Loader’s Format tab, the Fusion page in most cases displays these options in the main Image tab of
the Medialn node. The only exception being the OpenEXR format. Its extensive options are displayed
in a separate tab even in the Medialn node of the Fusion page. Not all file formats have options. Only
the DPX, OpenEXR, PSD, and QuickTime formats provide additional options when loaded.

DPX

The Format tab in Fusion Studio’s Loader node for DPX files is used to convert image data from
logarithmic to linear. These settings are often left in bypass mode, and the Log to Linear conversion is
handled using a Cineon Log node.

OpenEXR

The OpenEXR format provides a compact and flexible high dynamic range (float) format. The format
supports a variety of extra non-RGBA channels and metadata. These channels can be viewed and
enabled in the Format tab of the Inspector.

Loader; Shot8-2_##Ht#it###.ex W

t @

v Channels

The Format tab in a Loader node Inspector
displays Aux channels in EXR files.
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Photoshop PSD

There are two methods for importing Photoshop PSD files. You can either import the PSD file and
have it represented as a single node in the Node Editor or import the PSD and have each layer
represented as a node in the Node Editor. If you do not need independent control over each layer or
blend modes are not used when creating the PSD file, then importing the PSD file as a single node will
make for a more manageable experience. If you do need control over each layer or Blend modes used
in the PSD file are critical, then you should import the file so each layer becomes a node in the Node
Editor. Each method is explained below for the Fusion page and Fusion Studio.

— Using the Media Pool in DaVinci Resolve’s Fusion page: Any PSD file added to the Media Pool in
DaVinci Resolve can be accessed from the Fusion page. After dragging the PSD file from the Media
Pool into the Node Editor, the image appears as a Medialn node. From there, you can select which
layer to use from the PSD file from the Layer drop-down menu in the Inspector.

— Using a Loader node in Fusion Studio: This lets you read in Photoshop PSD files with the ability
to select the layer in the PSD file that is used in the comp. Fusion can load any one of the individual
layers stored in the PSD file, or the completed image with all layers. Transformation and adjustment
layers are not supported.

Inspector

Loader3: EatAtjoes.psd

The Format tab in the Inspector displays
specific controls for a Photoshop PSD file.

To load all layers individually from a PSD file, with appropriate blend modes, do one of the following:
— In DaVinci Resolve, switch to the Fusion page and choose Fusion > Import > PSD.

— In Fusion Studio, choose File > Import > PSD.

Using either of the methods above creates a node tree where each PSD layer is represented by a node
and one or more Merge nodes are used to combine the layers. The Merge nodes are set to the Apply
mode used in the PSD file and automatically named based on the Apply mode setting.

ADDRESS SCREEN

The two layers of a Photoshop PSD file
are imported and connected to a Merge
node set to a Screen Apply mode.
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QuickTime

QuickTime files can potentially contain multiple tracks. You can use the Format tab in the Inspector to
select one of the tracks.

You can load WAV format audio-only files into Fusion Studio. The entire WAV file is loaded into RAM in

order to quickly display the waveform in the Keyframe Editor. That being the case, it is best to use the
shortest possible audio file you need for the Comp, so as not to use up more memory than necessary.

TIP: AIFF files can be loaded on macOS.

You can either load the audio file independent of any nodes, or load an audio file into the Saver node.
The benefit of using a Saver node to load the audio is that you can view the audio waveforms in the

Keyframes Editor.

To load a WAV audio file, do the following:
Right-click over the speaker icon and select Choose from the contextual menu.

In the file browser window, select the audio WAV file track to be used.

To load a WAV audio file using a Saver node, do the following:
Add a Saver node to the Node Editor.
In the Inspector, click the Audio tab and click the Browse button.

In the file browser window, select the audio WAV file track to be used.

To view the Audio Waveform in Fusion Studio, do the following:
Open the Keyframes Editor.

Expand the Saver track to view the audio waveform.

When you want to find the precise location of an audio beat, transient, or cue, you can slowly drag
over the audio waveform to hear the audio.

Getting Clips into Fusion 89



Rendering Using
Saver Nodes

This chapter covers how to render compositions using Saver nodes in Fusion Studio and the

Fusion page in DaVinci Resolve. It also covers how to render using multiple computers over a network

when using Fusion Studio.
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Rendering Overview

When you have finished creating a composition in Fusion, you need to render the files out to disk for
playback and integration into a larger timeline. Fusion Studio and the Fusion page in DaVinci Resolve
use very different workflows for rendering. To finish a composite in the Fusion Page, you use a
MediaOut node to cache the results into the Edit or Cut page Timeline. The DaVinci Resolve Deliver
page handles the final render of the entire Timeline. To get completed composites out of Fusion
Studio, you configure and render them starting with a Saver node in the Node Editor. Fusion Studio is
also capable of distributing a variety of rendering tasks to other machines on a network.

In the Fusion page, a MediaOut node is required for getting your composite from the Fusion page
back into the Edit or Cut page Timeline. Whatever the MediaOut node displays when you see it in

the viewer is what gets rendered back into the Edit or Cut page. This process is semi-automatic

in DaVinci Resolve, where the Smart Render Cache setting begins caching the MediaOut node

almost immediately when you return to the Edit or Cut page Timeline. The cache file format and any
resolution scaling to fit the composition into the Timeline Resolution is handled in the DaVinci Resolve
Project Settings.

In Fusion Studio, all rendering goes through Saver nodes. Similar to MediaOut nodes in the Fusion
page, Saver nodes are most often appended to the end of a node tree to render the final composite.
The Saver node determines the name, format, and location of the rendered files.

Rendering with the Saver Node

To begin rendering in Fusion Studio, you must add at least one Saver node to the node tree. Most of
the time, you will place at least one Saver node at the very end of your tree to render the final image.

A single Saver node is added to the end of a node tree to render the final composite.
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You can attach multiple Saver nodes anywhere along the node tree to render out different parts
of a composite. In the example below, three Saver nodes are added at different points in the node
tree. The top two render out each half of the composite while the bottom renders the results of
the entire composite.

Deltakeyer1

Saver_02 Mergei = \ Saver 03
[ ]

Multiple Saver nodes can be added to different parts of a node tree.

You can also use multiple Saver nodes stemming from the same node in order to create several
output formats. The below example uses the three Savers to export different formats of the
same shot.

v v
ColorCorrector1

Saver_H264 T Saver_EXR B Saver_ProRes 7

Multiple Saver nodes can be added to create different formats for output.

Adding a Saver node to a node tree automatically opens a Save dialog where you name the file
and navigate to where the exported file is saved. You can then use the Inspector to configure the
output format.

For more information on the Saver node, see Chapter 42, “I/O Nodes,” in the Fusion Reference Manual
or Chapter 104 in the DaVinci Resolve Reference Manual.
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If you use a file extension when naming the file, Fusion will set the output format accordingly. For
example, naming your file image_name.exr will set the Inspector to output an EXR file or naming a
file image_name.mov will set the Inspector for an H264 QuickTime movie. If you decide to change
or modify the setting of the file type, the Saver’s format tab in the Inspector contains the specific
parameters for the selected format.

Inspector

Saver1: movie.mov

> Advanced

The Saver’s Format tab with controls for QuickTime

If you decide to output an image sequence, a four-digit frame number is automatically added before
the filename extension. For example, naming your file image_name.exr results in files named image_
name0000.exr, image_name0001.exr, and so on. You can specify the frame padding by adding several
zeroes to indicate the number of digits. For example, entering a filename as image_name_000.exr
results in a sequence of images with the names Image_name_000.exr, Image_name_001.exr, Image_
name_002.exr, and so on.

NOTE: The starting frame number always uses the Time Ruler start frame number.

Using the Render Settings Dialog

In Fusion Studio, you initiate rendering by clicking the Render button and opening the Render Settings
dialog. This dialog configures the quality, frame range, and network usage of the rendering.

To Render a comp in Fusion Studio:

Connect a Saver node at the end of your composition.
Enter a name and a location for the saved file(s) in the Save window.
Set the format using the Format tab in the Inspector, if necessary.

Click the Render button in the transport controls area or choose File > Render All Savers.

The Render Settings dialog opens providing options for the rendered output.
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D Render Settings

MB  Some

Across the hall

Not all branches of this composition end
with a Saver!

Some results of this render will not be
Preview o saved.

Warning: Settings may not be suitable for

final output.

The Render Settings dialog options

Ensure that the frame range and other parameters are correct and click Start Render.

Saver nodes in the DaVinci Resolve Fusion page

The Fusion page also includes a Saver node, although it is used for a different purpose

than the Saver node in Fusion Studio. Rendering from the Fusion page is handled primarily
through the MediaOut node. There is no Render Settings dialog since the rendering location
and format is predetermined by DaVinci Resolve's cache settings. Saver nodes in the Fusion
page are a special case, and are used to render OpenEXR files only. Once you add a Saver
node, you enter the filename with the extension. exr. Click the Browse button to select a
location for the EXR sequence, and then choose Fusion > Render All Savers.

Using the Saver node is useful for optimizing extremely complex and processor-intensive
compositions. For example, you can render out specific branches of a node tree that no
longer requires frequent adjustment to OpenEXR via a Saver node, and then reimport the
result to take the place of the original branch of nodes in order to improve the performance

of your composition.

Alternatively, you can render out multi-channel mattes or EXR images containing Arbitrary
Output Variables (AOVs) to bring into other applications.

Many of the options in the Fusion Studio Render Settings dialog are used when you need to create
a quick preview or a test render. The options in this dialog allow you to increase performance by
disabling some of the image-processing operations that are time consuming but deliver higher
quality results. Often the first settings you set are those in the Configurations section. This section
determines whether you want to produce a final high quality render or a faster preview render.
Selecting Final prevents you from modifying the options that will limit the quality.
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Settings

When the Configuration section is set to Preview, the Settings section of the Render dialog includes
three options that determine the overall quality and appearance of your final output. These buttons
also have a significant impact on render times. When the Configurations setting is set to Final, these
options cannot be disabled

— HiQ: When enabled, this setting renders in full image quality. If you need to see what the final
output of a node would look like, then you would enable the HiQ setting. If you are producing a
rough preview to test animation, you can save yourself time by disabling this setting.

— MB: The MB in this setting stands for Motion Blur. When enabled, this setting renders with motion
blur applied if any node is set to produce motion blur. If you are generating a rough preview and
you aren't concerned with the motion blur for animated elements, then you can save yourself time
by disabling this setting.

— Some: When Some is enabled, only the nodes specifically needed to produce the image of the
node you're previewing are rendered.

Size
When the Configurations section is set to Preview, you can use the Size options to render out frame

sizes lower than full resolution. This is helpful when using the Render dialog to create proxies or just
creating a smaller file size.

Network

The Network setting controls the distribution of rendering to multiple computers. For more
information, see the network rendering section in this chapter.

Shoot On

Again, this option is only available when Configurations is set to Preview. The Shoot On setting allows
you to skip frames when rendering. You can choose to render every second, third, or fourth to save
render time and get faster feedback. You can use the Step parameter to determine the interval at
which frames are rendered.

Frame Range

Regardless of whether the Configurations is set to Final or Preview, this option defaults to the current
Render In/Out Range set in the Time Ruler to determine the start and end frames for rendering. You
can modify the range to render more or fewer frames.

Configurations

When set to Final, the Render Settings are set to deliver the highest quality results, and you cannot
modify most of the options in this dialog. When set to Preview, you can set the options to gain faster
rendering performance. Once you've created a useful preview configuration, you can save it for later
use by clicking the Add button, giving it a name, and clicking OK.
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You can render Flipbook previews into a viewer. These Flipbook previews exist entirely within RAM.
They are created by right-clicking over a node in the Node Editor and choosing Create > Play/Preview
on > Left viewer/Right viewer from the drop-down menu. The Render Settings dialog appears where
you can configure the preview and initiate the rendering. You can also Option-drag a node directly
from the Node Editor into a viewer. The Render Settings dialog will be displayed, and the preview will
appear on the viewer you target.

For more information on rendering RAM previews, see Chapter 7, “Using Viewers,” in the Fusion
Reference Manual or Chapter 69 in the DaVinci Resolve Reference Manual.

TIP: Option-Shift-dragging a node into a viewer will skip the Render dialog and
previously used settings.

Setting Up Network
Rendering in Fusion Studio

Fusion Studio is capable of distributing a variety of rendering tasks to an unlimited number of
computers on a network, allowing multiple computers to assist with creating network-rendered

previews, disk caches, and final renders.

Using the Render Settings dialog or the built-in Render Manager, you can submit compositions to be
rendered by other copies of Fusion Studio, as well as to one or more Fusion Render nodes. Rendering
can also be controlled through the command line for integration with third-party render managers
like Deadline, Rush, and Smedge.

Render nodes are computers that do not have the full Fusion application installed but do have Fusion
Render node software installed. The Render node software is not installed by default when you install
Fusion Studio, but it can be installed at any time using the Fusion Render node Installer. The installer is
located in the Blackmagic Fusion Studio installer.dmg on macOS and the Blackmagic Fusion Studio.zip
on Linux and Windows. Fusion Studio is licensed for an unlimited number of Render nodes, so you can
install the Render node software on as many macOS, Windows, and Linux computers that you want
involved in network rendering.

To install a Render node:
Download and unzip the Blackmagic Fusion Studio archive. Then locate the Render Node Installer.

Copy the Install Fusion Render Node [version] to each computer on the network that you want to

perform rendering operations.

Install the Render node.

By default, the Render node application will be added to the Start Menu on Windows under
Blackmagic Design. On macQS, it is added to the menu bar, and on Linux it appears in the app
launcher. Each time you log in to the computer, the Render node application will run automatically.
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To disable the Render node application from starting up automatically, choose Quit from the Render
node icon in the macOS menu. On Linux, right-click over the icon and choose Kill Process, and on

Windows, delete the shortcut from the Windows Startup directory.

Most versions of Fusion Studio are licensed by connecting a single-seat hardware key (dongle) to

the same computer where Fusion is installed. Each dongle includes an unlimited number of cross-
platform Render node licenses, which you can install on as many macOS, Windows, and Linux
computers as you need. For Fusion Studio to access the Render nodes, the computer with the Fusion
Studio dongle needs to be on the same local network subnet as the Render nodes. The network
licensing does not require individual license files; instead, the Render nodes automatically search for
the dongle on the subnet, making it easy to set up. Single-seat dongles do not “float” over a network;
they must be connected to the same computer where Fusion Studio operates.

Multi-License Dongles

Using a multi-license dongle, you can license 10 copies of Fusion Studio by connecting the dongle to
any computer on the same subnet. Since these licenses “float” over a network, Fusion Studio does not
have to be running on the same computer where the dongle is connected. As long as Fusion Studio is
on the same subnet, it can automatically find the license server and check out an available license.

Multi-seat dongles can be combined together to tailor the number of Fusion seats in a larger facility.
For example, three dongles each licensed for 10 Fusion Studios would serve up 30 licenses. This
also allows for redundancy. For instance, in the example above, three computers can act as license
servers. If the first server fails for some reason, Fusion Studio will automatically try the next server.

Alternatively, multiple dongles can also be plugged into a single computer.

Setting Up a License Server

Setting up the license for network rendering begins by connecting either a single-seat or multi-seat
dongle to a computer that will act as the host for the license server. The Render node installer installs
Fusion Server, which acts as the license server, although the Render node does not have to run on
that same computer. The Fusion Server is set up to launch at startup and run unobtrusively in the
background as a service/daemon, ready to serve licenses and Fusion bins. The Fusion Server is used
to serve up multiple licenses so it must be running whenever you want to operate Fusion Studio or use
the Render nodes for network rendering. Its default is to start up automatically and remain running as
long as a license is being used by another computer or a Render node is operating. If nothing is using

the Fusion Server, it will quit after 30 seconds.

You will need your network administrator to set firewall rules allowing the Fusion Server, FusionScript,
and the Fusion Render node applications to communicate and confirm licensing with the computer
that has the Fusion Studio dongle.

If for some reason you remove a dongle or the network drops out, the licenses of any connected
Fusion Studio application will also drop. Upon losing its license, Fusion Studio will start searching for
another license, locally or on a different machine. If no license is found, Fusion pauses rendering and
displays a dialog with options to retry the search or autosave the comp and quit. Render nodes only
check for a license on the network once during startup, so they are not affected by removing the
dongle or network issues.
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Setting Up a License Server with Environment Variables

Environment variables provide a way to specify flexible or “variable” configuration options. When
network rendering with Fusion, environment variables can be useful for temporarily setting a location
or choosing a preference file. Using the FUSION_LICENSE_SERVER environment variable, you can set
different locations for the File Server.

Instead of looking in a single location for the Fusion Server, you can set up multiple license servers
separated by semicolons. For instance, fu:SetPrefs("Global.EnvironmentVars.FUSION_LICENSE _
SERVER'", "192.168.1.12; 192.168.10.55;*")

You can also use the environment variable to scan for license servers within a subnet—for example,
“bobs-mac.local;10.0.0.23;%;license.mystudio.com”. Including an asterisk (*) indicates a broadcast
search of the local subnet.

Like most environment variables, you can put the license server in the Global Preferences via
the Prefs text file. EnvironmentVars: fu:SetPrefs("Global.EnvironmentVars. FUSION_LICENSE_
SERVER", "10.0.0.23;*") fu:SavePrefs(), see Chapter 13, “Preferences,” in the Fusion Reference
Manual or Chapter 75 in the DaVinci Resolve Reference Manual for more information on using
environment variables.

NOTE: The use of straight quotes (" ") in the environment variables above are intentional and

should not be replaced with typographer’s, or curly, quotes (“").

There are two roles played by computers involved in network rendering.

— The Render Master manages the list of compositions to be rendered (the queue) and allocates
frames to Render nodes for rendering. Metaphorically speaking, the Render Master is the traffic
cop of this process.

— The Render nodes are the main computers used for the rendering process. All computers involved
in network rendering must be on the same network subnet, and they all must have access to the
various files (including Fonts and third-party plugins) used to create the composite. The path to the
files must be the same for each computer involved in rendering.

Preparing the Render Master

The Render Master manages the list of compositions to be rendered (the queue) and allocates frames
to Render nodes for rendering. The Render Master is also used to maintain the Render node list and
to push updates to the various Render nodes when needed. At least one computer in the render farm
must be configured to act as the Render Master.

Any copy of Fusion can act as a Render Master by setting up the Fusion Network Preferences.
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® =] Preferences

My Workstation

Network

The Network panel sets up computers as Render Masters.

Acting as a Render Master has no significant impact on render performance. The system resources
consumed are insignificant. However, there are specific steps you must take to make one of your
computers a Render Master.

To set up the Render Master:

Install a copy of Fusion Studio on the computer you want to be the Render Master.

In Fusion Studio, choose Fusion Studio > Preferences on macOS or File > Preferences on
Windows and Linux

In the Preferences dialog, select the Global > Network Preferences panel.
Enter the name of the Render Master in the Name field and enter the IP address.
Enable the Make This Machine a Render Master checkbox.

If you want to use this computer as part of the render farm, enable the Allow This Machine to Be
Used as a Render Node checkbox as well.

To have the Render Node act as the Render Manager:
— Select a node in the Render Manager and choose Set Default Master from the contextual menu.

Once a computer is enabled to act as the master, use the Render Manager to add the Render nodes it
will manage. The Render Manager dialog is described in detail later in this chapter.

Preparing Render Nodes

Before you can begin rendering on the network, the Render nodes must be set up to accept
instructions from the Render Master.
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In Fusion Studio, you can enable the computer to be used as a Render node in two ways:
— Choose File > Allow Network Renders.

— Enable the Allow This Machine to Be Used as a Network Render Node in the Global >
Network Preferences.

On a macOS Render Node computer:

— Click the Render Node icon in the menu bar and choose Allow Network Renders.

ﬂ # T QoW
Render Status...
v Allow Network Renders

Preferences...

Quit

The Render Node menu accessed
in the macOS menu bar

On a Linux Render Node computer:

— Right-click the Fusion Render Node icon in the App Launcher and choose Allow Network Renders.

On a Windows Render Node computer:

— Right-click the Fusion Render Node icon in the taskbar Notification area and choose
Allow Network Renders.

The Render Manager window is used to monitor the progress of rendering. It can be used to reorder,
add, or remove compositions from a queue, and to manage the list of Render nodes used for
rendering. To open the Render Manager window in Fusion Studio, choose File > Render Manager.

Render Manager - [Queuel]

The Render Manager is used to reorder, add, and remove compositions from a render queue.
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The Render Master is always listed as the first computer in the Render Node list along the right side.
This allows the Render Manager to render local queues without using the network. For the Render
Master to control additional Render nodes, the nodes must be added to the Render Node list.

Right-clicking in the Render Node list allows you to add Render nodes by entering the Render node’s
name or IP address. You can also choose Scan to have the Render Manager look for Render nodes on
the local network.

Pause Render

The Render Manager is used to add Render nodes.

Scanning for Render Nodes
With the Render Manager open, you can scan for Render nodes by right-clicking in the Render

Manager’s Render node list and choosing Scan for Render nodes from the drop-down menu.

Scanning looks through all IP addresses on the network subnet to determine whether any other
computers in the local network are actively responding on the port Fusion uses for network
rendering. A copy of the Fusion Render node must be running on the remote computer in order for it
to be detected by the scan.

Manually Adding Render Nodes

To manually add a Render node to the Render Node list, right-click in the Render Manager’s Render
Node list and choose Add Render Node from the drop-down menu.
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Render Node

all

Cancel

The Add Render Node dialog allows you
to manually enter a Render Node name or
IP address to locate it on the subnet.

In the Add Render Node dialog that opens, enter the name or the IP address of the remote Render
node. The Render Manager will attempt to resolve names into IP addresses and IP addresses into
names automatically. You can use this method to add Render nodes to the list when they are not
currently available on the network.

Removing Render Nodes

To remove a computer from the Render Node list, right-click over the Render Node in the Render
Node list and choose Remove Render Node(s) from the pop-up menu. You can use Command on
macOS or Ctrl on Windows and Linux to select multiple Render nodes for removal.

Loading and Saving Render Node Lists

The list of Render nodes is automatically saved in the Documents > Blackmagic Design > Fusion >
Queue folder when you quit the Render Manager. You can save and reload alternative lists of Render
nodes by choosing Render Node > Save Render Node List and Load Render Node list from the menu.

Submitting Comps to
Network Render

To submit a comp to render on the network, you can use the Render Manager, the Render Settings
dialog, or a third-party render farm application. The Render Settings dialog is quicker, while the
Render Manager and third-party render farm applications can provide more feedback and control
over the process.
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When starting a preview or a final render, selecting the Use network checkbox from the Render
Settings dialog and submitting the render adds a composition to the end of the current queue in the
Render Manager. The Render Master used is based on the Fusion preferences from the workstation
submitting the comp.

The Use Network checkbox
enables network rendering
from the Render Settings dialog.

NOTE: Distributed network rendering works for image sequences like EXR, TIFF, and DPX.
You cannot use network rendering for Quicktime, H264, ProRes, or MXF files.

The Render Manager uses a render queue that lets you batch render comps. Compositions are
rendered in the order in which they are listed in the Render Manager, with the top entry rendered first,
followed by the next item down, and so on. Multiple comps in a queue may render simultaneously
depending on the group of Render nodes they are using and the priority assigned to each comp.

To add a comp to the queue in the Render Manager:
— Click the Add Comp button and navigate to the comp on your hard drive.

— Right-click in the queue list and select Add Comp from the drop-down menu, and then navigate to
the comp on your hard drive.

— Drag a comp file from an OS window into the Render Manager’s queue list.

The Add Comp button in the Render
Manager adds a comp to the queue for
batch rendering over the network.
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Removing a Composition from the Queue

To remove a composition from the queue, select the composition in the queue list and press the
Backspace/Delete key or right-click over the comp in the queue list and choose Remove Composition
from the drop-down menu.

Saving and Reloading Queue Lists

It can be useful to save a queue list to reuse at a later time. The current queue list is saved in the
Documents > Blackmagic Design > Fusion > Queue folder. To save the current queue with a new name,
choose File > Save Queue As in the Render Manager menu bar. To reload a saved Queue, choose File >
Load Queue and navigate to the saved location.

Reordering the Queue Lists

In the middle of a job, priorities for finishing a composition may change. Shifting deadlines may
require that a composition further down in the queue be rendered sooner. You can move comps to

a new position in the queue by dragging them in the queue list. If a composition with a status set to
Done is moved lower in the queue, it does not re-render. To re-render a comp, right-click on the comp
in the queue and choose Clear Completed frames from the drop-down menu.

Render nodes can be configured into Groups, which are then used when submitting compositions.
For example, imagine you have five Render nodes. All the Render nodes are members of the group
named All. Two of the Render nodes include more memory and faster processors, so you create a new
group called Hi-Performance.

New Render nodes are automatically added to All, but you can assign them to other groups as well.

To assign a Render node to a Group:
Open the Render Manager and select the Render nodes to assign to a group.

Choose Render Node > Assign Group or right-click over the Render nodes and choose Assign
Group from the drop-down menu.

In the Choose Group dialog, enter a name for the group.

To assign Render nodes to multiple groups, separate the name of each group using a comma
(e.g., All, Local, or Hi-Performance). The order of the groups determines the priority. See “Using
Multiple Groups” below.

When a render is submitted to the network, it is automatically sent to the All group. However, you can
choose to submit it to other groups in the list.

To submit a comp to a group from the Render Manager:
Open the Render Manager.
Submit the comp.
Click the Pause Render button.
Right-click over the comp in the queue list and select Assign Group.
In the Assign Group dialog, select an existing group to render the comp and click OK.

Click the Resume Render button.
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To submit a comp to a group from the Render Settings dialog:
Click the Render button in the transport controls area.
In the Render Settings dialog, enable the Use Network checkbox.
Select an existing group from the Available groups list.

Click the Start Render button.

Continuing with the group example above, five Render nodes are contained in the All group, and

two of those Render nodes are also in the Hi-Performance group. If you submit a render to the
Hi-Performance group, only two of the computers on the network are used for rendering. If a
composition is then submitted to the All group, the remaining three machines will start rendering the
new composition. Once the two Render nodes in the Hi_Performance group complete the first job,
they join the render in progress on the All group.

Groups are optional and do not have to be used. However, groups can make managing large networks
of Render nodes easier and more efficient.

Using Multiple Node Groups

A single Render node can be a member of multiple groups. A single composition can also be
submitted to multiple groups. Submitting a composition to multiple groups results in it rendering on
all Render nodes in the selected groups.

When a Render node is a member of multiple groups, the order of the groups is important because
the order defines the priority for that Render node.

For example, if groups are assigned to a Render node as All, Hi-Performance, then renders submitted
to the All group take priority. Any renders in progress that were submitted to the Hi-Performance
group will be overridden. If the order is changed to Hi-Performance, All, then the priority is reversed.

The Render Log is displayed in the lower half of the Render Manager window, although it can also be
displayed in the console window. The text in the log displays the Render Manager activities, including
which frame is assigned to which Render node, which Render nodes have loaded the compositions in

the queue, and statistics for each render after completion.

To view the Render Log in the console:

— Open the Render Manager and choose Misc > Show Render Log.

There are two modes for the Render Log: a Verbose mode and a Brief mode. Verbose mode logs
all events from the Render Manager, while Brief mode logs only which frames are assigned to each
Render node and when they are completed.

To disable Verbose mode:

— Choose Misc > Verbose Logging from the Render Manager's menu bar.
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You can make use of third-party render manager software to control network rendering. This allows
for efficient sharing of your computer resources between the many applications that may make use of
them. Examples of such managers are Smedge from Uberware LLC, Rush from Seriss, and Deadline
from GetRender. Generally, these render managers use a command line renderer. By default, Fusion’s

Render nodes operate as a service to the Fusion internal Render Manager. However, you can also run
the Render nodes via the command line for third-party render managers.

Keep in mind that using a third-party render manager will prevent the use of some of Fusion’s network
rendering features, such as the ability to create network rendered Flipbook Previews and disk caches.

Command Line Rendering

For studios using third-party render farm managers like Deadline, Smedge, or Rush, the Fusion
Render node can be called via command line passing arguments and file paths. In this Windows
example, a Render node is called to load a composition called exampleV001, and render 10 frames:

//pathtoRN/FusionRenderNode.exe //pathtoProject/examplevV00l.comp -render
-start 101 -end 110 -quit

This would start up, render frames from 101 to 110, and then quit.

The following table lists additional command line features.

Command Description

Installs the license server as a service or daemon, launching

"Fusion Server -i" . :
it on startup before user login.

Causes the Fusion Server to run persistently in the

"Fusion S -S" ital S
usion Server -5" (capital 5) background, until force-quit.

Full path and comp name, like

<filename.comp> ) ) )
P /storage/project/episode/shot/filename.comp.
-render Tells the Render Node to render.

Passes a series of frame ranges to be rendered—e.g.,

_ < >
frames <frameset 101.110,120,121,130..150.

-start <frame> Sets the start frame of the render.

-end <frame> Sets the last frame of the render.

Normally set to 1, step skip frames for rendering.

-step <step> .
P P For instance, 2 would render every second frame

-quit Causes the Render Node to quit after the render is complete.
oin <host> Prompts the node to connect to a manager at

J <hostname,IP>, and (re)join any ongoing renders.

listen The node remains running and waits for incoming requests

from a manager.
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Command Description

Causes the Render Node to output information about
-log <filename> the render to a log file. This appends to the end of an
existing log file.

-cleanlog Clears existing text from a log file.

-verbose Outputs more detailed information into the log file.

Suppresses pop-ups and interface buttons from displaying

-quiet Co :
g and needing interaction.

-version Returns the Render Node version number.

Sets the node’s process priority to high, above, normal,

-pri high|above|normal|below|idle below, or idle.

Allows storing custom values that can be fetched by calling
-args <arg1>[, <arg2>..] the script function GetArgs(), which will return a table of {
<argl> <arg2>, ... }

TIP: An X11 virtual frame buffer is required to make a headless Linux command line

interface work.

Preparing Compositions
for Network Rendering

The way you construct a composition in Fusion Studio can help or hinder network rendering.

The media you read in, where plugins are installed, and the mix of operating systems on your
networked computers all play a part in how smoothly your network rendering goes. Your setup must
include several essential parts before network rendering will work:

— License dongle, Render Master, and Render nodes must be on the same local network (subnet).

— Fusion Server must be running as a background service on the same

computer where the dongle is installed.
— All source media from the comp should be placed on a network volume.
— The network volume must be mounted on each Render node.
— Loaders must point to the media on the mounted volumes.
— Savers must write to a drive that is mounted on each Render node.
— The Fusion comp must be saved to a volume that is mounted on each Render node.

— All Render Nodes and Render Masters need read and write access to any volumes specified as a

source media location or render destination.
— Make sure all fonts used in the comp for Text+ and 3D text nodes are installed on all the Render nodes

— Make sure all Render nodes have third-party OFX plugins installed if any are used in the comp.

Below are more details about some of these items.
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The file paths used to load a composition and its media, and to save the composition’s rendered
results, are critical to the operation of network rendering. Each computer used for network rendering
must be able to access the media location for each Loader in the comp. Savers must be set up to save
to folders that all Render nodes can see and to which all Render nodes have write permission. Even
the composition must be saved in a folder accessible to all Render nodes, and it should be added to
the queue list using a path that's visible to all Render nodes.

For example, if you open a composition located at c:\compositions\test1.comp in Fusion Studio and
add the composition to the network rendering queue, the Render Manager sends a message to each
Render node to load the composition and render it. The problem is that each computer is likely to
have its own c:\drive that does not contain the comp you created. In most cases, the Render nodes will
be unable to load the composition, causing it to fail.

Path Maps located in Fusion Preferences are virtual paths used to replace segments of file paths. They
can change the absolute paths used by Loader and Saver nodes to relative paths. There are a number
of Path Maps already in Fusion, but you can also create your own. The most common path to use is the
Comp:\ path.

Comp:\is a shortcut for the folder where the actual composition is saved. So, using Comp:\ in a Loader
makes the path to the media file relative, based on the saved location of the comp file. As long as

all your source media is stored in the same folder or subfolder as your comp file, Fusion locates the
media regardless of the actual hard drive name.

Here's an example of a file structure that enables you to use relative file references.
The composition is stored in the following file path:

Volumes\Project\Shot0810\Fusion\Shot0810.comp

And your source media is stored here:

Volumes\Project\Shot0810\Fusion\Greenscreen\0810Green_0000.exr

This overall directory structure can be seen in the following screenshot:

Favorites Project L] Shot0810 » Fusion > Greenscreen >
Shot0811 » *# Shot0810.comp
Locations Shot0812 3

Q Volumes

I»

File paths can use relative paths based on the location of the saved comp file.

In this situation, using the Comp:\ path means your media location starts from your comp file’s
location. The relative path set in the Loader node would then be:

Comp:\Greenscreen\0810Green_0000.exr

Comp\Greenscreen\0810Green_00

Replacing the Loader’s path to start with Comp:\
creates a relative path from the comp file’s location.
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If your source media’s actual file path uses a subfolder in the same folder as the comp file's folder:

Volumes\Project\Shot0810\Footage\Greenscreen\0810Green_0000.exr

The relative path set in the Loader node would then be:

Comp:\..\Footage\Greenscreen\0810Green_ 0000.exr

The two dots .. instruct the path to go up one folder.

TIP: Some Path Maps are not set up on a Fusion Render Node automatically. For instance,
you must manually add an entry for macros if you are using macros in your comp.

Having the comp and media set to relative paths solves only part of the problem. Each computer
involved in rendering needs to have access to the drive where the comp and source media are
located. Mapping a drive provides permanent access to a folder on another computer or network
storage device.

Windows assigns a new drive letter to the folder, and it can be accessed just like any other drive
connected to your computer. Mapped drives assign a letter of the alphabet to a shared network
resource. Your shared drives must be the same drive letters on all Render nodes. For example, if your
media is on drive Z, then the network drive must appear as the letter Z on each of the Render nodes.

On macOsS, you can map a network drive using Connect to Server from the Go menu. Entering the
smb:// path to the drive will mount it on the computer. Using Accounts > LogIn Items, you can have the

network drive auto-mount after a reboot as well.

All fonts used by Text tools in the composition must be available to all nodes participating in the
render. The render will otherwise fail on the Render nodes that do not have the font installed.

All third-party plugins and tools used by a composition must be installed in the plugins directory of
each Render node. A Render node attempting to render a composition that uses a plugin that's not
installed will fail to render. Licensed plugins are required on each Render node.
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Other Uses of Network Rendering

Although you will probably set up network rendering for the purpose of accelerating the output
of your final renders, Fusion is capable of using the network for other purposes as well. You can
use the Render nodes on your network to accelerate the creation of Flipbook Previews and disk
caching as well.

Fusion Studio is able to use Render nodes to accelerate the production of Flipbook Previews, allowing
for lightning fast previews. Frames for previews that are not network rendered are rendered directly
into memory. Select the Use Network checkbox and the Render nodes to render the preview frames
to the folder set in the Preferences Global > Path > Preview Renders. This folder should be accessible
for all Render nodes that will participate in the network render. The default value is Temp\, which is a
virtual path pointing to the system'’s default temp folder. This will need to be changed before network
rendered previews can function. Once the preview render is completed, the frames that are produced
by each Render node are spooled into memory on the local workstation. As each frame is copied into
memory, it is deleted from disk.

Right-clicking a node in the Node Editor and choosing Cache to Disk opens a dialog used to create the
disk cache. If you enabled the Use Network checkbox and click the Pre-Render button to submit the
disk cache, the network Render nodes are used to accelerate the creation of the disk cache.

® Disk cache on "ColorCorrector!”:

Mar/folders/pp/gm808tds7_7ght1d7mt3flw00000gr mm

Render nodes can be used for disk
caching as well as final renders.

When Renders Falil

It is a fact of life that render queues occasionally fail. The composition has an error, the power goes
out, or a computer is accidentally disconnected from the network are some causes for failure. If no
one is available to monitor the render, the risk that an entire queue may sit inactive for several hours

may become a serious problem.

Fusion Studio includes a variety of measures to protect the queue and ensure that the render
continues even under some of the worst conditions.
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If a Render node becomes unavailable to the Render Master for any reason, frames assigned to that
Render node are reassigned among the remaining Render nodes in the list.

When the Render node becomes available for rendering again, it will signal the Render Master that it is
ready to render again, and new frames will be assigned to that Render node.

This is why it is important to set the Render Master in the network preferences of the Render nodes. If
the master is not set, the Render node will not know what master to contact when it becomes available.

In the Fusion Render Node Preferences, select the Tweaks panel. Using the Last Render Node Restart
Timeout field, you can enter the number of seconds Fusion waits after the last Render node goes
offline before aborting that queue and waiting for direct intervention.

Fusion Server is a small utility installed with Fusion Studio and the Render node. The application is
Fusion Server is a small utility installed with Fusion Studio and the Render node. The application is

silently launched by each Fusion Render node when started.

Fusion Server monitors the Render node to ensure that the Render node is still running during

a render. It consumes almost no CPU cycles and very little RAM. If the monitored Render node
disappears from the system'’s process list without issuing a proper shutdown signal, as can happen
after a crash, the Fusion Server relaunches the Render node, allowing it to rejoin the render.

Fusion Server will only detect situations where the Render node has exited abnormally. If the Render node
is still in the process list but has become unresponsive for some reason, the Fusion Server cannot detect
the problem. Hung processes like this are detected and handled by frame timeouts, as described below.

Frame timeouts are a fail-safe method of canceling a Render node’s render if a frame takes longer
than the specified time (with a default of 60 minutes, or one hour). The frame timeout ensures that
an overnight render will continue if a composition hangs or begins swapping excessively and fails to
complete its assigned frame.

The timeout is set per composition in the queue. To change the timeout value for a composition from
the default of 60 minutes, right-click on the composition in the Render Manager’s queue list and select
Set Frame Timeout from the contextual menu.

13N n 13n

M

fUsers/dion/Docum...asic 3D Comp.comp 0,

27Munf1912:03:51 localhost (127.0.0.1) is as:
27/Junf19 12:03:51 localhost (127.0.0.1) comy

Right-click over a comp in the Render Manager to set a timeout value.
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To change the frame timeout value, choose Set Frame Time Out from the Render Manager'’s Misc
menu and enter the number of seconds you want for the Time Out.

The Render Master regularly sends out heartbeat signals to each node, awaiting the node’s reply.

A heartbeat is basically a message from the manager to the Render node asking if the node is still
responsive and healthy. If the Render node fails to respond to several consecutive heartbeats, Fusion
will assume the Render node is no longer available. The frames assigned to that Render node will be
reassigned to other Render nodes in the list.

The number of heartbeats in a row that must be missed before a Render node is removed from the list
by the manager, as well as the interval of time between heartbeats, can be configured in the Network
Preferences panel of the master. The default settings for these options are fine for 90% of cases.

If the compositions that are rendered tend to use more memory than is physically installed, this will
cause swapping of memory to disk. It may be preferable to increase these two settings somewhat to
compensate for the sluggish response time until more RAM can be added to the Render node.

Managing Memory Use

Often, the network environment is made up of computers with a variety of CPU and memory
configurations. The memory settings used on the workstation that created a composition may not be
appropriate for all the Render nodes in the network. The Render node software offers the ability to
override the memory settings stored in the composition and use custom settings more suited to the
system configuration of a specific Render node.

To access preferences for a node, right-click on the icon in the Windows Notification area or from the
macOS menu bar and choose Preferences. In the Preferences dialog, select the Memory panel.

Enable this option to use the Render node’s local settings to render any incoming compositions.
Disable it to use the default settings that are saved into the composition.

Fusion has the ability to render multiple frames at once for increased render throughput. This slider
controls how many frames are rendered simultaneously. The value displayed multiplies the memory

usage (a setting of 3 requires three times as much memory as a setting of 1).

Normal values are 2 or 3, although machines with a lot of memory may benefit from higher values,
whereas machines with less memory may require the value to be 1.

Enable this option to render every layer in parallel. This can offer substantial gains in throughput
but may also use considerably more memory, especially if many layers are used in the composition.
Machines with limited memory may need to have Simultaneous Branching disabled when rendering

compositions with many layers.
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Limitations of Render Nodes

There are a few important limitations to remember while setting up compositions and

rendering over a network.

Compositions using the Time Stretcher and Time Speed tools may encounter difficulties when
rendered over the network. Speeding up or slowing down compositions and clips requires fetching
multiple frames before and after the current frame that is being rendered, resulting in increased 170
to the file server. This may worsen bottlenecks over the network and lead to inefficient rendering. If
the composition uses the Time Stretcher or Time Speed tools, make certain that the network is up to
the load or pre-render that part of the composition before network rendering.

Certain tools cannot be network rendered properly. Particle systems from third-party vendors, such
as Genarts's Smoke and Rain, and the Fusion Trails node cannot render properly over the network.
These tools generally store the previously rendered result and use it as part of the next frame’s
render, so every frame is dependent on the one rendered before it. This data is local to the tool, so
these tools do not render correctly over a network.

Multiple machines cannot render a single QuickTime file. Always render to separate sequential file
formats like EXR, DPX, JPEG, and so on. Once the render is complete, a single workstation can load the
image sequence in order and save to the desired compiled format.

NOTE: The above does not apply to network rendered previews, which are previews created
over the network that employ spooling to allow multi-frame formats to render successfully.
Only final renders are affected by this limitation.

Troubleshooting

There are some common pitfalls when rendering across a network. Virtually all problems with network
rendering have to do with path names or plugins. Return to the “Preparing Compositions for Network
Rendering” section in this chapter to review some of the essential setup requirements. Verify that all
Render nodes can load the compositions and the media, and that all Render nodes have installed the
plugins used in the composition.

If some difficulties persist, contact Blackmagic Design’s technical support using the support section
on the Blackmagic Design website. Save a copy of the render.log file to send to technical support.
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The log file shown in the Render Manager dialog displays messages that can assist with diagnosing
why a render or node has failed. The render log shows a step-by-step account of what happened
(or didn't happen) during a render. If a Render node cannot be found, fails to load a composition or
render a frame, or simply stops responding, it will be recorded here.

The Render Manager’s Status field in the render log indicates if a composition fails to render. Some
possible causes of this are as follows:

— No Render Nodes Could Be Found: On the Preferences Network tab, make sure that there is at
least one Render node available, running and enabled. If all Render nodes are listed as Offline
when they are not, check the network.

— The Composition Could Not Be Loaded: Some Render nodes may not be able to load a
composition while others can. This could be because the Render node could not find the
composition (check that the path name of the composition is valid for that Render node) or because
the composition uses plugins that the Render node does not recognize.

— The Render Nodes Stop Responding: If a network link fails, or a Render node goes down
for some reason, the Render node will be removed from the active list and its frames will be
reassigned. If no more Render nodes are available, the composition will fail after a short delay
(configurable in network preferences). If this happens, check the render log for clues as to which
Render nodes failed and why.

— The Render Nodes Failed to Render a Frame: Sometimes a Render node simply cannot render
a particular frame. This could be because the Render node could not find all the source frames
it needed, or the disk it was saving to become full or because of any other reason for which Fusion
might normally be unable to render a frame. In this case, the Render Manager will attempt to
reassign that failed frame to a different Render node. If no Render node can render the frame, the
render will fail. Try manually rendering that frame on a single machine and observe what happens.

— Check the Render Nodes: Fusion’s Render Manager incorporates a number of methods to
ensure the reliability of network renders. Periodically, the Render Manager will send signals called
Heartbeats, generated at regular intervals, to detect network or machine failures. In this event, a
failed Render node’s outstanding frames are reassigned to other Render nodes where possible.
In rare cases, a Render node may fail in a way that the heartbeat continues even though the
Render node is no longer processing. If a Render node failed (although the Render Master may
not have detected it) and you do not want to wait for the Frame Timeout, simply restart the Fusion
workstation or Fusion Render Node that has hung. This triggers the heartbeat check, reassigns
the frames on which that Render node was working, and the render should continue. Heartbeats
may fail if the system that is performing the render is making extremely heavy use of the Swap
file or is spending an extraordinary amount of time waiting for images to become available over a
badly lagged network. The solution is to provide the Render node with more RAM, adjust memory
settings for that node, or upgrade the network bandwidth.

— Check the Network: At the Render Master, bring up the Network tab of the Preferences dialog
box and click Scan. If a Render node is not listed as running, the Render Master will not be able to
contact it for network rendering. Alternatively, bring up a command prompt and ping the Render
nodes manually. If the remote systems do not respond when they are up and running, the network
is not functioning and should be examined further.
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Working in the

Node Editor

This chapter discusses how to work in the Node Editor, including

multiple ways to add, connect, rearrange, and remove nodes to

create any effect you can think of.
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Learning to Use the Node Editor

The Node Editor (formerly called the Flow or Flow Editor) is the heart of Fusion’s compositing
interface. It uses a flowchart structure called a node tree that lets you build a composition out of
interconnected nodes, as opposed to using layers in a layer list. Each clip you add to the composition,
and each image-processing operation you apply to those clips, is added as a node, all of which

are joined together with connections that propagate image data from one node to the next. Each
individual node performs a relatively simple operation, but collectively they combine to let you create
wonderfully complex results.

The Node Editor.

This chapter discusses how to work in the Node Editor in greater detail, showing you how to add,
connect, rearrange, and remove nodes to create any effect you can think of.

Working in the Node Editor 116



To display the Node Editor:
— Click the Nodes button on the Ul toolbar.

The Nodes button in the UI toolbar.

Navigating within the Node Editor

The Node Editor is the place where everything relating to nodes and the construction of your
composites happens. The more you learn about how to navigate within the Node Editor, the faster
you'll be able to work. There are a variety of standard methods of panning and zooming around the
Node Editor, many of which are shared with other panels in Fusion.

Methods of panning the Node Editor:
— Middle-click and drag to pan around the Node Editor.
— Hold down Shift and Command, and then click and drag within the Node Editor to pan.

— Drag with two fingers on a track pad to pan in the Node Editor

Methods of zooming the Nod4e Editor:

— Press the Middle and Left buttons simultaneously and drag to resize the Node Editor.

— Hold down the Command key and use your pointer’s scroll control to resize the Node Editor.

— Right-click the Node Editor and choose an option from the Scale submenu of the contextual menu.
— Press Command-1 to reset the Node Editor to its default size.

— Hold down the Command key and drag with two fingers on a track pad to resize the Node Editor.

If a node that is not visible in the Node Editor becomes selected, either by using the Find command
or by selecting a node’s header in the Inspector, the Node Editor will automatically pan to display the
node in the visible area.

Another useful way to pan around the Node Editor is to use the Node Navigator. The Node Navigator
is a small rectangular overview in the upper-right corner of the Node Editor. It gives a bird's eye view
of the entire composition, with an inner outline that indicates the portion of the composition that is
visible in the panel. You can use the Node Navigator when you are zoomed in on a node tree and want
to pan around a composition.
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The Node Navigator.

To display or hide the Node Navigator, do one of the following:

— Right-click in an empty area of the Node Editor, and then choose Options > Show Navigator.
— Pressthe V key.

To have the Node Navigator resume displaying automatically when

needed after you've closed it:

— Right-click in an empty area of the Node Editor, and then choose Options > Auto Navigator.

To change the size of Node Navigator, do the following:

— Drag the lower-left corner of the Navigator to resize it.

Drag the corner to resize the Navigator.

To return to the default Node Navigator size, do the following:

— Right-click anywhere within the Node Navigator and choose Reset Size.

To pan the Node Editor using the Node Navigator, do the following:
— Drag within the Node Navigator to move around different parts of your node tree.

— Within the Navigator, drag with two fingers on a track pad to move around different
parts of your node tree.
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Bookmarks are another way of navigating the Node Editor. Bookmarks save the position and scale of the
Node Editor, so you can quickly and precisely jump from viewing one group of nodes to viewing another.

To add a bookmark, do the following:
Pan and scale in the Node Editor to view a group of nodes you are interested in.
From the Options menu in the upper right of the Node Editor, choose Add Bookmark, or press Cmd-D.

In the Manage Bookmarks dialog that opens, enter a name for the bookmark and click the Add button.

The first nine saved bookmarks are given keyboard shortcuts and listed in the Options menu. They are
also listed in the Go To Bookmarks dialog along with any saved bookmarks beyond the initial nine.

The Node Editor Options menu
with nine bookmarks added

TIP: You can return the Node Editor to the default scale by right-clicking in the Node Editor
and choosing Scale > Default Scale or pressing Cmd-1.

If your Node Tree changes and you want to update Bookmark names or delete bookmarks, those tasks

can be done in the Manage Bookmarks dialog.

To rename or delete a bookmark, do the following:
From the Options menu in the upper right of the Node Editor, choose Manage Bookmarks.
In the Manage Bookmarks dialog that opens, right-click over the bookmark and
choose Rename or Remove.

Click OK to close the Manage Bookmarks dialog.

Using Bookmarks

You can jump to a Bookmark view by selecting a bookmark listed in the Options menu or choosing
Go To Bookmarks to open the Go To Bookmarks dialog. The Go To Bookmarks dialog has all the
bookmarks listed in the order they were created in the current composition. Double-clicking on any
entry in the dialog will update the Node Editor to that view and close the Go To Bookmarks dialog.
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If you have a long list of bookmarks, you can use the search field at the bottom of the dialog to enter
the name of the bookmark you want to find.

Changing the Sort Order and Assigning Keyboard Shortcuts

Bookmarks appear in the Options menu and in the Go To Bookmarks dialog in the order they were
created. The top nine bookmarks listed are assigned keyboard short cuts. If you want to change the
sort order of the list you can do that in the Manage Bookmarks dialog. This can be useful if you want
some bookmarks to have specific keyboard shortcuts, or you want a bookmark you made early in the
process to not have a keyboard shortcut assigned to it.

To change the order of the listed bookmarks, do the following:
From the Options menu in the upper right of the Node Editor, choose Manage Bookmarks.
In the Manage Bookmarks dialog drag a bookmark up or down in the list.

Aninsert line appears where the bookmark will be inserted. Release the mouse button when the
insert line is where you want the bookmark to be listed.

The keyboard short cuts will update to reflect the new order.

TIP: You can hold down the Shift key to select multiple bookmarks and move them

simultaneously up or down in the Manage Bookmark list.

Using Underlays as Bookmarks

Underlays added to the Node Editor are automatically added as bookmarks. They are listed in the
Options menu below the list of your custom bookmarks. You can omit Underlays from showing in
the list of bookmarks by opening the Go To Bookmarks dialog and disabling the checkbox to Show
Underlays. When the checkbox is disabled, Underlays will not show in the Go To Bookmarks dialog,
and they will not appear in the Options menu.

Adding Nodes to a Composition

— You can add nodes to the Node Editor in a variety of ways, depending on the type of node you're
adding, and how much guidance you need to find what you're looking for. Additionally, the way
you add nodes to a composition may also be dictated by how you need to attach that node to the
current node tree.

Make Sure You're Adding Compatible Nodes

It's a good rule of thumb to make sure that whenever you're adding or inserting new nodes
to the node tree, that you're adding nodes that are compatible with the nodes you're trying to
attach to. For example, you'll have no problem inserting a Blur, Color, Filter, Paint, or Position
node after almost any 2D operation. However, if you try to add a Merge3D node after a Glow
node, it won't automatically connect, because those two nodes cannot be connected directly.
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The Fusion toolbar, located above the Node Editor, displays a selection of frequently-used nodes,
displayed as buttons with distinct icons. These buttons make it fast to add Merge, Background, Paint,
Mask, Transform, and many other commonly used nodes with the click of a button, or the drag of
your pointer.

The Fusion page toolbar.

TIP: If you don't know which node a particular icon corresponds to, just hover your pointer
over any toolbar button and a tooltip will display the full name of that tool.

Methods of adding nodes by clicking toolbar buttons:

— To add a node after a selected node: Select a node in the Node Editor and then click a
toolbar button.

— To add a disconnected node to the Node Editor: Deselect all nodes in the Node Editor and then
click a toolbar button.

Methods of adding nodes by dragging toolbar buttons:

— To insert a new node into the node tree: Drag a toolbar button into the Node Editor and onto
the connection line between any two compatible nodes. When the connection highlights as the
node is over it, drop the node and it'll be inserted.

— To create a disconnected node: Drag a toolbar button into an empty part of the Node Editor.
Dragging a toolbar button into the Inspector also creates a disconnected node.

— To insert a new node after a node loaded into a viewer: Drag a toolbar button onto a viewer to
insert a new node after whichever node is viewed, regardless of whether any nodes are selected.

To replace a node in the Node Editor with a node from the toolbar:

Drag a button from the toolbar so that it's directly over the node in the Node Editor that you want
replaced. When the node underneath is highlighted, drop the node.
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Dragging a node from the toolbar
to replace an existing tool.

Click OK in the dialog to confirm the replacement.

TIP: When you replace one node with another, any settings that are identical between the
two nodes are copied into the new node. For example, replacing a Transform node with a
Merge will copy the existing center and angle values from the Transform to the Merge.
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The next fastest way of adding or inserting nodes to the Node Editor is using the Select Tool window,
which lets you search for any node available to Fusion by typing a few characters. Once you learn this
method, it'll probably become one of your most frequently-used ways of adding nodes.

To use the Select Tool window to add nodes:

Do one of the following to determine if you want to insert a node or create a disconnected node:

— If youwant to insert a node, select a node that's compatible with the one you'll be creating, and
the new node will be inserted after it.

— If you want to create a disconnected node, deselect all nodes.

Press Shift-Spacebar to open the Select Tool dialog.

When the window appears, type characters corresponding to the name of the node you're looking
for. A list automatically appears with likely candidates, and you can use the Up and Down arrow
keys to select the correct node (if it's not selected already). If you don't know the name of the exact
tool you're looking for, you can also type in common keywords and categories (i.e., keyer, materials,
etc.) to get a selection of tools based on your input.

When you've selected the correct node, press the Return key (or click OK), and that node will be
either inserted or added.

] @ Select Tool

The Select Tool dialog lets you find any
node quickly if you know its name.

TIP: Whenever you use the Select Tool window, the text you entered is remembered the
next time you open it, so if you want to add another node of the same kind—for example, if
you want to add two Blur nodes in a row—you can just press Shift-Spacebar and then press
Return to add the second Blur node.
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While the toolbar shows many of the most common nodes you'll be using in any composition, the
Effects Library contains every single tool available in Fusion, organized by category, with each node
ready to be quickly added to the Node Editor. If you need more guidance to find the node you're
looking for, or if you just want to browse around and see what's available, the Effects Library is the
perfect place to start.

To open the Effects Library:

— Click the Effects Library button in the UI toolbar at the top of the Fusion window.

The Effects Library appears at the upper-left corner of the Fusion window, and consists of two panels.
A category list at the left shows all categories of nodes and presets that are available, and a list at the
right shows the full contents of each selected category.

The Tools bin of the Effects Library exposing 3D nodes.

By default, the category list shows the primary sets of effects: Tools, Open FX, Templates, and LUTs;
with disclosure controls to the left that hierarchically show all subcategories within each category.
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The categories are:

— Tools: Tools consist of all the effects nodes that you use to build compositions, organized by
categories such as 3D, Blur, Filter, Mask, Particles, and so on.

— Open FX: All Resolve FX and any installed third party Open FX plugins will appear here.

— Templates: When using the Fusion page in DaVinci Resolve, templates consist of presets, macros,
and utilities that have been created to get you started quickly. For example, Backgrounds consists
of a variety of customizable generators that have been created using a combination of Fusion
tools. Lens flares presents a wide variety of multi-element lens flares that you can add to any
composition. Particles has a selection of pre-made particle systems that you can customize for
your own use. Shaders has a variety of materials that you can use as texture maps for 3D text and
geometry that you create in Fusion. And there are many, many other categories’ worth of useful
presets and macros that you can learn from and use in your own projects.

— LUTs: An assortment of pre-installed Look Up Tables for gamma, gamut, and colorspace
conversions can be found here. Inserting a LUT into the Node Editor creates a new FileLUT (FLUT)
node with the selected LUT file preloaded. For more information on adding your own LUTs to this
list, see Chapter 148, “Using LUTs,” DaVinci ResolveReference manual.

Adding, Inserting, and Replacing Tools Using the Effects Library

Adding nodes to the Node Editor from the Tools category of the Effects Library is very similar to
adding nodes from the toolbar.

Methods of adding nodes by clicking in the Effects Library:

— To add a node after a selected node: Select a node in the Node Editor and then click a node in
the browser of the Effects Library.

— To add a disconnected node to the Node Editor: Deselect all nodes in the Node Editor and then
click a node in the browser of the Effects Library.

Methods of adding nodes by dragging from the Effects Library:

— To insert a new node into the node tree: Drag a node from the browser of the Effects Library
into the Node Editor and onto the connection line between any two compatible nodes. When the

connection highlights as the node is over it, drop the node and it'll be inserted.

— To create a disconnected node: Drag a node from the browser of the Effects Library into
an empty part of the Node Editor. Dragging a toolbar button into the Inspector also creates a
disconnected node.

— To insert a new node after a node loaded into a viewer: Drag a node from the browser of the
Effects Library onto a viewer to insert a new node after whichever node is viewed, regardless of

whether any nodes are selected.

To replace a node in the Node Editor with a node from the Effects Library:

Drag a node from the browser of the Effects Library so it's directly over the node in the Node Editor
that you want replaced. When that node is highlighted, drop it.

Click OK in the dialog to confirm the replacement.
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Adding, Inserting, and Replacing Templates Using the Effects Library

Adding items from DaVinci Resolve's Fusion page Templates category is often a bit different.
Sometimes, as when adding a Lens Flare, a single node can be added or inserted into the Node Editor.
When this is the case, adding nodes works the same as when adding from the Tools category.

v
W Lens_Flare_V06

Adding a Lens Flare effect.

Other times, such as when adding an item from the “How to” category, dragging a single item from
the Node Editor results in a whole node tree being added to the Node Editor. Fortunately, all nodes
of the incoming node tree are automatically selected when you do this, so it's easy to drag the entire
node tree to another location in the Node Editor where there’s more room. When this happens, the
nodes of the incoming effect are exposed so you can reconnect and reconfigure it as necessary to
integrate the effect with the rest of your composition.
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Adding a LightWrap effect from the “How to” bin of
the Templates category of the Effects Library.
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Another way of adding, inserting, and replacing nodes is to use the Node Editor’s contextual menu,
which has dedicated submenus that let you create any kind of node available in Fusion. This can be a
convenient when the pointer is already in the Node Editor selecting, moving, or connecting nodes.

Methods of adding nodes using the contextual menu:

— To add a node: Right-click in an empty area of the Node Editor, and choose a node from the
Add Tool submenu.

— To insert a node: Right-click a node in the Node Editor, and choose a node from the Insert
Tool submenu.

— To replace a node: Right-click a node in the Node Editor, and choose a node from the
Replace Tool submenu.

TIP: When you replace one node with another, any settings that are identical between the
two nodes are copied into the new node. For example, replacing a Transform node with a
Merge will copy the existing center and angle values from the Transform to the Merge.

To delete one or more selected nodes, press Delete (macOS) or Backspace (Windows), or right-click
one or more selected nodes and choose Delete from the contextual menu. The node is removed

from the Node Editor, and whichever nodes are connected to its primary input and output are now
connected together. Nodes connected to other inputs (such as mask inputs) become disconnected.

v v
Background2 ColorCurves1

A

Background2

Before deleting a node from a node tree (top), and after upstream
and downstream nodes have automatically reconnected (bottom).

It's perfectly fine to have disconnected nodes, or even entire disconnected branches of a node tree,
in the Node Editor alongside the rest of a composition. All disconnected nodes are simply ignored
while being saved for possible future use. This can be useful when you're saving nodes that you've
customized but later decided you don't need. It's also useful for saving branches of trees that you've
since exported to be self-contained media that's re-imported to take the place of the original effect,
but you want to save the original nodes just in case you need to redo your work.

Working in the Node Editor

126




Selecting and Deselecting Nodes

In order to work with nodes in the Node Editor in any way, or modify node parameters in the
Inspector, you first need to learn to select the node or nodes you want to work with.

Selecting nodes is one of the most fundamental things you can do to move nodes or target them for

different operations. There are a variety of methods you can use.

Methods of selecting nodes:

— To select a single node: Click any node in the Node Editor.

— To select multiple nodes one at a time: Command-click each node you want to select.

— To select a whole region of nodes: Drag a bounding box around all nodes you want to select.

— To select all upstream or downstream nodes: Right-click a node and choose Select >
Upstream Nodes/Downstream Nodes from the contextual menu.

— To select all nodes in the Node Editor: Press Command-A.

— To select a node from the Keyframe Editor: Click any layer in the Keyframe Editor to select the
corresponding node in the Node Editor.

When you select a single node using any of the methods described above, the selected node is known
as the active node, and is highlighted orange to indicate that its parameters are currently editable

in the Inspector (if the Inspector is open). This also indicates that node will be targeted for specific
operations (such as inserting new nodes).

While multiple nodes can be selected, only one node will be the active node. To indicate the difference,
the active node remains highlighted with orange, while all other selected nodes are highlighted with
white. Unselected nodes have simple black outlines.

> Background2 —

The active node is highlighted orange, while other selected nodes are highlighted white.

To set the active node when there are multiple selected nodes:
— Option-click one of the selected nodes in the Node Editor to make that one the active node.

— Open the Inspector (if necessary), and click a node’s header bar to make it the active node.
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Deselecting nodes, when necessary, works pretty much as you would expect.

Methods of deselecting nodes:

— Click once in the background of the Node Editor to deselect all nodes.
— Press Command-Shift-A to deselect all nodes.

— Command-click to deselect multiple nodes one at a time.

— Command-drag a bounding box to deselect a group of selected nodes at one time.

Loading Nodes into Viewers

Once you've started building a composition, the next thing you need to learn is how to view specific
nodes that you want to work on. This is important because the combination of which node is being
viewed and which node is currently selected (these aren't always the same node) often determines
which onscreen controls are available and how they appear.

In the following example, you're set up to rotoscope an image using a Polygon node that's attached to
the garbage mask input of a MatteControl node which is inserting the mask as an alpha channel.

» Polygon1
[ ]

v v
Mediain1 —p MatteControl1 »

A A

A node tree for doing a simple rotoscoping job.
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As seen in the screenshot above, you'll want to load the upstream Medialn or Loader node into a
viewer while the Polygon node is selected for editing in order to see the full image you're rotoscoping
while keeping the Polygon node’s spline visible.

When you first open the Fusion page in DaVinci Resolve, the output of the current empty composition
(the MediaOut1 node) is usually showing in viewer 2. If you're in Dual-viewer mode, viewer 1 remains
empty until you assign a node to one of them.

When you first open Fusion Studio with an empty comp, both viewers remain empty even after
reading in media using a Loader node. The viewers only display content when you assign a node to
one of them.

There are several different ways to display a node in a viewer. Which ones you use depends on how
you like to work.

The View indicators are displayed under each node, and serve two purposes. First, they're a clickable
interface for displaying a node’s output in one of the viewers. Second, they're an indication of which
nodes in the Node Editor are being viewed. By default, there are two round indicators, representing
the two viewers. The left and right indicators correspond to the left and right viewers, regardless of
whether both viewers are visible or just one.

p Polygoni On

A viewer indicator enabled for the right
viewer and disabled for the left viewer.

To load a node into a viewer using the Node View indicators:

— Clicking an indicator turns it white to show that node is currently loaded in the corresponding
viewer. Clicking it again turns the indicator black and removes it from the viewer. Nodes only
display View indicators if they're currently being viewed. If you want to view indicators, hovering the
pointer over the node makes the indicators visible and available for clicking.

— You can also use keyboard shortcuts to toggle each View indicator. The default two viewers are
assigned numeric keyboard shortcuts 1 and 2. Pressing the corresponding number once displays
the selected node in the appropriate display view, while pressing it again clears that display.

For complex compositions, you may need to open additional viewers. For example, one viewer may
be used to display the end result of the final comp, while another viewer displays the source, a third
viewer displays a mask, and a fourth viewer might be a broadcast monitor connected via a Blackmagic
DeckLink card or other display hardware. When you have more than two viewers, additional View
indicators are added and each one is assigned a consecutive number between 3 and 9.
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The more viewers you add, the more you may need help remembering which viewer is represented by
which View indicator. Positioning the pointer over the View indicator in question will display a tooltip

with the name of the viewer it represents.

If the View indicators are too small of a target for you to click on reliably and you are not keyboard
oriented, another way to load a node into a viewer is to drag and drop it onto the viewer you want to
load it into. This offers a quick explicit way to assign a node to a viewer, especially for pen and tablet
users. Please note that as you drag, the node will appear to move at first, but it'll snap back into its
original location once the pointer leaves the Node Editor.

You can also right-click a node, and then choose View On > Left or Right to display the node on the
appropriate viewer.

Whenever you load a node into a viewer, you prompt that node, all upstream nodes, and other related
nodes to be rendered. If you load nodes into both viewers, this is doubly true. If you want to prevent

your computer from processing views that aren’t currently necessary, you can clear each viewer.

Methods of clearing viewers:
— Press 1 or 2 to empty the left or right viewers if they're filled.

— Press " (the Accent key) to empty both viewers.

You can right-click a node, and choose an option from the Create/Preview Play On submenu of the
contextual menu to render and play a preview of any node’s output on one of the available viewers.
The Render Settings dialog is displayed, and after accepting the settings, the tool will be rendered and

the resulting frames stored in RAM for fast playback on that view.

TIP: Hold the Shift key when selecting the viewer from the menu to bypass the Render dialog
and to start creating the preview immediately using the default settings or the last settings

used to create a preview.

Working in the Node Editor 130




Connecting and Disconnecting Nodes

Once you've started to add nodes to your composition, you need to connect them to perform their
intended operations.

Each node displays small colored knots around the edges. One or more arrows represent inputs, and
the square represent the tool's processed output, of which there is always only one. Outputs are white
if they're connected properly, gray if they're disconnected, or red to let you know that something’s
wrong and the node cannot process properly.

A Blur node with a Foreground Input,
Mask Input, and Output.

Each node takes as its input the output of the node before it. By connecting a Medialn node’s
output to a Blur node, you move image data from the Medialn node to the Blur node, which does
something to process the image before the Blur node’s output is in turn passed to the next node
in the tree.

Medialn1

Two nodes connected together.

To manually connect one node to another, click on one node’s output and drag a connection line out
to drop on another node’s input. The order in which you drag node connections is not important;
you can just as easily drag a connection from one node’s input to another node’s output and get the
same results.

Medialn1

Mediain1

Before (top), and after (bottom) dragging a connection
line and dropping it to connect two nodes.
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To make your life a bit easier, you can also drag a connection line and drop it directly on top of the

tile of a node to automatically connect to the default input of that node, which is usually labeled
"background” or “input.” In the following example, a connection is dragged from the output of a
Medialn node and dropped onto the tile of a Blur1 node, and the background input is connected first.

Medialnl

Medialn1

Before (top), and after (bottom) dragging a connection
line and dropping it on top of a node.

If you drop a connection on top of a node that already has the background input connected,
then the second most important connection will be attached, which for multi-input nodes is the
foreground input, and for other single-use nodes may be the Effects Mask input.

» Polygon1

Medialn1

» Polygon1

Mediain1

Before (top), and after (bottom) dragging a connection
line and dropping it on top of a node that has
the background input already connected.

Some multi-input nodes are capable of adding inputs to accommodate many connections, such
as the Merge3D node. These nodes simply add another input whenever you drop a connection
onto them.
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SpotLight1

After dragging a connection line and dropping
it on top of a Merge3D node.

Attaching Connections to Specific Inputs

If you want to make sure you don't attach a connection to the default input of a node, then you need
to drop it right on top of the specific node input you want to attach it to. If you can see the input’s label
in the tooltip bar, then you know you're correctly positioned to make a good connection.

However, there’s an alternate method of connecting nodes together in instances where there are
several inputs to choose from and you want to make sure you're choosing the correct one. Hold down
the Option key while dragging a connection from one node'’s output and dropping it onto the body of
another node. This opens a pop-up menu from which you can choose the specific input you want to
connect to, by name. Please note that this menu only appears after you've dropped the connection on
the node and released your pointing device's button.

Text1 (Text+, Txt+)

A [ ]
Medialn2 (MI) — ) Matte ol1 (Mat) 4

A

Text1 (Text+, Txt+)

Medialn2 (MI)

Option-dragging a node connection to drop onto
another node exposes a node input menu.
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Automatically and Manually Attaching Mask Nodes

Mask nodes, such as the Polygon, B-Spline, Ellipse, or Rectangle, have a different automatic behavior
when you connect them to other nodes. If you drag a connection from a Mask node onto the body
of another node, it will automatically connect itself to the default mask input, which is usually the
effect mask input. The assumption is that you're using the mask to limit the node’s effect somehow.
However, this isn't always the case, so you'll need to be careful of this behavior to make sure you're
attaching your mask to the input that will actually create the effect you need.

» Polygon1i » Polygon1
]

Before (left) and after (right) dragging a connection from a Mask
node and dropping it on top of a MatteControl node.

While you are still figuring out all the nodes and their inputs, hovering the pointer over any knot will
display a node tip with the knot’s name.

TIP: Rather than remembering the different knot types, press the right mouse button, hold
Option, and drag from the output of a node to the center of another tool. When you release
the mouse, a tooltip will appear allowing you to select the knot you want to connect to.

The order in which nodes are attached defines the order in which each image-processing operation is
applied to the image.

In the following example, a Medialn node adds a clip to the composition, while a Defocus node
blurs the image, and then a TV node adds scanlines and vertical distortion. Those effect nodes are
then connected to the MediaOut node in the Fusion page in DaVinci Resolve or a Saver node in
Fusion Studio.
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Background1

Adding a Defocus effect first, then the TV node second.

As you can see above, connecting the Defocus node first, followed by the TV node, means that while
the initial image is softened, the TV effect is sharp. However, if you reverse the order of these two
nodes, then the TV effect distorts the image, but the Defocus node now blurs the overall result, so

that the TV effect is just as soft as the image it's applied to. The explicit order of operations you apply
makes a big difference.
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Medialn1 Defocus?

Background1

Adding a TV effect first, and a Defocus second.

As you can see, the node tree that comprises each composition is a schematic of operations with
tremendous flexibility. Additionally, the node tree structure facilitates compositing by giving you the
ability to direct each node’s output into separate branches, which can be independently processed
and later recombined in many different ways, to create increasingly complex composites while
eliminating the need to precompose, nest, or otherwise compound layers together, which would
impair the legibility of your composition.

In the following example, several graphics layers are individually transformed and combined with a
series of Merge nodes. The result of the last Merge node is then transformed, allowing you to move
the entire collection of previous layers around at once. Because each of these operations is clearly
represented via the node tree, it's easy to see everything that's happening, and why.
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Merge5 Transform1

The output of five Text nodes being combined using Merge
nodes is modified by a single Transform node.

Since nodes can be positioned anywhere in the Node Editor, and added in any direction, nodes are
referred to as being upstream and downstream of one another. Once you select a node, all other
nodes that directly or indirectly connect to its input are considered to be upstream. Any other nodes

that are directly or indirectly connected to the output are said to be downstream.

This is an important distinction to make because, unlike layer-based systems, the visual positioning of
nodes in your node tree has no bearing on the order of operations in that composition. The only thing
that matters is whether nodes are upstream or downstream of each other.

Tools upstream (left) and downstream (right) of the Merge node.

TIP: To help you stay organized, there are Select > Upstream/Downstream commands in the
Node Editor contextual menu for selecting all upstream or downstream nodes to move them,
group them, or perform other organizational tasks.

Node trees are a continuous work in progress, requiring constant revision and rearrangement as

you discover new details that need to be finessed, or things that you can do better once the overall
composition has taken shape. To facilitate quick changes, each connection between two nodes is
divided into two halves: the output half (connected to the upstream node’s output) and the input half
(connected to the downstream node’s input). This can only be seen when you hover the pointer over a
connection. The half your pointer is over is highlighted in blue.
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The two halves of a connection line that are
revealed when you hover your pointer over it.

By clicking and/or dragging these two halves, it's possible to quickly disconnect, reconnect, and
overwrite node connections, which is essential to rearranging your node tree quickly and efficiently.

To disconnect two nodes, do one of the following:
— Click once on the input half of the connection between two nodes.

— Click on the input arrow to which a connection is attached, then drag to pull the connection away
from the tool and drop it anywhere in an empty area of the Node Editor.

To overwrite a current connection:

— Drag the output or input half of a connection, and drop it directly onto another node’s input
or output. This simultaneously disconnects the previous connection and connects the one
you're dragging.

To reconnect a connection from one node to another:

— Drag the output or input half of a connection to disconnect it from one node, and drop the
connection directly on another node’s input or output.

Positioning the pointer over a node causes the connections attached to that node to become
highlighted, which makes it easier to see which nodes it's attached to. Additionally, highlighted
connections display the color of the input they're connected to, which makes it easy to see if they're
connected to a foreground, a background, or a particular kind of mask.

Hovering the pointer over a node highlights
the color of all connections, telling you
what kinds of inputs are connected.
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Additionally, positioning the pointer over a connection causes a tooltip to appear that displays the
output and input that connection is attached to.

v

Transform1 t\‘_ _ MediaOut1
————————— ™

Transform1.0Output -> MediaOut1.Input

Hovering the pointer over a node highlights the
connection between it and other nodes.

A node's input can only have one connection attached to it. However, a tool’s output can be connected
to inputs on as many nodes as you require. Splitting a node’s output to inputs on multiple nodes is
called branching. There are innumerable reasons why you might want to branch a node’s output.

A simple example is to process an image in several different ways before recombining these results
later on in the node tree.

» Polygon2

v
. Paintl
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Medialn2

A

u
» Polygon3

A Medialn node branched to two node operations
and then recombined using a Merge node.

Alternatively, it lets you use one image in several different ways—for example, feeding the RGB to
one branch for keying and compositing, while feeding the A channel to the Effects Mask input of
another node to limit its effect, or feeding RGB to a tracker to extract motion information.

v

P DeltaKeyer1
e
Medialn3 " A

v
Tracker1

A

A Medialn node branched to two different
kinds of inputs, used separately.
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Connecting Merge Nodes

The Merge node is the primary tool available for compositing images together. Each Merge

node is capable of combining two inputs to create a third, using standard compositing methods

and composite modes. For more extensive information about the Merge node, see Chapter 42,

“I/0 Nodes,” in the Fusion Reference Manual or Chapter 104 in the DaVinci Resolve Reference Manual.

For this chapter, all you need to know is that if you attach a background image to the Background
input (such as a landscape), and a foreground image with an alpha channel to the Foreground input
(such as a graphic with an alpha channel), the Merge node will combine them into a single image for
further compositing.

v b 4
Mediain1 DeltaKeyer1

A A

Medialn2

Two Medialn nodes and a DeltaKeyer node attached to a Merge node, creating a composite.

Each Merge node has three inputs:

— Background (orange): The default input. Whichever image is connected to this input defines the
output resolution of the Merge node.

— Foreground (green): The secondary input, meant for whichever image you want to be “on top.”

— Effect Mask (blue): An optional input you can use to attach a mask or matte with which to limit the
effect of the Merge node.

It's important to make sure you're attaching the correct nodes to the correct inputs to ensure you're
getting the result you want, and it's important to keep these inputs in mind when you connect to

a Merge node. Of course, you can always drag a connection to a specific input to make sure you're
connecting things the way you need. However, if you're in a hurry and you simply drag connections
right on top of a Merge node:

— The first connection will be made to the background input.
— The second connection will be made to the foreground input.

— The third connection will be made to the effect mask input.

TIP: When you add a Merge node after a selected node by clicking the Merge button on the
toolbar, by clicking on the Merge icon in the Effects Library, or by right-clicking a node in the
node tree and choosing Insert Tool > Composite > Merge from the contextual menu, the new
Merge node is always added with the background connected to the upstream node coming

before it.
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There's a nice shortcut for connecting Merge nodes if you want to connect the incoming clip
immediately to your node tree as the top layer of a composite, and that's to drag a clip from an
Operating System window or a Generator from the Effects Library right on top of any connection line.

When you drop the resulting node, this automatically creates a Merge node, the background input
of which is connected to the next node to the left of the connection you dropped the clip onto, and
the foreground input of which is connected to the new node that represents the clip or Generator
you've just added.

Medialn1 (MI)

Medialn1 (MI) - Mergel (Merge, Mrg) m
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Medialn2 (MI) .//ﬂ_/-

Dragging a node from the Media Pool onto a connection (top), and
dropping it to create a Merge node composite (bottom).

Additionally, If you drag two or more nodes from an OS window into the Node Editor at the same
time, Merge nodes will be automatically created to connect them all, making this a fast way to
initially build a composite.
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Medialn3

Medialn4

Medialn5

By dragging three nodes from an OS window to the Node Editor (top),
Merge nodes are automatically created to connect them all (bottom).

Here's an endlessly useful shortcut for when you have a disconnected node that you want to
composite over another node. Drag a connection from the output of the node you want to be the
foreground layer, and drop it on top of the output of the node you want to be the background layer,

and a Merge node will be automatically created to build that composite.

Medialn1 (M1}

Medialn2 (MI)

Medialn1 (MI) .\

v
Medialn2 (M) m—p Mergel (Merge, Mrg) m

Dragging a connection from a disconnected node to another node’s output
(top), and dropping it to create a Merge node composite (bottom).
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Connection Options and Routers

By default, the Node Editor uses linear connections that are drawn straight between any two
connected nodes. While efficient, this sometimes causes connection lines to overlap nodes, which

some people feel interferes with the view of the Node Editor.

Linear connections between nodes.

If you like, you can change how connections are drawn by enabling orthogonal connections, which
automatically draws lines with right angles to avoid having connections overlap nodes.

Optional orthogonal connections between nodes.

Functionally, there's no difference to your composition; this only affects how your node tree appears.

To change how connections are drawn in the Node Editor:

— Right-click the Node Editor background and choose one of the following from the contextual menu.
— Options > Direct Pipes
— Options > Orthogonal Pipes

If you want to force a particular connection to be drawn at an angle to keep your node tree tidy,
you can add a router to either linear or orthogonal connections to force an angle so it will be drawn
however you like.
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» BSpline1

Ca—» Transform1 m—» Drip1

A router added to force a connection to be drawn at an angle.

Routers are tiny nodes with a single input and an output, but with no parameters except for
a comments field (available in the Inspector), which you can use to add notes about what's
happening in that part of the composition.

Even more usefully, you can branch a router’s output to multiple nodes, which makes routers even
more useful for keeping node trees neat in situations where you want to branch the output of a
node in one part of your node tree to other nodes that are all the way on the opposite end of that
same node tree.

Medialn3
//
'/ v

MatteControl1

A n

A router branching its output to multiple nodes.
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Methods of using routers:
— To add a router to a connection: Option-click anywhere on a connection.

— To move a router: Drag the router to a new location, and the connection will reshape
itself as necessary.

— To branch a router’s output: Drag a connection from the router output to the input of another
node. You can branch a router’s output as many times as you need to.

— To remove a router: Select any router and press the Delete key, or right-click a router and choose

Delete from the contextual menu.

Swapping Node Inputs

For multiple-input nodes such as the Merge, Merge 3D, and Dissolve nodes, there's a quick method
of swapping the Primary and Secondary inputs, such as the foreground and background inputs of a
Merge tool, when you find you've accidentally connected them in the wrong order. If a node has more
than two of its inputs connected, only the foreground and background inputs will be swapped.

To swap the primary inputs of a multi-input node, do one of the following:
— Select a node and press Command-T to reverse its inputs.

— Right-click a node and choose Swap Inputs from the contextual menu.

Medialn3
| ]

Medialn3

Before swapping node inputs (top), and after swapping node inputs
(bottom), the connections don’t move but the colors change.

Inputs can move freely around the node, so swapping two inputs doesn't move the connection
lines; instead, the inputs change color to indicate you've reversed the background (orange) and

foreground (green) connections.
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Extracting and Inserting Nodes

When building a composition, you'll often find that you need to rearrange nodes that you've already
added, in order to connect them in different ways to obtain a better result. Happily, this is easy to do
by extracting one or more nodes from one part of a node tree and inserting them at another part of
the node tree.

To extract one or more nodes from their position in the node tree:

— To extract a single node: Hold down the Shift key, drag a node from the node tree up or down to
disconnect it, and then drop the node before releasing the Shift key. That node is now detached,
and the output of the next upstream node is automatically connected to the input of the next
downstream node to fill the gap in the node tree.

— To extract multiple nodes: Select the nodes you want to extract, hold down the Shift key,
drag one of the selected nodes up or down to disconnect them, and then drop the node before
releasing the Shift key. Those nodes are now detached (although they remain connected to one
another), and the output of the next upstream node is automatically connected to the input of the

next downstream node to fill the gap in the node tree.

~ BlurT

Glow1 [3

'Y

Before extracting a pair of nodes (left), and after extracting a pair of nodes (right).

After you've extracted a node, you can re-insert it into another connection somewhere else. You can

only insert one node at a time.

To insert a disconnected node in the Node Editor between two compatible nodes:
Hold down the Shift key and drag a disconnected node directly over a connection between two
other nodes.

Once the connection highlights, drop the node, and then release the Shift key. That node is now

attached to the nodes coming before and after it.

Before inserting a node (left), and after inserting a node (right).
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TIP: If you hold down the Shift key, you can extract a node and re-insert it somewhere else
with a single drag.

Cut, Copy, and Paste Nodes

The standard operations of cut, copy, and paste are also available in the Node Editor. You can use
them to temporarily remove nodes from the Node Editor, create duplicate nodes, or even copy the
settings from one node and paste those settings into another node with compatible settings.

The standard commands all work, but with some special features specific to the Node Editor.

To copy one or more selected nodes, do one of the following:
— Right-click a node and choose Copy from the contextual menu.

— Choose Edit > Copy from the Edit menu (Command-C).

To cut one or more selected nodes, do one of the following:
— Right-click over the node and choose Cut from the contextual menu.
— Choose Edit > Cut from the Edit menu (Command-X).

When you paste into the Node Editor, you create a copy of the last node or nodes you've cut or copied.
When pasting, there are a few different things you can do to control where pasted nodes appear.

To paste one or more selected nodes, do one of the following:

— To paste nodes to be inserted after another node: Select the node in the node tree you want to
insert the pasted node(s) to, and choose Edit > Paste (Command-V).

— To paste nodes to be disconnected from the rest of the node tree: Deselect all nodes, and then
choose Edit > Paste (Command-V), or right-click anywhere in the Node Editor and choose Paste
from the contextual menu.

— To paste disconnected nodes in a specific area of the Node Editor: Deselect all nodes, and
then click the place in the Node Editor where you want pasted node(s) to appear, and choose
Edit > Paste (Command-V), or right-click anywhere in the Node Editor and choose Paste from the
contextual menu.

— To paste a node to replace an existing node in the Node Editor: Right-click a node in the
Node Editor that you want to replace, choose Paste from the contextual menu, and when a dialog
appears asking if you want to replace that node, click OK. This only works when you use the
contextual menu command.

TIP: When you paste a Medialn, Loader, or Generator node so it will be inserted after a
selected node in the node tree, a Merge tool is automatically created and used to composite
the pasted node by connecting it to the foreground input. While this can save you a few steps,
some artists may prefer to perform these sorts of merges manually, so this can be changed
using the Defaults panel in the Auto tools section of the Fusion > Fusion Settings.
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Instead of pasting a node, you can choose to paste just the parameter settings that you copied from
another node. This can be useful if you've carefully set or animated parameters in one node that you
want to also use in another node.

Note that you can paste settings between two nodes of the same type, or between two entirely
different kinds of nodes that happen to have one or more of the same parameters in the Inspector.
When copying settings from one type of node to another, only the settings that match between two
nodes will be copied. Acommon example is to copy an animated Center parameter from a Transform
node to the Center parameter of a Mask node.

To Paste settings from one node to another:

Select a node that has settings you want to copy, and choose Copy from the
Edit menu (Command-C).

Right-click a node you want to paste those settings to, and choose Paste Settings
from the contextual menu.

The format of nodes in the Node Editor is not binary, but is in fact a simple text format. The

implications of that may not be obvious, but one example benefit is clear when you start dealing
with nodes.

One or more nodes can be copied from the Node Editor and pasted directly into a text editor or email.
This pastes the selection in text format, just as it's saved internally in Fusion. For example, if you copy
the following set of three nodes:

> Medialn3

v
> Merge3 —>
A

A set of three nodes being copied.
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And you then paste into a new text editing document, you get the following:

o0 e Untitied 2 —
Untithed 2
{
Tools = ordered() {
Medialnd = Medialn {
ExtentSet = true,
CustomData =
MediaProps = {
MEDIA_HEIGHT = 1880,
MEDIA_MARK_IN = @,
MEDIAMARK QUT = 244,
MEDIA_MAME = “@68830835-aerial-absiracti-vaves-crystals_PRORESHDLRER. nox",
MEDIA_HUM_FRAMES = 245,

MEDIAPATH = “/Valumes/Media Raid Teo/Davinci Media/Fusion Manual Example Media/PondS Media/Textures/RGB39838-aerial-abstract-waves-crysial=_PRORESHOL080.mox"
MEDTA_SAC_FRAME_RATE = 25,
MEDIA_START_FRARE = 8,
MEDIA_WIOTH = 1920
h
h
Inputs =
GlobalOut = Input { Value = 244, },
SRdc-Aehiz44aR-0e09-32129040 06457, b,

4, b,

MedisID = Input { Value =
Layer = Ingut { Value = ™
ClipTimeEnd = Input { Val

h
Viewlnfo = Operatorinfo { Pos = { 825, 115.5 1 h,

H
Herged = Merge {
Inputs = {
Background = Tnput {
Sourcelp = "Medialnd",
Source = “0utput®,

k.
A PerforsDeptnMerge = Input { value = @, },
R ViewInfe = Ogeratorinfo { Pos = { 825, 1815 } },
Glowl = Glow {
CtriWzoon = false,
Inputs =
Blend = Input { Value = 8.2, b

e
ViewInfo = OperatorInfo { Pos = { 935, 181.5 } },

The same three nodes pasted into a text editor.

At this point, you have the option of editing the text (if you know what you're doing), emailing it to
colleagues, or storing it in a digital notepad of some sort for future use. To use this script in Fusion
again, you need only copy it and paste it back into the Node Editor.

TIP: This is a very easy way to pass specific node settings back and forth between artists who

may not be in the same room, city, or country.

Instancing Nodes

Normally, when you use copy and paste to create a duplicate of a node, the new node is completely
independent from the original node, so that changes made to one aren't rippled to the other.
However, there are times when two nodes must have identical settings at all times. For example, when
you're making identical color corrections to two or more images, you don't want to constantly have to
adjust one color correction node and then manually adjust the other to match. It's a hassle, and you
risk forgetting to keep them in sync if you're working in a hurry.

While there are ways to publish controls in one node and connect them to matching controls in
another node, this becomes prohibitively complex and time consuming for nodes in which you're
making adjustments to several controls. In these cases, creating “instanced” nodes is a real time-saver,

as well as an obvious visual cue in your node tree as to what's going on.

Instanced nodes are nodes that have been created using the Paste Instance command, and
which share settings with the original node so that a change made to one instanced node is also
automatically applied to all other instances of that node (as well as the original node you copied).
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To create an Instance, do the following:
Select a node you want to instance, and copy it (Command-C).
Do one of the following:

To create a disconnected instance of a node: Right-click in the background of the Node Editor,
and choose Paste Instance from the contextual menu (Command-Shift-V).

To insert an instanced node between two other nodes: Select a node that's upstream of where
you want to insert the instanced node, and press Command-Shift-V. Alternatively, you can right-
click directly on a connection line, and choose Paste Instance from the contextual menu.

However you paste an instance, the name of that instanced node takes the form
"Instance_NameOfNode." If you paste multiple instances, each instance is numbered
"Instance_NameOfNode_01."

Medialn1

¥
Medialn2 I N . Instance_Blur1

A green link line shows an instanced Blur node’s relationship to the original Blur node it was copied from.

When a node tree contains instanced nodes, a green line shows the link between the original node
and its instances. You have the option to hide these green link lines to reduce visual clutter in the
Node Editor.

To toggle the visibility of green instance link lines in the Node Editor:
Right-click anywhere in the background of the Node Editor.
Choose Options > Show Instance Links from the contextual menu.

If you've been using an instance of a node and you later discover you need to use it to apply separate
adjustments, you can “de-instance” the node.

To de-instance a node, making it independent:
Right-click an instanced node.

Choose Deinstance from the contextual menu. That node is now independent from the original
node. Once you de-instance a node, you cannot re-instance it, but you can undo the operation.

NOTE: If you've de-instanced a node and you cannot undo the operation because you've
restarted DaVinci Resolve, you can only recreate an instance by copying the original and
pasting an instance again.

Working in the Node Editor




By default, every parameter in an instanced node is linked to the original node, so that any change
you make is rippled across. However, from time to time you'll find the need to independently adjust
just one or two parameters while keeping the rest of that node’s parameters linked. For this reason,
instead of de-instancing the entire tool, you can de-instance individual parameters.

To de-instance a single parameter:

— Right-click on a parameter’s name or value in the Inspector, and choose Deinstance from the
contextual menu.

If you've only de-instanced individual parameters, you can re-instance those parameters later on if
you change your mind.

To re-instance a single parameter:

— Right-click on a parameter’s name or value in the Inspector, and choose Reinstance from the
contextual menu. That parameter immediately inherits the setting of the original node.

Keeping Node Trees Organized

Similar to working with files on your desktop, even the simplest of composites require you to do some
amount of organization. In this section we'll look at some basic node operations, some of which you
may already be familiar with just from using your computer’s operating system or other applications.

Selecting one or more nodes and dragging them moves them to a new location, which is one of the
simplest ways of organizing a node tree, by grouping nodes spatially according to the role they play in
the overall composition.

Keep in mind that the location of nodes in the Node Editor is purely aesthetic, and does nothing to
impact the output of a composition. Node tree organization is purely for your own peace of mind, as
well as that of your collaborators.

TIP: Once you've arranged the nodes in a composition in some rational way, you can use
the Sticky Note and Underlay tools to add information about what'’s going on and to visually
associate collections of nodes more definitively. These tools are covered later in this section.

Snapping Nodes to the Grid

By default, you can position nodes freely wherever you want them to be. However, keeping nodes and
connection lines straight and aligned can make them easier to read. To help keep them aligned, you
can have nodes you're dragging automatically snap to the grid.
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To have nodes snap to the grid as they're dragged:

— Right-click over an empty area of the Node Editor, and choose Arrange Tools > To Grid from the
contextual menu. All nodes you drag now snap to the nearest grid coordinate.

— Right-click over an empty area of the Node Editor, and choose Arrange Tools > To Connected from
the contextual menu. All nodes you drag now snap to the horizontal or vertical position of the
nodes they're attached to.

TIP: You can set “Arrange to Grid” or “Arrange to Connected” as the default for new
compositions by choosing Fusion > Fusion Settings in DaVinci Resolve or File > Preferences
in Fusion Studio, and turning the Fusion > Node Editor > Arrange To Grid or Arrange to
Connected checkboxes on.

Commands to “Clean Up” a Node Tree

The grid in the background of the Node Editor can be used to align nodes, either by eye
or automatically.

To “clean up” an unruly node tree:

— Right-click in an empty section of the Node Editor, and choose Line Up All Tools to Grid from the
contextual menu. All nodes in the Node Editor will move to align and center themselves along the

nearest grid lines.

To “clean up” only one or more selected nodes:

— Right-click one of the selected nodes and choose Line Up to Grid from the contextual menu. All
selected nodes will move to align and center themselves along the nearest grid lines, while all

unselected nodes will be left as they are.

Each node that's created is automatically assigned a name (based on its function) and a number (based
on how many of that type of node have been created already). For example, the first Blur node added
to a composition will be called Blur1, the second will be Blur2, and so on. Although initially helpful, larger
compositions may benefit from important nodes having more descriptive names to make it easier to
identify what they're actually doing, or to make it easier to reference those nodes in expressions.

To rename a node:
Do one of the following:
— Right-click a node and choose Rename from the contextual menu.

— Select a node and press F2.

When the Rename dialog appears, type a new name, and then click OK or press Return.

NOTE: If multiple nodes are selected, multiple dialogs will appear asking for a
name for each tool.
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Since Fusion can be scripted and use expressions, the names of nodes must adhere to a scriptable

syntax. Only use alphanumeric characters (no special characters), and do not use any spaces.

Also, you cannot start a node name with a number. If you accidentally create a name that doesn't
exactly follow the guidelines, spaces and invalid characters will be automatically deleted.

If you want to see the original node types instead of the node names, press and hold Command-Shift-E.

You can change the color of any node by selecting it, opening the Inspector, and choosing a new color
from the Node Color pop-up in the Inspector header for that node. Alternatively, you can right-click a
node and choose a color from the Set Color submenu.

To return a node to its regular color, right-click it and choose Set Color > Clear Color from the
contextual menu, or open the Node Color pop-up for a node in the Inspector, and choose Clear Color.

A good way to add notes about different parts of a composition, client feedback about various details,
and other information you want to keep track of, is to add Sticky Notes to the Node Editor.

X Note1
This part adds a little bit of
sparkle, but is optional if you
don't like it.

Medialn3
| ]

A Sticky Note in the Node Editor.

Sticky Notes are yellow boxes in which you can type whatever text you want. They can be resized,
moved, and collapsed when they're not being edited, but once created they remain attached to the
background of the Node Editor where you placed them until you either move them or delete them.

Methods of working with Sticky Notes:

— To create a Sticky Note: Click somewhere in the Node Editor where you want a Sticky Note to
appear. Then, press Shift-Spacebar, type sticky, and press the Return key when the Sticky Note
appears in the Select Tool window. Alternatively, you can open the Effects Library, open the Tools >
Node Editor category, and click or drag the Sticky Notes node to create a new one.

— To open a Sticky Note to full size: Double-click a minimized Sticky Note and it expands to a larger,
resizable yellow box.
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— To edit a Sticky Note: If necessary, double-click a Sticky Note to open it to full size, and then click
once in the body of the note to place a text cursor. You can edit text within the Sticky Note just like

any other text editor.

— To rename a Sticky Note: Right-click a Sticky Note, choose Rename, type a new name into the
Rename dialog, and click OK. Alternatively, you can select a Sticky Note, press F2 to open the
Rename dialog, and press Return to close it when you're done.

— To resize a Sticky Note: Double-click a Sticky Note to open it to full size, and then drag any of the

edges or corners to make it larger or smaller.

— To minimize a Sticky Note: Click the close box at the upper left-hand corner of the Sticky Note,

and it collapses to a small tile.

— To delete a Sticky Note: Right-click any Sticky Note and choose Delete from the contextual menu
or select the Sticky note in the Node Editor and press the Delete key.

Underlay Boxes are a good way of associating a collection of nodes that work together to perform a
specific task in your composition. They're simply colored rectangles that you can put nodes inside of.
Once you place nodes inside an Underlay, you can move the Underlay, and all the nodes within move
along with it.

Mediain3

An Underlay in the Node Editor.

Underlay Boxes can be named to identify the purpose of that collection of nodes, and they can
be colored to be distinct from other Underlay Boxes or to adhere to some sort of color code for
your compositions.

Methods of working with Underlay Boxes:

— To create an Underlay Box: Click somewhere in the Node Editor where you want the Underlay Box
to appear. Then, press Shift-Spacebar, type under, and press the Return key when the Underlay Box
appears in the Select Tool window. Alternatively, you can open the Effects Library, open the Tools >
Node Editor category, and click or drag the Underlay Box node to create a new one.

— To create an Underlay Box around specific nodes: Select the nodes in the Node Editor that you
want surrounded by an Underlay Box. Then, press Shift-Spacebar, type under, and press the Return
key when the Underlay Box appears in the Select Tool window. Alternatively, you can open the
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Effects Library, open the Tools > Node Editor category, and click the Underlay Box node to have it
added and sized to encompass all the selected nodes.

— To resize an Underlay Box: Drag any of the edges or corners to make it larger or smaller.

— To rename an Underlay Box: Option-click the Underlay Box to select just the box and not the
contents, and then right-click it and choose Rename (or press F2). Type a new name into the
Rename dialog and click OK or press Return.

— To change the color of an Underlay Box: Option-click the Underlay Box to select just the box and

not the contents, and then right-click it and choose a color from the Set Color submenu.

— To put nodes inside of an Underlay Box: Select the nodes you want to place inside an
Underlay Box, and then drag them to fit inside. The Underlay Box must be big enough to fit all the
nodes. Alternatively, you can place an Underlay Box near a collection of nodes you want to put
inside it, and then resize the Underlay Box to encompass all those nodes.

— To move an Underlay Box and all its nodes: Once nodes have been placed inside an Underlay
Box and have been deselected, you can move the entire collection of nodes together by dragging
the Underlay Box by its title bar.

— To remove nodes from an Underlay Box: There are two ways you can remove nodes from an

Underlay Box.

— With both the Underlay Box and nodes deselected, drag a bounding box or Command-click to
select all nodes in the box you want to remove, and drag them out.

— Resize the Underlay Box so that it's smaller than the collection of nodes it originally
encompassed. Once an Underlay Box is so small that even the last node sticks out beyond its
edge, those nodes are automatically removed from the Underlay Box, and you can move or
delete the Underlay Box without moving those nodes.

— To delete an Underlay Box and all nodes within: Select an Underlay Box and press the Delete
key to delete both the Underlay Box and all nodes found inside it. If you don't also want to delete
the nodes, first drag the nodes out of the box.

— To delete an Underlay Box but keep all nodes within: Option-click the Underlay Box to select it
and not the nodes, and then press the Delete key. The nodes within remain where they were.

Node Thumbnails

Once a source or an effect has been added to the Node Editor, it's represented by a node. By default,
nodes are rectangular and thin, making it easier to fit reasonably complicated grades within a
relatively small area. However, if you like, you can also display node thumbnails.

» Paintl

A node in the Node Editor shown without and with a thumbnail.
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Nodes can be displayed as a small rectangle or as a larger square. The rectangular form displays
the node’s name in the center, while the square form shows either the tool's icon or a thumbnail of
the image it is outputting.

TIP: Even if you're not displaying node thumbnails, you can quickly obtain detailed
information about a node and the data it's processing by hovering your pointer over it in the
Node Editor and viewing the tooltip bar below.

If you want to use node thumbnails to help visually identify media and operations in your node trees,
there are a variety options for which nodes should display thumbnails in the contextual menu that
appears when you right-click anywhere in the background of the Node Editor.

Force All Tile Pictures

This option shows thumbnails for every single node in the Node Editor. This can make simple node
trees easier to read, but it'll make all node trees take up considerably more room.

NOTE: If Show Thumbnails is enabled, nodes may not update until the playhead is moved in
the Time Ruler.

Force Active Tile Pictures

You may also choose to only show thumbnails for nodes that are currently selected, which can make it
easier to see which node you're working on. When nodes become deselected, the thumbnails will be
hidden again.

Force Source Tile Pictures

This enables thumbnails for all Medialn and Loader nodes in the Node Editor, as well as all generators,
and is a great way to be able to quickly see where all the clips are in a composition.

Force Mask Tile Pictures

This enables thumbnails for all Mask nodes in a composition, which can make them easier to
distinguish when you're building complex shapes made from multiple Mask nodes.

Manually Showing Tile Pictures and Node Options

You also have the option of manually choosing which nodes you'd like to show thumbnails.
For example, there may be certain key points of the node tree where you'd like to see a small visual
representation of what's happening in the composition.
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To toggle thumbnails for one or more specific nodes:
Select one or more nodes in the Node Editor.
Right-click one of the selected nodes, and choose one of the following from the contextual menu:
— Show > Show Tile Pictures

— Show > Show Modes/Options

When you've manually enabled thumbnails for different nodes, they’ll remain visible whether or not
those nodes are selected.

Whenever you enable node thumbnails, you have the choice of having these thumbnails either display
an image of the state of the image at that node, or you can instead choose to display the icon for that
particular node. The setting for this affects all nodes at once.

To display icons instead of thumbnails:

— Right-click anywhere in the background of the Node Editor and deselect Show Thumbnails in the
contextual menu.

Sometimes Nodes Only Show Icons

As you add more and more nodes to a composition, you'll notice that some nodes never
display an image in their thumbnail. In these cases, the default icon for that node is displayed
instead of an image.

Most nodes in the Particle and 3D categories fall into this group. The exceptions are the
pRender node and the Render 3D node. These two nodes are capable of displaying a
rendered thumbnail if you have the menu options set for Thumbnails to be displayed.

In other cases, whether nodes display images in their thumbnail is more situational. Some
Transform nodes are able to concatenate their results with one another, passing the actual
processing downstream to another node later in the node tree. In this case, upstream
Transform nodes don't actually process the image, so they don’t produce a thumbnail.

In other situations where the Loader is not reading in a clip or the clip is trimmed in the
Keyframes Editor to be out of range, it can cause the node not to process the image, so it will
not produce a rendered Thumbnail image. Also, nodes that have been set to Pass Through
mode are disabled and do not display a rendered Thumbnail image.
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Finding Nodes

Modern visual effects require detailed work that often results in compositions with hundreds of
nodes. For such large node trees, finding things visually would have you panning around the Node
Editor for a long, long time. Happily, you can quickly locate nodes in the Node Editor using the
Find dialog.

] Find Tools

The Find dialog lets you quickly locate nodes
wherever they are in the Node Editor.

To do simple searches using node names is easy.

To search for a node in the Node Editor:
Press Command-F, or right-click in an empty area of the Node Editor and choose Find from the
contextual menu.
When the Find dialog appears, do the following:
— Enter a search term in the Find field.

— Choose search options, such as whether to match the whole phrase in the Find field, whether to
match the case, whether to use a sequence number, or whether to use a regular expression in
the Find field.

— Choose what to search. Options include tool name, tool type name, or tool type ID.

To perform the find, do one of the following:
— Click Find Next to try to select a downstream node matching the criteria.
— Click Find Previous to try to select an upstream node matching the criteria.

— Click Find All to try to select all nodes in the Node Editor that match the criteria.

The Find window closes. If either the Find Next, Find Previous, or Find All operations are successful,
the found node or nodes are selected. If not, a dialog appears letting you know that the string could

not be found.

TIP: Finding all the nodes of a particular type can be very useful if you want, for example, to
disable all Resize nodes. Find All will select all the nodes based on the search term, and you
can temporarily disable them by pressing the shortcut for Bypass, Command-P.
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If you need to do more complicated searches, you can turn on the Regular Expression checkbox,
which lets you enter some simple expressions with which to create more complex find operations.
Some useful examples of regular expressions that are valuable include the use of Character Sets.

Character Sets

Any characters typed between two brackets [ ] will be searched for. Here are some examples of

character set searches that work in Fusion.

[a-Z]

Every node using a lower caps letter

[a-d]

Every lower caps letter from a to d, and will find nodes with a, b, ¢, or d

[Tt]

Every node with an upper case T or a lower case t

[aeiou]

Every vowel

[0-9]

Every numeral

[5-7]

Every numeral from five to seven, and will find nodes numbered with 5, 6, or 7

Custom Node Settings

When a node is added to the Node Editor, its parameters are set to the default values for that type

of node. If you find yourself constantly readjusting the parameters of a node to a preferred starting
point as soon as it's added to the node tree, you can override the default node settings with your own
custom settings.

To save new default settings for a particular type of node:
Create a new node.
Open the Inspector and customize that node’s settings to the new defaults you want it to have.

Right-click that node in the Node Editor, or right-click that node’s control header in the Inspector,
and choose Settings > Save Default from the contextual menu.

TIP: You can also save six different settings for a node in the Node Editor using the Version
buttons at the top of the Inspector. For more information, see Chapter 8, “Editing Parameters
in the Inspector,” in the Fusion Reference Manual or Chapter 70 in the DaVinci Resolve

Reference Manual.
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Custom node default settings are saved to a folder on your hard drive that's based on the Path Map
> Defaults preference in the Fusion Settings. This path is customizable for facilities where multiple
compositing artists use a common set of facility defaults, stored somewhere commonly accessible.
The default paths are:

— For macOS systems, this path defaults to: /UserName/Library/Application Support/
Blackmagic Design/DaVinci Resolve/Fusion/Defaults.

— For Windows systems, this path defaults to C: \Users\<username>\AppData\Roaming\
Blackmagic Design\DaVinci Resolve\Fusion\Defaults.

— For Linux systems, this path defaults to: ~/fusion/BlackmagicDesign/DaVinci Resolve/
Fusion/Defaults.

If you browse this directory, the settings for each node are saved using a name taking the form
INTERNALNAME_PUBLICNAME settings, where INTERNALNAME is the internal name of the Fusion
tool, and PUBLICNAME is the name of the Node that's derived from the internal Fusion tool. For
example, the default setting for a Blur node would be called Blur_Blur.setting. This naming convention
is partly to ensure that third-party plugin nodes don't overwrite the defaults for built-in Fusion nodes

that happen to have the same name.

Even if you've created new default settings for new nodes, you can always reset individual parameters
to the original default setting. In addition, it's easy to restore the original default settings for new
nodes you create.

To reset a single parameter to the original default settings:
Create a new node.
Open the Inspector and customize a parameter to the new default value you want it to have.

Right-click that parameter in the Inspector, and choose Set to Default from the contextual menu.

To reset every parameter in a node to the original defaults, do one of the following:
— Right-click on the node and choose Settings > Reset Default.
— Right-click that node’s control header in the Inspector, and choose Settings > Reset Default.

— Delete the .setting file from the Defaults folder.

NOTE: When you use the Settings > Reset Default command, the default .setting file is
deleted. If you want to save a node’s settings as alternate settings, you should use the

Settings > Save As command.
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Once you change parameter values for a node using the Inspector, those values can also be saved as
an alternate setting for that node, which can be reused at a later time.

To save alternate settings for a node:

Right-click on a tool, and then choose Settings > Save As from the contextual menu.

When the Save File dialog appears, enter a name for the Setting and save it to your hard drive.
Unlike saved defaults, the .settings files can be saved anywhere on the file system. They do not
need to be in the Default Settings folder.

To load a saved setting for one or more nodes:
Right-click a node and choose Settings > Load from the contextual menu.

Use the Open File dialog to select the settings you want to load into that node, and then click Open.

Those settings are now applied to that node.

Saved settings in your File system can also be used to create new nodes by dragging the .setting file
into the Node Editor from a standard file browser. Once dropped, that setting turns into a new node.

TIP: If you drop a setting directly onto a connection line, the new node will be inserted onto

that connection.

Node Modes Including
Disable and Lock

Right-clicking one or more nodes and opening the contextual menu reveals a series of commands in
the Modes submenu, some with accompanying keyboard shortcuts, that let you set control visibility,

disable, lock, update, and cache nodes.

— Show Controls: Sets whether that node reveals its parameters in the Inspector when it's selected
and whether its onscreen controls appear in viewers. On by default.

— Pass Through: (Command-P) Identical to the toggle switch in the Inspector that turns nodes off
and on. Disabled nodes are ignored as image data is passed from the next previous upstream
node to the next downstream node. On by default.

— Locked: (Command-L) Identical to the lock button in the Inspector that prevents a node from being
edited in the Inspector. Off by default.

— Update: (Command-U) On by default. While this option is enabled, all changes to the node will
cause it to re-render. When Update is disabled, you can still change the node’s parameters, but
those changes will not process or update the image until Update is re-enabled. While disabled,
the last processed image for that node will be displayed as a freeze frame. One example of when
this is useful is when you have a large or processor-intensive composition (such as a particularly
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intense particle system), and disabling this option temporarily will let you quickly make several
quick parameter adjustments to different nodes without forcing you to wait for the node tree to
re-render after every adjustment. Another example of when this is useful is when you want to
quickly see the effect of animated downstream nodes while keeping upstream nodes that are too

processor-intensive to play in real time from rendering additional frames.

— Force Cache: When enabled, this node’s output for the current frame has an extremely high cache
priority, essentially forcing it to stay cached in memory. Off by default.

Toggling any one of these node modes displays a badge within that node indicating its state.

Node Editor Options

Right-clicking in an empty area of the Node Editor will bring up the contextual menu and the Options
submenu. The Options submenu contains several choices that can be used to customize how the

Node Editor looks and behaves.

— Pipes Always Visible: Enabling this option causes a connection to cross over a node instead of
beneath it, sometimes making it easier to follow the connection’s path.

— Show Hidden Pipes: When enabled, the Inspector option to Hide Incoming Connections in every
node is overridden and all connections are displayed in the Node Editor.

— Aspect Correct Tile Pictures: Aspect Correct Tile Pictures forces the display of thumbnails to be
aspect corrected, which is slower but visually more accurate. This option is enabled by default.

— Full Tile Render Indicators: Enabling this option causes the thumbnail to flash green when
rendering, which makes it easier to identify which node is processing in a large, complex node tree.

— Show Grid: This option can be used to enable or disable the Node Editor’s background grid.

— Show Instance Links: When enabled, the Node Editor draws a green connection between an

instanced node and its parent.

— Auto Remove Routers: If routers are disconnected from a tool, they are automatically
deleted from the Node Editor. This option is enabled by default to eliminate the need to delete
orphaned routers.

— Show Navigator: Enabling this option displays a small overview window of the entire node tree in
the Node Editor’s top-right corner. For more information, see the Navigator section in this chapter.
— Auto Navigator: The Navigator only appears when one or more nodes is outside the visible area of

the Node Editor. For more information, see the Navigator section in this chapter.

— Build Flow Vertically/Horizontally: Node trees can be built either horizontally from left to right
or vertically from top to bottom. Enabling one of these options determines whether new nodes are
added beneath the current node or to the right of the current tool.

— Orthogonal/Direct Pipes: Use these two options to decide whether connections between nodes
are drawn as Direct (straight) lines or Orthogonal (bent) lines.
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Node Tooltips and the Status Bar

Even in simple node trees, it's easy to forget some essential detail about the nodes in your comp.
To help you figure out what everything’s for, you can hover the pointer over any node in the Node
Editor to display information in the Status bar at the bottom of the Node Editor consisting of that
node’s name, frame size, pixel aspect, resolution, and color depth.

The Status bar located beneath the Node Editor.

If you wait a few moments later, a more elaborate presentation of the same information appears
within a floating tooltip in the Inspector. This tooltip gives you additional information about the
Domain (Image and DoD) and the data range used by that clip.

Merge2
(Merge, Mrg)

Domain: HiQ

Image: (0, 0) - (1920, 1080)

Frame Size (1920, 1080)
Pixel Aspect 1:1
Depth 32bit float

The floating tooltip showing node information
that appears within the Node Editor.
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Node Groups, Macros,
and Fusion Templates

This chapter reveals how to use groups, macros, and templates in
Fusion so working with complex effects becomes more organized,

more efficient, and easier.
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Groups

When you work on complex visual effects, node trees can become sprawling and unwieldy, so
grouping tools together can help you better organize all the nodes and connections. Groups are
containers in your node tree that can hold multiple nodes, similar to the way a folder on your Desktop
holds multiple files. There is no limit to the number of nodes that can be contained within a group, and
you can even create subgroups within a group.

Creating a group is as simple as selecting the nodes you want to group together and using the

Group command.

To create a group:
Select the nodes you want grouped together.

Right-click one of the selected nodes and choose Group from the contextual menu (Command-G).

.l[ Me{liialm -

|[ Meaialnz [ — Instance_Blur1 e

Group1

Several nodes selected in preparation for making a group (top), and the resulting group (bottom).

The selected nodes are collapsed into a group, which is displayed as a single node in the Node Editor.
The Group node can have inputs and outputs, depending on the connections of the nodes within
the group. The Group node only displays inputs for nodes that are already connected to nodes
outside the group. Unconnected inputs inside the group will not have an Input knot displayed on the
Group node.
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Deleting a group is no different from deleting any other node in the Node Editor. Select a group and
press Delete, Backspace, or Forward-Delete, and the group along with all nodes contained within it are

removed from the node tree.

A collapsed group is represented by a single “stack” node in the node tree. If you want to modify any
of the nodes inside the group, you can open the group by double-clicking it or by selecting the group

node and pressing Command-E.

An open group window showing
the minimize button.

When you open a group, a floating window shows the nodes within that group. This floating window is
its own Node Editor that can be resized, zoomed, and panned independently of the main Node Editor.
Within the group window, you can select and adjust any node you want to, and even add, insert, and
delete nodes while it is open. When you're ready to collapse the group again, click the minimize button
at the top left corner of the floating window, or use the keyboard shortcut (Cmd-E).

You can pan and scale an open group window using the same mouse buttons you use to pan and
scale the main Node Editor. However, when you're working in an expanded group and simultaneously
making changes to the main node tree, you may want to prevent the expanded group from being
individually panned or scaled. Turning off the Position button at the right of the group title bar locks
the group nodes to the size of the nodes in the rest of the overall node tree. Turning on this Position

button lets you size group nodes independently of the rest of the node tree.

If you decide you no longer need a particular group, or you simply find it easier to have constant
access to all the nodes in the group at once, you can decompose or “ungroup” the group without
deleting the nodes within it to eliminate the group but keep the contents in the Node Editor.

To ungroup nodes, do the following:
Right-click on the group.

Choose Ungroup from the contextual menu. The nodes inside the group are placed back in the
main node tree.
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One of the best features of groups is that every group and its settings can be saved for later use in
other shots or projects. Groups and their settings can be recalled in various ways.

A good example of when you might want to Save and Load a group is in a studio with two or more
compositing artists. A lead artist in your studio can set up the master comp and create a group
specifically for keying greenscreen. That key group can then be passed to another artist who refines
the key, builds the mattes, and cleans up the clips. The setting can then be saved out and loaded
back into the master comp. As versions are improved, these settings can be reloaded, updating the
master comp.

Methods of saving and reusing groups:
— To save a group: Right-click a group and choose Settings > Save As from the contextual menu.

— To reuse a group: Drag it from your computer’s file browser directly into the Node Editor.
This creates a new group node in the node tree with all the same nodes as the group you saved.

— To load the settings from a saved group to another group with the same nodes: Right-click a
group in the Node Editor and choose Settings > Load from the contextual menu.

In Fusion Studio, you can also save and reuse groups from the Bins window:

— To save a group: Drag the group from the Node Editor into the opened Bin window. A dialog
will appear to name the group setting file and the location where it should be saved on disk.
The .setting file will be saved in the specified location and placed in the bins for easy access
in the future.

Macros

Some effects aren't built with one tool, but with an entire series of operations, sometimes in complex
branches with interconnected parameter controls. Fusion provides many individual effects nodes

for you to work with but gives users the ability to repackage them in different combinations as
self-contained “bundles” that are either macros or groups. These “bundles” have several advantages:

— They reduce visual clutter in your node tree.

— They ensure proper user interaction by allowing you to restrict which controls from each node of
the macro are available to the user.

— They improve productivity by allowing artists to quickly leverage solutions to common compositing
challenges and creative adjustments that have already been built and saved.

Macros and groups are functionally similar, but they differ slightly in how they're created and
presented to the user. Groups can be thought of as a quick way of organizing a composition by
reducing the visual complexity of a node tree. Macros, on the other hand, take longer to create
because of how customizable they are, but they're easier to reuse in other comps.

While macros let you save complex functions for future use in very customized ways, they're actually
pretty easy to create.
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To make a macro from nodes in the Node Editor:
Select the nodes you want to include in the macro you're creating. Because the macro you're
creating will be for a specific purpose, the nodes you select should be connected together to
produce a particular output from a specific set of inputs.

TIP: If you want to control the order in which each node’s controls will appear in the macro
you're creating, Command-click each node in the order in which you want it to appear.

Right-click one of the selected nodes and choose Macro > Create Macro from the contextual menu.

A Macro Editor window appears, showing each node you selected as a list, in the order in which

each node was selected.

L [ ] Macro Editor - MacraTool1*

MacroTooll

Controls

Fast Gaussian

Common

The macro editor with a Blur node and Color Corrector node.

First, enter a name for the macro in the field at the top of the Macro Editor. This name should
be short but descriptive of the macro’s purpose. No spaces are allowed, and you should
avoid special characters.

Next, open the disclosure control to the left of each node that has controls you want to expose to
the user and click the checkbox to the right of each node output, node input, and node control that

you want to expose.

The controls you check will be exposed to users in the order in which they appear in this list, so you
can see how controlling the order in which you select nodes in Step 1, before you start editing your
macro, is useful. Additionally, the inputs and outputs that were connected in your node tree are
already checked, so if you like these becoming the inputs and outputs of the macro you're creating,
that part is done for you.

For each control's checkbox that you turn on, a series of fields to the left of that control’s row lets
you edit the default value of that control as well as the minimum and maximum values that control

will initially allow.
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When you're finished choosing controls, click Close.
A dialog prompts you to save the macro. Click Yes.

A Save Macro As dialog appears in which you can re-edit the Macro Name (if necessary), and
choose a location for your macro.

To have a macro appear in the Fusion page Effects Library Tools > Macros category, save it in the
following locations:

Macintosh HD/Users/username/Library/Application Support/Blackmagic Design/

DaVinci Resolve/Fusion/Macros/

C:\Users\username\AppData\Roaming\Blackmagic Design\DaVinci Resolve\Support\
Fusion\Macros

home/username/.local/share/DaVinciResolve/Fusion/Macros

To have a macro appear in the Fusion Studio Effects Library Tools > Macros category, save it in the
following locations:
Macintosh HD/Users/username/Library/Application Support/Blackmagic Design/
Fusion/Macros/
C:\Users\username\AppData\Roaming\Blackmagic Design\Fusion\Macros

home/username/.fusion/BlackmagicDesign/Fusion/Macros

When you're done, click Save.

Macros can be added to a node tree using the Add Tool > Macros or Replace Tool > Macros submenus
of the Node Editor contextual menu.

To re-edit an existing macro, just right-click anywhere within the Node Editor and choose the macro
you want to edit from the Macro submenu of the same contextual menu. The Macro Editor appears,
and you can make your changes and save the result.

Groups Can Be Accessed Like Macros

Groups can also be loaded from the Insert Tool > Macros submenu if you save a group’s
setting file to the Macros folder in your file system. For example, on macOS, the
Macintosh HD/Library/Application Support/Blackmagic Design/DaVinci Resolve/Fusion/
Macros/ directory.

A macro can also be used as a custom LUT. Just copy the macro’s .setting file to the LUTs: folder, and
the macro will be selectable in the viewers as a LUT. These LUT macros can be used for more than just
a color adjustment; you could make a macro that does YUV 4:2:2 resampling, a resize, a sharpening
filter, or just watermarking.
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Creating Fusion Templates

The integration of Fusion into DaVinci Resolve has enabled the ability to create Fusion Titles,
Transitions, Effects, and Generators templates for use in the Edit page. You can create these templates
in the Fusion page or within Fusion Studio and then copy them into DaVinci Resolve. Fusion Titles,
Generators, and Transition templates are essentially comps created in Fusion but editable in the
Timeline of the Edit page with custom controls. This section shows you how it's done.

The first part of creating a Fusion title template is to create a Fusion composition consisting of Fusion-
generated objects assembled to create nearly any kind of title or generator you can imagine. If you're
really ambitious, it can include animation. In this example, 3D titles and 2D titles have been combined
into a show opener.

Building a composition to turn into a title template.

Macros are basically Fusion compositions that have been turned into self-contained nodes. Ordinarily,
these nodes are used as building blocks inside of Fusion so that you can turn frequently-made
compositing tricks that you use all the time into your own nodes. However, you can also use this macro
functionality to build title templates for the Edit page.

Having built your composition, select every single node you want to include in that template except for
the Medialn and MediaOut nodes in DaVinci Resolve or Loader and Saver nodes in Fusion Studio.
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Text3D1 (3Txt) »| ReplaceMaterial3D1 Merge3n1 3Mg) .7, Renderer3D1 [
—

A
.},
»[ cloth (Cloth) L

Camera3D1 (3Cm)

Selecting the nodes you want to turn into a title template.

TIP: If you want to control the order in which node controls will be displayed later on, you
can Command-click each node you want to include in the macro, one by one, in the order
in which you want controls from those nodes to appear. This is an extra step, but it keeps
things better organized later on.

Having made this selection, right-click one of the selected nodes and choose Macro > Create Macro
from the contextual menu.

Create Macro... [\s‘

Merge3D1 (SMg] .

Camera3D1 (3Cm)
e \

SpotLight

Creating a macro from the selected nodes.
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The Macro Editor window appears, filled to the brim with a hierarchical list of every parameter in
the composition you've just selected.

(® @ Macro Editor - MacraTool1*

MacroTool1

The Macro Editor populated with the parameters of all the nodes you selected.

This list may look intimidating, but closing the disclosure control of the top Text1 node shows us
what's really going on.

A simple list of all the nodes we've selected.

Closing the top node’s parameters reveals a simple list of all the nodes we've selected. The Macro
Editor is designed to let you choose which parameters you want to expose as custom editable
controls for that macro. Whichever controls you choose will appear in the Inspector whenever you
select that macro, or the node or clip that macro will become.
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So all we have to do now is to turn on the checkboxes of all the parameters we'd like to be able to
customize. For this example, we'll check the Text3D node’s Styled Text checkbox, the Cloth node’s
Diffuse Color, Green, and Blue checkboxes, and the SpotLight node’s Z Rotation checkbox, so that
only the middle word of the template is editable, but we can also change its color and tilt its lighting

(making a "swing-on” effect possible).

Selecting the checkboxes of parameters we'd like to edit when using this as a template.

Once we've turned on all the parameters we'd like to use in the eventual template, we click the Close
button, and a Save Macro As dialog appears.

To have the Title template appear in the Effects Library > Titles category of DaVinci Resolve, save the

macro in the following locations:

— On macOS: Macintosh HD/Users/username/Library/Application Support/Blackmagic Design/
DaVinci Resolve/Fusion/Templates/Edit/Titles

— On Windows: C:\Users\username\AppData\Roaming\Blackmagic Design\DaVinci Resolve\Support\
Fusionm\Templates\Edit\Titles

— On Linux: home/username/.local/share/DaVinciResolve/Fusion/Templates/Edit/Titles

e @& Save Macro As

Ld it b

o

Big Show Title

Choosing where to save a title template for the Edit page in DaVinci Resolve.
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After you've saved your macro, you'll need to quit and reopen DaVinci Resolve. When you open the
Effects Library of the Edit page, you should see your new template inside the Titles category, ready to
go in the Fusion Titles list.

Fusion Titles

Titles

# Big Show Title

Favorites

Custom titles appear in the Fusion Titles section of the Effects Library.

Editing this template into the Timeline and opening the Inspector, we can see the parameters we
enabled for editing, and we can use these to customize the template for our own purposes.

o000202 ;. OO Fusion Title - Big Show Tite

MacraTooll

01:00:02:02

Video 1

=0

Customizing the template we made.

And that's it!
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When creating a Fusion transition template, it's easiest to start with an existing transition
template and build off that. Three transitions are located in the Fusion Transitions category of the

DaVinci Resolve Effects Library. The simplest transition is the Cross Dissolve, while the most complex
example is the Slice Push.

Video Transitions

Fusion Transitions

Favorites

The Fusion transition templates located in
DaVinci Resolve's Effects Library.

The three Fusion Transitions located in the DaVinci Resolve Effects Library are basically Fusion
compositions that have been turned into macros. Ordinarily, macros are used as building blocks inside
of Fusion so that you can turn frequently-made compositing tricks that you use all the time into your

own nodes. However, you can also use this macro functionality to build transition templates for the
DaVinci Resolve Edit page.

Once you apply a Fusion Transition in the Edit page, you can right-click it and choose Open in Fusion Page.

. Open in Fusion Page

Right-clicking over a Fusion Transition in
the DaVinci Resolve Edit page.
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The Fusion page opens, displaying the node tree used to create the Fusion transition.

Mediain2

Medialn1 CrossDissolve I —— MediaOut1

The Cross Dissolve node tree in Fusion.

The Medialn 1 node represents the outgoing clip in the Edit page Timeline. The Medialn 2 clip
represents the incoming clip. You can modify or completely change the Cross Dissolve effect to create
your own custom transition using any of Fusion’s nodes.

Medialn2

Mediaini m—» Transformi K R MediaOuti

The Fusion Cross Dissolve node tree replaced with Transforms and a Merge node.

TIP: To modify the duration of the Fusion transition from the Edit page Timeline, you must
apply the Resolve Parameter Modifier to any animated parameter. In place of keyframing
the transition, you create the transition using the Scale and Offset parameters of the Resolve
parameter modifier.

Updating a Fusion Transition

After modifying the transition in Fusion, you can choose to update the transition in the Timeline or
create a new transition, which you save into the Edit page Effects Library. To update the transition, just
return to the Edit page. The transition in the Edit page Timeline reflects the changes you make in the
Fusion page.

Saving a New Fusion Transition

If after modifying the transition in Fusion, you need to save it to the Effects Library to reuse it on other
transitions or other projects, you must make a macro and save it to the Transitions folder.

Start by selecting every node in the Node Editor that you want to include in the transition template,
including the two Medialn nodes and the MediaOut node.

TIP: Since the transition template must include the Medialn and MediaOut nodes, the final
steps for saving a transition template must be performed in DaVinci Resolve’s Fusion page
and cannot be performed in Fusion Studio.
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Having made this selection, right-click one of the selected nodes and choose Macro >
Create Macro from the contextual menu.

® @ Macro Editor - MacroTool1*

MacroTool1

Controls

The Macro Editor displaying the parameters of all the nodes you selected.

The Macro Editor window appears, displaying a hierarchical list of every parameter in the composition
you've just selected. The order of nodes is based on the order they were selected in the Node Editor
prior to creating the macro.

The Macro Editor is designed to let you choose which parameters you want to display as custom
controls in the Edit page Inspector when the transition is applied.

For transitions, you can choose not to display any controls in the Inspector, allowing only
duration adjustments in the Timeline. However, you can choose a simplified set of parameters for
customization by enabling the checkboxes next to any parameter name.

Once you enable all the parameters you want to use in the eventual template, click the Close button,
and a Save Macro As dialog appears. Here, you can enter the name of the transition, as it should
appear in the Edit page Effects Library.

To have the transition template appear in the Effects Library > Fusion Transitions category of
DaVinci Resolve, save the macro in the following locations:

On macOS: Macintosh HD/Users/username/Library/Application Support/Blackmagic Design/
DaVinci Resolve/Fusion/Templates/Edit/Transitions

On Windows: C:\Users\username\AppData\Roaming\Blackmagic Design\DaVinci Resolve\Support\
Fusion\Templates\Edit\Transitions

On Linux: home/username/.local/share/DaVinciResolve/Fusion/Templates/Edit/Transitions
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After you've saved your macro, you'll need to quit and reopen DaVinci Resolve. When you open the
Effects Library on the Edit page, the new transition template is listed in the Video Transitions category,
in the Fusion Transitions list.

Fusion Transitions

X My transition

A custom Fusion Transition saved in
the Edit page Effects Library.

Applying this transition to a cut in the Timeline and opening the Inspector shows the parameters you
enabled for editing, if any.

There is one simple Noise Gradient Fusion Generator located in the Effects Library that you can use as
a starting point for creating your own generators.

5fff* Effects Library

Generators

Generators

The Fusion Generator templates located in DaVinci Resolve’s Effects Library.

To open the Fusion Noise Gradient Generator in the Fusion page, do the following:

On the Edit page, drag the Fusion Noise Gradient Generator from the Effects Library to the Timeline.

Right-click over the Noise Gradient Generator and choose Open in Fusion Page from the
pop-up menu.
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The Fusion page opens, displaying the node tree that is used to create the Fusion Generator.

As easy as it is to begin with the Noise Gradient Generator template, you can just as easily start by
adding a Fusion Composition Effect to a Timeline in the Edit page.

To begin creating a Fusion Generator Template
with an empty Fusion composition, do the following:

On the Edit page, drag the Fusion Composition Effect from the Effects Library to the Timeline.

Right-click over the Composition Effect and choose Open in Fusion Page from the pop-up menu.

An empty Fusion page with a single MediaOut node opens, ready for you to create a Fusion Generator.

The Fusion Generator is a solid image generated from any number of tools combined to create a
static or animated background. You can choose to combine gradient colors, masks, paint strokes, or

particles in 2D or 3D to create the background generator you want.

Ellipse1 S Background2_1 Duplicate1

Ellipse2 o —— Background?2

Background1 E MediaOut1

The Fusion Generator node tree creating concentric circles.
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Saving a New Fusion Generator

After creating the generator you want in Fusion, you need to save it to the Effects Library to reuse
it in other projects from the Edit page. To do this, you must create a Macro and save it to the
Generator folder.

Ordinarily, macros are used as building blocks inside of Fusion so that you can turn frequently-made
compositing tricks that you use all the time into your own nodes. However, you also use this macro
functionality to build Generator templates for the DaVinci Resolve Edit page.

Start by selecting every node in the Node Editor that you want to include in the Generator template

including the MediaOut node.

Having made this selection, right-click one of the selected nodes and choose Macro > Create Macro

from the contextual menu.

(@ L 2 Macro Editor - MacroTool1*

MacroTooll

Background2_1

Color
Common
Background2

Duplicate1

The Macro Editor displaying the parameters of all the nodes you selected.

The Macro Editor window appears, displaying a hierarchical list of every parameter in the composition
you've just selected. The order of nodes is based on the order they were selected in the Node Editor
prior to creating the macro.

The Macro Editor is designed to let you choose which parameters you want to display as custom
controls in the Edit page Inspector when the Generator is applied. You can choose a simplified set of
parameters for customization by enabling the checkboxes next to any parameter name.

Once you enable all the parameters you want to use in the eventual template, click the Close button,
and a Save Macro As dialog appears. Here, you can enter the name of the Transition, as it should
appear in the Edit page Effects Library.
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To have the Generator template appear in the Effects Library > Fusion Generators category of
DaVinci Resolve, save the macro in the following locations:

— On macOS: Macintosh HD/Users/username/Library/Application Support/Blackmagic Design/
DaVinci Resolve/Fusion/Templates/Edit/Generators

— On Windows: C:\Users\username\AppData\Roaming\Blackmagic Design\DaVinci Resolve\Support\
Fusion\Templates\Edit\Generators

— On Linux: home/username/.local/share/DaVinciResolve/Fusion/Templates/Edit/Generators

After you've saved your macro, you'll need to quit and reopen DaVinci Resolve. When you open the
Effects Library on the Edit page, the new Generator template is listed in the Generators category, in
the Fusion Generators list.

Generators

Generators

Fusion Generators

Custom Fusion Generator saved in the Edit page Effects Library.

Applying this Generator to the Timeline and opening the Inspector shows the parameters you enabled
for editing, if any.

You start building a Fusion Effect template by bringing a clip from the Edit page Timeline into Fusion.
This clip is only used for creating the template and will not be saved with the effect.

Once inside Fusion, you use Fusion's nodes to create the effect you want. You can use a single node or
a hundred, depending on the effect you want to create. For instance, using Fusion’s Color Correction
nodes, you can create a simple color corrector you can use on the Edit page.
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To create a simple Color Corrector effect, do the following:
Insert the Color Corrector node between the Medialn and MediaOut nodes.

Select the Color Corrector node in the Node Editor, and then press Cmd-A to select the
remaining nodes.

Right-click over any of the selected node and choose Macro > Create Macros from the contextual
menu. Enabling the checkboxes in this window determines the parameters that appear in the
Edit page Inspector.

The Macro Editor window opens. Here, you can enable the checkboxes for any parameters you
want to be shown in the Edit page Inspector.

Enter the name of your effect at the top of the Macro Editor window.

To save the Macro, click Close at the bottom of the window, then click Yes in the dialog that appears
asking you to save the changes.

The Macros must be saved into the correct folder for DaVinci Resolve to recognize the
Macro as an effect.

In the save dialog, save the Macro in the following locations:

— On macOS: Macintosh HD/Users/username/Library/Application Support/Blackmagic Design/
DaVinci Resolve/Fusion/Templates/Edit/Effects

— On Windows: C:\Users\username\AppData\Roaming\Blackmagic Design\DaVinci Resolve\Support\
Fusion\Templates\Edit\Effects

— On Linux: home/username/.local/share/DaVinciResolve/Fusion/Templates/Edit/Effects

You can save and organize your Fusion Effects into separate subfolders underneath the paths above.
These subfolders will show up in the Effects section in the Edit page.

To see the effect in the Edit page Effects Library, you'll need to quit DaVinci Resolve and
relaunch the application.

Creating a Fusion Effect Template for Two or More Layers

If the effect you want to create requires multiple images like a video wall, you start by creating a
Fusion clip on the Edit page Timeline that includes the number of layers you want the effect to have.
The clips are only used to create the number of image inputs for the template and will not be saved
with the effect.

Once inside Fusion, use Fusion’s nodes to create the effect you want.

Save the Macro following the same steps you use for single clip effects. Enable any of the parameters
you want to control in the Edit page. To be able to switch the order of video layers within the effect,
make sure you have the Layer checkbox enabled for all the Medialn nodes.

Once you've saved the Macro and relaunched DaVinci Resolve, to use the effect on multiple timeline
layers, you must create a Fusion clip. The Fusion clip should contain the same number of layers the
effect requires. The order of the Timeline layers, going from the bottom track to the top, matches the
Medialn numbers. For instance, video track 1 will match the position and appearance of Medialn1,
video track 2 matches Medialn2 and so on. If you want to change how tracks map to Medialn nodes,
you can change the Layer number in the Inspector, assuming you enabled the Medialn Layer
checkbox when creating the Macro.
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After you make a template in Fusion, you may want to change its duration in the Edit or Cut page
Timeline. Changing the duration when animation is involved can be complicated, so there are two
Modifiers in Fusion that can help determine how keyframes react when the duration is updated in the
Edit or Cut page Timeline.

Anim Curves Modifier

The Animation Curves Modifier (Anim Curves) is used to dynamically adjust the timing, values, and
acceleration of an animation, even if you decide to change the duration of a Comp. Using this Modifier,
it becomes infinitely easier to stretch or squish animations, create smooth motion, add bouncing
properties, or mirror animations curves without the complexity of manually adjusting splines.

When creating Fusion templates for the Edit or Cut page in DaVinci Resolve, the Anim Curves Modifier
allows the keyframed animation you've created in Fusion to stretch and squish appropriately as the
transition, title, or effect’s duration changes on the Edit and Cut page Timelines.

Keyframe Stretcher Modifier

The Keyframe Stretcher modifier is primarily used when creating title templates in Fusion for use

in DaVinci Resolve's Edit or Cut page. The Keyframe Stretcher modifier is added to any animated
parameter so that the Hold keyframes between the initial animation on screen and the final animation
off-screen stretch when the template is trimmed in the Timeline. This allows the animation to retain its
timing while the static portion of the title stretches to meet the new duration requirements.

For additional ease of use in the Edit page, Fusion effects, plugins, and transitions can have media
drop zones, allowing the user to simply drag clips from the Media Pool directly to the template. For
example, you can instantly replace the background of a Fusion effect with a star-field, just by dragging
that clip from the Media Pool to the media drop zone in the Inspector.

To create a media drop zone in a Fusion template:
Create a Macro of your current Fusion template.

For any Medialn node that you want to make a media drop zone, make sure the ClipName
parameter is checked.

Place your template in the appropriate Fusion Edit template folder (Transition, Effect, etc.), and
relaunch DaVinci Resolve.

When you use this template in the Edit page, now you can drag clips from the Edit page Media Pool
and drop them in the Transition Inspector’s Clip Name field. They will then instantly update the
template with the chosen media.
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It is possible to create a custom icon that is embedded with your template thumbnail in the
Effects Library, instead of the default first three letters of the template name.

To create a simple Custom Template Icon:

Create a .png file of the icon you want to use for the template. The recommended size is
104 x 58 pixels, but any image will be resized to fit.

Name the file exactly the same name as your template, just with a .png extension rather than a
.setting extension.

Place the .png image in the same directory as your template.

When you restart DaVinci Resolve, the icon you created will be embedded in the template thumbnail
across all the Effects Libraries in the program.

A Custom Icon added to a fisheye template,
before (above) and after (below)

For ease in distributing templates to other Fusion users, multiple templates can now be bundled
together into a single .drfx file. This file can then be imported back into another Fusion workstation
easily to ensure that all custom templates are the same between computers.

Creating a Fusion Template Bundle requires using a specific directory structure and using your
operating systems file browser and .zip compression utility. The directory structure is listed below,
and you can always find a specific folder from within Fusion by right-clicking on any bin in the Effect
Library and selecting Show Folder.

Folder structure for Templates used in the Edit page:
— Edit

— Effects

— Generators

— Titles

— Transitions

Folder structure for Templates used in the Fusion page:

— Fusion
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To create a Fusion Template Bundle:

In your OS, create a folder structure above that includes the specific folder for the type of
templates you want to be in the bundle. For example, if you have a transition and two effects
templates, you would create an Edit folder, and two subfolders inside it named Transitions
and Effects.

Copy your template (.setting) files into the appropriate directories. You can also include icon files
and any associated assets as well.

Use your OS zip compression utility to create a .zip file of the directory structure.
Rename the .zip file in your OS with the “.drfx” extension instead of .zip. The file icon should change
to reflect the new extension.

To import a Fusion Template Bundle:

Double-click on a .drfx file in your OS. DaVinci Resolve will launch and a dialogue box will appear
asking if you want to install the template bundle.

Drag to the .drfx file from your OS directly into the Fusion page in DaVinci Resolve. A dialogue box
will appear asking if you want to install the template bundle.

To delete a Fusion Template Bundle:
Navigate to the appropriate template directory in your file browser.

Delete the .drfx file.

IMPORTANT: The Fusion Template Bundle contains all the templates in one file. It does not
uncompress them into separate template files again. Therefore if you delete the .drfx file, all
associated templates inside that bundle will be removed as well.
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Using Viewers

This chapter covers working with viewers in Fusion, including using

onscreen controls and toolbars, creating groups and subviews,

managing viewer Lookup Tables (LUTs), working with the 3D viewer,

and setting up viewer preferences and options.
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Viewers in Fusion display the current frame of the current composition in a variety of ways to help you

see what you're doing and evaluate the final result of your compositing artistry. Viewers display 2D

images, but they can also display a 3D environment using a 3D View as well as a special Quad viewer

to help you effectively work in three dimensions.

Side-by-side dual viewers: a 3D viewer (left), and a 2D viewer (right)

Additionally, you can expose “subviews” including color inspectors, magnifiers, waveforms,

histograms, and vectorscopes to help you analyze the image as you work.
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Viewer with a 3D Histogram subview at the upper left-hand corner

By default, there are two viewers positioned side by side across the top of the window. However, you
can use the Single/Dual Viewer button to toggle between displaying a single viewer or two viewers
displayed side by side.

The Single/Dual Viewer
toggle button

In addition to the dual views above the Node Editor, Fusion Studio provides the option to use an
unlimited number of floating viewers. These floating viewers are excellent for taking full advantage of
a dual monitor configuration. Floating viewers can also be set to full-screen mode to make the best
use of screen real estate.

To create a new floating display view, select Window > New View from the menu bar at the top of
the screen. The position and configuration of the new view can be saved in the layout preferences,
if required.

When using DaVinci Resolve or Fusion Studio, if Blackmagic video hardware is present in the computer,
then you can select a node to preview directly on that display. While video output can't be used for
manipulating onscreen controls such as center crosshairs or spline control points, they're extremely
valuable for evaluating your composition via the output format, and for determining image accuracy
using a properly calibrated display.

The video hardware is configured from the DaVinci Resolve and Fusion Studio preferences.
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When using DaVinci Resolve with dual computer monitors, a full-screen viewer can be displayed on
the secondary monitor from the Fusion page. This displays a third view indicator button under each
node to control what is shown on the second display. To activate this monitor, make sure you do not
have Dual Screen enabled under the Workspace menu and then select Workspace > Video Clean Feed
and select your second computer display from the submenu.

Loading Nodes into Viewers

The Fusion page in DaVinci Resolve and Fusion Studio show two different things when you first open
each application. When you first open the Fusion page, the output of the current empty composition
(the MediaOut1 node) is usually showing in viewer 2. If you're in dual-viewer mode, viewer 1 remains
empty until you assign a node to one of them. In Fusion Studio, because there are no nodes when you
first begin a comp, nothing is displayed in the viewers.

To load specific nodes into specific viewers, do one of the following:

— Hover the pointer over a node, and click one of two buttons that appear at the bottom-
left of the node.

— Click once to select a node, and press 1 (for the left viewer) or 2 (for the right viewer).
— Right-click a node and choose View On > None/Left View/Right View in the contextual menu.

— Right-click the control header of a node in the Inspector, and choose View On > None/Left View/
Right View from the contextual menu.

— Drag a node and drop it over the viewer you'd like to load it into (this is great for tablet users).

When a node is being viewed, a View Indicator button appears at the bottom left. This is the same
control that appears when you hover the pointer over a node. Not only does this control let you know
which nodes are loaded into which viewer, but they also expose little round buttons for changing
which viewer they appear in.

p!  Transforml1 (Xf) |m

Viewer assignment buttons at the
bottom left of nodes indicate when
they're being viewed, and which
dot is highlighted indicates which
viewer that node is loaded into.

To clear an image from a viewer, click in the viewer to make it active; a light purple outline is displayed
around the active panel. With the viewer active, press the " (accent) key. This key is usually found to the
left of the 1 key on U.S. keyboards. The fastest way to remove all images from all viewers is to make
sure none of the viewers is the active panel, and then press the accent key.
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Position and Layout

In Fusion Studio, when you resize and change the layout of viewers in the composition, that
configuration is always saved with the composition. So each time you open the composition, the size
and layout is remembered. You can prevent this behavior by disabling the Recall Layout checkbox in
the Fusion Global Layout preferences.

If you want all new compositions to open with a certain viewer layout, you can configure the layout
of the two primary viewers, and then use the Grab Document Layout button in the Fusion Global
Layout preferences to remember the layout for any new compositions. To save the position and size
of floating viewers, you use the Grab Program Layout button. Finally, if you want to have the floating
viewers opened automatically when you open Fusion, enable the Create Floating Views checkbox.

You can change the relative sizes of the left and right viewers using the horizontal viewer divider that
runs between them. Drag the viewer divider to increase or decrease the amount of space used by one
viewer. The adjacent viewer will adjust to accommodate the new layout.

The amount of vertical space available for both viewers can be adjusted by dragging the horizontal
scrollbar between the viewers and the work area below them.

The viewer divider bar
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Zooming and Panning into Viewers

There are standardized methods of zooming into and panning around viewers when you need
a closer look at the situation. These methods also work with the Node Editor, Spline Editor, and
Keyframes Editor.

Methods of panning viewers:
— Middle-click and drag to pan around the viewer.
— Hold down Shift and Command and drag the viewer to pan.

— Drag two fingers on a track pad to pan.

Methods of scaling viewers:

— Click a viewer and press the Equals key (=) to zoom in, and the Minus key (-) to zoom out.

— Press the middle and left mouse buttons simultaneously and drag left or right to resize the viewer.
— Hold down the Command key and use your pointer’s scroll control to resize the viewer.

— Hold down the Command key and drag two fingers on a track pad to resize the viewer.

— Hold down the middle mouse button, and then click the left mouse button to zoom in, or click the
right button to zoom out. The scaling uses a fixed amount, centered on the position of the cursor.

— Click a viewer and press Command-1 to resize the image in the viewer to 100 percent.
— Click a viewer and press Command-2 to resize the image in the viewer to 200 percent.

— Click a viewer and press Command-F or Command-1 to reset the image in the viewer
to fit the viewer.

— Click the Scale Viewer menu and choose Fit or a percentage.

— Right-click on a viewer and choose an option from the Scale submenu of the contextual menu. This
includes a Custom Scale command that lets you type your own scale percentage

Methods of spinning 3D viewers:

— In 3D Perspective view, hold down the middle mouse button and the right mouse button and drag

to spin the stage around.

Flipbook Previews

As you build increasingly complex compositions, and you find yourself needing to preview specific
branches of your node tree to get a sense of how various details you're working on are looking, you
may find it useful to create targeted RAM previews at various levels of quality right in the viewer by
creating a RAM Flipbook. RAM Flipbook Previews are preview renders that exist entirely within RAM
and allow you to render a node's output at differing levels of quality for quick processing in order to

watch a real-time preview.

Creating a Flipbook Preview is relatively fast, once you know where to look.

To create a Flipbook Preview:

Choose the node in your node tree that you want to preview by doing one of the following:
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— Hold down the Option key while dragging a node into the viewer.

— Right-click a node and choose an option from the Create/Play Preview submenu in the
contextual menu.

When the Preview Render dialog opens, choose the quality, resolution, and motion blur settings
you want to use for the Flipbook Preview.

@ Render Settings

Preview

The Flipbook Preview Render dialog

When you've chosen the settings you want to use, click Start Render.

The current frame range of the Time Ruler is rendered using the settings you've selected, and the
result is viewable in the viewer you selected or dragged into.

Once you've created a Flipbook Preview within a particular viewer, right-clicking that viewer presents
Flipbook-specific commands and options to Play, Loop, or Ping-Pong the Flipbook, to open it Full
Screen, to Show Frame Numbers, and to eliminate it.

TIP: If you want to create a Flipbook Preview and bypass the Render Settings dialog by just
using either the default setting or the settings that were chosen last, hold down Shift-Option
while you drag a node into the viewer. The Settings dialog will not appear, and rendering the

preview will start right away.

While the Flipbook Preview is loaded into a viewer, or open in full-screen mode, you can play or scrub
through it using the mouse and the keyboard.

To play back a Flipbook using the mouse, do the following:

— Double-click in the viewer to start playback.

To scrub through a Flipbook using the mouse, do the following:

— Hold down the right mouse button down and drag left or right to scrub through frames.
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To play back a Flipbook using the keyboard, do one of the following:

— Press the Spacebar to start or stop playback.

— Hold Shift and press the Spacebar to play in reverse.

To scrub through a Flipbook frame-by-frame using the keyboard, do one of the
following:

— Press the Left or Right Arrow keys to move to the previous or next frame.

— Hold Shift and press the Left or Right Arrow keys to jump back or forward 10 frames.

— Press Command-Left Arrow to jump to the first frame.

— Press Command-Right Arrow to jump to the last frame.

TIP: The mouse and keyboard shortcuts work in full-screen mode as well.

Once you create a Flipbook Preview, you need to know how to clear it from RAM.

To eliminate a Flipbook you’ve created:

— Right-click within a viewer containing a Flipbook Preview, and choose Remove Preview.

This section covers all the settings available for rendering Flipbook Previews to RAM.

Settings
The Settings section of the Preview Render dialog includes three buttons that determine the overall

quality and appearance of your Flipbook Preview. These buttons also have a significant impact on
render times.

— HiQ: When enabled, this setting renders the preview in full image quality. If you need to see
what the final output of a node would look like, then you would enable the HiQ setting. If you are
producing a rough preview to test animation, you can save yourself time by disabling this setting.

— MB: The MB in this setting stands for Motion Blur. When enabled, this setting renders with motion
blur applied if any node is set to produce motion blur. If you are generating a rough preview and
you aren't concerned with the motion blur for animated elements, then you can save yourself time
by disabling this setting.

— Some: When Some is enabled, only the nodes specifically needed to produce the image of the
node you're previewing are rendered.

Size

Since RAM Flipbook Previews use RAM, it's helpful to know how many frames you can render into RAM
before you run out of memory. The Flipbook Preview dialog calculates the currently available memory
and displays how many frames will fit into RAM. If you have a small amount of RAM in your computer
and you cannot render the entire range of frames you want, you can choose to lower the resolution to
a setting that delivers the best quality/duration ratio for your preview.
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Network

Network rendering is only available in Fusion Studio. For more information on network rendering,
see Chapter 4, “Rendering Using Saver Nodes,” in the Fusion Reference Manual or Chapter 66 in the
DaVinci Resolve Reference Manual.

Shoot On

Sometimes you may not want to render every single frame, but instead every second, third, or fourth
frame to save render time and get faster feedback. You can use the Step parameter to determine the
interval at which frames are rendered.

Frame Range

This field defaults to the current Render Range In/Out set in the Time Ruler to determine the start and

end frames for rendering. You can modify the range to render more or fewer frames.

Configurations

Once you've created a useful preview configuration, you can save it for later use by clicking the
Add button, giving it a name, and clicking OK.

Updating a Preview

This option is designed for the interactive frame-by-frame work of rotoscoping and painting. Right-
click over a preview in the viewer and choose Update from its contextual menu. When active, any
frames that are modified on the previewed node are automatically updated in the preview’s playback.
This lets you reserve the RAM for playback. You can keep it playing on a loop or ping-pong while you
work in another viewer.

Onscreen Controls

When it comes to adjusting images, the Control Panel provides very precise numerical values, but
sometimes visually positioning an element using onscreen controls can get you where you want to go
with less tweaking.

The Angle preview control
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The viewers show onscreen controls for manipulating the parameters of the currently selected node.
Common onscreen controls include crosshairs, angle indicators, polylines, and paint strokes. Each of
these controls can be manipulated directly in the viewer using the mouse or keyboard.

The controls shown in viewers are determined by which nodes are selected, not by the node displayed
in the viewer. For example, a downstream blur is easily viewed while manipulating the controls for a
selected polygon mask or merge. If multiple nodes are selected, the controls for every selected node
are shown simultaneously.

The onscreen controls for a viewer can be hidden so they don't interfere with viewing the image.

To toggle the visibility of onscreen controls, do one of the following:
— Click a viewer’s Option menu and choose Show Controls to toggle the controls on or off.
— Right-click in a viewer and choose Options > Show Controls from the contextual menu.

— Select a viewer and press Command-K.

Enabling/Disabling Onscreen Controls in Specific Nodes

Some nodes, like masks, allow disabling of their onscreen controls on a per-node basis, since you
often use multiple Polygon nodes to organize and animate masks.

Polygon1

You can disable some nodes, like the
Polygon node, on a per-node basis.

If you want the visual guidance of onscreen controls with the precision of the Inspector, you can use
different keyboard modifiers.

— Up and Down Arrow keys can be used to adjust the vertical position of an onscreen
control by small steps.

— Holding down the Command key while using the Up and Down Arrow keys reduces the scale of
each step by a factor of ten. Holding Shift increases the scale of each step by a factor of ten.

Toolbars

There are two toolbars in the viewer: a viewer toolbar, which always appears at the top of each
viewer and gives you control over what that viewer shows, and an optional node toolbar that appears
underneath that gives you contextual controls based on the node you've selected in the Node Editor.
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Aviewer toolbar runs across the top of each viewer, providing access to many of the most commonly
used viewer-related settings, as well as an indication of the status of many of the most important settings.
Most of the menus and buttons found on this toolbar are described in detail throughout this chapter.

The viewer toolbar

In addition to the viewer toolbar, a node toolbar is displayed underneath, at the top of the viewer
display area, whenever you select a node that exposes special nodes. Examples of nodes that expose
a toolbar include the text, masks, paths, paint strokes, and the 3D environment.

»

The node toolbar shown for the Paint node

Customizing the Node Toolbar

If you want to change the size of the buttons that appear in the Node toolbar, or turn on text names
for each node, you can right-click anywhere in the empty area of the toolbar and choose new settings
from the Icon Size and Button Style submenus in the contextual menu.

Button Style N
3

The

The contextual menu for the node toolbar

A/B Buffers

Each viewer has two buffers, each of which can contain images from different nodes, enabling easy
comparison of two different nodes within the same viewer by either toggling between buffers, or
via an adjustable split-wipe. Each buffer can be considered a complete and separate viewer within
the same viewer pane. The A buffer is always shown by default, so when you first load a node into a
viewer, the image loads into the A buffer.
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Switching between buffers is easy, either to view a different image while keeping another image
handy, or to flip between the original image and the affected image for comparison.

To switch between buffers, do one of the following:
— Select a viewer and press comma (,) to select the A buffer or press period (.) to select the B buffer.

— Click the Buffer menu and choose either Switch to A View or Switch to B View.

Switch to B View

N

The Buffer menu lets you switch between buffers

TIP: Each buffer can be set to different display settings—for example, showing different
channels or different viewing LUTSs, either applied to different nodes or applied to two
buffered versions of the same node.

You can also wipe between both buffers, providing a more direct means of comparison.

To wipe between buffers, do one of the following:

Prepare to wipe between two images by loading different nodes into each buffer, or load the same
node with different viewer options into each buffer.

To toggle the split wipe on or off, do one of the following:
Click the Switch to Split Wipe View button.

Press Forward Slash (/).

To adjust the wipe, do one of the following:
Move the center of the wipe by dragging the center handle of the wipe divider.

Press Command-Option and click anywhere in the viewer to jump the wipe divider to
that location.

Change the angle or the wipe by dragging the wipe divider. Dragging the wipe divider while
holding the Shift key snaps it to the nearest 45-degree angle.

Panning or zooming the viewer pans and zooms both buffers together.

(Optional) If you want to change the image that's displayed on that side of the split, you can drag
new nodes onto either half of the viewer.

To turn off the wipe, click the Switch to Split Wipe View button again (or press /).

Using Viewers

198




The wipe divider
can be adjusted
for comparing
different areas of
the A and B images

Even when you wipe, you can choose different display channels, view LUTs, or other display options
for each buffer individually by clicking on the half of the wipe you want to alter, and then choosing the
options you want that buffer to use. This allows easy comparison of different channels, LUTs, or other
viewer settings while wiping the same image, or different images.

Occasionally, you will have either zoomed in or panned so far from the viewer divider that it's no
longer visible in the viewer. Holding down Command-Option and clicking anywhere in the image will
cause the viewer divider to jump to the current position of the pointer.

Subviews

A subview is a “mini” viewer that appears within the main viewer. A subview is usually used to show
different information about the image.

0000 025 050 075 Ti

The Subview
menu with
the Histogram
subview
displayed
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For example, the RGB channels can be viewed in the main viewer, while the alpha channel is displayed
in a subview. For the most part, the subview is a fully functional miniature viewer, with its own
contextual menu and options. It responds to the same keyboard shortcuts and navigation controls as
any other viewer. However, there are several view types designed for use only in the subview, including

the Navigator, Magnifier, Color Inspector, and Image Info.

Subviews are easily shown and hidden.

To enable the currently selected subview in the Subview menu of a viewer,
do one of the following:

— Click the Subview button in the View toolbar.
— Choose Views > Subview > Enabled from the contextual menu.

— Click a viewer, and press the V key.

v Vectorscope N
2\

The Subview button in the viewer toolbar

The Subview button enables and disables the subview, which usually shows the last subview you
chose. You can change this at any time.

To change which subview type is displayed, do one of the following:

— Click the small arrow to the right of the Subview button to open its menu and choose which

subview you want.

— Right-click within a subview to bring up the subview’s contextual menu.

The Subview drop-down menu and contextual menu show all the available subview types. Once you
choose an option from the list, that view will be displayed in the subview, and the Subview button will
show and hide it as you wish.

It's possible to swap the contents of the main viewer and the subview for select subview types.
However, certain view types, such as the Color Inspector and Magnifier, can only be used in the
subview. In these cases, the swap will not take place.
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To swap the contents of the subview with the main view, do one of the following:
— Press Shift-V.

— Right-click in a viewer and choose Views > SubView > Swap from the contextual menu.

Viewers can be changed to show a variety of different information about the image, but not all view
types are available at all times. For example, the 3D Viewer is not available for a 2D node, and some
of the measurement viewers are available only as subviews. Below is detailed information about the
different view types available.

Navigator

The Navigator can only be used in a subview. It provides a small overview of the entire image, with
a rectangle that indicates the portion of the image that is actually visible in the main viewer. This is

useful when zooming in on an image in the main view.

The Navigator subview
for panning the image
while zoomed in

Magnifier
The Magnifier can be used only in a subview. It shows a zoomed-in version of the pixels under the
cursor in the main viewer.

The Magnifier subview
used to view a zoomed-
in version of the image
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2D Viewer

The 2D Viewer is the default type for showing images. When used as a subview, a different node than
the one used in the main viewer can be displayed by dragging the node into the subview.

This is the only subview type that is not just a different view of the same node in the main viewer.

The subview used
as another viewer

3D Image Viewer

The 3D Image Viewer is available when viewing a node from the 3D category.

A 3D Image Viewer
as a subview

3D Histogram

The more advanced 3D Histogram Viewer shows the color distribution in an image within a 3D
cube. One advantage to a 3D Histogram is that it can accurately represent the out-of-range colors
commonly found in floating-point and high-dynamicrange images. It can also be used to look at
vector images like position, normal, velocity, and so on.
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The 3D Histogram
Viewer type

for evaluating
out-of-range colors

To rotate within a 3D Histogram, do one of the following:
— Hold down the Option key, and drag left or right using the middle mouse button.

— Hold down the middle and right mouse buttons while dragging.

Color Inspector

The Color Inspector can only be used in a subview. The Color Inspector shows information about
the color channels of the pixel under the cursor. It will show all channels present, even the auxiliary
channels such as Z buffer, XYZ normals, and UV mapping channels.

The Color Inspector
subview for evaluating
colorsin animage

Histogram

The Histogram Viewer is an analysis node that can be used to identify problems with the contrast and
dynamic range in an image. The graph shows the frequency distribution of colors in the image, including
out-of-range colors in floating-point images. The horizontal axis shows the colors from shadows to
highlights. The vertical axis shows the number of pixels in the image that occur at each level.

The Histogram Viewer
type for evaluating
the contrast and color
castin animage
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The Histogram Viewer will also display gradient information. You can use the From Image and Perturb
modifiers to output gradients. If you need to see the gradient represented in a histogram, drag the
modifier’s title bar into the viewer.

Image Info

The Image Info view can only be used in a subview. The Image Info tab shows a horizontal bar across
the top of the image with information about the frame size, pixel aspect, and color depth of the
viewed image.

Frame Size b= 1976, Pix ct: 1.1, Depth: 1abit float

The Image Info subview for viewing size, pixel aspect, and color depth information

Metadata

The content of this subview is based entirely on the amount of metadata in your image. Most Loaders
will give the color space and file path for the image. Much more information can be displayed if it
exists in the image.

CreationTime = 2013:70:11:14:517:30
screemWindowCenter = {0, 0
sereemWindoandidth = | The Metadata

Filemame = C\templout.ex subview for viewing
embedded metadata

Vectorscope

The Vectorscope Viewer duplicates the behavior of a specific type of video test equipment, displaying
a circular graph that helps to visualize the intensity of chrominance signals.
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The Vectorscope
Viewer type for
evaluating chrominance
in an image

Waveform

The Waveform Viewer duplicates the behavior of a specific type of video test equipment, displaying a
line or bar graph that helps to visualize the voltage or luminance of a broadcast signal.

The Waveform Viewer
type for evaluating
luminance in an image

Viewing Selective Channels

When compositing, you often deal with individual color components or channels in an image as much
as you deal with the full RGB color of the entire image. The viewers and subviews can display the
isolated color, alpha, depth channels, and even auxiliary channels that make up the image.

The default view is the full RGB color channel, but to change the channel that is displayed you can use
the Channel toolbar button, the viewer's contextual menu, or keyboard shortcuts.
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The Channel toolbar
button for switching
between color, alpha,
and depth channels

To toggle between RGB and alpha channels in the active viewer:

— Click the Color button in the viewer toolbar to toggle between full RGB color and that image’s
alpha channel.

To toggle the channel that's displayed in the active viewer:

— Click the arrow to the right of the Color button to choose a specific channel to view from the list of
available channels in the currentimage.

— Click the viewer you want to toggle, and press one of the following keyboard shortcuts;

C - Full RGB color display
R - Display red channel

G - Display green channel
B - Display blue channel
A - Display alpha channel

Z - Display Z-buffer channel

The viewers support RGBA and Z channels using keyboard shortcuts, but they support other channels
as well. File formats such as OpenEXR often include auxiliary image data that provide more control
and compositing options when working with rendered 3D images. To view auxiliary image datain a
viewer, click the arrow to the right of the RGB button to display the drop-down menu or right-click in
the viewer and choose an option from the Channels submenu of the contextual menu.

The 3D Viewer

Building a composite in 3D space has different requirements from traditional 2D compositing.
When a node from the 3D category or some particle systems is selected, a 3D Viewer is used to
display the scene. The 3D Viewer shows a representation of a composite in a true GPU-accelerated
3D environment.

For more information on 3D controls, see Chapter 23, “3D Compositing Basics,” in the Fusion Reference
Manual or Chapter 85 in the DaVinci Resolve Reference Manual.
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For the most part, navigation in the 3D Viewer is similar to the navigation in the 2D Viewer. Panning
and zooming work with the same controls even though you're moving within a 3D space. However,
when viewing a 3D scene, panning changes the point of view and thus the center point for scaling and
rotation, too. A combination of panning and rotation will allow you to move the point of view anywhere
in the scene.

Another small change is that there’s a lower limit to the scale of a 3D scene. Continuing to zoom in
past this limit will instead move (“dolly”) the point of view forward. The mouse wheel will move forward
slowly, and the keyboard will move more quickly.

Critically, the 3D Viewer gives you additional control to rotate the viewer within the three dimensions

of the scene to better see your scene from different angles as you work.

To rotate within a 3D Viewer, do one of the following:
— Hold down the Option key and drag left or right using the middle mouse button.

— Hold down the middle and right mouse buttons while dragging.

The rotation is centered on the middle of the view.

TIP: These rotation controls can be used with the 3D Histogram subview as well.

3D composites not only work with 2D images on image planes but can also integrate true geometry,
such as that generated by the Particle system, Text 3D node, imported FBX meshes, and basic
primitives from the 3D toolset. Using a Wireframe view helps to see through a mesh or see the density
of the geometry. It is much easier to see a change in the Subdivision level of an ImagePlane3D in
wireframe than viewing the rendered image.

To display 3D geometry in wireframe, do the following:

— Right-click the 3D Viewer and choose 3D Options > Wireframe from the contextual menu.

Compositing a 3D scene often requires that you view the scene from different angles to make sure the
position and animation are what you want. While the 3D Viewer uses a perspective camera that allows
you to look at the 3D scene from any angle, you can also switch the 3D Viewer to view from the front,

top, left, or right side of the scene; these are collectively called Orthographic views.

Additionally, if you have a camera or spotlight in your scene, you can switch the viewer to face the
scene from the point of view of those objects.

To change the 3D viewpoints:

— Right-click the viewer and choose an option from the Camera submenu of the contextual menu.
The choices include Perspective, Front, Top, Left, and Right.
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Changing Cameras in a 3D Viewer

If you have one or more camera objects in the 3D scene, they will be listed as options in the contextual
menu. Spotlights and other lights or objects in the scene will be listed in the Other submenu. If you
choose any one of these objects, the 3D Viewer jumps to display the scene from the point of view of
the chosen object. While looking “through” an object, rotating, panning, or zooming, the viewer will
instead change the rotation, position, and scale of the camera, light, or other object.

There are many times you will have used the default perspective view to set up your scene and then
want that point of view (POV) to become your main camera’s point of view. You can easily position and
orient a camera, light, or other object to match the current point of view shown in the viewer using the
Copy PoV To command.

To copy the point of view in the viewer to a camera, do the following:
Set up a 3D Viewer with the point of view you want by zooming, panning, and rotating the viewer.
Add a camera to your 3D scene.

Right-click anywhere within the 3D Viewer and choose Camera > Copy PoV To >

Camera3DNameOfCamera from the contextual menu.

The Camera3D’s controls will inherit the viewer’s position and angle values.

TIP: The Copy PoV To command uses the object’s own coordinate space; any transformations
performed downstream by another node are not taken into account.

POV Labels

As you switch the POV of the viewer, you can keep track of which POV is currently displayed via a text
label at the bottom-left corner of the viewer. Right-clicking directly on this label, or on the axis control
above it, acts as a shortcut to the Camera submenu, allowing you to easily choose another viewpoint.

Copy PoV to Camera3D1 N
iy

The Viewpoint label and Axis control in a 3D Viewer
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Before you add lights to a 3D scene, default lighting is provided. This basic, flat lighting allows you
to see the shading on objects without requiring you to add and set up lights as you work in the 3D
Viewer. Additionally, shadows are hidden by default. Once you start adding lights of your own, you
need to switch modes to see what they affect as you work.

To see the effects of the default light on the scene:
— Right-click within the 3D Viewer and choose 3D Options > Default Lights from the contextual menu.

When you're ready to add your own lighting to a scene, you can connect light nodes in various ways
to a Merge 3D node for the scene you're working on. Once you connect a light to a Merge 3D node,
you need to switch the 3D Viewer over to showing the new, proper lighting.

To toggle lighting rendering within a 3D scene:

— Right-click within the 3D Viewer and choose 3D Options > Lighting from the contextual menu.

A 3D scene using default lights (top), and the same scene with lighting turned on (bottom)

TIP: Attempting to load a Light node into a viewer all by itself will result in an empty scene,
with nothing illuminated. To see the effects of lights, you must view the Merge 3D node

the light is connected to.
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Similar to lights, the default 3D Viewer has shadows turned off. To see shadows cast from the
lighting you've created, you must turn them on.

To toggle shadows rendering within a 3D scene:

— Right-click within the 3D Viewer and choose 3D Options > Shadows from the contextual menu.
Enabling shadows will automatically turn on lighting, if it is not already turned on.

A 3D scene with shadows enabled along with the lights

NOTE: The shadows shown in the 3D Viewer are always hard edged. Soft shadows are
available for output to the rest of your composition in the software renderer of the
Renderer3D node.

Image planes and 3D objects are obscured by other objects in a scene depending on the X, Y, and
Z position coordinates of each object in 3D space. The default method used to determine which
polygons are hidden and which are shown based on these coordinates is called Z-buffering.

Z-buffering is extremely fast but not always accurate when dealing with multiple transparent layers in
a scene. Fortunately, there is another option for more complex 3D scenes with transparency: Sorted.
The Sorted method can be significantly slower in some scenes but will provide more accurate results
no matter how many layers of transparency happen to be in a scene.

The default behavior in the viewer is to use Z-buffering, but if your scene requires the Sorted method,

you can easily change this.

To choose a Sorted method of 3D compositing:
— Right-click anywhere within the 3D Viewer and choose one of the options in the Transparency
submenu of the contextual menu;
Renders every polygon in Z order to produce the most accurate rendering of
transparency.
Reorders the polygons in the scene serially, from back to front, to produce a

reasonably accurate rendering of transparency.
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The 3D Viewer displays a grid that's used to provide a plane of reference in the 3D scene. By default,
the grid is 24 x 24 units in size, centered on the origin at (0,0,0), and subdivided into large squares of 2
units with small squares of 0.25 units each. These defaults can be altered in the 3D View panel of the
Fusion Settings window, available from the Fusion menu.

To toggle the grid on and off:
— Right-click anywhere within the 3D Viewer and choose 3D Options > Grid from the

contextual menu.

The default grid of the 3D Viewer grid with its originatx=0,y=0andz=0

Normals indicate what direction each vertex of 3D geometry is facing, and they are used when
calculating lighting and texturing on an object. When viewing any kind of 3D geometry, including an
image plane or a full FBX mesh, you can display the normals for each object in a scene.

To view the normals in a scene:

— Right-click anywhere within the viewer and choose 3D Options > Vertex Normals from
the contextual menu.

The normals viewed in a 3D scene
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Quad View

3D compositing often requires you to view the scene from different points of view to better control
transformations in three dimensions. While you can switch the 3D Viewer to different points of view,
doing so frequently can become cumbersome. Happily, you can instead enable a Quad view, which
divides the viewer into four panes. These panes can then display four different angles of the scene
at one time.

To toggle the display of the Quad view, do one of the following:
— Right-click anywhere within the viewer and choose Views > Quad View from the contextual menu.

— Press Shift-Q.

A Quad view of a 3D scene

While there are four panes in the Quad view, they all show the same scene. When assigning views
within a Quad view, you can choose between displaying Front, Left, Top, Bottom, and Perspective
orthographic views, or you can choose the view through any camera or spotlight that's present in
the scene.

To assign different views to panes of a Quad view, do one of the following:

— Right-click directly on the POV label at the bottom left of the pane you want to reassign, and choose

another camera, light, or Point of View from the contextual menu.

There are a variety of Quad view layouts, ranging from four equally sized panels to having three small

panels across the bottom of a larger single panel.

To switch to a different Quad view layout, do the following:
Enable the Quad view.

Right-click anywhere within the viewer and choose an option from the Views > Quad Layouts
submenu of the contextual menu.
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Quad views aren't only useful for 3D scenes. They can also be used with 2D scenes, with each pane
showing a different image channel or subview type. For example, one pane can show the image while
the other panes show the alpha channel, a vectorscope, and a histogram.

To assign different channels or subviews to panes of a Quad view for a 2D scene:
Right-click in a viewer and choose Views > Quad View.
Click once in the pane you want to reassign.
Do one of the following:
Choose a channel from the Channel Viewer menu.

Right-click in the viewer and choose Views, and then choose a Subview from the submenu.

Guides

Guides are onscreen overlays used to help you compose elements within a boundary or along the
center vertical and horizontal axes. While guides are displayed in the viewer, they're not rendered
into the scene. There are four commonly used guides that can be displayed, including Monitor Safety,
Safe Title, Center, and Film.

The Guides submenu in the viewer’s contextual menu

Methods of using guides:

— To display guides in a viewer: Right-click in the viewer and then choose Guides > Show Guides
from the contextual menu, or press Command-G.

— To change the aspect ratio of the displayed guides: Right-click in the viewer and then choose
an option from the Guides > Frame Aspect submenu. The frame aspect is usually set to Default,
which forces the frame aspect to the same resolution as the image that's displayed in the view.
However, when the frame aspect is set to a specific value, the guides will conform to the exact
boundaries of the specified format and any image area outside of that will be dark gray.
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— To show or hide specific guides: Right-click in the viewer and then choose an option from the
Guides submenu. A variety of specific guides are provided, each of which can be individually
enabled and disabled.

Monitor Safety indicates the safe action area viewable on most monitors
and TV screens.
Safe Title indicates the safe area for titles viewable on all TV and monitor screens.

Center shows a crosshair for the center point and x- and y-axis of the view.

Some frame formats include film guides preset for you, whereas some will require
customization. The film guides can be customized in the Preferences > Frame Format window.

In the Frame Format panel of the Fusion Settings window (available in the Fusion menu), there are two
film guide settings that you can use to customize these guides.

— Guide 1 contains four fields that specify the offset from the edges of the image for the left,
top, right, and bottom guides, in that order. As with all offsets in Fusion, this is a resolution-
independent number where 1 is the width of the full image and 0.5 is half the width of the image.

— Guide 2's text box is used to set the aspect ratio of the projection area.

(@0 ® Fusion Settings

HDTV 1080

Frame Format

17777775

The Frame Format Guides settings

Domain of Definition and
Region of Interest

As a compositing environment, the Fusion page uses the standard compositing conventions of Region
of Interest (Rol) and Domain of Definition (DoD) to dramatically improve performance.

In compositing, the Domain of Definition, frequently abbreviated to DoD, refers to a rectangular
region that defines what part of an image actually contains data. DoD makes the concept of an
image’s actual frame somewhat flexible, since rendering is no longer limited to the actual width and
height of the image. This has two effects on the way Fusion renders images.
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Firstly, nodes will no longer be required to render portions of the image that will not be affected by
the node. This helps the renderer to optimize its performance. Secondly, Fusion can now keep track of
and apply a node’s effect to pixels that lie outside the visible portion of the image.

For example, consider the output of a Text+ node rendered against a transparent background. The
text occupies only a portion of the pixels in the image. Without Domain of Definition, you would be
required to process every pixel in the image needlessly. With a DoD, you are able to optimize effects
applied to the image, producing faster results and consuming less memory in the process.

The following image shows an image with the DoD outlined.

The DoD is shown as two XY coordinates indicating the corners of an axis-aligned bounding box (in pixels)

For the most part, the DoD is calculated automatically and without the need for manual intervention.
For example, all the nodes in the Generator category automatically generate the correct DoD. For
nodes like Fast Noise, Mandelbrot, and Background, this is usually the full dimensions of the image. In
the case of Text+ and virtually all of the Mask nodes, the DoD will often be much smaller or larger.

The OpenEXR format is capable of storing the data window of the image, and Fusion will apply this as
the DoD when loading such an image through a Loader node and will write out the DoD through the
Saver node.

When using the Fusion page in DaVinci Resolve, clips from the Edit page timeline or Media Pool will
typically have the DoD default to the full image width of the source media. The exception is media
stored in OpenEXR format.

The DoD is established as soon as the image is created or loaded into the composition. From there,
it passes downstream, where viewers combine it with their Region of Interest in order to determine
exactly what pixels should be affected by the node. As you work, different nodes will automatically
shrink, expand, or move the DoD as they apply their effect to an image, causing the DoD to change
from node to node.

Showing the DoD

If the current DoD for a node is different from the frame size of that image, it's shown in the tooltip
that appears when the pointer hovers over a node in the Node Editor. The DoD is also visible in the
viewer when you right-click in a viewer and choose Region > Show DoD from the contextual menu.

Setting the DoD Manually in the Node Editor

It is also possible to set the DoD for an image manually using the Tools > Miscellaneous > Auto Domain
node in the Effects Library. This node can be useful when dealing with pre-created media that does
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not occupy the full image dimensions. For example, a rendering of a 3D character that walks toward
the camera will frequently occupy only a portion of the image. The Auto Domain node can be used to
animate a DoD that covers the character and ignores the rest of the image, making image processing

more efficient.

The Region of Interest, frequently abbreviated to Rol, is a rectangular region similar to the Domain of
Definition. However, unlike the DoD, which tells the node what pixels are actually present in the image,
the Rol tells the node which pixels actually need to be rendered. When a node renders, it intersects
the current Rol with the current DoD to determine what pixels should be affected.

You can turn on the Rol controls to restrict rendering to a small region of the image to significantly
improve performance when you're only working on a small part of a high-resolution or complex
composition. For example, if you're using paint to clean up some holes in a matte on the floor of a
composition with many, many high-resolution layers, 3D, and Lighting operations, you can use the
Rol controls to isolate the part of the floor you're working on, which makes caching that part of the
composition much faster.

To enable the Rol controls, do one of the following:
— Click the Rol button in the 2D Viewer toolbar.

— Right-click in a viewer and choose Region > Show Region from the contextual menu.

When Rol is enabled and Show Region is selected from the menu, a rectangular Rol control appears in
the viewer. If this is the first time Rol has been enabled, it will be set to the full width and height of the
image. Otherwise, the last known position of the Rol for that view is used. However, if you want to set
the Rol to a custom area within the frame, you can do one of the following.

To adjust the Rol controls, do one of the following:
— Drag any edge of the Rol rectangle to adjust one side of the Rol.
— Drag a corner to adjust the size of the Rol rectangle from that corner.

— Drag the small circle found at the top left corner of the Rol rectangle to move the Rol without

adjusting its dimensions.

Sometimes, it's faster to simply draw a rectangle where you want the Rol to be.

To quickly draw the Rol at the desired size:

Choose Set from the viewer menu next to the Rol button, or right-click anywhere within the viewer

and choose Region > Set Region.
When the pointer turns into an Rol drawing cursor, drag within the viewer to set a Rol rectangle.

Alternatively, an Auto command sets the Rol to fit whichever pixels are visible at the current zoom/
pan level in the viewer. This lets you quickly limit the Rol to whatever part of the composition you've

zoomed into.

Using Viewers 216




To automatically draw the Rol:
— Choose Auto from the viewer menu next to the Rol button.
— Right-click anywhere within the viewer and choose Region > Auto Region.

— When you no longer need to use the Rol, you can reset it.

To reset the Rol to the full width and height of the current image, do one of the
following:

— Choose Reset from the viewer menu next to the Rol button.

— Right-click anywhere within the viewer and choose Region > Reset Region from the contextual
menu or from the toolbar button menu.

— Disable the ROI control, which will also reset it.

While the Rol Is Active

The Rol is only used for previewing your composition while you work, not for output from Fusion.
While the Rol is active, Fusion will only request rendering of the pixels inside the region when it
displays an image in that viewer. Flipbook Previews that you create in that viewer will also respect the
current Rol. MediaOut and Saver nodes will always use the full image dimensions when writing the
image to disk, ignoring any Rol you've set in the viewers.

The Rol improves not only rendering speed and memory use, but it can also reduce file I/0, since
Loaders and Medialn nodes only load pixels from within the Rol, if one is specified. This does require
that the file format used supports direct pixel access. Cineon, DPX, and many uncompressed file
formats support this feature, as well as OpenEXR and TIFF in limited cases.

Please note that changes to the viewed image size or color depth will cause the pixels outside the Rol
to be reset to the image’s canvas color. This also happens when switching in and out of Proxy mode,
as well as during Proxy mode switching with Auto Proxy enabled. When the image size is maintained,
so are the last rendered pixel values outside the Rol. This can be useful for comparing changes made
within the Rol with a previous node state.

TIP: Right-clicking in a viewer and choosing Options > Show Controls for showing onscreen

controls will override the Rol, forcing renders of pixels for the entire image.

Managing Viewer Lookup Tables (LuTs)

Lookup Tables, or LUTs, can be used to help match the appearance of a viewer to its eventual output
destination. They're essentially image-processing operations that affect only the image being
previewed in the viewer, not the image data itself. There are two basic ways that LUTs can calculate
color transformations: The firstis a simple 1D LUT, and the second is a more sophisticated 3D LUT.

— The simplest form of a LUT is a 1D LUT. It accounts for one color channel at a time, so it can make
overall tonality changes but not very specific color changes.

— A 3D LUT looks at each possible color value (red, green, and blue) independently. A 3D LUT allows
for large global changes as well as very specific color changes to be applied to images very quickly.
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A Lookup Table (LUT) is a table of values used to transform the color and luminance of an image. A 1D
LUT uses a two-column table for input color and output color, while a 3D LUT uses more of a matrix.
A LUT is used primarily to correct for variances in the monitor or the source color space of the image.
You can choose to apply a LUT to all the viewers or apply different LUTs to each viewer.

Image LUTs

Image LUTs can be applied to each viewer. In fact, you can even apply separate Image LUTs for the A
and B buffers of a single viewer. These LUTs can only be applied to 2D images and not to 3D scenes.
Image LUTs are routinely used to get from one scene-referred color space to another. For example,
if you're working with log-encoded media but want to see how the image will look in the final color
space, you can choose a LUT to make the image transform as a preview.

Buffer LUTs

The Buffer LUT is applied to the viewers regardless of contents, including 3D scenes, 3D materials, and
subview types. Only one Buffer LUT can be applied. If a 2D image is being displayed with an Image
LUT applied, then the Buffer LUT is applied to the result of the image LUT. Buffer LUTs are typically
used to simulate another output color space that's unique to the display you're using—for instance,
making a DCI-P3 projector show the image as it would look on an sRGB monitor.

To use a Buffer LUT:
Disable the LUT button above the viewer.
Right-click in the viewer and choose Global Options > Buffer LUT > Enable.

Right-click in the viewer and choose Global Options > Buffer LUT > Type of LUT you want to apply.

When dealing with nonlinear files from many of today's digital cinema cameras, a modern workflow
would be to convert everything to linear at the beginning of the node tree, then create your
composite, and then apply an Image LUT or Buffer LUT that matches the color space you want it to be
in for either grading in the Color page or for final output.

However, in more elaborate production pipelines, you may need to apply multiple LUTs consecutively.

Aside from the industry standard 1D and 3D LUTs, other types of LUTs are supported, including script-
based Fuse node LUTs and macros assembled from standard nodes. Generally, LUT processing is
performed on the graphics card’s GPU in real time, although the performance of macro-based LUTs is
based on the nodes they contain.

Fusion View LUT

The Fusion View LUT is the default and is a frequently used LUT type. It provides an RGBA curve
that can be used to assign IN/OUT value pairs. This control is identical to that provided by the Color
Curve node.

Since the purpose of the View LUT is to provide an unchanging correction for the monitor or the file's
color space, however, these splines cannot be animated.
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Log-Lin View LUT

The Log-Lin LUT converts logarithmic data to linear, and vice versa. This can be particularly useful
when used in conjunction with supplied LUT files that expect logarithmic data. It is similar to the
Cineon Log node.

Gamut View LUT

The Gamut LUT converts a source color space to an output color space, with options to deal with
gamma settings, alpha channels, and premultiplication. The Gamut LUT is a frequently used LUT type
to correct the viewer when working with Linear Gamma in the Node editor.

Macro LUTs

Any macro node can also be used as a viewer LUT simply by saving the macro’s .setting file to the
correct Fusion directory.

In DaVinci Resolve, LUTs are saved in the following locations:

— On mac0S: Macintosh HD/Users/username/Library/Application Support/Blackmagic Design/
Fusion/LUTs/

— On Windows: C:\Program Files\Blackmagic Design\Fusion\LUTs

— On Linux: home/username/.local/share/DaVinciResolve/Fusion/LUTs

In Fusion Studio, LUTs are saved in the following locations:

— On macOS: Macintosh HD/Users/username/Library/Application Support/Blackmagic Design/
Fusion/LUTs/

— On Windows: C:\Users\username\AppData\Roaming\Blackmagic Design\Fusion\LUTs

— On Linux: home/username/.fusion/BlackmagicDesign/Fusion/LUTs

For this to work, the macro must have one image input and one image output. Any controls exposed
on the macro will be available when the Edit option is selected for the LUT. For more information
about creating macros, see Chapter 6, “Node Groups, Macros, and Fusion Templates.” in the Fusion
Reference Manual or Chapter 68 in the DaVinci Resolve Reference Manual.

LUT Presets

All LUTs available to DaVinci Resolve are also accessible to the Fusion page, which includes custom
LUTs you've installed, as well as preset LUTs that come installed with DaVinci Resolve, such as the
highly useful VFX IO category that includes a wide variety of miscellaneous to Linear and Linear to

miscellaneous transforms. All of these LUTs appear by category in the viewer LUT menu.

Fuse LUTs

Fuses are scriptable plugins that are installed with the application or that you create in Fusion. A fuse
named CT_ViewLUTPlugin can be applied as a LUT to a viewer. You can also script fuses that use
graphics hardware shaders embedded into the LUT for real-time processing. Since fuse LUTs require
shader-capable graphics hardware, they cannot be applied in software. For more information about
Fuses, see the Fusion Scripting Guide located on the Blackmagic Design website.
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Viewer LUTs can be enabled, edited, and turned off using the viewer LUT button and menu, as well as
by using the viewer contextual menu. This menu shows all LUTs available to Fusion, including custom
LUTs you've installed yourself.

EH Inspector

Fusion View LUT k

The viewer LUT button and menu from
the Fusion page in DaVinci Resolve

To turn the current viewer LUT on and off:
— Click the LUT button in the viewer toolbar to toggle the viewer LUT on and off.

— The LUT menu can also be found as a submenu in the viewer's contextual menu.

To choose another viewer LUT:

— Open the menu to the right of the viewer LUT button and choose an option from the
viewer LUT menu.

To apply a Buffer LUT:
Right-click anywhere within the viewer and choose Global Options > Buffer LUT > Enable.

To choose a specific Buffer LUT, right-click again and choose a LUT from the Global Options >
Buffer LUT submenu.

Buffer LUTs are often useful for applying monitor corrections, which do not usually change
between projects.

To remove a Buffer LUT:

— Right-click anywhere within a viewer and choose Global Options > Buffer LUT >
Enable to uncheck it.
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The viewers are the primary area where composites are assessed, so it's crucial that they provide an
accurate representation of what the content will look like when it's played for an audience. The LUT
Editor allows you to customize your viewer's output to match the gamma and color characteristics of
your eventual playback device, or to test how the current image looks in a completely different color
space, or how it holds up over a range of different color spaces.

To open any editable viewer LUT option’s Editor:
Click the LUT button in the viewer toolbar to enable it.
Do one of the following:

— Choose Edit from the top of the viewer LUT menu.

— Right-click in the viewer and then choose LUT > Edit from the contextual menu.

Editing the Fusion View Lookup Table

Similarly to the Color Curves node, the Fusion View LUT Editor uses spline-based color correction. In
addition to the ability to modify the separate color channels, the LUT has Gain and Gamma sliders.
The Gain slider is helpful for temporarily brightening or darkening the viewed image, allowing easier
examination of shadow or highlight detail. The Color Gamma and Alpha Gamma sliders are used to
duplicate the gamma values of the eventual output device. Video monitors, for example, commonly
have a gamma of 1.7, while computer monitors can range anywhere from 1.6 to 2.2. Alpha Gamma is
applied only when viewing the alpha channel of an image, or when viewing masks.

FusionViewLUT

The LUT Editor for the default Fusion View LUT

Editing the Gamut View LUT

The Gamut View LUT Editor lets you choose a Source and Output color space to guide the

viewer transform.

The Remove and Add Gamma checkboxes let you choose to do the gamut conversion with linear
or nonlinear gamma, or they let you simply remove or add the appropriate gamma values without
changing the color space.
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Selecting the Pre-Divide/Post-Multiply checkbox will cause the image's pixel values to be divided
by the alpha values prior to this conversion, and then re-multiplied by the alpha value after this
conversion. This helps to avoid the creation of illegally additive images, particularly around the edges

of a blue/green key or when working with 3D rendered objects.

GamutViewLUT

No Change
< Re
No Change

s B

The Gamut View LUT Editor

Editing the Log-Lin View LUT

The Log-Lin LUT lets you apply a Log to Lin or Lin to Log operation using the Mode pop-up menu. You
can choose the type of log-encoding to process from the Log Type drop-down, and choose whether to
lock the R, G, and B channels together. A level adjustment lets you redefine the digital range of values
used for the output, while Soft Clip (Knee), Film Stock Gamma, and Conversion Gamma sliders let you
further customize the color transform. Lastly, a Conversion Table field and Browse button let you add

an additional LUT as part of this operation.

LogLinViewLUT

Log to Lin

Cineon

v

The Log-Lin LUT Editor
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In elaborate workflows, facilities may apply multiple LUTs in a row before the image is seen. The order
of these is important since each LUT delivers different outputs. For instance, for a Cineon file in Log
color space you may often apply three LUTs. First a Log to Lin conversion, followed by a Fusion View
LUT to apply a color calibration, and a third one to correct it for display on an sRGB monitor, or replace
the last with a 3D DCP LUT if you are viewing on a projector.

When you select a node to be displayed, the image produced is processed before it is shown in the
viewers. The processing order is slightly different for 2D images and 3D scenes.

2D images first have the image LUT applied, and the result is composited over the checker underlay.
3D scenes are instead rendered with OpenGL.

Image Image LUTs Post Processing Buffer LUT Viewer

Output Macro LUTs Checker underlay (single) Output

Fusion View LUT Dithering

v

Order of processing

The order of processing for 2D images and 3D scenes

For either 2D or 3D, the result may be drawn to an offscreen buffer where a Buffer LUT can be applied,
along with dithering, a full view checker underlay, and any stereo processing. The final result is then
drawn to the viewer and any onscreen controls are drawn on top.

The viewer contextual menu can be used to apply multiple image LUTs into a processing chain.

To apply an additional LUT, do the following:
Right-click anywhere within the viewer.
From the viewer’'s contextual menu, choose LUT > Add New.

From the Add New submenu, choose a LUT to add.

To remove a LUT other than the first LUT, do the following:
Right-click anywhere within the viewer.
From the viewer’s contextual menu, choose LUT > Delete.

From the Delete submenu, choose a LUT to remove.

A complete stacked LUT configuration can be saved to and loaded from a .viewlut file, as
described below.
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There are a variety of ways to create and use different viewer LUTs in Fusion. You can save LUTs
when you save viewer settings, you can import LUTs that have been exported from Fusion or other
applications, and you can open any one of the various supported LUT file types. In addition, you can
use the standard nodes in Fusion to create macros, which can then be saved and used as a LUT.

LUT Settings

The most straightforward way to save a LUT you have created using the Fusion View LUT Editor is to
use the LUT > Save menu found in the viewer contextual menu. The settings are saved as an ASCII
file with the extension .viewlut in the LUTs folder. Any files with this extension found in that folder will
appear in the Image LUT menus for ease of loading. You can also load the settings that are not found
in the menu by choosing LUT > Load from the viewer’s contextual menu.

Using Viewer Settings

If you've modified a LUT, choosing Settings > Save New from the viewer’s contextual menu will save
all the viewer's settings, including all LUT curves and gain/gamma values. You can save these under
different names, and each settings file can be reloaded at any time by choosing Settings > filename
from the viewer'’s contextual menu. Choosing Save Default from the same menu will make these
settings the standard for all new comps.

Using LUT Curves

The Viewer LUT Edit dialog can be used to import and export LUT curves. You can export the LUT
curves as either ASCII or Saved format. The ASCII (.alut) file format is useful for sharing LUT curves
with other software, whereas the Saved (.lut) file format is preferred for Fusion, as it is more compact,
accurate, and allows further editing.

To export a LUT, do the following:
Click the viewer LUT button to enable it.
Click the viewer LUT menu, and then choose Edit.
Right-click on the LUT Curve Editor, and then choose Export LUT.
Select a LUT format at the bottom of the file browser window.

Enter a name for the LUT and click Save.

The Import LUT option will load LUT files back into the Curve Editor, or alternatively, if the file has been
saved in Fusion’s LUTs folder, it will appear in the LUT drop-down menu list.

TIP: This is one way to move LUTs between viewers or to and from the Color Curves node or
any other LUT Editor in Fusion.
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Any supported LUT files in the LUTs folder can be used by choosing them either from the LUT drop-
down menu or the viewer’s contextual menu. This includes 1D and 3D LUTs such as Fusion’s .lut, .alut
and .alut3 formats, as well as .cube, .shlut, .look, .3dl, and .itx formats. This is a convenient way to
access standard format LUT files for different projects.

Settings and Macros

Since LUTs are a form of color correction, you can also use any node, macro, or group of nodes as a
viewer LUT.

To use a node, group, or macro as a viewer LUT, do the following:
Select the node, group, or macro.
Right-click over the selected node, and then choose Settings > Save As from the menu.
In the file browser, go to the LUTs folder as set in Preferences > Global > Path Map > LUTS.

Click Save to save the .settings file.

This allows almost any combination of nodes to be used as a viewer LUT. This is the most flexible
approach but is also potentially the slowest. The LUT nodes must be rendered solely on the CPU,
whereas other methods are GPU-accelerated.

Setting a Default LUT

The default LUT applied when a new composition is created can be assigned in the Viewer panel of the
Fusion Settings window. Clicking the Enable Display LUT checkbox allows you to select a LUT from the
Display LUT plugins list.

The LUT default settings found in the View panel of the Fusion Settings window
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Viewer Preferences and Settings

The default settings for each viewer can be changed using the Viewer panel in the Preferences. The
position and size of each floating viewer can also be saved using the Layout menu in the Preferences.

It is often preferable to switch between entirely different viewer configurations while working.

For example, while keying, the image may be in the main viewer, and the alpha channel may be in a
subview. Viewer settings toward the end of a project may consist of the histogram, vectorscope, and
waveform, as well as the image in a view set to Quad view.

Fusion provides the ability to quickly load and save viewer settings to help reduce the amount of effort
required to change from one configuration to another.

To save a viewer setting, do the following:
Right-click over the viewer you want to save.
From the contextual menu, choose Setting > Save New.

Enter a name for the settings and click Save.

To load a viewer setting, do the following:
Right-click over the viewer you want to load a setting into.

From the contextual menu, choose Settings > filename.

Loading and Saving Defaults for a Viewer

The viewer can save new defaults and be returned to its defaults using the Load Defaults and the Save
Defaults options in the Settings portion of the View contextual menu.

The Viewer Options Menu

The Options menu of the viewer contains several ways you can customize the look and behavior of the
viewer. Many of these options are also in the viewer contextual menu.

Show Controls

When onscreen controls are not necessary or are getting in the way of evaluating the image, you can
temporarily hide them using the Show Controls option. This option is toggled using Command-K.

Checker Underlay

The Checker Underlay shows a checkerboard beneath transparent pixels to make it easier to identify
transparent areas. This is the default option for 2D viewers. Disabling this option replaces the
checkerboard with black.

Show Pixel Grid

Enabling this option will show a light black grid that outlines the exact boundaries of pixels in the
image when the image is scaled past a certain threshold. The default is Off.
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Smooth Resize

The Smooth Resize option uses a smoother bilinear interpolated resizing method when zooming into
animage in the viewer. When Smooth Resize is disabled, scaling uses the nearest neighbor method
and shows noticeable aliasing artifacts but is more useful for seeing the actual pixels of the viewed
image when you zoom all the way down to a pixel level since there is no interpolation. This option is
enabled by default and can be toggled by clicking on the SmR button in the viewer toolbar.

Show Square Pixels

Depending on the frame format preferences and the type of footage loaded, many images may have
pixels that are rectangular instead of square. Both the NTSC and PAL video standards, as well as some
anamorphic film formats, use rectangular pixels. A computer monitor uses perfectly square pixels.

To compensate for this, aspect correction is automatically performed when viewing non-square pixels.
This prevents non-square pixel images from appearing squashed or stretched in the viewer.

You can enable the Show Square Pixels option to override the aspect correction. Show Square Pixels
can also be toggled on and off using the 1:1 button in the viewer toolbar.

Gain/Gamma

Exposes or hides a simple pair of Gain and Gamma sliders that let you adjust the viewed image.
Especially useful for “gamma slamming” a composite to see how well it holds up with a variety of

gamma settings. Defaults to no change.

360° View

Sets the Fusion page viewer to properly display spherical imagery in a variety of formats, selectable
from this submenu. Disable toggles 360 viewing on or off, while Auto, LatLong, Vert Cross, Horiz
Cross, Vert Strip, and Horiz Strip let you properly display different formats of 360° video.

Locking the Viewer (Command-1)

You can lock a viewer to prevent it from updating. The node that's loaded into that viewer still
processes and the new image is queued for display in the viewer, but until you unlock it, the viewer
does not update. By default, the viewer is unlocked.

Additional Viewer Options

There are additional commands when you right-click anywhere within a viewer and choose from the
generically named Options submenu.

Alpha Overlay

When you enable the alpha overlay, the viewer will show the alpha channel overlaid on top of the
color channels. This can be helpful when trying to see where one image stops and another beginsin a
composite. This option is disabled by default.
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Overlay Color

When you turn the alpha overlay on, the default color is to show white for the area the alpha covers.
There are times when white does not show clearly enough, depending on the colors in the image.
You can change the color by choosing a color from the list of Overlay Color options.

Follow Active

Enabling the Follow Active option will cause the viewer to always display the currently active node in
the Node Editor. This option is disabled by default, so you can view a different node than what you
control in the Control Panel.

Show Controls

When onscreen controls are not necessary or are getting in the way of evaluating the image, you can
temporarily hide them using the Show Controls option. This option is toggled using Command-K.

Show Full Color Range

When working with floating-point images, you will occasionally need to visualize the values that fall
outside the normal luminance range. Enabling the Show Full Color Range option using the toolbar
button automatically normalize any image displayed in the viewer. Normalization causes the brightest
pixel in a color channel to be mapped to a value of 1.0 (white) and the darkest pixel to be mapped to a
value of 0.0 (black). Midrange values are scaled appropriately to fit within that range. It is also useful
when viewing Z-buffer or other auxiliary channels, which often use value ranges far different from
those in the color channels.

Show Labels

The Show Labels option lets you toggle the display of the text that sometimes accompanies onscreen
controls in the viewer without disabling the functions that are showing those overlays, and without
hiding the onscreen controls themselves.

Status Bar Information

The status bar at the bottom of the Fusion window provides the exact RGBA and Z values for the pixel
beneath the pointer when it's hovering within one of the viewers. Additional information about the
Xand Y coordinates of the cursor and the exact pixel position are also displayed.

psition X 021148 406 Y 0.31667 342 Color R 0.59229 G 0.63184 3 0.61377

The status bar showing coordinates and color information
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Editing Parameters in
the Inspector

The Inspector is where you adjust the parameters of each node to

do what needs to be done. This chapter covers the various node

parameters and methods for working with the available controls.
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Overview of the Inspector

While the creation and connection of nodes in the Node Editor determines the tools and order of
operations that make up a composition, the Inspector is where you adjust the various parameters
inside each node to do what needs to be done.

2§ Inspector

MediaOut1 23] Inspector
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BrightnessContrast1

Forward

» BrightnessContrast! g—p MediaOut1 n

Inspector displays the Brightness Contrast controls

This chapter covers methods for opening node parameters in the Inspector to edit them in different
ways according to the type of available controls.

To display the Inspector:
— Click the Inspector button on the Ul toolbar.

The Inspector is divided into two overall panels.

— The Tools panel is where the parameters of selected nodes appear so you can edit them.
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— The Modifiers panel is where you edit optional extensions to the tool's standard toolset as well as
automated expressions that you can attach to individual parameters to create animated effects.
Additionally, certain nodes such as the Paint node generate data such as Strokes, which are saved

in the Modifiers panel.

Perturb1

Modifiers displayed in the Modifiers panel

Customizing the Inspector

You can customize how the Inspector is presented in a variety of ways.

A small arrow button at the far right of the UI toolbar lets you toggle the Inspector between full-height
and half-height views, depending on how much room you need for editing parameters.

Y& Inspector

The Maximize button on the
left side of the Inspector

In maximized height mode, the Inspector takes up up the entire right side of the U], letting you see
every control that a node has available, or creating enough room to see the parameters of two or
three pinned nodes all at once. In half-height mode, the top of the Inspector is aligned with the tops of
the viewers, expanding the horizontal space that's available for the Node Editor.

By default, you see only selected nodes in the Inspector, and only the Active node is expanded to show
its controls. You can change this behavior by choosing Fusion > Fusion Settings in the Fusion page

or File > Preferences in Fusion Studio and opening the User Interface panel. In the User Interface,
checkboxes manage the display of controls.
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(@ ® Fusion Settings

User Interface

Control preferences in the User Interface category

— Auto Control Open: When enabled (the default), whichever node is active automatically opens
its controls in the Inspector. When disabled, selecting an active node opens that node’s Inspector
header in the Inspector, but the parameters remain hidden unless you click the Inspector header.

— Auto Control Hide: When enabled (the default), only selected nodes are visible in the Inspector,
and all deselected nodes are automatically removed from the Inspector to reduce clutter. When
disabled, parameters from selected nodes remain in the Inspector, even when those nodes are
deselected, so that the Inspector accumulates the parameters of every node you select over time.

— Auto Control Close Tools: When enabled (the default), only the parameters for the active
node can be exposed. When disabled, you can open the parameters of multiple nodes in the
Inspector if you want.

— Auto Controls for Selected: When enabled (the default), selecting multiple nodes opens multiple
control headers for those nodes in the Inspector. When disabled, only the active node appears in

the Inspector; multi-selected nodes highlighted in white do not appear.

Opening Nodes in the Inspector

Before you can edit a node’s parameters, you need to open it in the Inspector.

To display a node’s controls in the Inspector:

— Select one or more nodes from the Node Editor, Keyframes Editor, or Spline Editor.

When you select a single node so that it's highlighted orange in the Node Editor, all of its parameters
appear in the Inspector. If you select multiple nodes at once, Inspector headers appear for each
selected node (highlighted in white in the Node Editor), but the parameters for the active node
(highlighted in orange) are exposed for editing.
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Opening multiple nodes in the Inspector

Only one node's parameters can be edited at a time, so clicking another node’s Inspector header
opens that node’s parameters and closes the parameters of the previous node you were working on.
This also makes the newly opened node the active node, highlighting it orange in the Inspector.

Pinning Multiple Nodes
in the Inspector

For instances where you need to work quickly by editing the parameters of multiple nodes at the
same time, you can use the Pin button in the Inspector header of nodes in the Inspector to keep those
parameters exposed in the Inspector, regardless of whether that node is selected and active.

4

The Pin button of a node’s Inspector
header in the Inspector

While the Pin button is on, that node’s parameters remain open in the Inspector. If you select
another node in the Node Editor, that node’s parameters appear beneath any pinned nodes.
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You can have as many pinned nodes in the Inspector as you like, but the more you have, the more
likely you'll need to scroll up or down in the Inspector to get to all the parameters you want to edit.
To remove a pinned node from the Inspector, just turn off its Pin button in the Inspector header.

Hiding Inspector Controls

If you like, Inspector parameters for specific nodes can be hidden so they never appear, even
when that node is selected. This can be useful for preventing accidental changes by you or
other compositors who may be working on a composition in situations where you don't want to
lock the node.

To Toggle the Inspector controls for a node or or off:

— Right-click on the node in the Node Editor, or on the Inspector header, and choose Modes > Show
Controls from the contextual menu.
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Using the Inspector Header

When you select a node, it populates the Inspector with a title bar, or Inspector header, that displays
that node’s name as well as other controls that govern that node. A node’s Inspector header itself
has a variety of controls, but clicking (or double-clicking) on an Inspector header also exposes that
node’s parameters.

A node’s Inspector header

When you select multiple nodes at once, you'll see multiple headers in the Inspector. By default, only
the parameters for the active node (highlighted orange in the Node Editor) can be opened at any
given time, although you can change this behavior in Fusion’s Preferences.

Inspector headers are click targets for selecting nodes, opening and closing node parameters, and
other things.

Methods of using headers:

— To select a node using the Inspector header: When multiple nodes are selected, you can make
a node the active node by clicking its Inspector header in the Inspector. As the actively selected
node, the Inspector header and the corresponding node in the Node Editor are highlighted orange,
and its parameters are exposed.

— To load a node into the viewer using the Inspector header: You can view a node by dragging its
header into one of the viewers.

— To view a node’s splines with the control header: If you want to view the animated curves
of a node in the Spline Editor, you can add them by dragging the Inspector header into the
Spline Editor. All animated splines for the parameters of that node will automatically be displayed.

The controls found in each node’s Inspector header makes it fast to do simple things.

To turn nodes off and on: Each Inspector header has a toggle switch to the left
of its name, which can be used to enable or disable that node. Disabled nodes
pass image data from the previous upstream node to the next downstream node
without alteration.

To change the Inspector header name: The name of the node corresponding to

- that Inspector header is displayed next. You can change the name by right-clicking
the Inspector header to expose contextual menu commands similar to those found
when you right-click a node in the Node Editor and choosing Rename. Alternatively,
you can click an Inspector header and press F2 to edit its name. A Rename dialog
appears, where you can enter a new name and click OK (or press Return).
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To color-code nodes: A color pop-up menu lets you color code with one of 16 colors.
Choose Clear Color if you want to return that node to the default color.

To version nodes: Turning on the Versions button displays a Version bar
with six buttons. Versioning is described in the following section.

To pin Inspector controls: Clicking the Pin button “pins” that node’s parameters
in the Inspector so they remain in place, even if you deselect that node. You can
have as many pinned nodes as you like in the Inspector, but the more you have,
the more likely you'll be scrolling up and down the Inspector to navigate all the
available parameters.

To lock nodes: Clicking the Lock button locks that node so no changes
can be made to it.

To reset Inspector controls: The rightmost button in the Inspector header is a

Reset button that resets the entire node to the default settings for that node.

Versioning Nodes

Each button is capable of containing separate parameter settings for that node, making it easy to save
and compare up to six different versions of settings for each node. All versions are saved along with
the node in the Node Editor for future use.

The Version bar, underneath an Inspector
header, with versions enabled

An orange underline indicates the currently selected version, which is the version that's currently
being used by your composition. To clear a version you don't want to use any more, right-click that
version number and choose Clear from the contextual menu.

Parameter Tabs

Underneath the Inspector header is a series of panel tabs, displayed as thematic icons. Clicking one of
these icons opens a separate tab of parameters, which are usually grouped by function. Simple nodes,
such as the Blur node, consist of two tabs where the first contains all of the parameters relating to
blurring the image, and the second is the Settings tab.

6

Controls

The parameter tabs of the Blur node
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More complicated nodes have more tabs containing more groups of parameters. For example, the
Delta Keyer has seven tabs: separating Key, Pre-Matte, Matte, Fringe, Tuning, and Mask parameters,
along with the obligatory Settings tab. These tabs keep the Delta Keyer from being a giant scrolling
list of settings and make it easy to keep track of which part of the keying process you're finessing

as you work.

DeltaKeyer12

The parameter tabs of the Delta Keyer node

Every node that comes with Fusion has a Settings tab. This tab includes a set of standard controls
that appear for nearly every node, although some nodes have special Settings tab controls that
others lack.

&

Settings

v Settings

when Blend is
Process € EI

Apply Mask Inverted

Multiply by Mask

Use Object

Use Material
Use GPU  Auto
Hide Incoming Connections

v Comments

Keep this node set to Gaussian only.

> Frame Render Script

> Start Render Scripts

The Settings tab in the Inspector

The following controls are common to most nodes, although some are node-specific. For example,
Motion Blur settings have no purpose in a Color Space node.
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Blend

The Blend control is found in all nodes, except the Loader, Medialn, and Generator nodes. It is used
to blend between the node’s unaltered image input and the node’s final processed output. When the
blend value is 0.0, the outgoing image is identical to the incoming image. Ordinarily, this will cause the
node to skip processing entirely, copying the input straight to the output. The default for this node

is 1.0, meaning the node will output the modified image 100%.

Process When Blend is 0.0

This checkbox forces the node to process even when the input value is zero and the image output

is identical to the image input. This can be useful on certain nodes or third-party plugins that store
values from one frame to the next. If this checkbox is disabled on nodes that operate in this manner,
the node will skip being processed when the Blend is set to 0, producing incorrect results on
subsequent frames.

Red/Green/Blue/Alpha Channel Checkboxes

Most nodes have a set of RGBA boxes in the Settings tab. These selectable boxes let you exclude any
combination of these channels from being affected by that node.

Process

The channel limiting boxes in the Settings
panel of a Transform node set so that only
the green channel is affected.

For example, if you wanted to use the Transform node to affect only the green channel of an image,
you can turn off the Red, Blue, and Alpha checkboxes. As a result, the green channel is processed by
this operation, and the red, blue, and alpha channels are copied straight from the node’s input to the
node’s output, skipping that node’s processing to remain unaffected.

Transforming only the green color channel
of the image with a Transform effect

Skipping Channel Processing

Under the hood, most nodes actually process all channels first, but afterward copy the input image
to the output for channels that have been unchecked. Modern workstations are so fast that this isn't
usually noticeable, but there are some nodes where deselecting a channel actually causes that node
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to skip processing that channel entirely. Nodes that operate this way have a linked set of Red, Green,
Blue, and Alpha boxes on another tab in the node.

(]

Contrals

Filter  Gaussian

Channel boxes on the Controls tab of the
Blur node indicate that disabled channels won't
be processed at all, to save rendering time..

In these cases, the Common Control channel boxes are instanced to the channel boxes found
elsewhere in the node. Blur, Brightness/Contrast, Erode/Dilate, and Filter are examples of nodes that
all have RGBY checkboxes in the main Controls tab of the Inspector, in addition to the Settings tab.

Apply Mask Inverted

When the Apply Mask Inverted checkbox is enabled, masks attached to the Effect Mask input of that
node are inverted.

TIP: The Apply Mask Inverted checkbox option operates only on effects masks, not on
garbage masks.

Multiply By Mask
Selecting this option will cause the RGB values of the masked image to be multiplied by the Mask

channel’s values. This will cause all pixels of the image not included in the mask (i.e., those set to 0) to
become black. This creates a premultiplied image.

Use Object/Use Material (For Masking)

Some 3D animation and rendering software can output to file formats that support auxiliary channels.
Notably, the OpenEXR file format supports Object ID and Material ID channels, either of which can be
used as a mask for an effect. This checkbox determines whether the channels will be used if they are
available. The specific Material ID or Object ID affected is chosen using the next set of controls.

— Sample Controls

The Sample Controls are only displayed once the Use Object or Use Material checkbox is enabled.
These controls select which ID is used to create a mask from the Object or Material channels saved
in the image. You use the Sample button to grab IDs from the image in the viewer, the same way
you use the Color Picker to select a color, by holding down the left mouse button on the Sample
button, then dragging over to the viewer to the part of the image you want to select. The image or
sequence must have been rendered from a 3D software package with those channels included.

— Correct Edges

The Correct Edges checkbox is only displayed once the Use Object or Use Material checkbox
is enabled. When the Correct Edges checkbox is enabled, the Coverage and Background Color

Editing Parameters in the Inspector

239




channels are used to separate and improve the effect around the edge of the object. When
disabled (or no Coverage or Background Color channels are available), aliasing may occur on the
edge of the mask.

Motion Blur

For nodes that are capable of introducing motion, such as Transform nodes, Warp nodes, and so on,
the Motion Blur checkbox toggles the rendering of motion blur on or off for that node. When this
checkbox is enabled, the node’s predicted motion is used to produce the blur caused by a virtual
camera shutter. When the control is disabled, no motion blur is created.

When Motion Blur is disabled, no additional controls are displayed. However, turning on Motion Blur
reveals four additional sliders with which you can customize the look of the motion blur you're adding
to that node.

— Quality
Quality determines the number of samples used to create the blur. The default quality setting
of 2 will create two samples on either side of an object’s actual motion. Larger values produce

smoother results but will increase the render time.

— Shutter Angle

Shutter Angle controls the angle of the virtual shutter used to produce the Motion Blur effect.
Larger angles create more blur but increase the render times. A value of 360 is the equivalent of
having the shutter open for one whole frame exposure. Higher values are possible and can be
used to create interesting effects. The default value for this slider is 100.

— Center Bias

Center Bias modifies the position of the center of the motion blur. Adjusting the value allows for the
creation of trail-type effects.

— Sample Spread

Adjusting Sample Spread modifies the weight given to each sample. This affects the brightness of
the samples set with the Quality slider.

Scripting

Scripting fields are present on every node and contain one or more editable text fields that can be
used to add scripts that process when that node is rendering. For more information on the contents
of this tab, please consult the Scripting documentation.

Comments

A Comments field is found on every node and contains a single text field that is used to add comments

and notes to that node. To enter text, simply click within the field to place a cursor, and begin typing.

When a note is added to a node, the comments icon appears in the Control Header and can be seen
in a node’s tooltip when the cursor is placed over the node in the Node Editor. The contents of the
Comments tab can be animated over time, if required.

Additional controls appear under this tab if the node is a Loader. For more information,
see Chapter 41, “Generator Nodes.” In the Fusion Reference Manual or Chapter 103 in the
DaVinci Resolve Reference Manual.
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Inspector Controls Explained

Although a few nodes use fully customized interface elements that are unique to only that node, the
vast majority of nodes use a mix of sliders, angle wheels, and checkboxes. This section explains how to
use these controls.

Slider Controls are used to select a single value from a range of values. You change the value by
dragging the slider or entering a value into the edit box. This is fairly standard behavior for sliders.
However, there is additional functionality that can increase your productivity when making changes
with sliders.

Clicking on the gutter to the left or right of the handle will increase or decrease the value. Holding
Command while clicking on the gutter will adjust the values in smaller increments. Holding Shift while
clicking will adjust the value in larger increments.

Hold Command while clicking in the gutter
to move in smaller increments

While slider controls use a minimum and maximum value range, entering a value in the edit box
outside that range will often expand the range of the slider to accommodate the new value. For
example, it is possible to enter 500 in a Blur Size control, even though the Blur Size sliders default
maximum value is 100. The slider will automatically adjust its maximum displayed value to allow entry
of these larger values.

If the slider has been altered from its default value, a small circular indicator will appear below the
gutter. Clicking on this circle will reset the slider to its default.

A Thumbwheel control is identical to a slider except it does not have a maximum or minimum value.
To make an adjustment, you drag the center portion left or right or enter a value directly into the
edit box. Thumbwheel controls are typically used on angle parameters, although they do have other
uses as well.

Y Rotation

Thumbwheel controls for X,Y, and Z rotation with
arrows on either end for fine-tuning adjustments
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Once the thumbwheel has been selected, you can use the Up and Down Arrows on your keyboard
to further adjust the values. As with the slider control, the Command and Shift keys can be used to
increase or decrease the change in value in smaller or larger increments.

If the thumbwheel has been altered from its default value, a small circular indicator will appear below
above the thumbwheel. Clicking on this circle will reset the thumbwheel to its default.

The Range controls are actually two separate controls, one for setting the Low Range value and one
for the High Range value. To adjust the values, drag the handles on either end of the Range bar. To
slide the high and low values of the range simultaneously, drag from the center of the Range bar. You
can also expand or contract the range symmetrically by holding Command and dragging either end of
the Range bar. You find Range controls on parameters that require a high and low threshold, like the
Matte Control, Chroma Keyer, and Ultra Keyer nodes.

A Matte Threshold Range control

TIP: You can enter floating-point values in the Range controls by typing the values in using
the Low and High numeric entry boxes.

Checkboxes are controls that have either an On or Off value. Clicking on the checkbox control will
toggle the state between selected and not selected. Checkboxes can be animated, with a value of O for

Off and a value of 1.0 or greater for On.

Checkboxes used to select options for tracking

Drop-down menus are used to select one option from a menu. Once the menu is open, choosing one
of the items will select that entry. When the menu is closed, the selection is displayed in the Inspector.

Interpolation Mode  Blend

Blend

Drop-down menu in the TimeSpeed node
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Drop-down menu selections can be animated, with a value of 0 representing the first item in the list, 1
representing the second, and so forth.

Button arrays are groups of buttons that allow you to select from a range of options. They are
almost identical in function to drop-down menu controls, except that in the case of a button array it
is possible to see all of the available options at a glance. Often button arrays use icons to make the

options more immediately comprehensible.

The Lens Type button array in the Defocus node

The Color panel is displayed wherever a parameter requires a color as its value, such as the Fill or
Outline color in the Text+ node. The selected color is shown in a swatch with an Eyedropper to its

right, and below the swatch is the Color Chooser.

0.588500 0.512970 0.794539

0.386963
0.578114

0.794539

The Color panel with transparency preview

The Color panel is extremely flexible and has four different techniques for selecting and
displaying colors.

TIP: Color can be represented by 0-1, 0.255, or 0-65000 by setting the range you want in the
Preferences > General panel.

macOS and Windows Color Nodes

Clicking on the color swatch will display the operating system'’s standard Color Selection node.
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macOS Colors panel

Pick Screen Color

Custom colors

Add to Custom Colors

Windows Color dialog

Each operating system has a slightly different layout, but the general idea is the same. You can choose
a color from the swatches provided—the color wheel on macOS, or the color palette on Windows.
However you choose your color, you must click OK for the selection to be applied.
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The Color Chooser

You also have access to the built-in color chooser, which includes sections for choosing grayscale
values, as well as the currently chosen hue with different ranges of saturation and value. A hue bar
and alpha bar (depending on the node) let you choose different values.

0.588554  0.527989  0.771473

The color chooser in
the Background node

Picking Colors from an Image

If you are trying to match the color from an image in the viewer, you can hold down the cursor over
the Eyedropper, and then drag the pointer into the viewer. The pointer will change to an Eyedropper,
and a pop-up swatch will appear above the cursor with the color you are hovering over and its values.

When you are over the color you want, release the mouse button to set the color.

R: 0.38696

G: 0.58253
B: 0.79797
A 1.0

The Eyedropper
with color swatch

The Color Picker normally selects from a single pixel in the image, but you can adjust the size of the
selection by dragging into the viewer with the Eyedropper, and then holding Command and dragging
out a rectangle for the sample size you want. The size change applies to all Color Pickers until the size
is changed again.

The Gradient Control bar is used to create a gradual blend between colors. The Gradient bar displays
a preview of the colors used from start to end. By default, there are two triangular color stops: one on
the left that determines the start color, and one on the right that determines the end color.

Linear

0.0

1.0

The default Gradient controls
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Gradient Type

The Gradient Type button array is used to select the form used to draw the gradient.

Linear gradient: Linear draws the gradient Cross gradient: Cross draws the gradient using
along a straight line from the starting color stop a cross pattern when the starting point is at the
to the ending color stop. center of the image.

Linear gradient Cross gradient

Reflect gradient: Reflect draws the gradient by Radial gradient: Radial draws the gradientin a
mirroring the linear gradient on either side of circular pattern when the starting point is at the
the starting point. center of the image.

Reflect gradient Radial gradient

Square gradient: Square draws the gradient by Angle gradient: Angle draws the gradientin
using a square pattern when the starting point a counter-clockwise sweep when the starting
is at the center of the image. point is at the center of the image.

Square gradient Angle gradient

Start and End Position

The Start and End Position controls have a set of X and Y edit boxes that are useful for fine-tuning the
start and end position of the gradient. The position settings are also represented by two crosshair
onscreen controls in the viewer, which may be more practical for initial positioning.

Gradient Colors Bar

The Gradient Colors bar is used to select the blending colors for the gradient. The default two color
stops set the start and end colors. You can change the colors used in the gradient by selecting the
color stop, and then using the Eyedropper or color wheel to set the new color.

You can add, move, copy, and delete colors from the gradient using the Colors bar.
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To add a color stop to the Gradient Colors bar:
Click anywhere along the bottom of the Gradient Colors bar.

Use the Eyedropper or color wheel to set the color for the color stop.

To move a color stop on the Colors bar:

— Drag a color stop left or right along the Gradient Color bar.

To copy a color stop on the Colors bar:

— Hold Command while you drag a color stop.

To delete a color stop from the Colors bar, do one of the following:
— Drag the color stop up past the Gradient Colors bar.

— Select the color stop, then click the red X button to delete it.

Interpolation Space

The Gradient Interpolation Method pop-up menu lets you select what color space is used to calculate
the colors between color stops.

Offset

When you adjust the Offset control, the position of the gradient is moved relative to the start and end
markers. This control is most useful when used in conjunction with the repeat and ping-pong modes
described below.

Once/Repeat/Ping-Pong

These three buttons are used to set the behavior of the gradient when the Offset control scrolls the
gradient past its start and end positions. The Once button is the default behavior, which keeps the
color continuous for offset. Repeat loops around to the start color when the offset goes beyond the
end color. Ping-pong repeats the color pattern in reverse.

1x1, 2x2, 3x3, 4x4, 5x5

These buttons control the amount of sub-pixel precision used when the edges of the gradient become
visible in Repeat mode, or when the gradient is animated. Higher settings will take significantly longer
to render but will be more precise.

Gradient Contextual Menu

Gradients have their own contextual menu that you can bring up by right-clicking on the Gradient bar.
In the Gradient contextual menu are options for animating, publishing, and connecting one gradient
to another. There is also a gradient-specific modifier that builds a custom gradient by sampling colors
from the output of a node in the Node Editor.

Modifiers are expressions, calculations, trackers, paths, and other mathematical components that
you attach to a parameter to extend its functionality. When a modifier is attached to a parameter, its
controls will appear separately in the Inspector Modifiers tab.
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To attach a modifier:
Right-click over the parameter to which you want to attach a modifier.

Make a selection from the Modifier submenu in the contextual menu.

Animating Parameters
in the Inspector

Fusion can keyframe most parameters in most nodes, in order to create animated effects such as
animated transforms, rotoscoping with splines, dynamically altering warping behaviors, and so on; the
listis endless. For convenience, a set of keyframing controls are available within the Inspector next to
each keyframable parameter. These controls are:

— A gray Keyframe button to the right each keyframable parameter. Clicking this gray button creates
a keyframe at the current position of the playhead, and turns the button orange.

— When you add a keyframe to a parameter, moving to a new frame and changing the parameter will
automatically add a keyframe at the current position.

— Whenever the playhead is sitting right on top of a keyframe, this button turns orange. Clicking an
orange Keyframe button deletes the keyframe at that frame and turns the button gray again.

— Small navigation arrows appear to the right and left if there are more keyframes in those
directions. Clicking on navigation arrows to the right and left of keyframes jumps the playhead to
those keyframes.

Amplitude

iing @ 0.0

10.0 #

1.602188 < ¢

Orange Keyframe buttons in the Inspector
show there's a keyframe at that frame

Once you've keyframed one or more parameters, If Show Modes/Options has been enabled, the
node containing the parameters you keyframed displays a Keyframe badge, to show that node has
been animated.

A keyframed node displays a
Keyframe badge in the Node Editor

Once you've started keyframing node parameters, you can edit their timing in the Keyframes Editor
and/or Spline Editor. For more information about keyframing in Fusion, see Chapter 9, “Animating

in Fusion’s Keyframes Editor,” in the Fusion Reference Manual or Chapter 71 in the DaVinci Resolve
Reference Manual.
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To remove all keyframes from a parameter:
Right-click over the name of the keyframed parameter in the Inspector.

Choose Remove “node name:parameter name” from the contextual menu.

TIP: If you change the default spline type from Bézier, the contextual menu will display the

name of the current spline type.

Multiple parameters can be connected to the same animation curve. This can be an invaluable

timesaver if you are identically animating different parameters in a node.

To connect a second parameter to the same animation curve:

Right-click on the second parameter you want to attach.
In the contextual menu, hover over the Connect To submenu.

In the Connect To submenu, choose the name of the animated parameter.

Connecting Parameters

It is often useful to connect two parameters together even without an animation curve. There are two

methods you can use.

If you want to tie two parameters together so adjusting one adjusts the other, you must connect them
together using the Publish menu command on the first parameter and the Connect menu command

on the second parameter.

To Publish and Connect parameters:
Right-click the name of the parameter you want to publish, and choose Publish from the
contextual menu.
Right-click on the second parameter you want to attach, and choose the name of the parameter

you just published from the Connect To submenu.

Publish L\s

The Publish contextual menu
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You can also use simple expressions to link two parameters together. By using simple expressions via
pick whipping, values can be connected and combined visually without the need to publish a value
first. The pick whip is a temporary line drawn from one parameter to another in order to create a link
between the two.

To link two parameters using a pick whip:

Double-click the field of a parameter you want to pick whip to another parameter, type =, and then
press the Return key.

When Pick Whip controls appear underneath the parameter, drag a “whip” from the Add button to
the target parameter.

Now, adjusting the target parameter automatically adjusts the original parameter.

v Bottom Right

4
//

" Point(0.859, )

Pick whipping one parameter to another

TIP: Disabling the Auto Control Close node’s General preference, and then selecting two

nodes in the Node Editor will allow you to pick whip two parameters from different nodes.

The Expression field can further be used to add mathematical formulas to the value received from the
target parameter.

For more information on Pick Whipping and Expressions, see Chapter 12, “Using Modifiers, Expressions,
and Custom Controls,” in the Fusion Reference Manual or Chapter 74 in the DaVinci Resolve
Reference Manual.

Contextual Menus

There are two types of contextual menus you can invoke within the Inspector.

Node Contextual Menus

To display the Node Context menu from the Inspector, right-click on the Inspector header. The node’s
contextual menu includes the same menu options that are accessed by right-clicking on a node in the
Node Editor. see Chapter 5, “Working in the Node Editor.” in the Fusion Reference Manual or Chapter 67
in the DaVinci Resolve Reference Manual for more information on these options.
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Parameter Contextual Menus

The contextual menu for individual parameters is accessed by right-clicking over the parameter’s
name, slider, thumbwheel, range control, button array, or other control type. For example, right-
clicking on a slider will provide the slider’s contextual menu, with options to animate the control or add
additional modifiers. Many of these options were described in this chapter.

Customizing Node Parameters
with User Controls

The user interface for each node in Fusion is designed to provide access to the parameters in a logical
manner. Sometimes, though, you may want to add, hide, or change the controls. This is commonly
done for simple expressions and macros, but it can be done for usability and aesthetic reasons for

favorites and presets.

User custom controls can be added or edited via the Edit Control dialog. Right-click the name of a
node in the Inspector (in the header bar) and choose Edit Control from the contextual menu. A new
window will appear, titled Edit Control.

ED) Edit Control

New Control

NewControl

The Edit Control window

In the Input attributes, you can select an existing control or create a new one, name it, define the type,
and assign it to a tab. In the Type attributes, you define the input controls, the defaults and ranges,
and whether it has an onscreen preview control. The Input Ctrl attributes box contains settings
specific to the selected node control, and the View Ctrl attributes box contains settings for the preview
control, if any.

All changes made using UserControls are stored in the node instance itself, so they can be copy/
pasted, saved to a setting, added to the Bins, or added to your favorites.
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In the following example, let's suppose we wanted to create a more intuitive way of controlling a linear
blur than using the Length and Angle sliders independently.

Linear Radial Centered

Center X 05

Length

Domain

Default Directional Blur controls in the Inspector

We could use the Center input control, along with its preview control, to set an angle and distance
from directly within the viewer using expressions.

Right-click the label for the Length parameter, choose Expression from the contextual menu, and
then paste the following expression into the Expression field that appears:

-sgrt(((Center.X-.5)*(Input.XScale))"2+((Center.Y-.5)*(Input.YScale)*(Input.
Height/Input. Width))"2)

Next, right-click the label for the Angle parameter, choose Expression from the contextual menu,
and then paste the following expression into the Expression field that appears:

atan2(Center.Y-.5)/(Input.OriginalwWidth/Input.X , .5-Center.X) * 180 / pi

Linear Radial Centered
Center

Length

Directional Blur controlled by the Center’s position
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This functions fine, but the controls are confusing. The Center control doesn’t work as the center
anymore, and it should be named “Blur Vector” instead. The controls for the Length and Angle aren't
meant to be edited, so they should be hidden away, and we're only doing a linear blur, so we don't
need the buttons for Radial or Zoom. We just need to choose between Linear and Centered.

Adding Another Control

For the first task, let's rename the Center. From the Add Control window, select Center from the ID
list. A dialog will appear asking if you would like to Replace, Hide, or Change ID. We'll choose Replace.
Now we are editing the Center input. We'll change the Name to Blur Vector, set the Type to Point,
and the Page to Controls, which is the first tab where the controls are normally. Press OK, and our
new input will appear on our node in the Node Editor. The ID of the control is still Center, so our
SimpleExpressions did not change.

To hide the Length and Angle, we'll run the UserControls script again. This time when we select the
Length and Angle IDs, we'll choose Hide in the dialog. Press OK for each.

Finally, to change the options available in the Type, we have two options. We can hide the buttons and
use a checkbox instead, or we can change the MultiButton from four entries to two. Let's try both.

To add the checkbox, run UserControls again, but this time instead of selecting an existing ID, we'll
type Centered into the Name. This will set the name and the ID of our input to Centered. The Type
is set to Number, and the Page is set to Controls. Now in the Type Attributes, set the Input Ctrl to
be CheckboxControl. Press OK, and now we have our checkbox. To make the new control affect the
Type, add a SimpleExpression to the Type:

iif(Centered==1, 2, 0).

Once that's done, we can use the UserControls to hide the Type control.

To make a new MultiButton, run the UserControl script, and add a new control ID, TypeNew. You
can set the Name to be Type, as the Names do not need to be unique, just the IDs. Set the Type to
Number, the Page to Controls, and the Input Ctrl to MultiButtonControl. In the Input Ctrl attributes,
we can enter the names of our buttons. Let's do Linear and Centered. Type them in and hit Add for
each. Press OK, and we have our new buttons with the unneeded options removed. To make this
new control affect the original Type, add a SimpleExpression to the Type:

iif(TypeNew==0, 0, 2).

Once that's done, we can use the UserControls to hide the original Type control.

Domain

Linear Centered

Directional Blurs with UserControls applied
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Animating in Fusion’s
Keyframes Editor

This chapter covers how you can keyframe effects in Fusion’s

Inspector and how you can edit clips, effects, and keyframes in the

Keyframes Editor.
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Keyframing in the Inspector

Most parameters in most effects nodes can be keyframed in order to create animated effects such as
animated transforms, rotoscoping with splines, dynamically altering warping behaviors, and more; the
listis endless.

For convenience, a set of keyframing controls is available within the Inspector next to each
keyframable parameter. These controls are:

— A gray Keyframe button to the right each keyframable parameter. Clicking this gray button creates
a keyframe at the current position of the playhead, and turns the button orange.

— Whenever the playhead is sitting right on top of a keyframe, this button turns orange. Clicking an
orange Keyframe button deletes the keyframe at that frame and turns the button gray again.

— Small navigation arrows appear to the right and left if there are more keyframes in those
directions. Clicking on navigation arrows to the right and left of keyframes jumps the playhead to

those keyframes.

Amplitude

0.0

10.0

1.602188

Orange Keyframe buttons in the Inspector
show there’s a keyframe at that frame

Once you've keyframed one or more parameters, if Show Modes/Options has been enabled, the
node containing the parameters you keyframed displays a Keyframe badge to show that node has
been animated.

A keyframed node displays a
Keyframe badge in the Node Editor

Once you've started keyframing node parameters, you can edit their timing in the Keyframes Editor

and/or Spline Editor.

To remove a keyframed spline from a parameter:
Right-click the keyframe control of the parameter you want to remove animation from.

Choose Remove [Name of parameter] from the contextual menu.
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Multiple parameters can be connected to the same animation curve. This can be an invaluable
timesaver if you are identically animating different parameters in a node.

To connect a second parameter to the same animation curve:
Right-click on the second parameter you want to attach.
In the contextual menu, hover over the Connect To submenu.

In the Connect To submenu, choose the name of the animated parameter.

Keyframes Editor Overview

The Keyframes Editor is essentially a timeline view of your composition, within which each clip

and effect node in your composition is represented by a track. These tracks have the same color
coding as the nodes they represent and are labeled where appropriate. A Time Ruler at the top
indicates the timing of your composition, while numerous controls let you control the contents of the
Keyframes Editor.

The Keyframes Editor can be used for one of two things:

— To adjust the timing of elements in a project, whether they're clips or effects. You can trim, slide,
and extend clips, adjust the timing of an animation spline, or trim the duration of an effects node.
You can freely rearrange the order of nodes in the Timeline without affecting the layering order of
your composition. All compositing operations are handled in the Node Editor, while the Keyframes
Editor manages the timing of your composition.

— To create and/or edit keyframes that you've applied to effects in a track-based manner, you can
retime keyframes, add and delete keyframes, and even edit keyframe values

| MOVEMENT!

Medialn1

The Keyframes Editor

To show the Keyframes Editor, do one of the following:

— Click the Keyframes Editor button in the UI toolbar to toggle visibility of the Keyframes Editor
on and off.

— Press F7 on the keyboard.
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While each clip and effect node in your composition is represented by a track, keyframed parameters
are exposed either as keyframes superimposed upon the track to which they're applied (as seen on
the MOVEMENT track), or they can be opened up onto their own tracks for more precise editing, one
keyframe track per keyframed parameter, by clicking a disclosure control to the left of that track’s

name in the Timeline header (as seen under the “Drip1” track).

MOVEMENT

The Timeline tracks

The Timeline header area on the left side of the Timeline is a hierarchical list of all tracks in a
composition. Each track displays the name of its corresponding node, a lock button, and a disclosure
control for revealing keyframe tracks for each keyframe animation, modifier, and mask that's
attached to it.

Collapse/Open All

A quick way to open or close all available keyframe tracks at
once is to use the Expand/Collapse Tool Controls commands
in the Keyframe Timeline Option menu.

The Timeline header area

As elsewhere in Fusion, the playhead is a red vertical bar that runs through the Timeline view to
indicate the position of the current frame or time. The Keyframes Editor playhead is locked to the
viewer playhead, so the image you're viewing is in sync.

You must click on the playhead directly to drag it, even within the Timeline ruler (clicking and
dragging anywhere else in the Timeline ruler scales the Timeline). Additionally, you can jump the
playhead to a new location by holding down the Command-Option keys and clicking in the track area
(not the Timeline ruler).

The playhead about to be
dragged by the pointer
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If you turn on the Spreadsheet and then click on the name of a layer in the keyframe track, the
numeric time position and value (or values if it's a multi-dimensional parameter) of each keyframe
appear as entries in the cells of the Spreadsheet. Each column represents one keyframe, while each
row represents a single aspect of each keyframe.

Center : Path1 : Displacement

Editing keyframes in the Spreadsheet

For example, if you're animating a blur, then the Key Frame row shows the frame each keyframe is
positioned at, and the Blur1BlurSize row shows the blur size at each keyframe. If you change the Key

Frame value of any keyframe, you'll move that keyframe to a new frame of the Timeline.

Scaling and Panning the Timeline

At the top, a series of zoom and framing controls let you adjust the work area containing the layers.

The Keyframe Editor framing controls

A Horizontal zoom control lets you scale the size of the editor.

A Zoom to Fit button fits the width of all tracks to the current
width of the Keyframes Editor.

A Zoom to Rect tool lets you draw a rectangle to define an area
of the Keyframes Editor to zoom into.

A Sort pop-up menu lets you sort or filter the tracks in
various ways.

An Option menu provides access to many other ways of filtering
tracks and controlling visible options.
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Working with Segments
in the Timeline

Most of the work in the Timeline involves trimming and aligning clip segments.

To select a single segment in the Timeline, do one of the following:
— Click the node’s name in the header.

— Click the node’s segment in the Timeline.

To add another segment to the selection, do one of the following:

— Hold Command and click additional segments to select discontiguous selections.

— Select a segment, and then hold Shift and click another segment to make a contiguous selection of
all segments in between.

To remove a segment from the selection, do the following:

— Hold Command and click a selected segment to deselect it.

TIP: Selecting a node’s name from the Timeline header also selects the node’s tile in the
Node Editor, with its controls displayed in the Inspector.

To move the position of a segment, drag on the node’s segment in the Keyframes Editor. The cursor
will resemble a bar with two arrows pointing in either direction. Moving a segment changes where
that clip begins and ends in the composition.

Medialn2  +>

The Move cursor

Trimming segments has different effects on Loaders, Medialn and Effect nodes:

— Trimming a Loader or Medialn node is similar to trimming clips in an editing application, in
that you're changing the in and out points of the range of media that clip makes available to

your composition.

— Trimming the segments of effect nodes instead modifies the range of that node’s effect in the
composition. Outside of the trimmed region, that effect node will behave as if it were disabled.
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TIP: Shortening the duration of effects nodes can optimize processing. Imagine a Loader
or Medialn node that represents a clip that’s 100 frames long and is connected to a Defocus
node that's animated from frames 80-100. There is little to no point in processing the
defocus node between frames 0-79, so trimming the defocus segment to start at frame 80
in the Timeline will effectively prevent it from rendering and consuming either memory or
processor time until needed.

To trim a segment in the Timeline, do the following:
— Drag on either end of the node’s segment in the Timeline.

The cursor changes to a vertical bar with a single arrow when the cursor is in the right
location to trim.

The Trim cursor

If you want to hold a Loader’s first or last frame of a clip for a certain number of frames, also called a
freeze frame, you can hold Command while you drag beyond the first or last of the segment in
the Timeline.

Working with Keyframes
in the Timeline

Keyframes can be drawn in one of two ways. When keyframe tracks are closed, they're drawn

over the node’s segment. Clicking on the disclosure icon to the left of the node’s name in the track
header expands the display so each keyframed parameter has its own track in the Timeline, enabling
precise editing.

Furthermore, each keyframe track, whether open or closed, exposes a miniature curve overlay
that provides a visual representation of the rise and fall of keyframed values. This little overlay isn't
directly editable.

[ MovEMENT!

The Drip1 segment has its keyframe tracks exposed, while the Text1 segment has
its keyframe tracks collapsed so they're displayed within the segment.
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Here are pointer-based keyframe editing methods that will get you started.

Methods of selecting keyframes:

— Click a single keyframe to select it.

— Drag a bounding box over a series of keyframes to select them all.
— Command-click to select discontiguous keyframes.

— Shift-click the first and last of a range of keyframes to select a contiguous range.

Methods of adjusting keyframes:
— You can drag keyframes left and right to reposition them in time.

— You can right-click one or more selected keyframes and use contextual menu commands to change
keyframe interpolation, copy/paste keyframes, or even create new keyframes.

A drop-down and editing field at the bottom right of the Keyframes Editor lets you numerically edit
the timing, in frames, of any selected keyframe, making it easy to make precise adjustments.

To change the position of a keyframe using the toolbar, do one of the following:
— Select a keyframe, and then enter a new frame number in the Time Edit box.

— Choose T Offset from the Time Editor drop-down, select one or more keyframes, and
enter a frame offset.

— Choose T Scale from the Time Editor drop-down, select one or more keyframes,
and enter a frame offset.

Toffset [JEIN TScale ol

The Time button can switch to Time Offset
or Time Scale for moving keyframes.

If you turn on the Spreadsheet and then click on the name of a layer in the keyframe track, the
numeric time position and value (or values if it's a multi-dimensional parameter) of each keyframe
appear as entries in the cells of the Spreadsheet. Each column represents one keyframe, while each
row represents a single aspect of each keyframe.

MOVEMENT

CharacterSpacing N
s

Editing keyframes in the Spreadsheet

Animating in Fusion’s Keyframes Editor

261




For example, if you're animating a blur, then the Key Frame row shows the frame each keyframe is
positioned at, and the Blur1BlurSize row shows the blur size at each keyframe. If you change the Key

Frame value of any keyframe, you'll move that keyframe to a new frame of the Timeline.

Keyframes can be duplicated, either onto the same keyframe track or onto different tracks. This can
save you time if you need to repeat a keyframe sequence at another time on the same segment, or
even just create identically-timed keyframes on two different segments.

To duplicate keyframes, do the following:
Select one or more keyframes you want to duplicate.

Hold Command and drag one of the selected keyframes to a new position.

If you select a range of keyframes in a keyframe track, you can turn on the Time Stretch tool in the
lower left of the Keyframes Editor, to show a box you can use to squeeze and stretch the entire range
of keyframes relative to one another, to change the overall timing of a sequence of keyframes without
losing the relative timing from one keyframe to the next. Alternatively, you can turn on Time Stretch
and draw a bounding box around the keyframes you want to adjust to create a time-stretching
boundary that way. Click the Time Stretch tool again to turn it off.

Merge2

Center : Path1 : Displacement

Time stretching keyframes

When a node and its accompanying segment have animated parameters, keyframes appear as
colored tick marks in keyframe tracks to indicate when animated changes occur. If the tracks and
splines are open on a parameter, choosing Show Values from the Keyframes Editor Option menu
shows editable fields beneath each keyframe. These fields show each keyframe’s current value and

allow you to edit them simply by entering a new number.

Show values from the Keyframes Editor Option menu
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Timeline Filters

When a composition grows to include hundreds of nodes, locating specific node layers can quickly
become difficult. Timeline filters can be created and applied to sift out nodes that are not necessary to
the current operation. The Global Timeline preferences include a number of pre-made filters that you

can enable, or you can create new ones as needed.

To use a Timeline filter:

Open the Keyframes Editor Option menu and choose an item from the top of the menu. Default
Timeline filters include;

— Show All, which shows all node layers in the current composition.
— Show None, which hides all layers.
— Show Tools at Current Time, which only displays node layers under the playhead.

— If you've created custom filters, they appear here as well, in alphabetical order.

To go back to showing everything:

— Choose Show All from the Keyframes Editor Option menu. All layers will reappear.

+ Show All

Choosing a Timeline filter

To create a Timeline filter:

Choose Create/Edit Filters from the Keyframes Editor Option menu to open the Timeline panel of

the Fusion Settings window. This is where you can create new Timeline filters.

‘@@ Fusion Settings

Show All (Read Only)

Timeline

The Global Timeline preferences for enabling filters
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Click the New button, enter a name for your new filter setting, and click OK. The filter you created is
now selected in the Filter pop-up menu at the top.

Use the “Settings for filters” list to turn on the checkboxes of nodes you want to be seen and turn
off the checkboxes of nodes you want to filter out. Each category of node can be turned on and
off, or you can open up a category’s disclosure control to turn individual nodes on and off. Clicking
Invert All immediately turns off all node categories.

When you're finished creating filters, click the Save button to hide the Fusion Settings window.

Filters that you've created in the Timeline panel of the Fusion Settings window appear in the
Keyframes Editor Option menu.

To delete a filter:
Choose Create/Edit Filters from the Keyframes Editor Option menu to open the Timeline panel of
the Fusion Settings window. This is where you can delete Timeline filters.
Choose the filter you want to delete from the Filter pop-up menu.

Click the Delete button, and when a dialog asks if you really want to do that, click OK.

Choosing “Show only selected tools” from the Keyframes Editor Option menu filters out all segments
except for layers corresponding to selected nodes. This option can be turned on or off.

TIP: When “Show only selected tools” is enabled, you can continue to select nodes in the
Node Editor to update what's displayed in the Keyframes Editor.

Sorting in the Timeline

You can change the order in which the nodes are displayed from top to bottom in the Timeline.

— You can use the Tree Item Order Selection menu to sort the tracks by an assigned number.

— You can use the Sort pop-up menu.

Right-clicking over any track on the Keyframes Editor will display a contextual menu that contains the
Tree Item Order Selection submenu. Choosing Start from the submenu allows you to start numbering
each item in the track header by clicking on them. The first item you click will be #1, the second item
#2, the third #3, and so on. Once you have selected all the items in the order you want them to be
organized in the Keyframes Editor, right-click over a track, and from the Tree Item Order Selection
submenu, choose End. The items will be ordered using the assigned numbers, with #1 appearing
above #2, which appears above #3, and so on. The first items in the Keyframe track list will always

be the nodes that are the root of the node tree. The numbered nodes will appear in order after

the root nodes. For example, if the node tree starts with a background node, and then connects
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to a Fast Noise, Blur, and Color Corrector, the background node will always appear at the top of the
Keyframes Editor track list because it is the root node.

o|ele]|o

I Tree Item Order Selection
-
W

(=]

The Keyframes Editor Tree Item Order Selection menu

If you begin numbering nodes in the track header and change your mind or decide on a different
order, you can choose Restart to begin numbering again or choose Cancel to keep the current order.

The Sort menu reorders how the layers of each node appear in the Keyframes Editor. Setting the
menu back to All Tools will display them in a linear order, scanning the Node Editor from left to right
and top to bottom. This is the default setting.

The Timeline Sort Order menu

— All Tools: Forces all tools currently in the Node Editor to be displayed in the Keyframes Editor.

— Hierarchy: Sorts with the most background layers at the top of the header, through to the most
foreground layers at the bottom, following the connections of the nodes in the Node Editor.

— Reverse: The opposite of Hierarchy, working backward from the last node in the Node Editor
toward the most background source node.

— Names: Sorts by the alphabetical order of the nodes, starting at the top with the beginning
of the alphabet.

— Start: Orders layers based on their starting point in the composition. Nodes that start earlier
in the Global project time are listed at the top of the header, while nodes that start later are
at the bottom.

— Animated: Restricts the Timeline to showing animated layers only. This is an excellent mode to use
when adjusting the timing of animations on several nodes at once.
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Markers

Markers help identify important frames in a project that might affect how you keyframe animation.
They may indicate the frame where a dragon breathes fire at a protagonist, the moment that
someone passes through a portal, or any other important frame in a composition that you need to
keep track of. Markers added to the Timeline in the Cut, Edit, Fairlight, or Color page will appear in the
Keyframes Editor and Spline Editor of the Fusion page. They can also be added from the Keyframes
Editor or the Spline Editor while working in Fusion Studio or the Fusion page. Markers in Fusion appear
as a small handle with a line extending vertically through the graph view when selected.

A marker being moved in
the Keyframed Editor

To create a marker, do the following:

— Right-click at a frame in the Timeline Ruler of the Keyframes Editor and choose Add Marker from
the contextual menu.

The most important attribute of a marker is its position. For it to add value, a marker must be placed
on the frame you intended it to be on. Hovering the cursor over a marker displays a tooltip with its
current frame position. If it is on the wrong frame, you can drag it along the Time Ruler to reposition it.

Markers added to the Time Ruler are editable in the Fusion page, and the changes appear back in the
other DaVinci Resolve pages. Time Ruler markers can be added, moved, deleted, renamed, and given
descriptive notes from within Fusion’'s Keyframes or Spline Editor.

NOTE: Markers attached to clips in the Edit page Timeline are visible on Medialn nodes in
Fusion’s Keyframes Editor but not editable. They are not visible in the Spline Editor.

Double-clicking a marker jumps the playhead to that marker’s position.

By default, a marker uses the frame number in its name, but you can give it a more descriptive name
to go along with the frame number, making it easier to identify. To rename a marker in Fusion, right-
click over the marker and choose Rename Guide from the contextual menu. Enter a name in the dialog
and click OK.
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The Marker contextual menu is
accessed by right-clicking over a marker
or Keyframe Editor Time Ruler.

Markers can be used to jump to specific locations in a composition using the Marker List. If you right-
click over a marker or within the Keyframe Editor Time Ruler to bring up the contextual menu, you
can choose Show Marker List, or press Shift-G, to display the Marker List dialog. The Marker Listis a
floating dialog that will remain on top of the main window until closed.

The Marker List shows all the current markers in the composition, listed according to their position in
time along with any custom name you've given them. If you double-click a marker’s name from the list,

the playhead jumps to the marker’s location.

@] [ ] Markers

The Marker List dialog allows you to navigate
through a composition using markers.

There is a pair of checkboxes beside the names of each marker. One is for the Spline Editor, and one
is for the Keyframes Editor. By default, markers are shown in both the Spline Editor and Keyframes
Editor, but you can deselect the appropriate checkbox to hide the markers in that view.

You can delete a marker by dragging it up beyond the Time Ruler and releasing the mouse. You can

also use the marker’s contextual menu to choose Delete Marker.
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Autosnap

To help with precisely positioning keyframes and the start and end of segments as you drag in the
Timeline, you can have them snap to a field, a frame, or to markers. The Autosnap option is accessed
through the Options section in the Keyframes Editor’s contextual menu. There are two submenu
options for autosnapping. One option controls the snapping behavior when you drag keyframes,
control points, or the starting and ending edges of segments. The other option controls the snapping
behavior of markers.

When you drag keyframes or the edges of segments, often you want them to fall on a specific frame.
Autosnap restricts the placement of keyframes and segment edges to frame boundaries by default,
but you have other options found in the contextual menu. To configure autosnapping on keyframes
and segment edges, right-click anywhere within the Keyframes Editor and choose Options > Autosnap
Points from the contextual menu. This will display the Autosnap Points submenu with options for the
snapping behavior. The options are:

— None: None allows free positioning of keyframes and segment edges with subframe accuracy.
— Frame: Frame forces keyframes and segment edges to snap to the nearest frame.

— Field: Field forces keyframes and segment edges to snap to the nearest field,
which is 0.5 of a frame.

— Guides: When enabled, the keyframes and segment edges snap to markers.

When you click to create a new marker, the default behavior is that it will snap to the closest frame.
If you reposition the marker, it also snaps to the nearest frame as you drag. This behavior can be
changed in the Keyframes Editor's contextual menu by choosing from the Options > Autosnap
Markers submenu. The options are:

— None: Markers can be placed anywhere with subframe accuracy.
— Frame: Frame forces all markers to snap to the nearest frame.

— Field: Field forces all markers to snap to the nearest field.

The Spreadsheet Editor

The Spreadsheet Editor is a separate panel that can be displayed beneath the Keyframes Editor.
It is used to compactly show the numeric values of the keyframes for selected parameters in the
Keyframes Editor's header, via a table with rows and columns, showing time and value.

To reveal the Spreadsheet Editor, click on the Spreadsheet button in the toolbar. The Spreadsheet will
split the Work Area panel and appear below the Keyframes Editor’s interface.
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The Spreadsheet Editor showing editable data for six keyframes

To display a node's timing in the Spreadsheet, select the node’s name in the Keyframes Editor header.
The Start and End points of the selected node will appear in the keyframe’s line of the Spreadsheet.

To edit an animation parameter in the Spreadsheet Editor, select the parameter in the Keyframes
Editor header. The keyframe row includes a box for each frame number that contains a keyframe.

The value of the keyframe is displayed in the cell below the frame number. Clicking on a cell allows you
to change the frame number the keyframe is on or the parameter’s value for that keyframe.

Clicking on the parameter’s keyframe
value allows you to change it

TIP: Entering a frame number using a decimal point (e.g., 10.25 or 15.75) allows you to set
keyframes on a subframe level to create more natural animations.

You can also add new keyframes to an animation by clicking in an empty keyframe cell and entering
the desired time for the new keyframe. Using the cell under the new keyframe, you can enter a value
for the parameter.

Multiple splines and nodes can be edited together in the Spreadsheet. By default, selecting a new
parameter in the Timeline header will replace the parameter and keyframes currently listed in the
Spreadsheet Editor. Holding down Command, you can click on additional parameters on different
nodes to add them to the Spreadsheet.
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Customizing the Keyframes Editor

There are a few ways you can change the appearance of the Keyframes Editor to better fit your needs.
All these options are found by right-clicking anywhere within the Keyframes Editor and choosing an
option from the contextual menu that appears.

The Line Size option controls the height of each Timeline segment individually. It is often useful to
increase the height of a Timeline bar, especially when editing or manipulating complex splines.

Methods of increasing or decreasing the height of segments:

— To change the hight of just one segment: Right-click anywhere within the Keyframes Editor
and choose a size from the Line Size submenu. The options are Minimum, Small, Medium,
Large, and Huge.

— To change the height of all segments: Right-click anywhere within the Keyframes Editor
and choose a size from the All Line Size submenu. The options are Minimum, Small, Medium,
Large, and Huge.

A more traditional view of keyframes is to view them as control points instead of vertical bars, making
them easier to select for some people. From the Timeline contextual menu, you can right-click
anywhere within the Keyframes Editor and choose Options > Display Point Values to change how
keyframes look.

Options

The Options submenu for changing Display Point Values

Here are the two options, compared.

Keyframes displayed as bars (left), and keyframes displayed as Point Values (right).
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Displaying Audio Waveforms

You can display a Medialn node’s audio waveform in the Keyframes Editor and use it as a guide as you
add and move keyframes.

Keyframes

S . Mediaint ) 410_BackgroundPlanet_0000._S000.mov 2001

Waveforms are displayed in the Keyframes Editor for all Medialn nodes

To display the audio waveform in the Keyframes Editor:
Open the Keyframes Editor.

Click the disclosure arrow next to the Medialn node to view the audio waveform for that clip.

To change the size of an audio waveform display:
Open the Keyframes Editor.
In the Keyframes Editor, select the audio track of the waveform you want to modify.
Right-click over the audio waveform and choose Line Size > Minimum/Small/Medium/Large/Huge.

When using Fusion Studio, you can view the audio waveforms in the Keyframes Editor by displaying

the Saver node.

To view the Audio Waveform in Fusion Studio, do the following:
Open the Keyframes Editor.
Expand the Saver track to view the audio waveform.

When you want to find the precise location of an audio beat, transient, or cue, you can slowly drag
over the audio waveform to hear the audio. If you need to see more resolution in the waveform
display, you can increase the size.

To change the size of an audio waveform display:
Open the Keyframes Editor.

Right-click over the audio waveform and choose Line Size > Minimum/Small/Medium/Large/Huge.

TIP: Right-clicking a track in the Keyframes Editor and choosing All Line Size > Minimum/
Small/Medium/Large/Huge changes all the tracks and audio waveforms in the
Keyframes Editor.
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Animating in Fusion’s
Spline Editor

This chapter covers how you can keyframe effects and control

animations in Fusion’s Spline Editor.
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Spline Editor Overview

The Spline Editor is the main area where animation is manipulated and refined. You primarily use
the Spline Editor to show the changing values of parameters over time in the form of splines.
Whereas Keyframes explicitly set the value of a parameter on a given frame, Splines are lines or
curves that interpolate the values between keyframes. Once you set a keyframe on a parameter, a
spline is created and can be displayed in the Spline Editor so you can make further refinements to
the animation. However, the Spline Editor is more advanced than a standard curve editor since it
can also display functions, which may not be splines, like changing characters within a text string or
mathematical expressions that drive your animations.

Spline

The Spline Editor with three animated parameters

What Are Splines?

All animation uses splines that describe the value of a parameter at any given point in time. The Spline
Editor graph shows the time of the comp along the horizontal axis and the value of the parameter
along the vertical axis.

The advantage of using splines to represent animation instead of keyframes as in the Keyframes
Editor is that splines allow you to manipulate the interpolation between keyframes. For example, if a
keyframe is set at a value of 1.0 on a parameter for frame 1, followed by a keyframe value of 10.0 for
frame 10, the values between keyframes are smoothly interpolated or calculated based on the shape
of the spline. Using the functions and controls in the Spline Editor, you have a fantastic amount of
control over that interpolation.

Spline Editor Interface

The Spline Editor is not visible by default, but you can show it at any time by clicking the Spline
button in the user interface toolbar. You can also display the Spline Editor by right-clicking on a
node in the Node Editor or a segment in the Keyframes Editor and choosing Edit Splines from the
drop-down menu.
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The Spline Editor can be open alongside the Node Editor or Keyframes Editor, or displayed separately
in order to take up the entire work area.

The Spline Editor has three main working areas: the graph, header, and toolbar. On the left side of the
Spline Editor is the header, which shows a list of animated parameters. The majority of the panel is
taken up by the splines displayed in the graph area, and a toolbar runs along the bottom, providing a
variety of ways to manipulate the splines.

Graph

The graph is the largest area of the interface. It is here that you see and edit the animation splines.
There are two axes in the graph. The horizontal axis represents time, and the vertical axis represents
the spline’s value. A thin bar, called the playhead, runs vertically through the graph to represent the
current time as it does in the Timeline Editor. You can drag the playhead to change the current time,
updating the frame displayed in the viewers.

Removing a spline from a parameter removes the animation

Spline Editor Header

The header provides a mechanism for determining what splines are visible in the graph. It shows the
name of each spline in the project beneath the tool that contains that parameter. The checkbox beside
each name shows whether that spline is currently displayed in the graph and whether the spline can
be edited.
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The Spline header

Spline Editor Toolbar

The toolbar across the bottom of the Spline Editor represents the most common operations applied
to an animation spline. The various operations represented in the toolbar are all accessible from the
graph'’s context menu as well, but the following buttons provide a faster shortcut.

Spline toolbar buttons

Playhead

The playhead is the thin red vertical bar that runs vertically through the Spline Editor graph and
represents the current time of the comp. You can drag the playhead to change the current time.

Status Bar

The status bar in the lower-right corner of the Fusion window regularly displays information about the
position of the pointer, along with the time and value axes.

Contextual Menus

There are two contextual menus accessible from the Spline Editor. The Spline contextual menu is
displayed by right-clicking over the graph, while the Guide contextual menu is displayed by right-
clicking on the Time Ruler above the graph.

Right-click on the horizontal axis
Time Ruler for the Guide menu
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The name of a spline in the header is based on the parameter it animates. You can change the name
of a spline by right-clicking on it in the header and choosing Rename Spline from the contextual menu.

Each spline in the graph is assigned a different color, making individual splines easier to identify when
multiple splines are visible at once. When the spline is active, a round color swatch is displayed next to
the spline’s name in the header.

To change the color of a spline:
Click on the color circle next to the spline name in the header.

Or right-click on the name of the spline in the header and choose Change Color from the
contextual menu.

Select the new color from the dialog box that appears and click OK.

It is often necessary to magnify and pan around the graph area to ensure that the splines you want

to work on are visible. In general, scaling and panning the Spline Editor works the same as in all
navigable parts of the Fusion interface. However, there are several unique functions to the Spline
Editor for controlling your view based on the height, width, and selection of multiple animation splines.

The most obvious navigation methods to use are the scale sliders and buttons located in the upper

left of the Spline Editor panel.

The Zoom Height and Zoom Width sliders, Fit button, and Zoom to
Rectangle button can be used to navigate around the graph

To scale and pan using the sliders and buttons:

Zoom Height and Zoom Width sliders let you change the height
and width of the graph area.

The Fit button attempts to rescale the view so that all currently
active splines fit within the graph.

The Zoom to Rectangle button (Command-R) allows you to draw
a bounding box around the area of the graph you want centered

and scaled.
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To scale using the axis labels:

— Place the mouse pointer over the rulers for the horizontal or vertical axis and drag to resize

the graph on that axis only. The view is scaled centered on the original position of the

pointer on the ruler.

Dragging in the Time Ruler
scales the graph horizontally

To scale and pan with the mouse and/or keyboard:

— With the Spline Editor active, press the + and - keys on your keyboard to zoom in and
out of the graph.

— You can also zoom to a specific control point by holding down the Command key and scrolling the
middle mouse wheel. The mouse pointer location determines the area that gets magnified.

— Position the mouse pointer over the graph, and then hold down the middle mouse button. With the
middle mouse button pressed down, click once on the left mouse button to zoom in and once on
the right button to zoom out.

To pan the graph area:

— Drag left or right using the middle mouse button or use the scroll bar along the bottom and right
side of the graph.

Using the Graph contextual menu for navigation:

There are several ways to navigate the graph area using the Spline Editor contextual menu as well.

— Choose Scale > Scale to Fit (Command-F) to fit all active splines into the graph area.

— Choose Scale > Scale to Rectangle (Command-R) to draw a bounding box around the area of the graph
you want centered and scaled. This has the same effect as clicking the Zoom to Rectangle button.

— Choose Scale > Default to reset the scaling of the graph area to default values.

— Choose Scale > Zoom In/Zoom Out to scale the graph area. This performs the same functions as
pressing the + and - keys on the keyboard.

— Choose Scale > Auto Fit to scale the graph to fit all splines dynamically as you make splines visible
and hidden. If the scaling is changed with Auto-Fit enabled, the graph area will scroll as you play
the comp to view all the keyframes.

— Choose Scale > Auto Scroll to scroll the graph area if the splines fall outside the graph horizontally
as you play.

— Choose Scale > Manual to disable all automatic attempts at showing splines in the graph.

— Choose Options > Fit Times to automatically scale along the X-axis to fit the selected spline.

All visible splines are taken into account, not just the newly selected spline. With this option off,
activating a new spline will not change the horizontal scale.

— Choose Options > Fit Values to automatically scale along the Y-axis to fit the selected spline.

All visible splines are taken into account, not just the newly selected spline. With this option off,
activating a new spline will not change the vertical scale.
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Markers help identify important frames in a project. They may indicate a frame where a ray gun
shoots a beam in the scene, the moment that someone passes through a portal in the image, or any
other important event in the composite.

Markers added to the Timeline in the Cut, Edit, Fairlight, or Color page will appear in the Keyframes
Editor and Spline Editor of the Fusion page. They can also be added from the Keyframes Editor or the
Spline Editor while working in Fusion Studio or the Fusion page. Markers appear along the top of the
horizontal axis Spline Editor’s Time Ruler. They are displayed as small blue shapes, and when selected,
a line extends from each guide down vertically through the graph.

NOTE: Markers attached to clips in the Cut, Edit, Color, or Fairlight pages Timeline are not

visible in Fusion’s Spline Editor.

Unselected markers appear as blue shapes along the top, while selected
markers display a vertical line running through the graph

Working with Markers
Markers call attention to a particular frame within a comp. They can be named, displayed in a list, and
edited. After you add markers, you can easily jump the playhead between them, change their position,

or delete them altogether.

Markers can be added by right-
clicking in the horizontal time axis

To create a marker:

— Right-click in the horizontal axis Time Ruler and choose Add Marker.

To delete a marker, do one of the following:

— Drag the marker up outside the Spline Editor panel.

— Right-click on the marker and then choose Delete Marker from the menu.
— Select the marker and then press Delete or Backspace on the keyboard.

— From the Marker List, select a guide in the list and click the Del button.
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To move a marker to a new frame, do one of the following:

— Drag the marker handle along the time axis.

— Right-click in the marker area and choose Options > Enable Marker Grab, and then drag the
marker’s vertical line to move the guide.

To move the Playhead to a marker:

— Right-click on a marker and choose Set Current Time To [Frame number].

Using the Marker List

The Marker List is a list of all markers in the current comp. It can display the markers from either the
Keyframes Editor, the Spline Editor, or both panels simultaneously. Clicking on the frame number or
name of a guide causes the current time to change to that marker’s frame. Since the Marker Listis a
floating window, it can remain open, allowing you to quickly jump to different markers while you work
in the Spline Editor.

To show the Marker List:

— Right-click in the horizontal axis and choose Show Marker List, or press Shift-G.

@ ® Markers

The Marker List above shows markers in the current comp.

If markers currently exist in the comp, they are automatically displayed in the Marker List,
regardless of whether they were added in the Keyframes Editor or the Spline Editor or any other
page in DaVinci Resolve. You can also add markers directly from the Marker List, which can be
helpful if you have multiple markers you need to add, and you know the rough timing.

To add a guide from the Marker List:
Click the Add button in the Marker List window.
Enter a frame number in the Time field.

Press Tab or click the Close button to close the Marker List.

To name a marker, do one of the following:

— In the Marker List, double-click in the Name column, to the right of the frame number, and enter a
name for the marker.

— Right-click over a marker in the horizontal axis and choose Rename Marker. In the dialog that
opens, enter a name for the marker.
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Displaying Marker with the Timeline

The Marker List window includes checkboxes next to each marker that determines whether a marker
displays in the Spline Editor, the Keyframes Editor, both, or neither. By default, when you create
markers, they are active in both panels. To hide a marker from appearing in either panel, deselect the
appropriate checkbox.

To assist in precisely positioning keyframe control points along the horizontal (time) axis, you can
enable the Spline Editor's Autosnap function. Right-clicking over a spline and choosing Options >
Autosnap Points provides a submenu with four options.

— None: Allows free, sub-frame positioning of the keyframes.
— Frame: Keyframes snap to the nearest frame.

— Fields: Keyframes snap to the nearest field.

— Markers: Keyframes snap to the nearest marker.

Autosnapping and Markers

By default, a newly-created marker snaps to the closest frame. Moving markers with the mouse also
snaps them to the current frame. You can change this behavior by selecting Options > Autosnap
Markers > None or by selecting Options > Autosnap Markers > Field from the contextual menu.

Creating Animation Splines

Animation splines are created automatically when you keyframe a parameter in the Inspector or the
Keyframes Editor. However, you can create an animation spline without first having to add a keyframe.

To create a spline:

— Right-click on the parameter to be animated in the Inspector, and choose Animate from the
contextual menu.

[_F Animate

Choosing Animation from the menu
displays a spline in the Spline Editor

Selecting Animate from the contextual menu connects the parameter to the default spline type.
This is usually a Bézier Spline unless you change the default spline in the Defaults panel of the
Fusion Preferences.
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Deleting Animation Splines

To remove an animation spline from a parameter, right-click on the control in the Inspector and select
Remove [tool parameter’s name] from the contextual menu. Removing a spline from a parameter only
deletes the spline if no other tool in the composition is connected to the same spline at that time.

BrightnessContrast1

Remove BrightnessContrast1Gain

ty

Removing a spline from a parameter
removes the animation

A Bézier spline is the default spline unless changed in the Preferences. However, if you want to use a
spline type other than Bézier for the animation curve, you can choose the spline type from the Modify

With contextual submenu before creating any keyframes.

Three spline types in the Modify With menu
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— Bézier Spline: Bézier splines are the default curve type. Three points for each keyframe on the
spline determine the smoothness of the curve. The first point is the actual keyframe, representing
the value at a given time. The other two points represent handles that determine how smoothly
the curve for the segments leading in and out of the keyframe are drawn. Bézier is the most used

spline type because Bézier splines allow you to create combinations of curves and straight lines.

Bézier spline

— Modify with > B-Spline: B-splines use a single point to determine the smoothness of the curve.
Instead of using handles, a single control point determines the value as well as the smoothness
of the curve. Holding down the W key while dragging left or right on the control point adjusts the
tension of the curve.

B-spline

— Modify with > Cubic Spline: Cubic splines are similar to Bézier splines, in that the spline
passes through the control point. However, Cubic splines do not display handles and always
make the smoothest possible curve. In this way, they are similar to B-splines. This spline type
is almost never used.

Cubic spline
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— Modify with > Natural Cubic Spline: Natural Cubic splines are similar to Cubic splines, except that
they change in a more localized area. Changing one control point does not affect other tangents
beyond the next or previous control points.

Natural Cubic spline

Working with Keyframes and Splines

Once you animate a parameter and display the Spline Editor, you can manipulate the spline’s
keyframes (and thus the animation) in a variety of ways. By selecting Keyframe control points, you can
move, copy, and change the interpolation of your animation.

Once you create one keyframe, additional keyframes are automatically added to a spline whenever
you move the playhead and change the value of that spline’s parameter. For example, if you change
the strength of an animated glow at frame 15, a keyframe with the new value occurs on frame 15.

In the Spline Editor, control points can also be added directly to a spline by clicking on the spline
where you want to add the new keyframe.

Adding Keyframes at the Playhead

If you want to add a new keyframe at the current playhead location, pressing Command-K on the
keyboard or right-clicking in the graph and choosing Set Key adds a keyframe under the playhead.

Adding Equal Keyframes

If you want to hold a value over several frames, right-clicking in the graph area and choosing Set
Key Equal To displays a submenu to add a new keyframe with a value equal to the next or the
previous keyframe.
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Set Key Equal To

R

To hold a value between two keyframes choose from the Set Key Equal To submenu

When animating the Center X/Y or Pivot X/Y parameters on any tool, you create a displacement spline
in the Spline Editor. The displacement spline represents the relative offset position of the animated
object along its path. Since the displacement spline is relative, keyframes use a value between 0.0 and
1.0. A displacement value of 0.0 in the Spline Editor indicates that the object is at the very beginning of
a path. Avalue of 1.0 indicates that the object is positioned at the end of the path.

The displacement spline represents the relative position along a motion path

Displacement paths are composed of locked and unlocked points. Whether a point is locked is
determined by how you added it to the polyline. Locked points on the spline have an associated point
in the viewer’s motion path; unlocked points do not have a corresponding point in the viewer's motion
path. Each has a distinct behavior, as described below.

TIP: You can convert displacement splines to X and Y coordinates by right-clicking over the
motion path in the viewer and choosing Path#: Polyline > Convert to X/Y Path.
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Locked Points

Locked points are the motion path equivalents of keyframes. They are created by moving the playhead
position and changing the parameter value. These points indicate that the animated object must be in
a specified position on a specified frame. Since these keyframes are only related to position along the

path, they can only be moved horizontally along the spline’s time axis.

The locked points appear as larger-sized lock icons in the Spline Editor. Each locked key has an
associated point on the motion path in the viewer.

Deleting a locked point changes the overall timing of the motion.

Unlocked Points

Unlocked points are created by clicking directly on the spline in the Spline Editor. These points give
additional control over the acceleration along the motion path without adjusting the path itself.
Conversely, you can add unlocked points in the viewer to control the shape of the motion path without
changing the timing.

You can change an unlocked point into a locked point, and vice versa, by selecting the point(s),

right-clicking, and choosing Lock Point from the contextual menu.

For more information on motion paths and locked keyframes, see Chapters 71 and 73 in the
DaVinci Resolve manual or Chapters 8 and 10 in the Fusion Studio manual.

The placement of keyframes greatly affects the style of the animation. Using the graph, you can select
keyframes and move them up or down to change their value or move them left and right to change
the timing. Keyframes can be copied and pasted between splines and parameters.

Methods of selecting keyframes:
— Click directly on a keyframe on the spline, or drag a bounding box around the keyframe.
— Drag a bounding box that encompasses multiple keyframes to select more than one.

— To add or remove a keyframe from the current selection, hold down the Command key while
selecting the keyframes. This will remove currently selected keyframes and add currently

unselected keyframes.

— Press Command-A or right-click in the graph area and choose Select Points > Select All from the
contextual menu to select all keyframes from the active splines.

Moving Keyframes

You can freely move keyframes with the mouse, keyboard, or the edit point controls. Keyframes can
even pass over existing points as you move them. For instance, if a keyframe exists on frame 5 and
frame 10, the keyframe at frame 5 can be repositioned to frame 15.

To move keyframes with the mouse:

— Drag the selected keyframe to its new position in the graph. If more than one keyframe is selected,
all selected keyframes will be moved simultaneously.

— Hold down the Option key before dragging the keyframe to constrain its motion to a single axis.
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To move keyframes with the keyboard:
— The Up and Down Arrow keys will adjust the value of the keyframes by a small amount.

— The current scale of the graph determines the degree of vertical movement applied to the value
with each key press. The closer the zoom in the spline, the finer the adjustment.

— Hold down the Shift key while pressing the Up or Down Arrow keys to increase the value

adjustment in larger increments.

To move keyframes using edit fields:

— The Value and Time Editors are found on the far right of the toolbar. These number fields allow
explicit values to be entered for selected keyframes. These controls are explained in more depth
later in this chapter.

To delete one or more keyframes:

— Select one or more keyframes and press the Delete or Backspace key on the keyboard. This only
removes the keyframes; it does not remove the spline, even if there are no keyframes on the
spline. To remove the spline, right-click over the parameter in the Inspector and choose Remove
[parameter name].

You can adjust the position of the keyframes in time, without worrying about manipulating splines, by
using the key markers. The horizontal time axis can show markers that indicate the position of each

keyframe. The display of these markers is enabled by right-clicking in the graph and choosing Show >
Key Markers from the contextual menu, or by clicking on the Show Key Markers button in the toolbar.

The key markers show keyframes in the horizontal axis using the same color as the splines

To precisely match animation, Keyframes can be copied to a new location on the same spline or onto
completely different splines and different tools.

There are two options in the graph’s contextual menu for copying keyframes. Choosing Copy Points
(Command-C) copies all selected points. Choosing Copy Value copies a single point identified by the
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pointer from multiple selected points. This does not deselect your selection set, and you can pick out

numbers as needed.

To copy and paste points to a new location on the same spline:
Select the desired keyframes on the spline.
Right-click over the spline and choose Copy Points from the contextual menu or press Command-C.
Click in an empty area of the graph to deselect all the copied points.

Move the playhead to the area of the spline where you want the points pasted and press

Command-V.

Or, move the pointer over the spline where you want the points pasted, and when the spline

highlights, right-click and choose Paste Points/Value.

Alternatively, you can copy and paste keyframes by dragging them with the mouse. After you select
the points, hold down the Command key and drag the points along the spline to where you want
them pasted.

To copy and paste keyframes from one spline to another:
Make one spline the active visible spline and select the desired keyframes on the spline.
Right-click over the spline and choose Copy Points from the contextual menu or press Command-C.

Set the spline to viewed or disabled using the status checkbox next to the spline’'s name in
the header.

Make the destination spline the active visible spline and select the keyframe on the spline where
the new keyframes should be pasted.

Right-click and choose Paste Points/Value or press Command-V.

You can copy a single point’s value from a group of selected points. Since this process does
not deselect the selected set, you can continue picking out values as needed without having to
reselect points.

To copy and paste a keyframe value:
Make one spline the active visible spline and select all the keyframes on the spline.
Right-click over a single point and choose Copy Value from the contextual menu.

Set the spline to viewed or disabled using the status checkbox next to the spline’s name in
the header.

Make the destination spline the active visible spline and select the keyframe on the spline where
the new keyframe should be pasted.

Right-click and choose Paste Points/Value or press Command-V.

Keyframes can also be pasted with an offset, allowing you to duplicate a spline shape but increase the
values or shift the timing using an offset to X or V.

To paste keyframes points and values with an X or Y offset:
Make one spline the active visible spline and select the desired keyframes on the spline.

Right-click over the spline and choose Copy Points from the contextual menu or press Command-C.
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Set the spline to viewed or disabled using the status checkbox next to the spline’'s name in
the header.

Make the destination spline the active visible spline and select the keyframe on the spline where
the new keyframes should be pasted.

Right-click and choose Paste with Offset. In the Offset dialog, enter the Y value, which will be added
to the values of the pasted keyframes.

TIP: You cannot copy and paste between different spline types. For instance, you cannot
copy from a Bézier spline and paste into a B-spline.

The Time and Value Editors in the lower-right corner of the Spline Editor are used to change the
position and parameter value of a keyframe by entering a number into the number field for each
button. Each field can switch between three modes that help modify the time and value of a keyframe
in three precise but distinct ways. The default mode for each field takes the explicit frame number or
parameter value at which you want the keyframe set. The other modes offset and scale the keyframe's
position or value.

Use the number fields to enter in a value or a
specific time to change the selected keyframe

Time Editor

The Time Editor is used to modify the current time of the selected keyframe. You can change the Time
mode to enter a specific frame number, an offset from the current frame, or spread the keyframes
based on the distance (scale) from the playhead. You can select one of the three modes from the Time
mode drop-down menu.

T Offset N
&

Three time editing modes
are selectable from the Time
mode drop-down menu

— Time
The number field shows the current frame number of the selected control point. Entering a
new frame number into the field moves the selected control point to the specified frame. If no

keyframes are selected or if multiple keyframes are selected, the field is empty, and you cannot
enter a time.
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— Time Offset

Selecting T Offset from the drop-down menu changes the mode of the number field to Time
Offset. In this mode, the number field offsets the selected keyframes positively or negatively in
time. An offset of either positive or negative values can be entered. For example, entering an offset
of 2 moves a selected keyframe from frame 10 to 12. If multiple keyframes were selected in the

previous example, all the keyframes would move two frames forward from their current positions.

— Time Scale

Selecting T Scale from the drop-down menu changes the mode of the number field to Time Scale.
In this mode, the selected keyframes' positions are scaled based on the position of the playhead.
For example, if a keyframe is on frame 10 and the playhead is on frame 5, entering a scale of 2
moves the keyframe 10 frames forward from the playhead'’s position, to frame 15. Keyframes on
the left side of the playhead would be scaled using negative values.

Value Editor

The Value Editor is used to modify the selected keyframe's parameter value using one of three Value
modes. You can change the Value mode to enter a specific value for a parameter, an offset from the
value, or to spread the values. The mode is chosen from the Value mode drop-down menu.

Three value editing modes
are selectable from the Value
mode drop-down menu

— Value

The number field shows the value of the currently selected keyframes. Entering a new number into
the field changes the value of the selected keyframe. If more than one keyframe is selected, the
displayed value is an average of the keyframes, but entering a new value will cause all keyframes to
adopt that value.

— Value Offset

Choosing Offset from the drop-down menu sets the Value Editor to the Offset mode. In this mode,
the value for the selected keyframes are offset positively or negatively. An offset of either positive
or negative values can be entered. For example, entering a value of -2 changes a value from 10 to
8. If multiple keyframes are selected, all the keyframes have their values modified by -2.

— Value Scale

Choosing Offset from the drop-down menu sets the Value Editor to the Scale mode. Entering a new
value causes the selected keyframes' values to be scaled or multiplied by the specified amount. For
example, entering a value of 0.5 changes a keyframe’s value from 10 to 5.
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All Bézier spline keyframes have a pair of control handles to shape the spline as it passes through the
key point. These handles are only displayed when the keyframe is selected. Initially, these handles are
set to linear, creating straight line changes between keyframes. However, any control point can be
made smooth by right-clicking over it and choosing Smooth or pressing Shift-S.

Bézier splines can mix linear and smooth curves

Dragging on a keyframe's handles adjusts the slope of the segments passing through the spline.
By default, the two control handles on a control point are locked together so that if one moves, the
one on the other side moves with it. This maintains a constant tension through the keyframe. There
are situations, however, when it is desirable to modify these control handles separately for a more

pronounced curve or effect.

To temporarily break the control handles on a Bézier spline, moving one
independently of the other:

Select the control point to be modified.
Hold down the Command key and drag one of the control handles. They will now move
independently of each other, as long as the Command key is held down.

To treat all Bézier handles as independent in the Spline Editor:

— Right-click in the graph and choose Independent Handles from the Options contextual menu.

Enabling this option causes all the Bézier handles to be independent. This is the same as using the
Command key when moving a handle, except it is applied to all control points until it is disabled.

When there are too many control points too close together on a spline, you can choose Reduce Points
to decrease their number, making it easier to modify the remaining points. The overall shape of the
spline is maintained as closely as possible while eliminating redundant points from the path.

To reduce the number of points on a spline:
Select the range of keyframes you want to thin out.
Right-click in the graph area and choose Reduce Points from the contextual menu.

When the Reduce Points dialog appears, drag the slider to a lower value.
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You can set the slider value as low as possible as long as the spline still closely resembles the shape of
your original spline.

TIP: When the value is 100, no points will be removed from the spline. Use smaller values to
eliminate more points.

Filtering the Spline Editor

The animation splines for multiple parameters can be displayed within the Spline Editor
simultaneously, and Fusion offers several ways for you to choose which spline to view and
which to edit.

A complex composition can easily contain dozens, if not hundreds, of animation curves. As a
composition grows, locating a specific spline can become more difficult. There are two ways to filter the
splines shown in the Spline Editor: display selected tools only or create a filter to show only certain tools.

The Spline Editor includes different ways to control which splines are displayed. The majority of these
options are available in the Options menu, located in the upper-right corner of the Spline Editor panel.

The Options menu is used to control which
splines are displayed in the Spline Editor

— Show Only Selected Tool: You can choose to limit the splines displayed in the Spline Editor by
showing only the splines from selected tools. Choosing this option at the top of the Options menu
displays only the splines for tools currently selected in the Node Editor.

— Show All/None: The default behavior of the Spline Editor displays all the splines for all the nodes
with animated parameters. You can override this by enabling Show Only Selected Tools in the

Options menu. You can also disable the Show All setting by choosing Show None, in which case the
Spline Editor remains empty.
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— Expose All Controls: The Expose All Controls option is a way of not filtering the parameters.
Choosing this option displays all parameters in the Spline Editor header for all nodes in the Node
Editor. It can be a fast way of activating one of the parameters and automatically adding an
animation spline for it if one does not exist.

With a large number of nodes displayed, which themselves might have a large number of
parameters, this might lead to cluttering and slowing down the interface. This option is most
effective when used in conjunction with the Show Only Selected Tool option to limit the number of
nodes and parameters displayed and yield optimum performance.

— Follow Active: The Follow Active option is located by right-clicking in the graph and choosing
Options > Follow Active. This option provides a way to filter the splines in the graph while not
filtering the header list of tools. Where the Show Only Selected Tool option hides other tools in the
header, the Follow Active option leaves the header displaying all the tools but automatically enables

only the splines of the Active tool.

Filters allow you to select the specific types and classes of tools shown in the Spline Editor and
Keyframes Editor. For example, you can make a filter that shows only particle nodes or one that only

shows color correction and brightness/contrast tools.

To create afilter:
From the Options menu, choose Create/Edit Filters.
Click the New button to create a new filter and name the new filter in the dialog box.

Enable a checkbox next to the entire category or the individual tools in each category to determine
the tools included in the filter.

Enable each tool you want to keep in the Spline Editor when the filter is selected

The Invert All and Set/Reset All buttons can apply global changes to all the checkboxes, toggling
the selected states as described.

To switch the selection state of the categories when creating a filter list:
Click the Invert All button.

After configuring the custom filter, click the Save button to close the Settings dialog and save
the filter.
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To enable all checkboxes or disable all checkboxes:

Click the Set/Reset All button as many times as needed until all categories are either checked or
unchecked.

After configuring the custom filter, click the Save button to close the Settings dialog and save
the filter.

To apply a filter to the Spline Editor:

— Choose the desired filter by name from the Options menu. The filter applies to both the Spline

Editor and the Timeline.

All Color Correction Modes

Each filter you create is listed
in the Options menu

To disable a filter and show all tools in the Spline Editor again:

— Choose Show All from the Options menu.

The Spline header is a hierarchical list of animated parameters and their parent nodes. Clicking
the disclosure arrow next to a tool’'s name reveals all the names of the animated parameters on
that tool. Clicking directly on the parameter name in the Spline header activates that spline for

display and editing.

v« BrightnessContrastl

L4
v

The Spline header with the Brightness
Contrast tool and its animated
Gain and Gamma parameters

Tool Status Checkbox

Next to the name of each spline is a checkbox that indicates the spline’s status. When you select a
parameter name, the checkbox becomes active, allowing you to see and edit the spline in the graph.
There are three selection modes for each checkbox: active, viewed, and disabled. Clicking directly
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on the checkbox will toggle it between these three states. Changing the state of the parent node
checkbox sets the state for all splines for that node.

— Active: When the checkbox is enabled with a check mark, the spline is displayed in the graph and
can be edited.

— Viewed: When the checkbox is enabled with a solid gray box, the spline is visible in the graph but
cannot be edited. It is read-only.

— Disabled: When the checkbox is clear, the spline is not visible in the graph and cannot be edited.

v
« Blur Size

Checkboxes determine which
splines are visible and editable

There are three selection options, labeled Select All Tools, Deselect All Tools, and Select One Tool,
that determine how the items in the Spline Editor header behave when a checkbox or label is selected
to activate a spline. These states are located in the Options menu in the upper-right corner of the
Spline Editor.

The Options menu selection states make it easier
to select and deselect all parameters in the header

— Select All Tools: Choosing this option activates all splines for editing.
— Deselect All Tools: Choosing this option sets all spline checkboxes to disabled.

— Select One Tool: This option is a toggle. When Select One Tool is chosen from the menu, only
one spline in the header is active and visible at a time. Clicking on any spline’s checkbox will set
it to active, and all other splines will be cleared. When disabled, multiple splines can be active
in the header.
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Selection Groups

It is possible to save the current selection state of the splines in the header, making selection groups
that can easily be reapplied when needed. To create a selection group, right-click over any parameter
in the header or in an empty area of the graph and choose Save Current Selection from the contextual
menu. A dialog will appear to name the new selection.

To reapply the selection group, choose the selection group by name from the Set Selection menu in the
same contextual menu. Other context menu options allow selection groups to be renamed or deleted.

Reshaping Splines Using the Toolbar

There are several ways to manipulate the shape of a spline, thereby altering the animation that spline
generates. Other than manually adjusting Bézier handles, you can quickly squish, stretch, loop, and
reverse a spline. You can also quickly change the interpolation between keyframes from the default
linear motion to more natural smooth motion. All these options are provided at the bottom of the
Spline Editor in the toolbar. The toolbar is divided into different groups for setting interpolation,
reversing splines, looping splines, time stretching, and reshaping splines.

Keyframes are specific frames in an animation where control points are set to exact values on a given
parameter. Interpolation is the method used to fill in the unknown values between two keyframes.
Fusion automatically interpolates between two keyframes. However, you may want to modify the
interpolation to achieve a specific style of animation. The Spline Editor includes several interpolation
methods you can choose from using the toolbar.

Interpolation buttons in the toolbar: Smooth, Linear, Invert, Step In, and Step Out

Smooth

A smoothed segment provides a gentle keyframe transition in and out of the keyframe by slightly
extending the direction handles on the curve. This slows down the animation as you pass through the
keyframe. To smooth the selected keyframe(s), press Shift-S or click the toolbar’'s Smooth button.

Smooth interpolation between keyframes
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Linear

Alinear segment effectively takes the shortest route between two control points, which is a straight
line. To make the selected keyframe(s) linear, press Shift-L or click the Linear button in the toolbar.

Linear interpolation between keyframes

TIP: Invertis used only for non-animated LUT splines, which are currently only available in
the LUT Editor window.

Step In/Step Out
On occasion, it is not desirable to have any interpolation between two keyframes. Instead, the value of
one keyframe may hold its value until another keyframe changes it. For these cases, use the Step In or

Step Out mode.

Step In causes the value of the previous keyframe to hold, then jump straight to the value of

the next keyframe.

Step In holds a value until the next
keyframe is reached in the comp

Step Out causes the value of the selected keyframe to hold right up to the next keyframe.
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Step Out switches immediately to the next keyframe value in a comp

Step In and Step Out modes can be set for selected keyframes by clicking on the toolbar buttons for
each mode, or by right-clicking and choosing the appropriate option from the contextual menu. The
keyboard shortcuts I and O can also be used to enable Step In and Step Out on selected keyframes.

Reverse inverts the horizontal direction of a segment of an animation spline. To apply reverse, choose
a group of points in a spline and click the Reverse button, or right-click and choose Reverse from the
contextual menu, or press the V key. The group of points is immediately mirrored horizontally in the
graph. Points surrounding the reversed selection may also be affected.

The Reverse button in the toolbar

It is often useful to repeat an animated section, either infinitely or for a specified number of times,
such as is required to create a strobing light or a spinning wheel. Fusion offers a variety of ways to
repeat a selected segment.

The various Loop buttons in the toolbar

Set Loop

To repeat or loop a selected spline segment, select the keyframes to be looped. Select Set Loop
from the contextual menu or click on the Set Loop button in the toolbar. The selected section of the
spline repeats forward in time until the end of the global range, or until another keyframe ends the
repeating segment.
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A looped section in the graph

Changing and Removing the Loop

You can change the looped segment by modifying any of the keyframes or control points originally
used to create the loop. Simply select one of the originating key points, make any necessary
modifications, and the looped segment updates. To remove the loop, select the keyframes you used
to create the loop, and then click the Loop button in the toolbar.

Ping-Pong
The Ping-Pong Loop mode repeats the selected segment, reverses each successive loop, and then

repeats. Ping-pong looping can be enabled on the selected segments from the context menu or
the toolbar.

A ping-pong section in the graph

Relative Loop

The Relative Loop mode repeats the segment like the Loop, but each repetition adds upon the last
point of the previous loop so that the values increase steadily over time.

Animating in Fusion’s Spline Editor

298




A Relative Loop section in the graph

Looping Backward

You can choose Set Pre-Loop by right-clicking in the graph area and choosing it from the contextual
menu. This option contains the same options for looping as the Loop option buttons in the toolbar,
except that the selected segment is repeated backward in time rather than forward.

Repeating Splines X Number of Times

You can duplicate splines and repeat them a set number of times by right-clicking in the graph area
and choosing Duplicate from the contextual menu. Duplicated splines are like looped splines, except
that the selected segment repeats only a specified number of times, and each repetition is a copy
rather than an instance. Adjustments to the original segment do not alter the shape of its repetitions.

The Duplicate modes are only accessed from the Duplicate contextual menu, which reveals a submenu
with all the looping modes described above. Selecting any of these modes opens a dialog in which the
number of repetitions can be entered.

Duplicate

The Duplicate contextual submenu
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Gradient Extrapolation

You can choose Gradient Extrapolation by right-clicking in the graph area and choosing it from the

contextual menu. This option continues the trajectory of the last two keyframes.

The Gradient Extrapolation applied to the spline

Time Stretching allows for a selected group of keyframes to be proportionally stretched or squashed.
This allows you to change the duration of the animation while keeping the relative distance between
each keyframe. To enable spline stretching, select the group of keyframes that you want to time
stretch, and then choose Modes > Time Stretching from the graph’s contextual menu or click the Time
Stretch button in the toolbar.

The Time Stretch button in the toolbar

When you have more than one keyframe selected on the spline, enabling Time Stretch surrounds the
outer keyframes with two vertical white bars. Drag on the white vertical bars to stretch or shrink the
timing of the spline segments within the bars. Drag these bars back and forth to stretch or squash the
spline segment.
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The Time Stretch bars in the graph

TIP: If no keyframes are selected when you enable Time Stretch, drag a rectangle to set the
boundaries of the Time Stretch.

To disable the Time Stretching mode:

— Click on the Time Stretch button in the toolbar again or reselect Modes > Time Stretching from the
contextual menu.

The Shape Box transform mode is similar to Time Stretching; however, it can adjust the vertical scaling
of keyframe values as well as time.

To enable the Shape Box, do one of the following:
— Select a group of keyframes, and then choose Modes > Shape Box from the contextual menu.
— Select a group of keyframes, and then click the Shape Box button in the toolbar.

— Select a group of keyframes, and then press Shift-B to enable or disable the Shape Box mode.

%

The Shape Box button in the toolbar

A white rectangle outlines the selected points when the mode is enabled. To scale, skew, or stretch the
spline, drag on any of the control points located around the box. To move all the keyframes, drag on
the box edges.
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The Shape Box in the graph

TIP: If no points are selected, or if you want to select a new group of keyframes, you can drag
out a new rectangle at any time.

For a more precise way to adjust the length of Bézier direction handles attached to selected
keyframes, you can use the Spline Ease dialog. To show the dialog, select a keyframe in the graph, and

then choose Edit > Ease In/Out from the graph’s contextual menu or press T on the keyboard.

The Ease In/Out controls appear above the graph area. You can drag over the number fields to
adjust the length of the direction handles or enter a value in the fields.

The Ease In/Out controls above the graph area

Clicking the Lock In/Out button will collapse the two sliders into one, so any adjustments apply to
both direction handles.
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Importing and Exporting Splines

Spline shapes can be imported and exported from or to an ASCII text file. This makes it easier to
save complex spline curves for later reuse, or to transfer tracking, path, and animation data from one
application to another. Exported splines are assigned the file extension .spl for easy identification.

To export a spline:

Select the active spline in the Spline Editor.
Right-click on the spline in the graph area to display the contextual menu and select Export.
Choose from three format options in the submenu.

Enter a name and location in the file browser dialog, and then click Save.

Exporting a spline gives you three options. You can export the Samples, Key Points, or All Points.
Samples adds a control point at every frame to create an accurate representation of the spline.
Key Points replicates the control point positions and values on the spline using linear interpolation.
All Points exports the spline as you see it in the Spline Editor, using the same position, value, and
interpolation.

To import a spline:
Add an animation spline for the parameter.

In the Spline Editor, right-click on the animation spline and select Import Spline from the
contextual menu.

In the File Browser dialog, select the spline curve .spl file, and then click Open.

Importing a new curve will replace any existing animation on the selected spline.
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Animating with
Motion Paths

Layers and 3D objects can move along a designated spline shape to
create motion path animations. This chapter discusses how you can

create, edit, and use motion paths in Fusion.
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Animating Using Motion Paths

Motion paths are created from splines (polylines) including paint strokes and masks that have a path
modifier applied to them. The path modifier defines the movement that transforms ordinary spline
shapes into motion paths. You apply the path modifier either explicitly to the Center X/Y or Pivot X/Y
parameters or implicitly by keyframing the Center or Pivot parameters. In either case, the spline path
is displayed and then visually adjusted in the viewers. For all motion paths, the coordinate control in

the viewer represents the position of an object or effect, such as a Transform or Rays node's center
that moves along the path. Coordinate controls are represented onscreen with vertical and horizontal
positioning arrows or an X.

A Center Offset onscreen control for an object’s Transform node

The following nodes have parameters that can be animated using path modifiers to move an image
around the composition. These include, but are not limited to:

— Transform: Center X/Y can be animated to move an image around.

— DVE: Center X/Y can be animated to move an image around.

— Merge: Center X/Y can be animated to move the Foreground connected image around.
— Paint: Stroke Controls > Center X/Y can be animated to move a stroke around.

— Camera 3D node: Translation X/Y/Z

— Shape 3D node: Translation X/Y/Z
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The following nodes have parameters that can be animated using paths to alter the direction of a
visual effect. These include, but are not limited to:

— Directional Blur: Center X/Y can be animated to change the direction of the blur.
— Hot Spot: Primary Center X/Y can be animated to move the hot spot around.
— Rays: Center X/Y can be animated to change the angle at which rays are emitted.

— Polygon/BSpline/Ellipse/Rectangle/Triangle mask: Center X/Y can be animated to
move the mask.

— Corner Positioner: Top Left/Top Right/Bottom Left/Bottom Right X/Y can be animated to move
each corner of the corner-pinned effect.

— Vortex: Center X/Y can be animated to move the center of the warping effect.

NOTE: It's not possible to add a motion path to a one-dimensional value, such as blur
strength or merge angle. However, you can use the Spline Editor to edit these kinds of values
in a visual way.

There are three types of motion paths: Polyline paths, XY paths, and 3D motion paths for 3D scenes.

— A Polyline path is generated by applying the path modifier. It uses two splines to define the path;
one for the shape of the path displayed in the viewer, and a Displacement spline for the speed of
the object along the path, displayed in the Spline Editor. The Polyline path is the default type of
path modifier, and most documentation in this chapter assumes that this type is used.

— The XY path modifier employs a spline for the X position of the point and another for the Y position.
The XY path modifier is explained in detail later in this chapter.

— 3D motion paths pertain only to positional controls within 3D scenes.

Polyline paths are the easiest motion paths to work with. You can use the spline shape in the viewer
to control the shape of the path, while a single Displacement curve in the Spline Editor is used to
control the acceleration along the path. The most obvious way to create a Polyline motion path is by
keyframing the Center X/Y parameter of a Transform node in the Inspector.

To create a Polyline motion path using the Center X/Y parameter in the Inspector:
Position the playhead on the frame where the motion will begin.
In the Inspector, click the gray Keyframe button to the right of the Center X and Y parameters.
This action applies the path modifier in the Modifiers tab in the Inspector.
Adjust the Center X and Y for the first keyframe position.
Position the playhead on the frame where the motion should change or stop.

In the Inspector, change the Center X and Y parameters to set a keyframe for the new location
automatically.
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In the viewer, modify and refine the motion path by selecting a control point and using any of the
spline controls in the viewer toolbar.

Open the Spline Editor and adjust the Displacement spline to control the speed of the object
along the path.

Keyframing Center X/Y is not the only way to apply the path modifier. An alternative method is to apply
the path modifier to the Center X/Y parameter either in the Inspector or using the coordinate control

in the viewer.

To apply a Polyline path to the Center X/Y parameter:
Position the playhead on the frame where the motion will begin.
Position the center coordinate control for the object, or effect, at its starting position.

Right-click the onscreen center coordinate control in the viewer (or over the Center Xand Y
parameter in the Inspector), and choose Path from the contextual menu for that control.
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Applying a path modifier to the center of a Transform node

The object now has a path modifier applied, so without setting a keyframe you can drag the object
to begin creating a motion path in the viewer.

Move the playhead to a new frame.

Drag the onscreen coordinate control or adjust the Offset or Center values in the Inspector. A
keyframe is automatically created on the motion path, and a polyline is drawn from the original
keyframe to the new one.
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Two keyframes spaced several frames apart display a
motion path showing the direction of animation.

The position of the center control is interpolated between the two keyframes. You can continue
adding points by moving the playhead and adjusting the object’s position until the entire motion
path you need is created. For motion paths, there’s no need to close the spline path; you can
leave it open.

Upon completion, set the polyline to Insert and Modify mode by selecting a point on the path

and pressing Command-I or clicking the Insert and Modify button on the toolbar. Don’t worry too
much about the overall shape of the motion path at this point. The shape can be refined further by
adding additional points to the polyline and modifying the existing points.

Afinal alternative method for creating a motion path is to draw a spline shape first and then connect

a path modifier to the spline. Using any of Fusion’s spline tools, you can draw the shape of the path
and then connect the path modifier to the published spline. Once the path modifier and the published
spline are connected, you can keyframe the Displace parameter to move an image along the path. This
method is useful when you want to use a paint stroke or mask shape as a motion path.

To use a mask shape or paint stroke as a path:
Draw a polygon mask or paint stroke in the shape of the path you want to use.

You do not have to close the mask shape.

An open Polyline mask shape

When done drawing the shape, click the Insert and Modify button in the viewer toolbar to leave the
mask shape as an open spline.
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At this point you can select any of the control points along the spline and press Shift-S to make
them smooth or Shift-L to make them linear.

All mask polylines have animation enabled by default, but that is usually not desirable for a motion
path. You will need to remove this keyframe animation if you are using a mask shape.

At the bottom of the Inspector, right-click on the “Right-click here for shape animation” label and
choose Remove Polygon1Polyline.

Alternate

.. Remove Polygon1Polyline
I YE! y
iy

Right-clicking at the bottom of the Inspector to
remove auto-keyframing from a mask shape

Right-click at the bottom of the Inspector again and select Publish to give other nodes access to
this spline shape. (For a paint stroke, you will need to make the Stroke editable first by clicking the
Make Editable button in the Stroke Controls.)

This enables the Modifiers tab with the Published Polyline modifier. This published spline can be
used to define the shape of splines in other nodes.

Connect a Transform node to the image you want to have follow the path.

Right-click over the Center X/Y parameter in the Inspector and choose Path.

This adds a path modifier into the Modifiers tab.

In the Inspector, click the Modifiers tab and double-click the Path1 heading to open its parameters.

The Displacement parameter already has a keyframe on it automatically. You'll want to remove that
SO you can set your own.

Click the red keyframe button to the right of the Displacement parameter to remove it.

Displacement

Remove the automatic displacement keyframe
prior to creating your own keyframes.
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At the bottom of the Modifiers tab, right-click on “Right-click here for shape animation” and choose
Connect To > Polygon1Polyline.

To quickly see where your object has gone, drag the Displacement slider back and forth.
You may want to use the Size parameter to adjust the size of the overall path.

The Displacement slider is meant to be keyframed for animating the object along the path.

In terms of functionality, it makes no difference which method you use to generate the path modifier.
All the above methods are just different ways to get to the same point. Whichever way you decide to
add the path modifier, the Modifiers tab contains controls for the path.

0.872857

0.0

Creating a path adds controls to the
Modifiers tab in the Inspector.

You can use the path modifier controls in the Inspector to change the position, size, and rotation of
the entire path shape. The Displacement parameter is represented as a spline in the Spline Editor,
which determines the object'’s position along the path and the Heading Offset is used for the
orientation along the path.

Every Polyline path has an associated Displacement spline in the Spline Editor. The Displacement
spline represents acceleration, or the position of the animated object along its path, represented as a

value between 0.0 and 1.0.
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The Displacement curve of a Poly path represents the acceleration of an object on a path.

Smaller values are closer to the beginning of a path, while larger values are increasingly closer to the
end of the path.

For instance, let's say you have a bumblebee that bobs up and down as it moves across the screen.
To have the bee accelerate as it moves up and down but slow down as it reaches its peaks and valleys
you use the Displacement curve.

A curvy path defined by a spline shape

The curved shape path does not define how fast the bee moves. The speed of the bee at any point
along the path is a function of the Displacement parameter. You can control the Displacement
parameter either in the Modifiers tab or in the Spline Editor.

To use the Displacement parameter to control the speed of an object on a path,
do the following.

Position the playhead at the start of the animation.

In the Modifiers tab, drag the Displacement parameter to 0.0. This positions the object at the start
of the path.

Click the Keyframe button to the right of the Displacement parameter.

Position the playhead somewhere further into the comp and drag the Displacement parameter
until the object is where you want it to be based on the current frame.

Continue updating the playhead and the Displacement parameters at key points in the comp until
you have reached the end of the path.
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After the initial animation is set, you can use the Displacement curve in the Spline Editor to adjust
the timing.

To adjust the timing of an object along a path:
Open the Spline Editor and enable the Displacement spline in the header.

Move control points horizontally closer together to increase the speed between the two points

while maintaining the location of the object along the path.

Alonger, flatter curve between two points indicates a slower rate of change.

Drag a control point up or down to change its location on the path while maintaining the timing
between two points.

A Displacement curve in the Spline Editor

TIP: Holding down the Option key while clicking on the spline path in the viewer will add a
new point to the spline path without adding a Displacement keyframe in the Spline Editor.
This allows you to refine the shape of the path without changing the speed along the path.

Using a Path Modifier to Adjust Orientation

The Heading parameter is used to adjust the orientation of the object along the path. For instance, if
you want the bee in our animation to auto-orient based on the direction of the path, you can connect
the bee’s angle to the Heading parameter.

To connect the Heading to an object’s angle:
Right-click over an object’s angle parameter in a Transform node.

Choose Connect To > Path > Heading.

In our example comp, the bee now auto-orients as the path descends and rises.
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The Transform’s angle parameter connected to the path modifier's Heading parameter

Unlike a Polyline path, the XY path modifier uses separate splines in the Spline Editor to calculate
position along the X-axis and along the Y-axis.

To animate a coordinate control using an XY path modifier:

— Right-click on the center coordinate control in the viewer or the Center X/ Y parameter in the
Inspector, and then choose Modify With > XY Path from the contextual menu.
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Adding the XY Path modifier to a Center parameter in the Inspector

At first glance, XY paths work like Polyline paths. To create the path once the modifier is applied,
position the playhead and drag the onscreen control where you want it. Position the playhead
again and move the onscreen control to its new position. The difference is that the control
points are only there for spatial positioning. There is no Displacement parameter for controlling
temporal positioning.
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Tools

Text1:Center <- XYPath1
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XY path modifier controls in the
Modifiers tab of the Inspector

Instead of dragging in the viewer, you can use the controls in the Modifiers tab to create a motion

path, while using the object’s original Inspector controls as an offset to this motion path. You can use
the XYZ parameters to position the object, the Center X/Y parameters to position the entire path, the
Size and Angle to scale and rotate the path, and the Heading Offset control to adjust the orientation.

Text1:Center <- XYPath1

{
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MOVEMENT!

Using an XY path modifier to animate a piece of text

Using the XY Paths in the Spline Editor

The Spline Editor for the XY path displays the X and Y channel splines. Changes to the path in the
viewer or the Inspector will be displayed as keyframes on these splines in the Spline Editor. Unlike a
Polyline path, XY paths do not include a Displacement curve. The speed of the object along the path is
tied to the path itself and cannot be separated from the timing of the keyframes that define that path.

TIP: XY path and Poly path can be converted between each other from the contextual menu.
This gives you the ability to change methods to suit your current needs without having to

redo animation.

The advantage of the XY path modifier is that you can explicitly set an XY coordinate at a specific time

for more control.
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XY Path displays X and Y curves in the Spline Editor but does not include a Displacement control.

Switching Default Paths

If you want to change the default path type to XY path, you can choose Fusion > Preferences >
Globals in Fusion Studio or Fusion > Fusion Settings in DaVinci Resolve. In the Settings window, select
the Defaults category and choose XY Path for the Point With drop-down menu. The next time you
keyframe the Center X/Y parameter or choose Animate from CenterX/Y's contextual menu, an XY path
modifier will be used instead of a Polyline path.

Types of Control Points

The control points along an XY path in the viewer are locked to the control points on the X and Y curve
in the Spline Editor. The number of points are identical, and adding a control point in one place adds
it to the other. That is not the case with a Polyline path. Polyline paths are composed of locked and
unlocked points. Whether a point is locked is determined by how it was added to the Polyline. Locked
points on the motion path in the viewer will have an associated point on the Displacement spline in
the Spline Editor; unlocked points will not have corresponding points. Each has a distinct behavior, as
described below.

Locked points are the motion path equivalents of keyframes. They are created by changing the
playhead position and moving the animated control. These points indicate that the animated control
must be in the specified position at the specified frame.

The locked points are displayed as larger-sized hollow squares in the viewer. Each locked key has an
associated point on the path’s Displacement curve in the Spline Editor.
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Locked points on a path in the viewer

Deleting a locked point from the motion path will change the overall timing of the motion.

To change the duration of a path using locked points:
Connect an object to a Transform node.

Position the where you want to start the motion path.

A graphic placed on the right side of the frame

Set the playhead at frame 0.

Select the Transform node and in the Inspector, click the Keyframe button
to the right of the Center X/Y parameter.

This adds the path modifier and creates the first locked point of the path.

Position the playhead at frame 45.
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Move the object's center to the lower center of the screen.

Moving the playhead and repositioning the bee adds a second locked point

This sets the second locked point.

View the Spline Editor and display Path1's Displacement spline.
Spline

¢« Transform1
v « Center{Path1)

+ Displacement

The path’s Displacement spline with locked keyframes

At a value of 0.0, the control will be located at the beginning of the path. When the value of the
Displacement spline is 1.0, the control is located at the end of the path.

Select the keyframe at frame 45 in the Displacement spline and drag it to frame 50.

The motion path is now 50 frames long, without making any changes to the motion path'’s shape.

If you try to change this point’s value from 1.0 to 0.75, it cannot be done because the pointis the
last in the animation, so the value must be 1.0 in the Displacement spline.
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Position the playhead on frame 100 and move the bee center to the upper-left corner of the screen.

Moving locked points changes the duration of a motion path without changing its shape

This will create an additional locked point and set a new ending for the path.

Unlocked points are created when additional points are added to the motion path while in Insert and
Modify modes. These points are used to adjust the overall shape of the motion path, without directly
affecting the timing of the motion. This means you can add whatever unlocked points you want to
reshape a motion path, without that having any effect on the timing of the animation on that path.
This makes it vastly easier to fine-tune a motion path spatially after you've perfected the timing of the
animation temporally.

Unlocked points do not have corresponding points on the path’s Displacement spline. They appear in

the viewer as smaller, solid square points.

To add unlocked points to a motion path, do the following:
Select a motion path spline by using the Tab key to cycle controls until the path is selected.
To insert points along a path, click the Insert and Modify button in the toolbar.

Click on the path and create two new points: one half-way between the first and the second points,
and the other half-way between the second and the third points.

The two points just added are not present in the motion path’s Displacement spline. These are
unlocked points, used to shape the motion but unrelated to the timing of the path.
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Unlocked points added to the motion path are not displayed on the Displacement spline

You can add unlocked points to the Displacement spline as well. Additional unlocked points in the
Spline Editor can be used to make the object’s motion pause briefly.

To pause motion along a motion path using an unlocked point:

— Select a locked point on the Displacement spline and then hold down the Command key while
dragging the point horizontally to another frame. The point is copied as an unlocked point to the

new frame.

Create a pause in the motion by copying locked points

Knowing the difference between locked and unlocked points gives you independent control over

the spatial and temporal aspects of motion paths.
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You can change an unlocked point into a locked point, and vice versa, by selecting the point(s) and
choosing the Lock Point option from the contextual menu.

Tips for Manipulating Motion Paths

There are a variety of ways you can create and edit motion paths in the viewer.

Every motion path has a defined center represented by a crosshair. Path centers allow paths to be
connected to other controls and behave in a hierarchical manner, which is an exceptionally powerful
way of creating complex motion by combining relatively simple paths.

A useful example of this technique would be animating the path of a bee in flight. A bee often flies
in a constant figure eight pattern while simultaneously moving forward. The easy way of making this
happen involves two paths working together.

In the following example, the bee would be connected to a first path in a Transform node, which
would be a figure eight of the bee moving in place. This first path’s center would then be connected to
another path defining the forward motion of the bee through the scene via a second Transform node.

To create a compound motion path:
Create a figure-eight motion path by keyframing an object or drawing a polyline mask.

(If using a polygon mask, you'll need to remove the auto-keyframing and publish the mask prior to
the next step.)

Add a polyline mask and create a smooth curve spline that travels across the screen.

At the bottom of the Inspector, right-click over the “Right-click here for shape animation” label and
choose Remove Polygon Polyline to remove the auto-animation behavior.

Right-click over the label again and choose Publish.

Select the object’s Transform node and click the Modifiers tab.
Right-click over the Path1 Center X/Y parameter and choose Path.
At the bottom of Path2, choose Connect To > Polygon: Polyline.

Keyframe the Path2 Displacement to move the object along the second path.
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Two motion paths working together

It is possible to copy an entire motion path to the clipboard and then paste it onto another node or
path or composition.

Methods of copying and pasting motion paths:

— To copy a motion path: In the Inspector’s Modifiers tab, right-click on the path’s control header
and choose Copy from the contextual menu.

— To cut a motion path out of a node: In the Inspector, right-click on the path’s control header and
choose Cut from the contextual menu.

— To paste the copied path over another path: In the Inspector, right-click on the path’s control
header and choose Paste from the contextual menu.

When pasting a path, the old motion path will be overwritten with the one from the clipboard.

There are multiple ways to remove or delete a path, and they all involve a right-click contextual
menu. Removing a path modifier does not remove the object or the spline shape; it only removes the
animation from the object and the modifier from the Modifiers tab in the Inspector.

To remove a path, do one of the following:
— In the Modifiers tab, right-click over the Path1 header and choose Delete from the menu.

— In the Inspector, right-click over the Center XY parameter and choose Remove Path
from the menu.

— Right-click the center coordinate control in the viewer for the object you're animating, and choose
Remove Path1 from the submenu of the NameOfObject; Center submenu.
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Removing an entire motion path at once

You can animate both of the control's spatial and temporal information at the same time using the
Record mode. This is useful when both position and speed are crucial to achieve the desired result.

Right-click on the desired path and select Record from the contextual menu. This displays a submenu
of available data that may be recorded.

Use the Record Time option in conjunction with the Draw Append mode to create complex motion
paths that will recreate the motion precisely as the path is drawn.

The time used to record the animation may not suit the needs of a project precisely. Adjust the path’s
Displacement spline in the Spline Editor to more correctly match the required motion.

Importing and Exporting Polylines

You can import and export polyline shapes into a common editable ASCII text file or its native format.
These methods are used to save a particularly useful or generic mask or path for future use or for use
in another application, such as Maya or LightWave. You can also import FXF, SSF, or Nuke shape files.

To save a polyline shape in Fusion’s native ASCII format, right-click on the header of the Mask node in
the Inspector and select Settings > Save As from the contextual menu. Provide a name and path for
the saved file and select OK to write a file with the .setting extension. This file will save the shape of a
mask or path, as well as any animation splines applied to its points or controls.

To load the saved setting back into Fusion, you first create a new polyline of the same type, and
then select Settings > Load from the mask’s context menu or drag the .setting file directly into the
Node Editor.

If you want to move a polyline from one composition to another, you can also copy the
node to the clipboard, open your second composition, and paste it from the clipboard into the
new composition.
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Using Modifiers,
Expressions, and
Custom Controls

Some of the most powerful aspects of Fusion are the different
ways it allows you to go beyond the standard tools delivered

with the application.

This chapter provides an introduction to a variety of advanced features, including Modifiers,
Expressions, and Scripting, which can help you extend the functionality and better integrate

Fusion into your studio.
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The Contextual Menu for
Parameters in the Inspector

Most of the features in this chapter are accessed via a contextual menu that appears when you right-
click most parameters in the Inspector. Different contextual menus are available based on where in the
Inspector you right-click. Specifically, right-clicking over parameter names or sliders displays a feature-
rich contextual menu that can add animation, expression fields, modifiers to extend functionality, as
well as publishing and linking capabilities, allowing you to adjust multiple controls simultaneously.

Using Modifiers

Parameters can be controlled with modifiers, which are extensions to a node’s toolset. Many modifiers
can automatically create animation that would be difficult to achieve manually. Modifiers can be as
simple as keyframe animation or linking the parameters to other nodes, or modifiers can be complex
expressions, procedural functions, external data, third-party plugins, or fuses.

Which modifiers are available depends on the type of parameter you're right-clicking over. Numeric
values, text, polylines, gradients, and points each have different sets of modifiers that will work with
them, so the Modify With menu is filtered based on each parameter.

You add modifiers to a parameter using the Inspector’s contextual menu, or by right-clicking the
onscreen control for a parameter in the viewer. Either way, a dynamic list of modifiers that are
appropriate for the selected parameters is displayed. For instance, a Perturb modifier can be added to
any slider to auto-animate the parameter by randomly wiggling the value. Once the modifier is added,
controls are displayed in the Modifiers tab to adjust the speed and amplitude of the random animation.

Vv Layout
Paint
* N INATTA Y 0.661 574
0.0
1.0

Modify With o

Perturb [}

The Inspector contextual menu is used to add a Perturb
modifier to the Center X and Y parameters
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A modifier’s controls are displayed in the Modifiers tab of the Inspector. When a selected node has a
modifier applied, the Modifiers tab will become highlighted as an indication. The tab remains grayed

out if no modifier is applied.

Perturb1

Shake on Text1: Perspective

)

The Modifiers tab with two modifiers applied

Modifiers appear with header bars and header controls just like the tools for nodes. A modifier’s title
bar can also be dragged into a viewer to see its output.

Modifiers that auto-animate parameters like Perturb and Shake can be combined with keyframes to
create more natural, organic looking animations. For instance, you can create the general motion path
for an element by keyframing the Center X and Y parameters, and then apply a modifier to the same

parameters to create a secondary wiggling motion.

To combine a keyframed motion path with a Perturb modifier:
Add a Transform to an image like a butterfly or spaceship.
Select the Transform node in the Node Editor.
In the Inspector, click the Keyframe button to the right of the Center X and Y parameters.
Position the butterfly or spaceship image where you want the start of the animation to begin.
Continue to move the playhead in the render range and reposition the image until you create a
figure-8 motion path.
Right-click over the Center X label in the Inspector and choose Modify With > Perturb.

Click the Modifiers tab at the top of the Inspector and adjust random, wiggling motion by setting
the Strength, Wobble, and Speed parameters while the animation plays.

The Publish modifier makes the value of a parameter available, so that other parameters can connect
to it. This allows you to simultaneously use one slider to adjust other parameters on the same or
different nodes. For instance, publishing a motion path allows you to connect multiple objects to the
same path.

Using Modifiers, Expressions, and Custom Controls

325




: Publish

[:_-: y

Publish a parameter in order to
link other parameters to it

Once a parameter is published, you can right-click another parameter and choose Connect To >
[published parameter name] from the contextual menu. The two values are linked, and changing the
parameter value of one in the Modifiers tab changes the other.

Using the pick whip between two parameters provides similar linking behavior with more
flexibility. Pick whipping between parameters is covered later in this chapter.

A single modifier or published parameter can be applied to multiple parameters so they all act as one.
This is handled through the Connect To submenu. As with modifier assignment, the list is filtered to
show only options that are suitable for the parameter you've right-clicked on. When you do this, the
connection is bidirectional; editing either parameter will cause the other parameter to change.

The Connect To menu connects
modifiers to multiple parameters

Modifiers can be connected to each other and branched, just like nodes in the Node Editor. For
example, the Calculation modifier outputs a number, but has two Number parameters, both of which
can have modifiers added to them. If you want to insert a modifier between the existing modifier and
the modified parameter, use the Insert submenu of the parameter’s contextual menu.

Available Modifiers in Fusion:

— Anim Curves: Adds an animation curves modifier that allows you to dynamically adjust the timing,
scaling, and acceleration of an animation.

— Bézier Spline: Adds a Bézier spline to the Spline Editor for animating the selected parameter.

— B-Spline Spline: Adds a B-Spline spline to the Spline Editor for animating the selected parameter.
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— Calculation: Creates an indirect link that includes a mathematical expression
between two parameters.

— CoordTransform Position: Calculates the current 3D position of a given object even after multiple
3D transforms have repositioned the object through the node tree hierarchy.

— Cubic Spline: Adds a Cubic spline to the Spline Editor for animating the selected parameter.

— Expression: Allows you to add a variable or a mathematical calculation to a parameter, rather than
a straight numeric value. The Expression modifier provides controls in the Modifiers tab, giving you

more room and parameters than the SimpleExpression

— From Image: This modifier takes color samples of an image along a user-definable line and creates
a gradient from those samples.

— Gradient Color Modifier: Creates a customized gradient and maps it into a specified time range to

animate a value.

— KeyStretcher: Used to stretch keyframes in a Fusion Title template when trimming the template in
the Edit page or Cut page timeline.

— MIDI Extractor: Modifies the value of a parameter using the values stored in a MIDI file.

— Natural Cubic Spline: Adds a Natural Cubic spline to the Spline Editor for animating
the selected parameter.

— Offset (Angle, Distance, Position): The three Offset modifiers are used to create variances,
or offsets, between two positional values. For instance, when this modifier is added to a size
parameter, you can change the size of an object using the distance between two onscreen controls
(position and offset).

— Path: Produces two splines to control the animation of of an object: An onscreen motion path
(spacial) and a Time spline visible in the Spline Editor (temporal).

— Perturb: Generates smoothly varying random animation for a given parameter.

— Probe: Auto-animates a parameter by sampling the color or luminosity of a specific pixel or
rectangular region of an image.

— Publish: The first step in linking two non-animated parameters is to use the Publish modifier to
publish a parameter. That allows other parameters to use the Connect To submenu and link to the
published parameter.

— Resolve Parameter: Allows you to modify the duration of a Fusion transition template from the
Edit page Timeline. The Resolve Parameter Modifier is applied to any animated parameter instead
of keyframing the transition.

— Shake: Similar to Perturb, Shake generates smoothly varying random animation
for a given parameter.

— Track: Attaches a single point tracker to the selected parameter. The tracker can then track an
object onscreen to animate the parameter. This is quicker and more direct than using the normal
Tracker node; however, it offers less flexibility since the resulting tracker is only a single point and
can only be used for the selected parameter.

— Vector Result: Similar to the Offset modifier, Vector Result is used to offset position parameters
using origin, distance, and angle controls to create a vector. This vector can then be used to adjust
any other parameter.

— XY Path: Produces an Xand Y spline in the Spline Editor to animate the position of an object..

For more information on all modifiers available in Fusion, see Chapter 60, “Modifiers,” in the Fusion
Reference Manual and Chapter 122 in the DaVinci Resolve Reference Manual.
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Performing Calculations
in Parameter Fields

You can enter simple mathematical equations directly in a number field to calculate a desired
value. For example, typing 2.0 + 4.0 in most number fields will result in a value of 6.0. This can be
helpful when you want a parameter to be the sum of two other parameters or a fraction of the
screen resolution.

Using SimpleExpressions

Simple Expressions are a special type of script that can be placed alongside the parameter it is
controlling. These are useful for setting simple calculations, building unidirectional parameter
connections, or a combination of both. You add a SimpleExpression by entering an equals sign directly
in the number field of the parameter and then pressing Return.

Entering an equals sign opens the
SimpleExpression field with Pick Whip control

An empty field will appear below the parameter, and a yellow indicator will appear to the left. The
current value of the parameter will be entered into the number field. Using Simple Expressions, you
can enter a mathematical formula that drives the value of a parameter or even links two different
parameters. This helps when you want to create an animation that is too difficult or impossible to set
up with keyframing. For instance, to create a pulsating object, you can use the sine and time functions
on a Size parameter. Dividing the time function can slow down the pulsing while multiplying it can
increase the rate.

sin(time/20)/2+.5

A SimpleExpression using the sine and time functions

Inside the SimpleExpression text box, you can enter one-line scripts in Lua with some Fusion-specific
shorthand. Some examples of Simple Expressions and their syntax include:

Expression Description
time This returns the current frame number.
Mergel.Blend This returns the value of another input, Blend,

from another node, Merge1.

Mergel:GetValue("Blend", time-5) This returns the value from another input, but
sampled at a different frame, in this case five
frames before the current one.
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Expression

sin(time/20)/2+.5

iif(Mergel.Blend == 0, 0, 1)

iif(Input.Metadata.ColorSpaceID ==
"SRGB", 0, 1)

Point(Textl.Center.X, Textl.
Center.Y-.1)

Textl.Center - Point(0,.1)

Text("Colorspace:
Background.Metadata.ColorSpacelD)

"..(Mergel.

Text("Rendered "..os.date("%b %d,
2Y").. " at "..os.date("%H:3M").."\n
on the computer "..os.
getenv("COMPUTERNAME").. " running
"..os. getenv("0S").."\n from the comp

"..ToUNC(comp.Filename))

os.date("%H:3M")

"..os.getenv("COMPUTERNAME").. "

running "..os.

"\n from the comp "..ToUNC(comp.
Filename)

Description
This returns a sine wave between 0 and 1.

This returns 0 if the Blend value is 0, and returns
1if itis not. The iff() function is a shorthand
conditional statement, if-then-else.

This returns 0 if the image connected to the
current node’s Input is tagged with the sRGB
colorspace. When no other node name is
supplied, the expression assumes the Input is
coming from the current node. It is equivalent
to self.Input. The Input in most, but not all,
Fusion nodes is the main image input shown in
the Node Editor as an orange triangle. Images
have members that you can read, such as
Depth, Width, Metadata, and so on.

Unlike the previous examples, this returns

a Point, not a Number. Point inputs use two
members, X and Y. In this example, the Point
returned is 1/10 of the image height below the
Text1's Center. This can be useful for making
unidirectional parameter links, like offsetting
one Text from another.

This is similar to the previous expression.

This SimpleExpression returns Text instead of a
Number or Point.

The string inside the quotes is concatenated
with the metadata string, perhaps returning:

Colorspace: sRGB

This returns a much larger Text, perhaps
something like:

Rendered Nov 12, 2019 at 15:43 on the
computer Rn309 running Windows_NT
from the comp WSRVR\Proj\Am109\
SlateGenerator_A01.comp

The OS library can pull various information
about the computer. In the previous example,
os.date gets the date and time in hours:minutes.

Any environment variable can be read by
os.geteny, in this case the computer name and
the operating system.

To get a new line in the Text, \n is used. Various
attributes from the comp can be accessed with
the comp variable, like the filename, expressed
as a UNC path.
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TIP: When working with long SimpleExpressions, it may be helpful to drag the Inspector
panel out to make it wider or to copy/paste from a text editor or the Console.

After setting an expression that generates animation, you can open the Spline Editor to view the
values plotted out over time. This is a good way to check how your SimpleExpression evaluates

over time.

value

A sine wave in the Spline Editor, generated by the expression used for Text1: Size

For more information about writing Simple Expressions, see the Fusion Studio Scripting Guide, and
the official Lua documentation.

With a SimpleExpression field open, a + button is displayed on the left side. Dragging the + button
onto another control, or "pick whipping," links the two parameters, similar to the Connect To menu.
However, unlike a Connect To parameter link, the pick whip allows you to modify the connection by
further editing the expression.

sin{time/20)/2+.5

Pick whipping to connect one
parameter to another quickly

SimpleExpressions can also be created and edited within the Spline Editor. Right-click on the
parameter in the Spline Editor and select Set SimpleExpression from the contextual menu. The
SimpleExpression will be plotted in the Spline Editor, allowing you to see the result over time.
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To remove a SimpleExpression, right-click the name of the parameter, and choose Remove Expression
from the contextual menu.

Customizing User Controls

Each tool's parameters are organized in a logical order in the Inspector. The most used controls are
closer to the top, and the more subtle refinement controls are lower in the list. Sometimes, though,
you may want to add, hide, or change the controls. You often need to do this for SimpleExpressions
and macros, but you may also do this for usability and aesthetic reasons for favorites and presets.

Custom controls can be added or edited via the Edit Control dialog, which you access by right-clicking
over the node’s name in the Inspector and choosing Edit Controls from the menu.

DirectionalBlu

Edit Contraols...

[y

Choose Edit Controls to create
and customize parameters

In the Edit Control dialog, you use the ID menu to select an existing parameter or create a new one.
You can name the control and define whether it is a text field, number field, or a point using the Type
attributes list.

(@ @ Edit Control

New Control

NewControl

Edit Control dialog
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You use the page list to assign the new control to one of the tabs in the Inspector. There are also
settings to determine the defaults and ranges, and whether it has an onscreen preview control. The
Input Ctrl box contains settings specific to the selected Type, and the View Ctrl attributes box contains
a list of onscreen preview controls to be displayed, if any.

All changes made using the Edit Controls dialog get stored in the current tool instance, so they can
be copied/ pasted to other nodes in the comp. However, to keep these changes for other comps, you
must save the node settings, and add them to the Bins in Fusion Studio or to your favorites.

As an example, we'll customize the controls for a DirectionalBlur:

DirectionalBlur1

()

Linear

0.5

The Inspector for a default direction blur

Let's say we wanted a more interactive way of controlling a linear blur in the viewer, rather than using
the Length and Angle sliders in the Inspector. Using a SimpleExpression, we'll control the length and
angle parameters with the Center parameter’s onscreen control in the viewer. The SimpleExpression
would look something like this:

For Length:

sqgrt(((Center.X-.5)*(self.Input.XScale))"2+((Center.Y-.5)*(self.Input.YScale)*(self.
Input.Height/self.Input.Width))"2)

For Angle:
atan2(.5-Center.Y , .5-Center.X) * 180 / pi

DirectionalBlur1

()

Linear
0.548715 Y 0.492679

0.048916

sqgrt(((Center.X-.5)*(self.Input.XS

171.4538

atan2(.5-Center.Y , .5-Center.X) *

DirectionalBlur controlled by the Center’s position.

This admittedly somewhat advanced function does the job fine. Dragging the onscreen control
adjusts the angle and length for the directional blur. However, now the names of the parameters are
confusing. The Center parameter doesn't function as the center anymore. It is the direction and length
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of the blur. It should be named "Blur Vector" instead. You no longer need to edit the Length and Angle
controls, so they should be hidden away, and since this is only for a linear blur, we don't need the

Type menu to include Radial or Zoom. We only need to choose between Linear and Centered. These
changes can easily be made in the Edit Controls dialog.

To change the Inspector parameters for the example above:
In the Edit Control dialog, select the Center from the ID list.
A dialog will appear asking if you would like to Replace, Hide, or Change ID. We'll choose Replace.
Change the Name to Blur Vector.
Set the Type to Point.
Select Controls in the Page list. (Controls is the first tab in the Inspector, normally.)

Click OK.

@ @ Edit Control

Blur Vector . Ty NormalCross

Center

Controls

DirectionalBlur Center parameter name changed to Blur Vector.

The new Blur Vector parameter now appears in the Inspector. The internal ID of the control is still
Center, so our SimpleExpressions did not change.

To hide the Length and Angle parameters in the Inspector:
In the Edit Control dialog, select the Length from the ID list.
Select Controls from the Page list.

In the input Ctrl list, select Node.

Click OK.

In the Edit Control dialog, select the Angle from the ID list.
In the input Ctrl list, select Node.

Click OK.

Finally, to remove Radial and Zoom options from the Type menu:
In the Edit Control dialog, select the Type from the ID list.
Select Controls from the Page list.
Select Radial from the Items list and click Del to remove it.
Select Zoom from the Items list and click Del to remove it.

Click OK.
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The Type menu now includes only two options.

If you want to replace the Type menu with a new checkbox control, you can do that by creating a new
control and a very short expression.

To create a new control:
In the Edit Control dialog, enter Center Blur in the Name field.
Select the New Control from the ID list.
Set the Type to Number, and set the Page to Controls.
Set the Input Ctrl to CheckboxControl.
Click OK.

To make this new checkbox affect the original Type menu, you'll need to add a SimpleExpression to
the Type:

iif(TypeNew==0, 0, 2)

The "iif" operator is known as a conditional expression in Lua script. It evaluates something based on a
condition being true or false.

FusionScript

Scripting is an essential means of increasing productivity. Scripts can create new capabilities or
automate repetitive tasks, especially those specific to your projects and workflows. Inside Fusion,
scripts can rearrange nodes in a comp, manage caches, and generate multiple output files for
delivery. They can connect Fusion with other apps to log artist time, send emails, or update webpages
and databases.

FusionScript is the blanket term for the scripting environment in Fusion. It includes support for Lua as
well as Python 2 and 3 for some contexts. FusionScript also includes libraries to make certain common
tasks easier to do with Lua and Python within Fusion.

You can run interactive scripts in various situations. Common scripts include:

— Utility Scripts, using the Fusion application context, are found under the File > Scripts menu.

— Comp Scripts, using the composition context, are found under the Script menu or entered
into the Console.

— Tool Scripts, using the tool context, are found in the Tool's context menu > Scripts.

Other script types are available as well, such as Startup Scripts, Scriptlibs, Bin Scripts, Event Suites,
Hotkey Scripts, Intool Scripts, and SimpleExpressions. Fusion Studio allows external and command-
line scripting as well and network rendering Job and Render node scripting.

FusionScript also forms the basis for Fuses and ViewShaders, which are special scripting-based
plugins for tools and viewers that can be used in both Fusion and Fusion Studio.

For more information about scripting, see the Fusion Scripting Documentation, accessible from the
Documentation submenu of the Help menu.
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Preferences

This chapter covers the various options that are

available from the Fusion Preferences Window.
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Preferences Overview

The Preferences window provides a wide variety of optional settings available for you to configure
Fusion’s behavior to better suit your working environment. These settings are accessed via the
Preferences window. The Preferences window can be opened from a menu at the top of the interface.

In DaVinci Resolve, to open the Fusion Preferences window, do one of the following:
— On macOs, switch to the Fusion page and choose Fusion > Fusion Settings.
— On Windows, switch to the Fusion page and choose Fusion > Fusion Settings.

— On Linux, switch to the Fusion page and choose Fusion > Fusion Settings.

In Fusion Studio, to open the Fusion Preferences window, do one of the following:
— On macOS, choose Fusion Studio > Preferences.
— On Windows, choose File > Preferences.

— On Linux, choose File > Preferences.

Preferences

Usability

General

Auto save

v Aut

The Preferences window includes composition settings.

Global and Composition Preferences

The Preferences window is divided into a category sidebar on the left and the settings panel on the
right. In Fusion Studio, there are two levels of preferences: Global and Composition. The Fusion page
in DaVinci Resolve uses just a single Global preference that affects every project, new and existing.

The Global preferences are used to set options specific to Fusion’s overall behavior as well as defaults
for each new composition. The Composition preferences in Fusion Studio can further modify the
currently open composition without affecting the Global preferences or any other composition that is
open but not displayed.
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Categories of Preferences

The first entry in the Preferences sidebar is assigned to the Global preferences. Clicking the Global
and Default Settings disclosure arrow reveals the following sections.

Preferences

Usability

Auto save

| Autosave Jelay:  10:00

Proxy

Fusion Studio Global and Default settings

3D View

The 3D View preferences offer control over various parameters of the 3D Viewers, including grids,
default ambient light setup, and Stereoscopic views.

AVI (Windows Fusion Studio Only)

The AVI preferences configure the default compression options when creating AVI files from a Saver
node. These settings can be overridden on a case-by-case basis using the Format tab in the Saver's
Inspector.

Defaults

The Defaults preferences are used to select default behavior for a variety of options, such as
animation, global range, timecode display, and automatic tool merging.

Flow

You use the Flow preferences to set many of the same options found in the Node Editor’s contextual
menu, like settings for Tile picture, the Navigator, and pipe style.
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Frame Format

The Frame Format preferences are used to create new frame formats as well as select the default
image height and width when adding new creator tools like Background and Text+. You also set the
frame rate for playback.

General

The General preferences contain options for the general operation, such as auto save, and gamma
settings for color controls.

GPU (Fusion Studio Only)

The GPU preferences include options for selecting specific GPU acceleration methods based on your
computer platform and hardware capabilities. It is also used for enabling caching, and debugging GPU
devices and tools.

Layout (Fusion Studio Only)

You can use the Layout preferences to save the exact layout of Fusion’s windows.

Loader (Fusion Studio Only)

Using the Loader preferences, you can set options for the default Loader’s depth and aspect ratio as
well as define the local and network LoaderCache settings.

Memory (Fusion Studio Only)

Memory management for multi-frame and simultaneous branch rendering is configured in the
Memory preferences.

Network (Fusion Studio Only)

The Network rendering preferences are used to configure options such as selecting a render master,
email notification, and whether the machine can be used as a render slave.

Path Map

Path Map preferences are used to configure virtual file path names used by Loaders and
Savers as well as the folders used by Fusion to locate comps, macros, scripts, tool settings, disk
caches, and more.

Preview (Fusion Studio Only)

The Preview preferences is where you configure the Preview creation and playback options.

QuickTime (macOS Fusion Studio Only)

This section lets you preconfigure the QuickTime codec used for rendering.
Script

The Script preferences include a field for passwords used to execute scripts externally, programs to
use for editing scripts, and the default Python version to use.
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Spline Editor

The Spline Editor preferences allow you to set various spline options for Autosnap behavior, handles,

markers, and more.

Splines
Options for the handling and smoothing of animation splines, Tracker path defaults, onion-skinning,
roto assist, and more are found in the Splines preference.

Timeline

The Timeline preferences is where you create and edit Timeline/Spline filters and set default options
for the Keyframes Editor.

Tweaks

The Tweaks preferences handle miscellaneous settings for modifying the behavior when loading
frames over the network and queue/network rendering.

User Interface

These preferences set the appearance of the user interface window and how the Inspector is
displayed.

Video Monitoring (Fusion Studio Only)

The Video Monitoring preferences is where you can configure your Blackmagic video display hardware
for monitoring on an HD, Ultra HD, or DCI 4K display.

View
The View preferences are used to manage settings for viewers, including default control colors,
Z-depth channel viewing ranges, default LUTs, padding for fit, zoom, and more.

VR Headsets

The VR Headsets preferences allow configuration of any connected Virtual Reality headsets, including

how stereo and 3D scenes are viewed.

Bins (Fusion Studio Only)

There are three panels as part of the Bins preferences: a Security panel where you set users and
passwords for serving the local bins; a Servers panel used to select which remote Bin servers are

connected; and a Settings panel for stamp rendering.

Import

The Import settings contain options for EDL Import that affect how flows are built using the data

from an EDL.
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Preferences In Depth

Within each category is a deep set of controls for configuring Fusion so that it better fits your working
environment. The preferences contain both software and hardware options that affect all newly
created comps. The following section explains every option located in the preferences categories.

The 3D View preferences contain settings for various defaults in the 3D Viewers, including grids,

default ambient light setup, and Stereoscopic views.
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The 3D View preferences

Grid

The Grid section of the 3D View preferences configures how the grid in 3D Viewers are drawn.

— Grid Antialiasing: Some graphics hardware and drivers do not support antialiased grid
lines, causing them to sort incorrectly in the 3D Viewer. Disabling this checkbox will disable
antialiasing of the grid lines. To turn off the grid completely, right-click in a 3D Viewer and choose
3D Options > Grid.

— Size: Increasing the Size value will increase the number of grid lines drawn. The units used for the
spacing between grid lines are not defined in Fusion. A “unit” is whatever you want it to be.

— Scale: Adjusting the overall scaling factor for the grid is useful, for example, if the area of the grid

appears too small compared to the size of your geometry.
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Perspective Views

The Perspective Views section handles the appearance of the perspective view in both a normal and
stereoscopic project.

— Near Plane/Far Plane: These values set the nearest and furthest point any object can get to or
from the camera before it is clipped. The minimum setting is 0.05. Setting Near Plane too low and
Far Plane too far results in loss of depth precision in the viewer.

— Eye Separation/Convergence/Stereo Mode: This group of settings defines the defaults when
stereois turned on in the 3D Viewer.

Orthographic Views

Similar to the Perspective Views, the Orthographic Views (front, top, right, and left views) section sets
the nearest and furthest point any object can get to or from the viewer before clipping occurs.

Fit to View

The Fit to View section has two value fields that manage how much empty space is left around objects
in the viewer when the F key is pressed.

— Fit Selection: Fit Selection determines the empty space when one or more objects are selected
and the F key is pressed.

— Fit All: Fit All determines the empty space when you press F with no objects selected.

Default Lights

These three settings control the default light setup in the 3D Viewer,

The default ambient light is used when lighting is turned on and you have not added a light to the
scene. The directional light moves with the camera, so if the directional light is set to “upper left,” the
light appears to come from the upper-left side of the image/camera.

The AVI preference is only available in Fusion Studio on Windows. It configures the default AVI codec
settings when you select AVI as the rendering file format in the Saver node.

— Compressor: This drop-down menu displays the AVI codecs available from your computer. Fusion
tests each codec when the application opens; therefore, some codecs may not be available if the
tests indicate that they are unsuitable for use within Fusion.

— Quality: This slider determines the amount of compression to be used by the codec. Higher values
produce clearer images but larger files. Not all codecs support the Quality setting.

— Key Frame Every X Frames: When checked, the codec creates keyframes at specified intervals.
Keyframes are not compressed in conjunction with previous frames and are, therefore, quicker to
seek within the resulting movie. Not all codecs support the keyframe setting.

— Limit Data Rate To X KB/Second: When checked, the data rates of the rendered file are limited to
the amount specified. Not all codecs support this option. Enter the data rate used to limit the AVI
in kilobytes (kB) per second, if applicable. This control does not affect the file unless the Limit Data
Rate To option is selected.
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The choices made here are used to determine Fusion’s behavior when new tools are added to the
Node Editor and when parameters are animated.
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Default Animate

The Default Animate section is used to change the type of modifier attached to a parameter when
the Animate option is selected from its contextual menu. The default option is Nothing, which uses a
Bézier spline to animate numeric parameters and a path modifier for positional controls.

— Number With and Point With: Drop-down lists are used to select a different modifier for the new
default. For example, change the default type used to animate position by setting the Point with
the drop-down menu to XY Path.

Choices shown in this menu come from installed modifiers that are valid for that type of parameter.
These include third-party plug-in modifiers, as well as native modifiers installed with Fusion.

Auto Tools

The Auto Tools section determines which tools are added automatically for the most common
operations of the Background tools and Merge operations.

— Background: When set to None, a standard Background tool is used; however, the drop-down
menu allows you to choose from a variety of tools including 2D and 3D tools to customize the

operation to your workflow.
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— Merge: When set to None, nothing happens. When set to Merge, connecting the outputs of two
tools or dragging multiple clips on the Node Editor uses a standard Merge. Other valid options for
this are Anaglyph, Channel Booleans, and Dissolve.

— Use Merge Only When Connecting Outputs Directly: When this option is active, Merges are not
automatically added when you drag multiple clips from the Finder or Windows Explorer onto the
Flow area.

Global Range

Using the Start and End fields, you can define the Global Start and End frames used when creating
new compositions.

Time Code

You use this option to determine whether new compositions will default to showing SMPTE Time Code
or frames (Feet + Frames) to represent time.

Many of the same options found in the Node Editor’s contextual menu, like settings for Tile Picture,
the Navigator, and Pipe Style, are found in this category.
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Force

The Force section can set the default to display pictures in certain tool tiles in the Node Editor rather
than showing plane tiles. The Active checkbox sets pictures for the actively selected tool, the All
checkbox enables pictures for all tiles, and the Source and Mask checkbox enables tile pictures for just
Source and Mask tools.

When Allis enabled, the picture shown will either be a thumbnail of the image rendered by the tool
if the tool has rendered, or if the Show Thumbnails option is disabled, the tool's defaulticon is used.
Concatenated transforms will also show a default icon.

— Show Modes/Options: Enabling this option will display icons in the tool tile depicting various
states, like Disk Caching or Locked.

— Show Thumbnails: When this checkbox is selected, tool tiles set to show tile pictures will
display the rendered output of the tool. When the checkbox is cleared, the default icon for the tool
is used instead.

Options
The Options section includes several settings that control or aid in the layout and alignment of tools in
the Node Editor.

— Arrange to Grid: This enables a new node tree’s Snap to Grid option to force the tool layout to
align with the grid marks in the flow.

— Arrange to Connected: Tools snap to the vertical or horizontal positions of other tools
they are connected to.

— Auto Arrange: This option enables the Node Editor to shift the position of tools as needed to make
space when inserting new tools or auto-merging layers.

— Show Grid: This enables or disables the display of the Node Editor’s background grid.

— Auto Remove Routers: Pipe Routers or “elbow nodes” in the Node Editor are considered

“orphaned” if the tools connected to either the input or output are deleted. When this option is
enabled, Orphaned Routers are automatically deleted.

— Pipes Always Visible: When enabled, the connection lines between tools are drawn over the top of
the tool tiles.

— Keep Tile Picture Aspect: Enabling this option forces tool tile thumbnail pictures to preserve the
aspect of the original image in the thumbnail.

— Full Tile Render Indicators: Enabling this checkbox causes the entire tile to change color
when it is processing. This can make it easier to identify which tools are processing in a large
composition. The coloring itself will form a progress bar to alert you to how close slower tools are
to finishing their process.

— Show Instance Links: This option is used to select whether Instance tools will show links,
displayed as green lines, between Instance tools.

— Navigator: The Navigator is a small square overview of the entire composition. It is used to quickly
navigate to different parts of a node tree while you are zoomed in. The checkboxes in this section
determine when the Navigator is displayed, if at all.

— On: The Navigator will always be visible.
— Off: The Navigator will always be hidden.

— Auto: The Navigator will only be visible when the Node Editor’s contents exceed the currently
visible Work area.
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— Pipe Style: This drop-down menu selects which method is used to draw connections between
tools. The Direct method uses a straight line between tools, and Orthogonal uses horizontal and

vertical lines.

— Build Direction: When auto-building or laying out a node tree, Build Direction controls whether
tools are organized horizontally or vertically.

— Scale: The Scale menu allows you to select the default zoom level of the Node Editor when a new

composition is created.

Pipe Grab Distance

The Pipe Grab Distance slider allows you to choose how close the pointer must be (in pixels) to a
connection line in the node tree when selecting them.

Link Grab Distance

The Link Grab Distance slider allows you to choose how close the pointer must be (in pixels) to a knot
on a node before a connection is made or removed. 0 pixels means you must be directly on the knot,
while a maximum setting of 20 means you can be 20 pixels from a knot and still connect to it.

Group Opacity

This slider controls the opacity of an expanded group’s background in the Node Editor.

Frame Format preferences allow you to select the resolution and frame rate for the nodes that
generate images like Background, fast noise, and Text+. It also sets the color bit depth for final
renders, previews, and interactive updates in the viewer. The color bit depth settings only apply to
Fusion Studio. Rendering in DaVinci Resolve always use 32-bit float.
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Default Format

This drop-down menu is used to select the default resolution for Generator tools from a list of presets.
This is only a default setting; these settings can be overridden using the Resolution settingsin a
node’s Inspector.

Use the Edit boxes to change any of the default settings. When creating a new setting, press the New
button and enter a name for the setting in the dialog box that appears and enter the parameters.

Settings
The Settings section defines the format that is selected in the Default Format menu. You can modify

an existing format or create a new one.

— Width/Height: When creating a new format for the menu or modifying an existing menu item, you
specify the Width or Height in pixels of the format using these fields.

— Frame Rate: Enter or view the frames per second played by the format. This sets the default Frame
Rate for previews and final renders from the Saver tool. It also sets the playback for the comp itself,
as well as the frame to time code conversion for tools with temporal inputs.

— Has Fields: When this checkbox is enabled, any Creator or Loader tool added to the Node Editor
will be in Fields process mode.

— Film Size: This field is used to define how many frames are found in one foot of film. The value is
used to calculate the display of time code in Feet + Frames mode.

— Aspect Ratio: These two fields set the pixel aspect ratio of the chosen frame format.

— Guide 1: The four fields for Guide 1 define the left, top, right, and bottom guide positions for
the custom guides in the viewer. To change the position of a guide, enter a value from 0 to 1.
The bottom-left corner is always 0/0, the top-right corner is always 1/1. If the entered value’s
aspect does not conform to the frame format as defined by the Width and Height parameters,
an additional guide is displayed onscreen. The dotted line represents the image aspect centered
about Guide 1's Center values.

— Guide 2: This setting determines the image aspect ratio in respect to the entire frame format width
and height. Values higher than 1 cause the height to decrease relative to the width. Values smaller
than 1 cause height to increase relative to width.

— New: You use the New button to create a new default setting in the drop-down menu. Once you
click the button, you can name the setting in the dialog box that appears.

— Copy: The Copy button copies the current setting to create a new one for customization.

— Delete: The Delete button will remove the current setting from the default drop-down list.

Color Depth

The three menus in the Color Depth section are used to select the color mode for processing preview
renders, interactive renders, and full (final) renders. Processing images at 8-bit is the lowest color
depth and is rarely sufficient for final work these days but is acceptable for fast previews. 16-bit color
has much higher color fidelity but uses more system resources. 16-bit and 32-bit float per channel
uses even more system resources and is best for digital film and HDR rendered images.

Generally, these options are ignored by the composition unless a Loader or Creator tool's Color Depth
control is set to Default.
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The sections contained in the General preferences affect the behavior of the Inspector as well as
some other user interface elements.
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Usability

Usability has a number of project, Node Editor, and user interface settings that can make the
application easier to work with, depending on your workflow.

— Auto Clip Browse: When this checkbox is enabled, the File Browser is automatically displayed
when a new Loader or Saver is added to the Node Editor.

— New Comp on Startup: When checked, a new, empty project is created each time Fusion Studio is
launched. This has no effect in DaVinci Resolve’s Fusion page.

— Summarize Load Errors: When loading node trees or “comps” that contain unknown tools
(e.g., comps that have been created on other computers with plugins not installed on the current
machine), the missing tools are summarized in the console rather than a dialog being presented for
every missing tool.

— Save Compressed Comps: This option enables the saving of compressed node trees, rather than
ASCII based text files. Compressed node trees take up less space on disk, although they may take
a moment longer to load. Node trees containing complex spline animation and many paint strokes
can grow into tens of megabytes when this option is disabled. However, compressed comps cannot
be edited with a text editor unless saved again as uncompressed.
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— Show Video I/0 Splash: This toggles whether the Splash image will be displayed over the video
display hardware. This is only applies to Fusion Studio.

— Use Simplified Copy Names: This option reduces the occurrence of underscores in tool names
when copying.

— Show Render Settings: When this checkbox is selected, the Fusion Render Settings dialog will be
displayed every time a render is started in Fusion Studio. Holding Shift while starting a render will
prevent the display of the dialog for that session, using whatever settings were applied during the
last render. Disabling this option reverses this behavior.

— Mouse Wheel Affects the Window Under the Pointer: Normally the mouse wheel or trackpad
swiping works in the currently active window. With this option enabled, it will work in the window
underneath the cursor, so you don't have to click into a window first to make it active.

— Frames Start From: This designates the starting frame number for clip times in the Loader and its
Clip list.

— Show Color As: This setting determines the numeric scale used to represent colors. The available
options are Normalized (0 to 1), 8-bit (0 to 255), and 16-bit (0 to 65,535). This does not affect the
actual processing or quality of the image, but it can make the mental math sometimes used to
figure out adjustments a bit easier.

Auto Save

The Auto Save settings only apply to Fusion Studio. To set auto backups for the Fusion page in
DaVinci Resolve, use the DaVinci Resolve Project Load and Save Preferences.

When Auto Save is enabled in Fusion Studio, comps are automatically saved to a backup file at regular
intervals defined by the Delay setting. If a backup file is found when attempting to open the comp, you
are presented with the choice of loading either the backup or the original.

If the backup comp is opened from the location set in the Path Map preference, saving the backup
will overwrite the original file. If the backup file is closed without saving, it is deleted without

affecting the original file.

— Save Before Render: When enabled, the comp is automatically saved before a preview or final

render is started.

— Delay: This preference is used to set the interval between Auto Saves. The interval is set using
mm:ss notation, so entering 10 causes an Auto Save to occur every 10 seconds, whereas entering
10:00 causes an Auto Save every 10 minutes.

Proxy

— Update All, Selective, No Update: The Update mode button is located above the toolbar. You can
use this preference to determine the default mode for all new comps. Selective is the usual default.
It renders only the tools needed to display the images in the Display view. All will render all tools in
the composition, whereas None prevents all rendering.

— Standard and Auto: These sliders designate the default ratio used to create proxies when the
Proxy and Auto Proxy modes are turned on. These settings do not affect the final render quality.

Even though the images are being processed smaller than their original size, the image viewing scales

in the viewers still refer to original resolutions. Additionally, image processing performed in Proxy
Scale mode may differ slightly from full-resolution rendering.

Preferences 348




The Proxy and Auto Proxy size ratios may be changed from within the interface itself by right-
clicking on the Prx and APrx buttons above the toolbar and selecting the desired value from the
contextual menu.

The GPU preference is only available in Fusion Studio. In DaVinci Resolve, you can configure the GPU
processing in Resolve's Memory and GPU preferences.

In Fusion Studio, the GPU preference is used to specify the GPU acceleration method used for
processing, based on your computer platform and hardware capabilities. It is also used for enabling
caching and debugging GPU devices and tools.
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The GPU preferences

Options
The GPU options include radio buttons to select whether the GPU is used when processing and, if so,
which computer framework is used for communicating with the GPU.

— GPU Tools: This preference has three settings: Auto, Disable, and Enable. When set to Disable,
no GPU acceleration is used for tools or third-party plugins. Fuses may still require GPU
acceleration. If Enable is selected, GPU acceleration is available for tools and plugins, if appropriate
drivers are installed.

— API: The API setting selects the GPU processing method to use.
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— Device: The Device setting determines which GPU hardware to use in the case of multiple GPUs.
The Auto setting gives priority to GPU processing; however, if it is unavailable, Fusion uses the
platform default. Currently, both the AMD and CPU options require either the AMD Catalyst 10.10
Accelerated Parallel Processing (APP) technology Edition driver or the ATI Stream SDK 2.1 or later to

be installed. The Select setting allows you to choose the device explicitly.

Debugging

The more advanced preferences located in this section are designed for diagnostics and analyzing
GPU operations.

— Verbose Console Messages: Enabling this option causes information to be shown in the Console.

For example, Startup Logs, Compiler Warnings, and Messages.

— OpenGL Sharing: Enabling this option shares system RAM with onboard GPU RAM to create a
larger, but slower, OpenGL memory pool.

— Clear Cache Files: This option will clear already compiled GPU code and then
recompile the kernels.

The Layout preferences are only available in Fusion Studio. To save a Layout in DaVinci Resolve's
Fusion page, use the Workspace > Layout Presets menu. The Layout options are used to control the
layout, size, and position of various windows in Fusion’s interface at startup or when a comp is created.

Preferences

Program |ayout

Maximized

Layout

Document layout

v

Window settings

W

Normal window

The Layout preferences

Preferences 350



There are a lot of options, but in practice, you simply organize the interface the way you prefer it on
startup and when a new composition is created, then open this Preferences panel and click on the
three buttons to grab the Program Layout, the Document Layout and the Window Settings.

Program Layout

The Program Layout is used to save the overall Fusion interface window and any open floating
windows. Each new composition you open within the lager overall Fusion interface window will adhere
to these preferences.

— Grab Program Layout: Pressing this button stores the application’s overall current
position and size.

— Run Mode: This menu is used to select the application’s default mode at startup.
You choose between a Maximized application window, a Minimized application, or a Normal
application display.

— Use the Following Position and Size: When checked, the values stored when Grab Program

Layout was selected will be used when starting Fusion Studio.

— Create Floating Views: When checked, the position and size of the floating viewers will be saved
when the Grab Program Layout button is used.

Document Layout

The Document Layout is used to save the layout of panels and windows for the current Fusion comp.

— Recall Layout Saved In Composition: When checked, all Document Layout settings in the controls
below will be recalled when a saved composition is loaded.

— Grab Document Layout: Pressing this button stores the entire interface setup, including all the

internal positions and sizes of panels and work areas.

— Window: When multiple windows on the same composition are used, this menu is used to select
the window to which the Window Settings will apply.

Window Settings

Rather than saving entire comp layouts, you can save position and size for individual floating windows
and panels within a comp using the Window Settings.

— Automatically Open This Window: When checked, the selected window will automatically be
opened for new flows.

— Grab Window Layout: Pressing this button stores the size and position of the selected window.

— Run Mode: Select the default run mode for the selected window. You can choose between a
Maximized window, a Minimized window, or a Normal window display.

— Use Grabbed Position and Size: When checked, the selected window will be created using the
stored position and size.
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The Loader preferences are only available in Fusion Studio. Using the Loader preferences, you can set
options for the default Loader’s color depth and aspect ratio as well as define the local and network
cache settings.
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The Loader preferences

Defaults

The Defaults section includes two settings to determine how color depth and aspect ratio are handled

for Loaders.

— Loader Depth: The Loader Depth defines how color bit depth is handled when adding a Loader.
Choosing Format means that the correct bit depth is automatically selected, depending on the file
format and the information in the file’s header. Choosing Default sets the bit depth to the value

specified in the Frame Format preferences.

Cache

The Cache preferences allow you to control how disk caching operates in Fusion. You can set how and

where the cache is generated, when the cache is removed, how the cache reacts when source files are
not available, as well as many other cache related options. This is not to be confused with RAM cache,

which is controlled in the Memory preferences.

— Disable All Local Caching: This setting disables local caching.
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— Cache Files from Network DiskCaches: If a tool has disk caching enabled, and the disk cache files
are stored remotely on the network, then enabling this option will use a local copy of those cache

files, similarly to the local cache on a networked Loader.

— Enable Local Caching of Loaders: Files will be copied into the LoaderCache path set below or in
the Path Maps preferences.

— Cache Multi-Frame Files: Files like AVI or QuickTime will be copied into the LoaderCache path.
This may take some time if the file is large.

— Don’t Cache Files from Local Disks: Files that do not sit on a network drive will not be copied into
the LoaderCache path. You can disable this option if you have, for example, a fast SSD cache drive

and want to use it for local files as well to speed up file access while working interactively.

— Only Files Smaller Than xxx MB.: Files larger than the value set here will not be copied into the
LoaderCache path.

— Cache Path Separator Character: When Enable Local Caching of Loaders is enabled, you can use
this setting to rebuild the path of the original files in LoaderCache.

For instance, given the default “1” character, the original path X\Project\MyShots\ Shot0815\ will be
translated into X!Project!MyShots!Shot0815! in the LoaderCache path. Other separator characters
may be used, including the "\" character, which will use subdirectories in LoaderCache: X\Project\
MyShots\Shot0815\.

— If Original File Is Missing: This setting provides three options to determine the caching behavior
when the original files can’t be found. The Fail option behaves exactly as the Default Loader in
Fusion. The Loader will not process, which may cause the render to halt. The Load Cache option
loads the cache even though no original file is present.The Delete Cache option clears missing files
from the cache.

— Cache Location: For convenience, this is a copy of the LoaderCache path set in the
Path Maps preferences.

— Explore: This button opens the LoaderCache path in the macOS X Finder window
or a Windows Explorer window.

— Clear All Cache Files: This button deletes all cached files present in the LoaderCache path.

The Memory preferences are only available in Fusion Studio. To control Fusion’s memory when using
the Fusion page in DaVinci Resolve, open DaVinci Resolve’'s Memory and GPU preferences.

Occasionally, it will be necessary to adjust the Memory preferences in order to make the best use of
available memory on the computer. For example, some people prefer a higher cache memory for
faster interactive work, but for final renders the cache memory is often reduced, so there’'s more
memory available for simultaneous processing of tools or multiple frames being rendered at once.

Caching Limits
The Caching Limits include options for Fusion’s RAM cache operation. Here, you can determine how
much RAM is allocated to the RAM cache for playing back comps in the viewer.

— Limit Caching To: This slider is used to set the percentage of available memory used for the
interactive tool cache. Available memory refers to the amount of memory installed in the computer.

When the interactive cache reaches the limit defined in this setting, it starts to remove lower
priority frames in the cache to clear space for new frames.
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— Automatically Adjust In Low Memory Situations: This checkbox will set the caching to adjust
when memory is low. The console will display any cache purges.

— Leave At Least X MBytes: This setting is used to set the hard limit for memory usage. No matter
what the setting of the Cache Limit, this setting determines the amount of physical memory
available for use by other applications. Normally, this value should not be smaller than 25 MBytes.
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The Memory preferences

Interactive Render

The Interactive Render option allows you to optimize Fusion's processing based on the amount of
RAM you have installed in your system.

— Simultaneous Branching: When checked, more than one tool will be processed at the same time.

Disable this checkbox if you are running out of memory frequently.

Final Render

These settings apply to memory usage during a rendering session, either preview or final, with no
effect during an interactive session.

— Render Slider: This slider adjusts the number of frames that are rendered at the same time.

— Simultaneous Branching: When checked, more than one branch of a node tree will be
rendered at the same time. If you are running low on memory, turn this off to increase

rendering performance.
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The Network preferences are only available in Fusion Studio. These preferences are used to set up
and control network rendering in Fusion Studio. The majority of settings are found in the Render

Manager dialog.
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The Network preferences

Submit Network Render Compositions

In these fields, you enter the Master Name and IP address of the computer that will manage all
network renders sent from this machine. If a standalone render master is in use on the network, these
fields may be pre-filled and may not be editable. This is done to prevent multiple unauthorized render
masters from being created by each person in a facility.

To re-enable editing of the master name and IP, create the environment variable FUSION_NO_
MANAGER and set the value to True. Check your operating system user guide for how to create

environment variables.

General

The General preferences are designed with the most used options at the top in the General section.

These options determine in what capacity the system is used during network rendering.

— Make This Machine a Render Master: When enabled, Fusion will accept network render
compositions from other computers and manage the render. It does not necessarily mean that this
computer will be directly involved in the render, but it will submit the job to the render nodes listed
in the Render Manager dialog.
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— Allows This Machine to Be Used as a Network Slave: When enabled, this computer can be used
as a Render node and will accept compositions for network rendering. Deselect it to prevent other

people from submitting compositions to render on this computer.

— Render on All Available Machines: Enable this checkbox to ignore groups and priorities
configured in the Render Manager. Compositions submitted from this computer for network
rendering will always be assigned to every available slave.

Email Notification

You can use the Email Notification section to set up who gets notified with status updates regarding
the render jobs and the network.

— Notify Options: These checkboxes cause emails to be sent when certain render events take place.
The available events are Queue Completion, Job Done, and Job Failure.

— Send Email to: Enter the address or addresses to which notifications should be sent. You separate
multiple addresses with a semicolon.

— Override Sender Address: Enter an email address that will be used as the sender address. If this
option is not selected, no sender address is used, which may cause some spam filters to prevent
the message from being delivered to the recipient.

Server Settings

This section covers Clustering and Network Rendering. For more information on these settings
and clustering, see Chapter 4, “Rendering Using Saver Nodes,” in the Fusion Reference Manual or
Chapter 66 in the DaVinci Resolve Reference Manual.

Path Maps are virtual paths used to replace segments of file paths with variables. For example,
define the path ‘movie_x' as actually being in X\Shows\Movie_X. Using this example, Fusion would
understand the path ‘movie_x\scene_5\ scan.000.cin’ as actually being X:\Shows\ Movie_X\scene_5\

scan.000.cin.

For Fusion Studio, there are two main advantages to virtual path maps instead of actual file paths.
One is that you can easily change the path to media connected to Loaders (for example, when moving
a comp from one drive to another), without needing to make any changes in the composition. The
other advantage is when network rendering, you can bypass the different OS filename conventions.

— Enable Reverse Mapping of Paths Preferences: This checkbox is at the top of the Path Map
settings. When enabled, Fusion uses the built-in path maps for entries in the path'’s settings
when applying mapping to existing filenames. The main benefit is for Fusion Studio. Enabling
this checkbox causes Loaders to automatically use paths relative to the location of the saved
composition when they are added to the Node Editor. For more information on using relative paths
for Loaders, see Chapter 42, “I/0 Nodes,” in the Fusion Reference Manual or Chapter 104 in the
DaVinci Resolve Reference Manual.

As with other preferences in Fusion Studio, paths maps are available in both Global and Composition
preferences. Global preferences are applied to all new compositions, while Composition path maps
are only saved with the current composition. Composition path maps will override Global path maps
with the same name.
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The Path Map preferences

The Global paths maps are divided into three sections:

— System Path Maps: The operating system determines system path maps, and they define
Fusion's global locations. You can override specific System path maps using the Defaults or current
Composition Path Map settings. If you change your mind at a later time, you are always able to
return to Fusion'’s “factory” defaults using the System path maps. There are several top-level path
maps established in the System Path Map settings.

The folder where Fusion saves all shared application data.
The folder where Fusion saves the public/shared document folder.
The nested LUTs path in the Defaults section, where Fusion saves LUTs.

The folder where Fusion Studio app is installed. For example, if you open Fusion from C:\
Program Files\Fusion, then the path Fusion:\Help refers to C:\Program Files\Fusion\Help. If you
instead used a copy of Fusion found in \\post-server\fusion\16, then Fusion:\Help would expand to
\\post-server\fusion\16\Help.

The Fusion libraries used for the application.
The folder where default Fusion preferences file is saved.

The folder where Fusion individual user preferences are saved.
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The location of Fusion Studio or DaVinci Resolve.
The folder where the OS saves fonts that appear for Text+ and Text 3D nodes.
The system'’s temporary folder.

The folder where Fusion saves all user-specific miscellaneous roaming data.
The individual elements included in the roaming data are listed in the Default Path Maps section.
For Fusion Studio on Windows, this is “C:\Users\username\AppData\Roaming\". On Linux, this will
be “$HOME/Blackmagic/Fusion”. On macOS, this is “Users/UserName/Library/Application Support/
Blackmagic Design/Fusion”.

The folder where Fusion saves the user’s document folders.

Default Path Maps: The Defaults are user-editable path maps. They can reference the System
paths, as part of their paths. For instance. the Temp folder is defined in the System path and used
by the Default DiskCache path map to refine the nested location (Temp:DiskCache). Default path
maps can also redirect paths without using the Global System path maps. After you change a
Default, the updated setting can be selected in the Preferences window, and a Reset button at the
bottom of the Preferences window will return the modified setting to the System default.
This setting determines the Fusion Comp AutoSave document’s location, set in the
Fusion General preferences.
Sets the location of Fusion Studio bins. Since the bins use pointers to the content, the content
is not saved with the bin. Only the metadata and pointers are saved in the bins.
Points Fusion to the folder that contains custom paintbrushes.
The folder where Fusion Studio compositions are saved. On macOS or Windows, the
default location is in Users/YourUserName/Documents/Blackmagic Design/Fusion.
Stores Configuration files used by Fusion Studio during its operation.
Identifies the location of node default settings so they can be restored if overwritten.
Sets the location for files written to disk when using the Cache to Disk feature. This
location can be overridden in the Cache to Disk window.
The location where Fusion macros are saved in order to appear as templates in
the DaVinci Resolve Effects Library.
Points to a folder containing Convolution filters like sharpen, which can be used for the
Custom Filter node.

The default path map for Fonts points to the operating system fonts folders. Changing this
will change the fonts that are available in the Text+ or Text 3D nodes as well as any Fusion Title
Template. In DaVinci Resolve. This path map does not affect the five additional Edit page titles
(L Lower 3rd, R Lower 3rd, M Lower 3rd, Scroll, and Text.)

Points to a folder containing Fusion Fuses plugins.

Location where Fusion macros are saved in order to appear as templates in
Fusion's Effects Library.
Location where custom viewer guide overlays are stored.
Identifies where Fusion Studio PDF files are located.
Location where Fusion Studio custom window layouts are saved.
Points to a support folder where custom Effects Library items can be stored.

The Fusion Studio Loader preferences allow the Loader to cache when reading from
a slow network. This path map point to the local drive location for that cache.

Location for Lua Scripting modules.

Points to a folder containing Look Up Tables (LUTSs).
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Points to the location for user created macros. The macros saved to this location appear in
the macros category of the Effects Library and in the right-click Edit Macro contextual menu.
This refers to user specific OpenFX plugins that you do not want loaded for all users.
Path map used for the older style, file sequence flipbook previews.
Location of the Render manager list.
Location of Lua and Python scripts. This path can be further refined into specific scripts
for tools (nodes), comps, and other specific script types.
Location where custom Node settings are saved.
Location for preview movies generated in a Fusion Studio bin. This is an outdated path
map since bins now include the Studio Player.

Location of the Templates folder. Saving Macros to the Template folder will cause them
to appear in the Effects Library in a Templates category. In Fusion Studio, the Templates category
does not appear until a Macros is saved into the folder.

Location for clip thumbnails generated in a Fusion Studio bin. This is an outdated path
map since bins include now include the Studio Player.

Used for locations of studio- or facility-specific tools, like custom plugins and scripts
located on a central server.

— User Path Maps: User paths are new paths that you have defined that do not currently exist in the
Defaults settings.

— Comp refers to the folder where the current composition is saved. For instance, saving media
folders within the same folder as your Fusion Studio comp file is a way to use relative file paths
for Loaders instead of actual file paths.

Modifying a System Path Map

To modify an existing System path map, select the path map in the System section. Click the folder
icon at the bottom of the Preferences window, and enter the name of the path map in the From field
below. Enter the value of the path map in the To: field.

Modifying a Default Path Map

To modify an existing Default path map, select the path map in the Default section. Click the folder
icon at the bottom of the Preferences window, and enter the name of the path map in the From field
below. Enter the value of the path map in the To: field.

Creating a User Path Map

To create a path map, click on the New button and enter the name of the path map in the From field
below. Enter the value of the path map in the To: field.

Deleting a Path Map

To delete a user-created path map, select it from the list and click the Delete button. System and
Default path maps cannot be deleted; only user created path maps can be removed from the
Path Maps list.

Nesting Path Maps

When defining your own path map, you can use an existing path map in the new definition.
For example, define a path map called ‘Episode’ that maps to MyDrive\ Projects\Episodel. Then create
new path maps called Renders and Stills that map to Episode\ Renders_v1 and Episode\Stills_v1.
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Preview is only available in Fusion Studio. Previews in DaVinci Resolve use the Scratch Disk setting in
the Media Storage preferences.

In the Preview preferences, you configure the creation and playback options for preview renders.
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The Preview preferences

Options
— Render Previews Using Proxy Scaling: When checked, this option scales down the images to the

preview size for the Loader and Creator tools. This causes much faster rendering. If this option is
disabled, frames will be rendered at full size and are then scaled down.

— Skip Frames to Maintain Apparent Framerate: When checked, frames are skipped during

playback of Flipbooks and file sequences to maintain the frame rate setting.

— Show Previews for Active Loaders: This setting determines whether the preview playback
controls are shown below the Inspector when a Loader with a valid file is activated.

— Show Previews for Active Savers: This setting determines whether the preview playback controls

below the Inspector are shown when a Saver with a valid file is activated.

— Display File Sequences On: This setting determines which viewer or external monitor is used for
the interactive and file sequence playbacks as well as for the scrubbing function in the bins.
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The QuickTime preferences are only available in Fusion Studio on macOS. These settings configure
the default QuickTime codec settings when you select QuickTime as the rendering file format in the
Saver node.

Preferences

QuickTime video compression options

QuickTime

The QuickTime preferences

— Compressor: This drop-down menu displays the QuickTime codecs available from your computer.
Fusion tests each codec when the program is started; therefore, some codecs may not be available
if the tests indicate that they are unsuitable for use within Fusion.

— Quality: This slider is used to determine the amount of compression to be used by the codec.
Higher values produce clearer images but larger files. Not all codecs support the Quality setting.

— Key Frame Every X Frames: When checked, the codec will create key frames at specified intervals.
Key frames are not compressed in conjunction with previous frames and are, therefore, quicker to
seek within the resulting movie. Not all codecs support the key frame setting.

— Limit Data Rate To X KB/Second: When checked, the data rates of the rendered file will be limited
to the amount specified. Not all codecs support this option. Enter the data rate used to limit the
QuickTime in kilobytes (kB) per second, if applicable. This control will have no effect if the Limit Data
Rate To option is not selected.
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The preferences for Scripting include a field for passwords used to execute scripts from the command
line and applications for use when editing scripts.
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The Script preferences

Login

There are three login options for running scripts outside of the Fusion application.

— No Login Required to Execute Script: When enabled, scripts executed from the command line, or
scripts that attempt to control remote copies of Fusion, do not need to log in to the workstation in
order to run.

— Specify Custom Login: If a username and password are assigned, Fusion will refuse to process
incoming external script commands (from FusionScript, for example), unless the Script first logs in
to the workstation. This only affects scripts that are executed from the command line, or scripts
that attempt to control remote copies of Fusion. Scripts executed from within the interface do not
need to log in regardless of this setting. For more information, see the Scripting documentation.

— Use Windows Login Validation: When using Fusion on Windows, enabling this option verifies
the user name and password (also known as credentials) with the operating system before running

the script.
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Options

— Script Editor: Use this preference to select an external editor for scripts. This preference is used
when selecting Scripts > Edit.

Python Version

— Two options are presented here for selecting the version of Python that you plan on using
for your scripts.

The Spline Editor preferences allow you to set various spline options for Autosnap behavior, handles,
markers, and more. This only affects splines displayed in the Spline Editor, not splines created in the
viewer using the polygon tool or paths.
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Spline Editor

The Spine Editor preferences

Spline Editor Options

These settings control the spline behavior in the Spline Editor, as well as the appearance of the

graph area.

— Independent Handles: Enabling this option allows the In or Out direction handle on newly created
key frames to be moved independently without affecting the other. This option is also available via
the Options submenu when right-clicking in the Spline Editor graph.
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— Follow Active: The Spline Editor focuses on the currently active tool. This option is also available
via the Options submenu when right-clicking in the Spline Editor graph.

— Show Key Markers: Small colored triangles will be displayed at the top of the Spline Editor
Time Ruler to indicate key frames on active splines. The colors of the triangles match the colors
of the splines. This option is also available via the Show submenu when right-clicking in the Spline
Editor graph.

— Show Tips: Toggles if tooltips are displayed or not. This option is also available via the Show

submenu when right-clicking in the Spline Editor graph.

— Autosnap Points: When moving points in the Spline Editor, these will snap to the fields or frames
or can be moved freely. This option is also available via the Options submenu when right-clicking in
the Spline Editor graph.

— Guides: When moving points in the Spline Editor, these will snap to guides as well. This option is
also available via the Options submenu when right-clicking in the Spline Editor graph.

— Autosnap Guides: When moving or creating guides, these will snap to the fields or frames or can
be moved freely. This option is also available via the Options submenu when right-clicking in the
Spline Editor graph.

— Autoscale: Keeps the Spline Editor scales intact on changing the editable spline content of the
graph. This scale is also available via the Options submenu when right-clicking in the Spline
Editor graph.

— Scroll: Scrolls horizontally and vertically to show all or most of the spline points. This option is also
available via the Scale submenu when right-clicking in the Spline Editor graph.

— Fit: Zooms to fit all points within the spline graph, if necessary. This option is also available via the
Scale submenu when right-clicking in the Spline Editor graph.

LUT View Options

These settings let you control how the LUT view is displayed.

— Independent Handles: Enabling this option allows the In or Out direction handle on newly created
key frames to be moved independently without affecting the other.

— Show Key Markers: Small colored triangles will be displayed at the top of the Spline Editor Time
Ruler to indicate key frames on active splines. The colors of the triangles match the colors of
the splines.

— Show Tips: Toggles whether tooltips are displayed.

Options for the handling and smoothing of animation splines, tracker path defaults, and rotoscoping
are found in the Splines preferences.

— Autosmooth: Automatically smooths out any newly created points or key frames on the splines
selected in this section. You can choose to automatically smooth animation splines, B-Splines,
polyline matte shapes, LUTs, paths, and meshes.

— B-Spline Modifier Degree: This setting determines the degree to which the line segments
influence the resulting curvature when B-Splines are used in animation. Cubic B-Splines determine
a segment through two control points between the anchor points, and Quadratic B-Splines
determine a segment through one control point between the anchor points.
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— B-Spline Polyline Degree: This setting is like the one above but applies to B-Splines
used for masks.
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The Splines preferences

— Tracker Path Points Visibility: This setting determines the visibility of the control points on
tracker paths. You can show them, hide them, or show them when your cursor hovers over the
path, which is the default behavior.

— Tracker Path: The default tracker creates Bézier-style spline paths. Two other options in this
setting allow you to choose B-Spline or XY Spline paths.

— Polyline Edit Mode on Done: This setting determines the state of the Polyline tool after you
complete the drawing of a polyline. It can either be set to modify the existing control points on the
spline or modify and add new control points to the spline.

— Onion Skinning: The Onion Skinning settings determine the number of frames displayed while
rotoscoping, allowing you to preview and compare a range of frames. You can also adjust if the
preview frames only from the frame prior to the current frame, after the current frames, or split
between the two.
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The Timeline preferences is where you create and edit Keyframes Editor/Spline Editor filters and set
default options for the Keyframes Editor.
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The Timeline preferences

Filter/Filter to Use

The Filter menu populates the hierarchy area below the menu with that setting. It lets you edit the filters.
The Filter to Use menu selects the default filter setting located in the Keyframes Editor Options menu.

Settings for Filters

This area is used to create a new filter and define its settings. You start by first clicking the New button
and entering the name of the new Filter. You then select any of the tools that you want the filter to
contain. Only tools that are checked will appear in the Keyframes Editor or Spline Editor when the filter
is selected. You can also create a copy of the filter using the Copy button or remove a filter from the
list by clicking the Delete button.

Timeline Options

The Timeline Options configure which options in the Keyframe Editor are enabled by default. A series
of checkboxes correspond to buttons located in the Timeline, allowing you to determine the states
of those buttons at the time a new comp is created. For more information on the Keyframes Editor
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functions, see Chapter 9, “Animating in Fusion’s Keyframes Editor,” in the Fusion Reference Manual or
Chapter 71 in the DaVinci Resolve Reference Manual..

— Autosnap Points: When moving points in the Keyframes Editor, the points will snap to the fields or
to the frames, or they can be moved freely.

— Guides: When moving points in the Keyframes Editor, the point will snap to the guides that are
placed in the Timeline graph.

— Autosnap Guides: When moving or creating guides, the guides will snap to the fields or to the

frames, or they can be moved freely.

— Autoscale: Keeps the Timeline scales intact while changing the editable spline content in the
graph. When set to scroll, the Timeline scrolls horizontally and vertically to show all or most of the
spline points when changing the editable spline content in the graph. When set to Fit, the Timeline
zooms to fit all points within the graph, if necessary.

— Tools Display Mode: This menu controls the default sort order of the tools displayed in the
Keyframes Editor. The default can be changed using the Sort order menu in the upper right of the
Keyframes Editor.

The Tweaks preferences handle a collection of settings for fine-tuning Network rendering in Fusion
Studio and graphics hardware behavior.
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Network

The Network section is used to control and monitor the health of communication packets over TCP/IP

when rendering over a network in Fusion Studio.

— Maximum Missed Heartbeats: This setting determines the maximum number of times the
network is checked before terminating the communication with a Render node.

— Heartbeat Interval: This sets the time between network checks.

— Load Composition Timeout: This timeout option determines how long the Render Manger will
wait for a composition to load before moving on to another task.

— Last Slave Restart Timeout: This timeout option determines how long the Render Manager will
wait for a render salve to respond before using another render slave.

File 170

The File I/0 options are used to control the performance when reading frames or large media files
from both direct and networked attached storage.

— I/0 Canceling: This option enables a feature of the operating system that allows queued
operations to be canceled when the function that requested them is stopped. This can improve the
responsiveness, particularly when loading large images over a network.

Enabling this option will specifically affect performance while loading and accessing formats that

perform a large amount of seeking, such as the TIFF format.

This option has not been tested with every hardware and OS configuration, so it is recommended
to enable it only after you have thoroughly tested your hardware and OS configuration using drive
loads from both local disks and network shares.

— Enable Direct Reads: Enabling this checkbox uses a more efficient method when loading a large
chunk of contiguous data into memory by reducing 1/0 operations. Not every operating system
employs this ability, so it may produce unknown behavior.

— Read Ahead Buffers: This slider determines the number of 64K buffers that are use to read ahead
in a file I/O operation. The more buffers, the more efficient loading frames from disk will be, but
the less responsive it will be to changes that require disk access interactively.

Area Sampling

The Area Sampling options allow you to fine-tune the RAM usage on Render nodes by trading off
speed for lower RAM requirements.

— Automatic Memory Usage: This checkbox determines how area sampling uses available memory.
Area sampling is used for Merges and Transforms. When the checkbox is enabled (default), Fusion
will detect available RAM when processing the tool and determine the appropriate trade-off
between speed and memory.

If less RAM is available, Fusion will use a higher proxy level internally and take longer to render.
The quality of the image is not compromised in any way, just the amount of time it takes to render.
In node trees that deal with images larger than 4K, it may be desirable to override the automatic
scaling and fix the proxy scale manually. This can preserve RAM for future operations.

— Pre-Calc Proxy Level: Deselecting the Automatic Memory will enable the Pre-Calc Proxy Scale
slider. Higher values will use less RAM but take much longer to render.
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Open GL

This section controls how Fusion makes use of your graphics card when compositing in 3D with the
Renderer 3D node. Most settings may be left as they are, but since OpenGL hardware varies widely in
capabilities and different driver revisions can sometimes introduce bugs, these tweaks can be useful if

you are experiencing unwanted behavior.

— Disable View LUT Shaders: OpenGL shaders can often dramatically accelerate View LUTs, but this

can occasionally involve small trade-offs in accuracy. This setting will force Fusion to process LUTs
at full accuracy using the CPU instead. Try activating this if View LUTs do not seem to be giving the
desired result.

— Use Float16 Textures: If your graphics hardware supports 16-bit floating-point textures,
activating this option will force int16 and float32 images to be uploaded to the viewer as float16
instead, which may improve playback performance.

— Texture Depth: Defines in what depth images are uploaded to the viewer.

The Auto option (recommended) lets Fusion choose the best balance of performance and
capability.

Similar to the Use Float16 Textures switch, this option can be used to force images to be
uploaded to the Display View as int8, which can be faster but gives less range for View LUT
correction.

The Native option uploads images at their native depth, so no conversion is done.

— Image Overlay: The Image Overlay is a viewer control used with Merge and Transform tools
to display a translucent overlay of the transformed image. This can be helpful in visualizing the
transformation when it is outside the image bounds but may reduce performance when selecting
the tool if cache memory is low. There are three settings to choose from: None, Outside, and All.

This setting never displays the translucent overlay or controls, which can reduce the need
for background renders, in some cases resulting in a speed up of the display.
This will display only those areas of the control that are outside the bounds of the image,
which can reduce visual confusion.

Displays all overlays of all selected tools.

— Smooth Resize: This setting can disable the viewer’s Smooth Resize behavior when displaying
floating-point images. Some older graphics cards are not capable of filtering floating-point
textures or may be very slow. If Smooth Resize does not work well with float images, try setting this
to flt16 or int.

— Auto Detect Graphics Memory (MB): Having Fusion open alongside other OpenGL programs
like 3D animation software can lead to a shortage of graphics memory. In those cases, you can
manually reduce the amount of memory Fusion is allowed to use on the card. Setting this too low
or too high may cause performance or data loss.

— Use 10-10-10-2 Framebuffer: If your graphics hardware and monitor support 30-bit color (Nvidia
Quadro/AMD Radeon Pro, and some Nvidia GeForce/AMD Radeon), this setting will render viewers
with 10 bits per primary accuracy, instead of 8 bits. Banding is greatly reduced when displaying 3D
renders or images deeper than 8-bit.
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The User Interface preferences set the appearance of the user interface window and how the
Inspector is displayed.
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The User Interface preferences

Appearance

When enabled, the Use Gray Background Interface checkbox will change the color of the background
in Fusion’s panels to a lighter, more neutral shade of gray.

Controls

This group of checkboxes manages how the controls in the Inspector are displayed.

— Auto Control Open: When disabled, only the header of the selected node is displayed in the
Inspector. You must double-click the header to display the parameters. When enabled, the
parameters are automatically displayed when the node is selected.

— Auto Control Hide: When enabled, only the parameters for the currently active tool (red outline)
will be made visible. Otherwise, all tool headers will be visible and displayed based on the Auto
Control Open setting.
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— Auto Control Close Tools: When enabled, only the active (red outlined) tool in the Node Editor
will have controls displayed. Any previous active node's tools will be closed in the Inspector. When
disabled, any number of tools may be opened to display parameters at the same time. This setting
has no effect if the Auto Control Hide checkbox is enabled.

— Auto Control Close Modifiers: When enabled, only one modifier's parameters will be displayed for
the active node. Any additional modifiers for the active node will show only their header.

— Auto Control Advance: If the Auto Control Advanced checkbox is enabled, the Tab key and Return/

Enter key will cause the keyboard focus to advance to the next edit box within the Inspector.
When disabled, Return/Enter will cause the value entered to be accepted, but the keyboard
focus will remain in the same edit box of the control. The Tab key can still be used to advance the
keyboard focus.

— Show Controls for Selected: When this option is disabled, only the active tool's parameters are
shown in the Inspector. By default, it is enabled, showing controls for the active tool as well as all
selected tools.

— Combined Color Wheel: When the Color Corrector tool is displayed in the Inspector, enabling this
checkbox will show one color wheel with buttons to switch between the master, shadow, midtones,
and highlight channels. Otherwise, four color wheels are displayed in the Inspector.

— Gamma Aware Color Controls: This setting adjusts color correction nodes when working with
Rec. 709 images in a non-color managed project. Rec. 709 images appear correct on the computer
monitor because monitors have a gamma adjustment built in. When working in the Rec. 709 color
space without color management, enabling Gamma Aware color removes the gamma, applies the
color correction as if it where linear, and then reapplies the gamma. For Rec. 709 images, enable
the Gamma Aware setting and enter a Gamma value of 2.4. In a color managed linear project,
this should be set to Off or a value of 1.0. When dealing with mixed color spaces, Fusion reads the
metadata from the image and sets the Aware gamma value based on the metadata available.

— Grab Distance: This slider ranges from 1 to 10 and defaults to 5. It designates the active area
around the mouse pointer and can be modified if you have difficulties in selecting points for
modification in paths and spline curves. Smaller values will require a more accurate selection with
the mouse pointer.

Touch Scrolling and Mouse Wheel

This group of settings allows you to configure which, if any, keyboard modifiers are needed to pan or
zoom a panel when using a trackpad or middle mouse wheel.

This setting is only available in Fusion Studio. Control over video hardware for the Fusion Page is
done in the DaVinci Resolve preferences. The Video Monitoring preferences are used to configure
the settings of Blackmagic Design capture and playback products such as DeckLink PCle cards and
UltraStudio i/0 units.
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The Video Monitoring preferences

Video Output

This group of drop-down menus allows you to select the type of video /O device you have installed,
the output resolution, and the pixel format. These settings have nothing to do with your rendered

output; it is only for your display hardware.

The Output HDR over HDMI settings are used to output the necessary metadata when sending high
dynamic range signals over HMDI 2.0a and have it correctly decided by an HDR capable video display.

The Auto setting detects the image’'s values and outputs HDR. This will not affect non HDR images.

The Always setting forces HDR on all the time. This can can be useful when checking non HDR and
HDR grades.

When Auto or Always is selected, you can then set the “nit” level (slang for cd/m?) to whatever peak
luminance level your HDMI connected HDR display is capable of.

Stereo Mode

This group of settings configures the output hardware for displaying stereo 3D content.

— Mono will output a single non stereo eye.

— Auto will detect which method with which the stereo images are stacked.
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— Use the Vstack option if the stereo images are stacked vertically as left on top and right at the bottom.
— Use the Hstack option if the stereo images are stacked horizontally as left and right.

The Swap eyes checkbox will swap the eyes if stereo is reversed.

The View preferences are used to manage settings and default controls for viewers.
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The View preferences

Saved View Settings

The area at the top of the view preferences lists the currently saved settings that you create

from the viewer’s contextual menu. You can use the Rename and Delete buttons to manage the
selected entries in the list. For more information on the viewer and its contextual menu,

see Chapter 7, “Using Viewers,” in the Fusion Reference Manual or Chapter 69 in the DaVinci Resolve
Reference Manual.

Settings for View

Each viewer has its own preferences. The Settings for View drop-down menu is used to select the

viewer you want to configure.
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Control Colors

The Control Colors setting allows you to determine the color of the active/inactive onscreen controls.

Color Picking Area Size

You can use these width/height controls to set the number of pixels sampled when using the Color

Picker in the viewers.

Displayed Depth Range

The Displayed Depth Range setting controls the view normalization of the Z-Channel.

Fit Margin
The Fit Margin setting determines how much padding is left around the frame when the Fit button is
pressed or Fit is selected from the viewer's contextual menu.

— Display LUT Plugins

This list shows the available display LUTs and activates the selected one as default.

The VR Headsets preferences allow configuration of any connected Virtual Reality headsets, including

how stereo and 3D scenes are viewed.
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The VR Headsets preferences

Preferences 374



Headset Options
The Headset options are used to select the type of VR headset you are using to view the composite as
well as the video layout of the 360° view.
API
— Disabled: Disabled turns off and hides all usage of headsets.
— Auto: Auto will detect which headset is plugged in.
— Oculus: Oculus will set the VR output to the Oculus headset.

— OpenVR: OpenVR will support a number of VR headsets like the HTC Vive.

360° Video Format
— Auto: Auto will detect the incoming image layout from the metadata and image frame aspect.

— VCross and HCross: VCross and HCross are the six square faces of a cube laid out in a cross,
vertical or horizontal, with the forward view in the center of the cross, in a 3:4 or 4.3 image.

— VStrip and HStrip: VStrip and HStrip are the six square faces of a cube laid vertically or
horizontally in a line, ordered as Left, Right, Up, Down, Back, Front (+X, -X, +Y, -Y, +Z, -Z),
ina 1:6 or 6:1image.

— LatLong: LatLong is a single 2:1 image in equirectangular mapping.

— Enable Mirror Window: Enable Mirror Window will show a window displaying the headset
user’s live view.

Stereo
Similar to normal viewer options for stereo 3D comps, these preferences control how a stereo 3D
comp is displayed in a VR headset.
Mode
— Mono: Mono will output a single non stereo eye.
— Auto: Auto will detect the method with which the stereo images are stacked.
— Vstack: Vstack stereo images are stacked vertically as left on top and right at the bottom.
— Hstack: Hstack stereo images are stacked horizontally as left and right.

— Swap Eyes: Swap eyes will swap the eyes if stereo is reversed.

3D
Similar to normal viewer options for 3D comps, these preferences control how a 3D comp is displayed
in a VR headset.
Light
— Disabled lighting is off.
— Auto will detect if lighting is on in the view.

— On will force lighting on in the VR view.

Sort Method
— Z buffer sorting is the fast OpenGL method of sorting polygons.
— Quick Sort will sort the depth of polygons to get better transparency rendering.
— Full Sort will use a robust sort and render method to render transparency .
— Shadows can be on or off.

— Show Matte Objects will make matte objects visible in view or invisible.
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Bins preferences are only available in Fusion Studio. These preferences are used to manage the Bin
users and their permissions.

Preferences

Permissions

Security

The Bins Security preferences

Users List

The Users List is a list of the users and their permissions. You can select one of the entries to edit their
settings using the User and Password edit boxes.

— Add: The Add button is used to add a new user to the list by entering a username and password.

— Remove: Click this button to remove the selected entry.

User

This editable field shows the username for the selected Bin Server item. If the username is unknown,
try "Guest” with no password.

Password

Use this field to enter the password for the Bin user entered in the Users list.

Preferences

376




Permissions

The administrator can set up different permission types for users.

— Read: This will allow the user to have read-only permission for the bins.
— Create: This will allow the user to create new bins.

— Admin: This gives the user full control over the bins system.

— Modify: This allows the user to modify existing bins.

— Delete: This allows the user to remove bins.

These preferences are used to add Bin Servers to the list of bins Fusion will display in the Bins dialog.

Preferences

Servers

Servers

The Bin Servers preferences

Servers
This dialog lists the servers that are currently in the connection list. You can select one of the entries

to edit its settings.

— Add: Use this button to add a new server to the list.

— Remove: Click this button to remove the selected entry.
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Server

This editable field shows the name or IP address of the server for the selected entry in the list.

User

This editable dialog shows the username for the selected Bin Server item.

Password

Use this field to enter the password for the server entered in the Server list.

Library

The Library field lets you name the bins. If you wanted to create a bin for individual projects, you
would name it in the Library field and each project would gets its own bin.

Application
The Application field allows larger studios to specify some other program to serve out the
Bin requests.

These preferences are used to control the default behavior of bins.

Preferences

Stamp quality

Stamp format

Uncompressed

Options

Settings

The Bins Settings preferences
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Stamp Quality

The Stamp Quality is a percentage slider that determines the compression ratio used for Stamp
thumbnail creation. Higher values offer better quality but take up more space.

Stamp Format

This drop-down list determines whether the Stamp thumbnails will be saved as compressed or
uncompressed.

Options
— Open Bins on Startup: When Open Bins on Startup is checked, the bins will open automatically
when Fusion is launched.

— Checker Underlay: When the Checker Underlay is enabled, a checkerboard background is used for
clips with alpha channels. When disabled, a gray background matching the Bin window is used as
the clip’s background.

The EDL Import options are used to determine how compositions are created from imported
CMX-formatted EDL files.

Preferences

Import properties

Loader Per Clip

The EDL Import preferences
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Flow Format

This drop-down menu provides three options that determine how the node tree is constructed for the
imported EDL file.

— Loader Per Clip: A Loader will be created for each clip in the EDL file.
— A-B Roll: A node tree with a Dissolve tool will be created automatically.

— Loader Per Transition: A Loader with a Clip list will be created, representing the imported EDL list.

Use Shot Names

When checked, shot names stored in the EDL file are used to locate the footage.

Customization

The following section covers the customization of preferences that are not technically part of

the Preferences window. Using Fusion Studio’s Hotkey Manager window, you can customize the
keyboard shortcuts, making the entire process of working in Fusion not only faster but potentially
more familiar if you are migrating from another software application. You can also customize Fusion
with environment variables to switch between different preferences files, allowing different working
setups based on different users or job types. Both of these customization options are only available in
Fusion Studio.

Keyboard shortcuts can be customized in Fusion Studio. You can access the Hotkey Manager by
choosing Customize HotKeys from the View menu.

Hotkey Manager

Display

The Hotkey Manager
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Fusion has active windows to focus attention on those areas of the interface, like the Node Editor,
the viewers, and the Inspector. When selected, a gray border line will outline that section. The

shortcuts for those sections will work only if the region is active. For example, Command-F in the
View will scale the image to fit the view area; in the Flow view, Command-F will open the Find tool

dialog; and in the Spline editor, it will fit the splines to the window.

On the right is a hierarchy tree of each section of Fusion and a list of currently set hotkeys. By
choosing New or Edit, another dialog will appear, which will give specific control over that hotkey.

Edit Hotkey

Add v Pressed

1414214

Scale by 141%

> Viewer

The Hotkey Editor

Creating a new keyframe will give you the key combo to press, and this Edit Hotkey dialog will
appear where the Action can be defined at top right: pressed, repeated, or released. The Name and
abbreviated Short Name can be set, as can the Arguments of the action.

Fusion Studio’s preferences configure Fusion's overall application default settings and settings for
each new composition. Although you access and set these preferences through the Preferences
window, Fusion saves them in a simple text format called Fusion.prefs.

These default preferences are located in a \Profiles\Default folder and shared by all Fusion users on
the computer. However, you may want to allow each user to have separate preferences and settings,
and this requires saving the preferences to different locations based on a user login.

To change the saved location of the preferences file requires the use of environment variables.

Setting the Preferences Location

When you fist open Fusion, the environment variable FUSION_PROFILE_DIR defines the folder that
contains the Profiles folder. If this variable defines a valid path, then the preferences are saved to this
folder. If the FUSION_PROFILE_DIR does not exist, then Fusion attempts to create it. If it cannot create
the path, then the preferences are stored in the default Path Map location: AllData:\Profiles.

Typically, all users share the same preferences.If you want each user to save separate preferences
within their home folder, you must create another environment variable with the name
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FUSION_PROFILE (e.g., FUSION_PROFILE=jane). Using this second environment variable, Fusion will
look for the preferences in the PROFILE_DIR of the user profile. Using a login script, you can make sure
the FUSION_PROFILE is set to the name of the logged in user.

Creating a Master Preferences File

When working with multiple Fusion users in a studio, you may want to standardize on a few settings.
Using the FUSION_MasterPrefs environment variable, you can create one or more site-wide

preferences in addition to your local personal preferences.

FUSION_MasterPrefs must contain the full path to at least one preferences file. If you have multiple
preferences paths, separate them using semicolons. Fusion does not write to these prefs files, and
they may contain a subset of all available settings. You may change settings in these files and use
them only where local prefs do not already exist unless you set the Locked flag.

Locking Preferences

If the line “Locked = true,” appears in the main table of a master file, all settings in that file are locked
and override any other preferences. Locked preferences cannot be altered by the user.
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2D Compositing
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Controlling
Image Processing
and Resolution

This chapter covers the overall image-processing pipeline.
It discusses color bit-depth and how to control the output
resolution in a resolution-independent environment.
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Fusion’s Place in the DaVinci Resolve
Image-Processing Pipeline

When working in a single unified environment like DaVinci Resolve, it is important to understand the
order of operations among the pages. DaVinci Resolve exposes some of this via the order of the page
buttons at the bottom of the screen, with the Media, Cut, and Edit page at the beginning of the chain
and the Color, Fairlight, and Deliver page at the end. However, this isn't the whole story, especially
when it comes to the Fusion page. The following sections describe where the Fusion page fits in the

image-processing chain of DaVinci Resolve.

For ordinary, single clips coming in from the Edit or Cut page, the Medialn node in the Fusion page
represents the source media, as modified by the Clip Attributes window. Although you select the clip
from the Edit or Cut page Timeline, in the Fusion page, the clip is accessed from the Media Pool.

TIP: The decoding or debayering of RAW files occurs prior to all other operations, and as

such, any RAW adjustments will be displayed correctly in the Fusion page.

This means you have access to the entire source clip in the Fusion page, but the render range is set
to match the duration of the clip in the Timeline. You also use the full resolution of the source clip,
even if the Timeline is set to a lower resolution. However, none of the Edit or Cut page Inspector
adjustments carry over into the Fusion page, with the exception of the Lens Correction adjustment.

When you make Zoom, Position, Crop, or Stabilization changes in the Edit or Cut page, they are not
visible in the Fusion page. The same applies to any Resolve FX or OpenFX third-party plugins. If you
add these items to a clip in the Edit or Cut page, and then you open the Fusion page, you won't

see them taking effect. All Edit and Cut page timeline effects and Inspector adjustments, with the
exception of the Lens Correction adjustment, are computed after the Fusion page but before the
Color page. If you open the Color page, you'll see the Edit and Cut page transforms and plugins
applied to that clip, effectively as an operation before the grading adjustments and effects you apply

in the Color page Node Editor.

With this in mind, the order of effects processing in the different pages of DaVinci Resolve can be

described as follows:

TIP: Retiming applied to the clip in the Edit page Timeline is also not carried over into the

Fusion page.
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There is a way you can force clips with Edit page Inspector adjustments, plugins, retiming, and Color
page grades into the Fusion page, and that is to turn that clip into a compound clip. When Edit page
effects and Color page grading are embedded within compound clips, Medialn nodes corresponding
to compound clips route the effected clip into the Fusion page. However, bringing a compound clip
into the Fusion page does change the resolution of the source clip to match the Timeline resolution.
For more information, see the section “Sizing Between DaVinci Resolve Pages” in this chapter.

The composition output from the Fusion page’s MediaOut node are passed on via the Color page’s
source input, with the sole exception that if you've added plugins to that clip in the Edit or Cut page,
then the handoff from the Fusion page to the Color page is as follows:

What Viewers Show in Different
DaVinci Resolve Pages

Owing to the different needs of compositing artists, editors, and colorists, the viewers show different
states of the clip.

— The Edit page source viewer: Always shows the source media, unless you're opening a compound
clip that's been saved in the Media Pool. If Resolve Color Management is enabled, then the Edit

page source viewer shows the source media at the Timeline color space and gamma.

— The Edit page Timeline viewer: Shows clips with all Edit page effects, Color page grades,
and Fusion page effects applied, so editors see the program within the context of all effects
and grading.

— The Fusion page viewer: Shows Media Pool source clips at the Timeline color space and gamma,
including Resolve Color Management adjustments. but no Edit page Inspector adjustments or
Resolve FX effects and no Color page grades.

— The Color page viewer: Shows clips with all Edit page effects, Color page grades, and Fusion page
effects applied.

Controlling Image Processing and Resolution 386




Managing Resolution In Fusion

There is no formal resolution to a comp in Fusion. Even though opening Fusion > Fusion Settings in
the Fusion page or Preferences in Fusion Studio allows you to set the Width and Height in the Frame
Format panel, those settings only affect the size of Fusion-generated images, like the Background
tool, Fast Noise, and Text+ tool. The actual resolution of your composition is initially determined by
the source resolution of the input image. However, it can be modified at any time using a variety of
operations and nodes.

For example, if you read in a full HD 1920 x 1080 resolution image, your comp starts at full HD 1920 x
1080 resolution. This is regardless of the Timeline resolution when you are using the Fusion page in

DaVinci Resolve. The initial resolution of the Fusion comp is the size of the source media. Depending

on how you combine images and the nodes you use, the output comp resolution can be maintained

or modified.

TIP: The output of the Fusion page is placed back into the Edit page Timeline based on
DaVinci Resolve's Image Sizing setting. By default, DaVinci Resolve uses an image sizing
setting called Scale to Fit. This means that even if the Fusion page outputs a 4K composition,
it conforms to 1920 x 1080 if that is what the project or a particular Timeline is set to.
Changing the image sizing setting in DaVinci Resolve’s Project Settings affects how Fusion
compositions are integrated into the Edit page Timeline.

If your comp uses a single image, you can change the pixel output resolution in several ways. Three
common tools that change the pixel resolution of a clip are the Resize, Scale, and Crop nodes. A fourth
node, Letterbox, is less commonly used but also changes the pixel resolution of a clip.

These four nodes are located in the Transform category of the Effects library. Resize is also located in
the toolbar.

— Crop: Sets the output resolution of the node using a combination of X and Y size along with X and
Y offset to cut the frame down to the size you want. Crop removes pixels from the image, so if you
later use a Transform node and try to move the image, those pixels are not available.

— Letterbox: Sets the output resolution of the node by adding horizontal or vertical black edges

where necessary to format the frame size and aspect ratio.
— Resize: Sets the output resolution of the node using absolute pixels.

— Scale: Sets the output resolution of the node using a relative percentage of the current input
image size.

TIP: To change resolution and reposition a frame without changing the pixel resolution of a
clip, use the Transform node.
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When you composite images with different resolutions using the Merge node, the image that's
connected to the orange background input determines the output resolution of the Merge node.

Often, it's easiest to control the comp resolution right at the start by connecting a node with
the desired output resolution you want to the orange background input on the Merge node. A
Background node is often used in this situation because it consumes meager system resources.

Background1

A Background node determines the output resolution of the merge

The Background node sets the output size, and the foreground image is cropped if it is larger.

A Background node created at 1280 x 720 crops the larger foreground.
However, all the pixels of the larger foreground are available for repositioning.

The order of sizing operations between DaVinci Resolve pages is a bit more nuanced. It's important

to understand which sizing operations happen in the Fusion page, and which happen after, so you
know which effects alter the image that's input to the Fusion page, and which effects alter the page’s
output. For example, lens correction, while not strictly sizing, is nonetheless an effect that changes
how the image begins in your Fusion composition. However, the Edit or Cut page stabilization function
is an effect that comes after the Fusion page, so it does not appear in the composition you're creating.
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The order of sizing effects in the different pages of DaVinci Resolve can be described as follows:

Sizing with Compound and Fusion Clips

Another way to modify the resolution before clips get handed off from the Edit page to the Fusion
page is to create a compound clip or a Fusion clip. Both compound clips and Fusion clips change the
working resolution of the individual clips to match the Timeline resolution. For instance, if two 4K clips
are stacked one on top of the other in an HD timeline, creating a compound or Fusion clip resizes

the clips to HD. The full resolution of the individual 4K clips is not available in Fusion and is therefore
handed off to the Color page at the rescaled size. To maintain the full resolution of source clips, bring
only one clip into the Fusion page from the Edit or Cut page Timeline, and then bring other clips into
the Fusion composition using the Media Pool. Of course, if your clips are full HD and your timeline is
full HD, then creating a Fusion clip or compound clip does not affect the resolution.

Color Bit Depths

The term bit depth describes how many colors are available in the color palette used to make up an
image. The higher the bit depth, the greater the precision of color in the image, and therefore the
greater the color reproduction. The higher precision is most apparent in gradients with subtle changes.
Lower bit-depth gradients have noticeable banding artifacts, whereas higher bit-depth images can
reproduce more colors, so fewer, if any, banding artifacts occur. The Fusion page within DaVinci Resolve
always uses 32-bit float bits per channel precision to process images. However, in Fusion Studio you
can choose to process images with 8-bit integer, 16-bit integer, 16-bit float, and 32-bit float bits per
channel. Although always working at 16-bit float or 32-bit float will produce the best quality, it may be
more efficient to use a lower bit depth if your images are 8-bit or 16-bit integer formats to begin with.

Generally, 8-bit integer color processing is the lowest bit depth you'll come across for video

formats. 8-bit images come from older or consumer-grade video equipment like mobile phones and
camcorders. If you try to perform any significant gamma or color correction on 8-bit images, you can
often see more visible banding.

16-bit integer color depth doubles the amount of precision, eliminating problems with banding.
Although you can select 16-bit integer processing for an 8-bit clip, it does not reduce banding that
already exists in the original file. Still, it can help when adding additional effects to the clip. This
sounds like the best solution until you realize that many digital cameras like Blackmagic Design URSA
Mini Pro and others record in formats that can capture over-range values with shadow areas below 0.0
and super highlights above 1.0, which are truncated in 16-bit integer.

The 16-bit float color depth sacrifices a small amount of the precision from standard 16-bit integer
color depth to allow storage of color values less than 0 and greater than 1.0. 16-bit float, sometimes
called half-float, is most often found in the OpenEXR format and contains more than enough
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dynamic range for most film and HDR television purposes yet requires significantly less memory and
processing time than is required for full float, 32-bit images.

16 bit float

Preserving over-range values allows you to
change exposure while maintaining highlights

Processing at 32-bit float can work with shadow areas below 0.0 and highlights above 1.0, similar
to 16-bit float, except with a much greater range of precision but also much greater memory and
processing requirements.

As we said earlier, DaVinci Resolve always processes at 32-bit float bits per channel; however, you can
use less memory and still achieve more-than-acceptable results using the Performance Mode setting
located in the User > Playback Preferences panel.

Fusion Studio automatically uses the color depth that makes the most sense for each file format.

For example, if you read in a JPEG file from disk, then the color depth for the Loader is set to 8 bits
per channel. Since the JPEG format is an 8-bit format, loading the image at a greater color depth
would generally be wasteful. If a 16-bit TIFF is loaded, the color depth is set to 16 bits. Loading a DPX
file defaults to 32-bit float, whereas OpenEXR generally defaults to 16-bit float. However, you can
override the automatic format color depth using the settings found in the Import tab of the Loader
node’s Inspector. The Loader’s Inspector, as well as the Inspector for images generated in Fusion (i.e.,
text, gradients, fast noise, and others), has a Depth menu for 8-bit, 16-bit integer, 16-bit float, and
32-bit float.

Import Format

Full Frames

int16

The Loader’s Inspector Color Bit Depth settings

Configuring Default Color Depth Preferences

The default color depth setting forces the tool to process based on the settings configured in the
Node Editor's Frame Format preferences. These are used to set a default value for color depth, applied
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when a Generator tool is added to the Node Editor. There are three drop-down menus to configure
color depth in the preferences. They specify the different color depths for the interactive session, final
renders, and preview renders.

To improve performance as you work on your comp, you can set the Interactive and Preview depth to
8-bits per channel, while final renders can be set to 16-bit integer. However, if your final render output
is 16-bit float or 32-bit float, you should not use the integer options for the interactive setting. The

final results may look significantly different from interactive previews set to integer options.

Color depth

16 bit float per channel (64 bit)
16 bit float per channel (64 bit)

16 bit float per channel (64 bit)

The Frame Format Color Depth settings

If you aren’t sure what the color depth process is for a tool, you can position the pointer over the
node’s tile in the Node Editor, and a tooltip listing the color depth for that node will appear on the
Status bar.

ClipAmov
(Loader, LD)

Pixel Aspe
Depth 1

- ClipAmov
—

Hover over a node to view its Color Bit Depth setting.

TIP: When working with images that use 10-bit or 12-bit dynamic range or greater, like
Blackmagic RAW or Cinema DNG files, set the Depth menu in the Inspector to 16-bit float or
32-bit float. This preserves highlight detail as you composite.
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You can combine images with different color depths in a single composition. When images of different
color depths are combined, the image from the background input of the node determines the bit
depth output, and the foreground image is adjusted to match.

There are two major advantages to floating-point processing that make the additional RAM
requirements and longer render times worth your while. The first benefit is that floating-point values
are more accurate than integer values. The second benefit is the preservation of shadow and highlight
values that go beyond the normal tonal range.

Greater Accuracy

Using 16- or 32-bit floating-point processing prevents the loss of accuracy that can occur when using
8- or 16-bit integer processing. The main difference is that integer values cannot store fractional or
decimal values, so rounding occurs in all image processing. Floating-point processing allows decimal
or fractional values for each pixel, so it is not required to round off the values of the pixel to the closest
integer. As a result, color precision remains virtually perfect, regardless of how many operations are
applied to an image.

If you have an 8-bit pixel with a red value of 75 (dark red) and that pixel is halved using a Color
Correction tool, the pixel’s red value is now 37.5. Since you cannot store decimal or fractional values
in integers, that value is rounded off to 37. Doubling the brightness of the pixel with another Color
Correction tool should bring back the original pixel value of 75 but because of rounding 37 x 2 is 74.
The red value lost a full point of precision due to integer rounding on a very simple example. This is a
problem that can result in visible banding over several color corrections. Similar problems arise when
merging images or transforming them. The more operations that are applied to an image, the more
color precision is lost to rounding when using 8- or 16-bit integer processing.

Accessing Extended Highlights and Shadows

Increasingly more productions are capturing out-of-range images thanks to digital cinema cameras
like the Blackmagic URSA Mini Pro and even the Pocket Cinema 6K camera. These cameras capture
very high dynamic range RAW images and maintain color detail even in heavily over or underexposed
frames. The extended white color detail can also give very nice, natural results when blurred, glowed,
color corrected, or even just when faded or dissolved. While it is possible to work with these RAW
images using integer data, doing so results in the loss of the extended range values, losing all

detail in the highlights and shadows. Float processing makes working with logarithmic RAW images
considerably easier by preserving highlight and shadow detail.

If you have an 8-bit pixel that has a red value of 200 (bright red) and a Color Gain tool is used to double
the brightness of the red channel, the result is 200 x 2, or 400. However, 8-bit color values are limited
to a range of 0 through 255. So the pixel's value is clipped to 255, or pure red. If now the brightness is
halved, the result is half of 255, or 127 (rounded), instead of the original value of 200.

When processing floating-point colors, pixel values brighter than white or darker than black are
maintained. There is no value clipping. The pixel is still shown in the viewer as pure red, but if float
processing is used instead of 8-bit, the second operation where the gain was halved would have
restored the pixel to its original value of 200.
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Using Float with 8-Bit HD Video

There is also some value to using float color depths with an 8-bit HD video when the images require a
lot of color correction. Using float helps maintain precision by avoiding the rounding errors common
to 8-bit processing, as described above.

Detecting Extended Highlight and Shadow Values

Although floating-point processing preserves extended values below 0.0 and greater than 1.0, also
called "out-of-range values,” the viewer still displays them as black or white. This can make it difficult
for you to determine the overall dynamic range of an image.

To discover whether there are out-of-range values in a viewed image:

Right-click in the viewer and choose Options > Normalized Color Range.

Options

v Normalized Color Range

Use the Normalized Color Range pop-up menu to detect out-of-range images.

Enabling this display mode rescales the color values in the image so that the brightest color in
the image is remapped to a value of 1.0 (white), and the darkest is remapped to 0.0 (black).

The 3D Histogram subview can also help visualize out-of-range colors in an image. For more
information, see Chapter 7, “Using Viewers,” in the Fusion Reference Manual or Chapter 69 in

the DaVinci Resolve Reference Manual.

Clipping Out-of-Range Values

When processing in floating point, there may be situations where the out-of-range values in an image
need to be clipped. The Brightness/Contrast tool provides checkboxes that can be used to clip out-of-

range values to O or 1.
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For example, there may be files that contain out-of-range alpha values. Since the alpha
channel represents the opacity of a pixel, it makes little sense to be more than completely
transparent or more than fully opaque, and compositing such an image may lead to
unexpected results. To easily clip alpha values below 0 and above 1, add a Brightness/
Contrast toolset to Clip Black and Clip White, with only the Alpha checkbox selected.

Clip White and Clip Black settings in
Brightness/Contrast can be used to clip mattes.

Alternatively, you can clip the range by adding a Change Depth node and switching to 8-bit or
16-bit integer color depths.
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Managing Color
for Visual Effects

This chapter discusses LUTs, color space conversions, and the value
of compositing with linear gamma while previewing the image in
the viewer using the gamma of your choice.
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Color Management

The simplified goal of color management is to make sure that the image you see on your computer
screen is what your audience sees when they view it on a television, cinema screen, or mobile device.
For such a simple goal, problems arise that you, as the compositor, must manage. These problems
begin with the fact that our eyes see luminance one way, and a computer display represents
luminance differently.

Each capture device records images using a nonlinear tonal curve or gamma curve to compensate
for this difference. Specifically, Rec. 709 HD gamma curves are designed so that when shown on
HD displays, the images have built-in compensation for the display. The result is that HD images on
HD displays appear normal to us.

Digital cinema cameras have taken the concept of gamma curves further. They use gamma curves as
a way to maximize the bit depth of an image and store a wider dynamic range. Digital cinema cameras’
gamma curve (often collectively referred to as log gamma), give more attention to the darker mid-
tones where the human eye is most sensitive. This allows them to save images with brighter highlights

and more detail in shadows.

A Rec. 709 HD gamma curve (left) and a nonlinear, or log gamma, curve (right)

The problem is that these images do not look normal on any monitor. Clips recorded with a log
gamma curve typically have a low contrast, low saturated appearance when viewed on an sRGB
computer display or Rec. 709 HD video monitor. This problem is easy to fix using a LookUp Table, or
LUT. ALUT is a form of gamma and color correction applied to the viewer to normalize how the image
is displayed on your screen.

A clip displayed with a nonlinear, log gamma curve (left) and corrected in the viewer using a LUT (right)
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The LUT applied to the viewer only solves the problem in the viewer. Now we come to the larger
problem. The image data is still using a log gamma curve. Fusion, and every other image-processing
application, operates with the assumption that the image data has linear gamma. The image-
processing filters you apply to images use standard math functions, like 1 + 1 =2. Common operations
such as those that add pixels like Brightness, or divide pixels (a.k.a. “unpremultiply”), or composite
modes that include multiplication such as “screen,” and many other compositing tasks assume that 1 +
1 always equals 2. In other words, if you perform an operation that doubles the amount of brightness,
then every pixel should be twice as bright. However, if you are starting with a nonlinear gamma curve,
pixels are not being adjusted linearly, so some pixels might end up 1.2 x as bright, 1.7 x as bright, or
2.4 x as bright. Now the math is 1 + 1 = 3. The further your images are from linear gamma, the more
pronounced the math error. A Rec. 709 HD clip shows less error than a log gamma clip from a digital
cinema camera. However, an error is still an error, and the more compositing operations you perform
on the image, the more the error is compounded.

You can see a more practical example when you apply filtering effects, such as a blur, to an image
with any gamma setting. The image probably looks fine. However, if you convert the image to a linear
gamma first and then apply the blur, the images (especially those with extremely bright areas) are
processed with greater accuracy, and you should notice a different and superior result.

The answer to these problems is to manage your color before compositing.

Introducing Color
Management in Fusion

Images loaded into Fusion by default are not color managed. The image is displayed directly from
the file to the viewer without any interpretation or conversion. However, Fusion includes nodes that
convert the output of each image to linear gamma at the beginning of your composite. The same
nodes can convert from linear back to your desired output gamma at the end of your composite, just
prior to the Saver or MediaOut node.

[ Medialn1 ._..[_ CineonLogl | [ Gamuti J._,| MediaOuti J=
s — ; ..

v ¥ [ ]
BrightnessContrast! g—p Transform1 — ColorCorrectort <

A log clip converted to linear and then converted for output

To manually set up a linear gamma workflow in Fusion:
Use a Gamut or CineonLog node after all Medialn or Loader nodes to convert them to linear.
Apply a GAMUT View LUT to the viewers to correct the display of a linear image to sRGB or Rec. 7009.

Before a Saver or MediaOut node, insert a Gamut or CineonLog node to convert from linear to your
target output format.
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Whether an image comes from the Edit page in DaVinci Resolve, or from a Loader in Fusion Studio, the
color and gamma are read directly into Fusion, with no modification. For some simple operations on
SRGB or Rec 709 clips, this may be fine, but it's not always the ideal way to work, especially for log-
encoded media. The ideal way to work with log-encoded media is to convert images to linear gamma,
since the majority of image-processing operations in Fusion expect gamma to be linear and will
produce superior results.

TIP: 3D rendered CGI images are often generated as EXR files with linear gamma, and
converting them is not necessary. However, you should check your specific files to make sure
they are using linear gamma.

Fusion includes several kinds of nodes you can use to convert the image out of each Medialn or
Loader node to linear gamma at the beginning of your composite, and then convert from linear back
to your desired output gamma at the end of your composite. These include:

— Cineonlog node: The CineonlLog node, found in the Film category of the Effects Library, performs
a conversion from any of the formats in the Log Type menu to linear, and also reverses the process,
adding log gamma back to a clip. This is most often used for images coming from common digital
cinema cameras like BlackMagic Design, Arri, or Red. The CineonLog node is added directly after a
Medialn or Loader node. The Mode menu chooses the direction of the conversion to or from linear.

CineonlLog1

& f
Controls
Depth  Auto

Mode Logto Lin

685
White
Soft Clip (Knee) @ 0
0.6

1.0

Add a CineonlLog tool to convert log
gamma curves to linear and vice versa.

— Gamut node: The Gamut node, found in the Color category of the Effects Library, lets you
perform linear conversions based on color space. This node converts to linear or from linear
and is often inserted after a Medialn or Loader node or just before a MediaOut or Saver node.
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Depending on where you insert the node, you either choose from the Source Space controls or the

Output Space controls.

&4

Controls

bl
N 1931 xy

Source Space  No Change

v Remove Gamma
No Change
v Add Gamma

Pre-Divide / Post-Multiply

Add a Gamut tool to convert gamma
curves to linear based on color space.

When converting media to linear gamma, set the Source Space menu to the color space of your
source material. For instance, if your media is full 1080 HD ProRes, then choose ITU-R BT.709
(scene) for gamma of 2.4. Then, enable the Remove Gamma checkbox if it isn't already enabled, to

use linear gamma.

Gamut1

7

Controls

1931 xy

Source Space  ITU-R BT.709 (scene)

' Remove Gamma

OutputSpace  No Change

< Add Gamma

Pre-Divide / Post-Multiply

Source Space is used to convert to linear gamma.

When converting from linear gamma for output, you insert the Gamut node before your output
node, which is a Saver in Fusion Studio or a MediaOut node in DaVinci Resolve's Fusion page. Make
sure the Source Space menu is set to No Change, and set the Output Space to your output color
space. For instance, if your desired output is full 1080 HD, then choose either sSRGB or ITU-R BT.709
(scene) for gamma of 2.4. Then, enable the Add Gamma checkbox if it isn't already enabled, to

format the output of the Gamut node for your final output.
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Gamut1

R4

Controls

Source Space  No Change
+ Remove Gamma
Output Space  sRGB

<+ Add Gamma

Pre-Divide / Post-Multiply

Output Space is used to convert from linear gamma.

— Medialn and Loader nodes: Medialn and Loader nodes have Source Gamma Space controls in
the Inspector that let you identify and remove the gamma curve without the need to add another
node. If your files include gamma curve metadata like RAW files, the Auto setting for the Curve
Type drop-down menu reads the metadata and uses it when removing the gamma curve. When
using intermediate files or files that do not include gamma curve metadata, you can choose either
a log gamma curve by choosing Log from the Curve Type menu or a specific color space using
the Space option from the menu. Clicking the Remove Curve checkbox then removes the gamma
curve, converting the image to linear gamma.

¥ Source Gamma Space

BMD Film
BMD Film 4.6K

800

Medialn and Loader nodes include a Remove
Curve checkbox in the Inspector.

— FileLUT node: The FileLUT node, found in the LUT category of the Effects Library, lets you do a
conversion using any LUT you want, giving you the option to manually load LUTs in the ALUT3,
ITX, 3DL, or CUBE format to perform a gamma and gamut conversion. Although LUTs are very
commonly placed at the end of a node tree for final rendering, you'll get more accurate gamma and
color space conversions using the Gamut and CineonlLog nodes to transform your Medialn and
Loader nodes into linear.
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Images converted to a linear gamma don't look correct. They usually look very dark, with extremely
bright highlights and oversaturated colors. Happily, even though the image may appear to be
incorrect, the fact that Fusion can work entirely with floating-point color data means that you're not
actually clipping or losing any image data. It just looks completely wrong when viewing the linear state

of your image data directly.

A clip displayed with a nonlinear, log gamma curve (left) and the clip transformed to linear gamma (right)

It would be impossible to work if you couldn’t view the image as it's supposed to appear within the
final gamut and gamma you'll be outputting. For this reason, each viewer has a LUT menu that lets
you enable a “preview” color space and/or gamma conversion, while the node tree is processing
correctly in linear gamma.

Inspector

Apply a Gamut View LUT to preview the image
in your intended output color space.

To preview the images in the viewer using sRGB or Rec. 709 color space:
Enable the LUT button above the viewer.

From the Viewer LUT drop-down menu, choose either a Gamut View LUT, or a LUT from the VFX IO
category that transforms linear to Rec. 709 or sRGB.
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If you choose the Gamut View LUT, then choose Edit from the bottom of the LUT menu to
configure the LUT.

In the LUT Editor, set the Output Space to the target color space you want.

Enable the Add Gamma checkbox to apply the gamma curve based on the selected color space.

GamutViewLUT3

1931 xy

No Change
4

Output Space  ITU-R BT.709 (scene)

7 e

Gamut View LUT Output Space set to Rec. 709
for HD with the Add Gamma checkbox enabled

TIP: If your monitor is calibrated differently, you need to select a LUT
that matches your calibration.

Whether you use the Gamut View LUT or a LUT for your specific monitor calibration, you can save the
viewer setup as the default.

To Save the Gamut LUT setup as the default viewer setup:

— Right-click in the viewer, and then choose Settings > Save Defaults.

For every comp, the viewer will now be preconfigured based on the saved defaults.

For more information on Viewer LUTs, see Chapter 7, “Using Viewers,” in the Fusion Reference Manual
or Chapter 69 in the DaVinci Resolve Reference Manual.

Using Resolve Color Management

If you're using the Fusion page within Davinci Resolve, you have the option of enabling

DaVinci Resolve's scene-referred color management, instead of inserting Gamut and CineonlLog
nodes. When DaVinci YRGB Color Managed (RCM) is enabled, the color of Medialn nodes in the Fusion
page is handled differently. The RCM automatically determines the input color spaces of all files used
for all Medialn nodes in the Fusion page, which then automatically get converted to linear gamma.
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The MediaOut node then gets converted back into the Color Processing mode to get graded in the
Color page or further edited in the Edit page Timeline.

Despite the seeming complexity of color management, using RCM is actually simple. In essence, all
you have to do is (A) turn on RCM, and (B) choose the Color Processing mode and Output Color Space

combination you want to use.

To enable Resolve Color Management:
Open the Color Management panel of the Project Settings.
Choose DaVinci YRGB Color Managed from the Color Science drop-down menu.

Check the Automatic color management box for a simplified selection, or un-check the box to
adjust the Color Processing mode and Output color spaces manually.

Set the desired options for the Color Processing mode and Output Color Space RCM settings.

Project Settings: Fusion Greenscreen

Color Space & Transforms

Color Management

When DaVinci YRGB Color Managed is enabled, Timeline color
space is used for all Medialn nodes in the Fusion page.

To override the input color space for differently recorded clips in the Media Pool:
Enable DaVinci YRGB Color Management as explained above.
Save and close the Settings dialog.
In the Media Pool, select the clip or clips you want to assign a new Input Color space.
Right-click one of the selected clips.

Choose the Input Color Space that corresponds to those clips from the contextual menu.

Using RCM eliminates a few steps, since the input color space math used to transform the source
preserves all wide-latitude image data, making highlights easily retrievable without any extra steps.
With RCM enabled, there is no need to insert CineonlLog or Gamut nodes while in the Fusion page.
The transforms from and to linear are done automatically based on the RCM settings. Switching to
the Fusion page converts the images to linear and enables the LUT button in the viewers with the
Managed LUT selected. The Managed LUT uses the RCM settings to take a linear image and display it
based on the RCM output color space.

For more information on Resolve Color Management, see Chapter 9, “Data Levels, Color Management,
and ACES,” in the DaVinci Resolve Reference Manual.
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Using ACES Color
Management in Resolve

The ACES (Academy Color Encoding Specification) color space is another standard for managing
color throughout an entire production. It's designed to make start-to-finish, scene-referred color
management a reality for digital cinema workflows. Just like DaVinci's RCM, ACES makes it easier to
extract high-precision, wide-latitude image data from raw camera formats, to preserve high-quality
image data from acquisition through the color grading process and to output high-quality data for
broadcast viewing, film printing, or digital cinema encoding.

ACES works by assigning an IDT (Input Device Transform) to every camera and acquisition device.
The IDT specifies how media from that device is converted into the ACES color space. At the end of
the pipeline, an ODT (Output Device Transform) is applied to convert the image data from ACES color
space into the gamut of your final output.

Similar to setting up RCM, DaVinci Resolve’s color management project settings can be configured
for ACES, which carries through the Edit, Fusion, and Color pages.

NOTE: When using Fusion Studio, the OpenColorIO (OCIO) framework is used for ACES
color management.

The Color Science drop-down menu in the Color Management panel of the Project Settings is used to
set up the ACES color management in DaVinci Resolve.

Color Space & Transforms

Color Management

When ACES is enabled, IDT and ODT are used to identify input and output devices.

— Color Science: Using this drop-down menu, you can choose either ACEScct or ACEScc color
science. This is primarily a personal preference since they are mostly identical, but the shadows
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respond differently to grading operations. In the Fusion page, images are automatically converted
to linear, so whoever does the grading has more of a reason to choose one or the other.

Choose ACEScc color science to apply a standard Cineon style log encoding to the ACES
data before it is processed by DaVinci Resolve.
This variation of ACEScc adds a roll-off at the toe of the image to make color correction lift
operations “feel” more like they do with film scans and LogC encoded images.

— ACES Version: When you've chosen one of the ACES color science options, this menu becomes
available to let you choose which version of ACES you want to use.

— ACES Input Device Transform: This menu lets you choose which IDT (Input Device Transform)
to use for the dominant media format in use.

— ACES Output Device Transform: This menu lets you choose an ODT (Output Device Transform)
with which to transform the image data to match your required deliverable.

— Process Node LUTSs In: This menu lets you choose how you want to process LUTs in the Color page
and does not affect the Fusion page.

— Disable tone mapping for Fusion conversion: Checking this box will remove any tone mapping

from the ACES color management.

For more information on ACES within DaVinci Resolve, see Chapter 9, “Data Levels, Color Management,
and ACES,” in the DaVinci Resolve Reference Manual.

Using OCIO for ACES
Color Management in Fusion

When using Fusion Studio or not using color management in DaVinci Resolve, you have the option to

use OpenColorIO nodes in Fusion to composite in an ACES color space.

OpenColorlIO (OCIO) is an open-source color management framework for visual effects and computer
animation. OCIO is compatible with the Academy Color Encoding Specification (ACES). Three

OCIO nodes located in the Color category of the Effects Library allow you to use OCIO color space
transforms in Fusion.

— OCIO CDL Transform node allows you to create, save, load, and apply a Color Decision List (CDL) grade.
— OCIO Color Space allows sophisticated color space conversions based on an OCIO config file.

— OCIO File Transform allows you to load and apply a variety of LookUp Tables (LUTs).

Using OCIO for converting Medialn or Loader nodes to linear gamma is based on the OCIO Color
Space node. Placing the OCIO Color Space node directly after a Loader (or Medialn in DaVinci Resolve)
displays the OCIO Source and Output controls in the Inspector.

p OClOColorspacel g

OCIO Color Space nodes can be used to work
in an ACES color managed environment.

Managing Color for Visual Effects

405




Within the Inspector for OCIO Color Space node, Fusion includes default Source and Output
transforms for standard color spaces. However, to use the full OCIO standard, you'll need to
download and install the OCIO config file. You can download the config file from the OCIO website.
https://opencolorio.org

Clicking the Browse button in the Inspector will allow you to navigate to the downloaded config file.
From the download, locate the ACES 1.0.3 or later folder and select the file config.ocio.

OClOColorspacel

Source and Output menus are populated based
on the config.ocio file that you download.

The Source menu is used to choose the color profile for your Loader or Medialn node. The default
raw setting shows an unaltered image, essentially applying no color management to the clip. The
selection you make from the menu is based on the recording profile of your media.

The Output menu is set based on your deliverables. When working in Fusion Studio, typically the
Output selected is ACEScg, to work in a scene linear space.

The viewer also includes OCIO View LUTs to calibrate the viewers. Once the OCIO Color Space View
LUT is selected from the LUT menu above the viewer, choosing Edit for the same menu opens a dialog
where you can load the OCIO config file.

Inspector

OCIO ColorSpace ViewLUT

The OCIO Color Space View LUT is located
in the Viewer LUT menu in Fusion Studio.
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By default, the same standard options are available in the View LUT. However, clicking the Browse
button allows you to load the same config file you loaded into the OCIO Color Space node. Once
loaded, all the expanded OCIO options are available. If you selected the OCIO Color Space node to
output ACEScg, you use the OCIO View LUT to go from a source setting of linear sSRGB to an output

setting of SRGB or Rec. 709 in most cases.

OClOColorSpaceViewlLUT1

fUsers/dion/Downloads/imagework

Qutput Space

The OCIO Color Space View LUT dialog is
used to configure the viewer when using the
OCIO Color Space node in the Node Editor.

TIP: If your monitor is calibrated differently, you will need to select a LUT that matches your

calibration.

To set the LUT using OCIO:
Click the LUT menu and choose the OCIO Color Space View LUT.
From the same menu, select Edit.
In the View LUT editor that opens, set the source’s color space to lin SRGB

Set the output space to SRGB or REC 709, assuming you are viewing on a standard computer
monitor. You now see a normalized image in the viewer, but all color operations will be on

linear images.

Whether you use the OCIO Color Space LUT or a LUT for your specific monitor calibration, you can
save the viewer setup as the default.

To save the OCIO ColorSpace LUT setup as the default viewer setup:

— Right-click in the viewer, and then choose Settings > Save Defaults. Now, for every comp, the viewer
is preconfigured based on the saved defaults.
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Understanding Image

Channels

This chapter seeks to demystify how Fusion handles image

channels and, in the process, show you how different nodes

need to be connected to get the results you expect.

It also explains the mysteries of premultiplication, and presents a full explanation of how Fusion

is capable of using and even generating auxiliary data.
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Channels in Fusion

Fusion introduces some innovative ways of working with the many different channels of image
data that modern compositing workflows encompass. This chapter’s introduction to color and data
channels and how they're affected by different nodes and operations is a valuable way to begin the
process of learning to do paint, compositing, and effects in Fusion.

If you're new to compositing, or you're new to the Fusion workflow, you ignore this chapter at your
peril, as it provides a solid foundation to understanding how to predictably control image data as you
work in this powerful environment.

Digital images can be divided into separate streams of image data called Channels, each of which
carries a specific kind of image data. Nodes that perform different image processing operations
typically expect specific channels to provide predictable results. You are probably familiar with
the three standard color channels of red, green, and blue, but there are many others. This section
describes the different kinds of channels that Fusion supports.

RGB Color channels

The red, green, and blue channels of any still image or movie clip combine additively to represent
everything we can see via visible light. Each of these three channels is a grayscale image when seen by
itself. When combined additively, these channels represent a full-color image.

Alpha Channels

An alpha channel is an embedded fourth channel that defines different levels of transparency in an
RGB image. Alpha channels are typically embedded in RGB images that are generated from computer
graphics applications. In Fusion, white denotes solid areas, while black denotes transparent areas.
Grayscale values range from more opaque (lighter) to more transparent (darker).

If you're working with an imported alpha channel from another application for which these
conventions are reversed, never fear. Every node capable of using an alpha channel is also capable of
inverting it.

Single-Channel Masks

While similar to alpha channels, mask channels are single channel images, external to any RGB image
and typically created by Fusion within one of the available Mask nodes. Mask nodes are unique in

that they propagate single-channel image data that defines which areas of an image should be solid
and which should be transparent. However, masks can also define which parts of an image should be
affected by a particular operation, and which should not. Mask channels are designed to be connected
to specific mask inputs of nodes including Effect Mask, Garbage Mask, and Solid Mask inputs.

Auxiliary Channels

Auxiliary channels (covered in more detail later in this chapter), describe a family of special-purpose
image data that typically expose 3D data in a way that can be used in 2D composites. For example,
Z-Depth channels describe the depth of each pixel in an image along a Z axis, while an XYZ
Normals channel describes the orientation (facing up, facing down, or facing to the left or right) of
each pixel in an image. Auxiliary channel data is generated by rendering 3D images, so it usually
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accompanies or is embedded with RGB images generated by 3D modeling and animation applications.
These channels can also be generated from within Fusion via the Renderer 3D node, which outputs

a 3D scene that you've assembled and lit as 2D RGBA channels, with optionally accompanying
auxiliary channels.

The reason to use auxiliary data is that 3D rendering is computationally expensive and time-
consuming, so outputting descriptive information about a 3D image that's been rendered empowers
compositing artists to make sophisticated alterations in 2D. You can add motion blur, perform
relighting, and composite with depth information faster than re-rendering the 3D source material
over and over.

TIP: You can view any of a node’s channels in isolation using the Color drop-down menu
in the viewer. Clicking the Color drop-down menu reveals a list of all channels within the
currently selected node, including red, green, blue, or auxiliary channels.

The connections that pass image data from one node to the next in Fusion’s Node Editor are capable
of carrying multiple channels of image data. That means that a single connection may route RGB,

or RGBA, or RGBAZ-Depth, or even just Z-Depth, depending on the Input you connect to and the
node’s function.

In the following example, the two Medialn nodes output RGB data. However, the Delta Keyer creates
an alpha channel and combined it with Medialn2's RGB image. The RGB-A of the Delta Keyer becomes
the foreground image that the Merge node can use to create a two-layer composite.

4 v
Medialn2 _— DeltaKeyer1

LA | A

Medialn1

The alpha channel generated by the Delta key is used for
compositing by the foreground input of the Merge node.

NOTE: Node trees shown in this chapter may display Medialn nodes found in
DaVinci Resolve's Fusion page; however, Fusion Studio Loader nodes are interchangeable
unless otherwise noted.

Running multiple channels through single connection lines makes Fusion node trees simple to read,
but it also means you need to keep track of which nodes process which channels to make sure that
you're directing the intended image data to the correct operations.
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By default, Medialn nodes in the Fusion page and Loader nodes in Fusion Studio output RGBA
channels. When you connect one node’s output to another node’s input, the active channels are
passed from the upstream node to the downstream node, which then processes the image according
to that node’s function. Only one node output can be connected to a node input at a time. In this
simple example, a Medialn node’s output is connected to the input of a Highlight node to create a
sparkly highlight effect.

Medialn1 (M) el Highlight1 (HiL) [ — MediaOut1 (MO) ™~

A .

Medialn node connected to a Highlight node
connected to MediaOut node in the Fusion page.

When connecting nodes, a node’s output carries the same channels no matter how many times the
outputis “branched.” You cannot send one channel out on one branch and a different channel out on
another branch.

Medialn1 (MI) ] Highlight! (HI) m
A

\, Paint1 (Paint,Pnt) © m

The Medialn node’s output is branched but carries
the same RGB channels to both inputs.

Using Multiple Inputs

Most nodes have two inputs, one for RGBA and another for an effect mask that can be optionally
used to limit the effect of that node to a particular part of the imag