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Welcome
Welcome to DaVinci Resolve for Mac, Linux and Windows!

DaVinci is the world’s most trusted name in color and has been used to 
grade more Hollywood films, TV shows, and commercials than anything else. 
With DaVinci Resolve, you get a complete set of editing, advanced color 
correction, professional Fairlight audio post production tools and Fusion visual 
effects combined in one application so you can edit, compose, grade, mix and 
master deliverables from start to finish, all in a single tool!

DaVinci Resolve has the features professional editors, colorists, audio engineers 
and VFX artists need, and is built on completely modern technology with 
advanced audio, color and image processing that goes far beyond what any 
other system can do. With this release, we hope to inspire creativity by letting you 
work in a comfortable, familiar way, while also giving you an entirely new creative 
toolset that will help you cut and finish projects at higher quality than ever before! 

We hope you enjoy reading this manual. With its customizable interface and 
keyboard shortcuts, DaVinci Resolve is easy to learn, especially if you’re switching 
from another editor, and has all of the tools you need to create breathtaking, 
high end work! 

The DaVinci Resolve Engineering Team

Grant Petty 
CEO Blackmagic Design



Introduction
The DaVinci Resolve 20.1 release adds several tools and quality of life improvements that build 
on the feature set of DaVinci Resolve 20. 

This New Features Guide provides detailed information on each new tool and improvement, 
organized by their Page in the application. These changes will be included in the next update 
of the full DaVinci Resolve Reference Manual, but in the meantime you can use the interactive 
table of contents to quickly jump to the description of each new feature.
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General Improvements
DaVinci Resolve 20.1 has several quality of life improvements across the application.

Improved Layouts for Small, Dual Screen, 
and Vertical Video Views
The UI layout has been redesigned with improvements to the Small, Dual Screen, and Vertical 
Video arrangements.

Per-System Bin Layout Retention  
for Multi-User Projects
The last opened bin is now retained and restored in collaborative projects across all users.

Shift-Space to Display the 
Effects Search Dialog in All Pages
Pressing Shift-Space will now bring up the Effects Search dialog in the Cut, Edit, Color, and 
Fairlight pages, similar to how it always worked in the Fusion page. If you have a clip selected, 
clicking on the effect in the search list will apply that effect to the selected clip.

Pressing Shift-Space will pop up the Effects search dialog.  
In this case, typing “film” will pull up any effect with Film in the name.

Search for Effects in Both English 
and Application Language
You can now search for effects using the language set in DaVinci Resolve > Preferences > User 
> UI Settings, in addition to English.
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Clone Tool Support for xxhash64 Checksums
The Clone tool now offers xxhash64 as a Checksum type, for faster checksum 
verification on copied media.

DRT Timeline Exports Include Fusion Media References
Exporting a DaVinci Resolve Timeline file (.drt) now includes the media referenced in Fusion.

Viewers Reflect Updates to 
Still Images by Other Applications
If you are working with a still image in a Viewer in DaVinci Resolve, you can now modify that 
same image in another image editing application, save it, and the image in the Viewer will 
automatically update to the new version. 

The original still image in a DaVinci Resolve Viewer

 

Modifying the image in another application, in this case drawing a red circle in Pixelmator Pro, then saving it
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After saving the still image in the other application,  
it automatically updates in DaVinci Resolve.

Concurrent Viewer Overlays for  
DeckLink and Remote Monitoring
Viewer overlays, such as Power Windows, will now be visible on both the 
DeckLink and Remote Monitoring outputs simultaneously.

Scripting API Support for Voice Isolation 
for Audio Clips and Tracks
There is now Scripting API support for Voice Isolation. 

For more information, please check the developer documentation found at 
Help > Documentation > Developer.

Support for Electron 36.3.2 for Workflow Integrations
Electron 36.3.2 is now supported for creating Workflow Integrations with DaVinci Resolve. 

For more information, please check the developer documentation found at 
Help > Documentation > Developer.
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New Javascript Promises API for 
Asynchronous Workflow Operations
Javascript Promises are now supported for creating Asynchronous Workflow Operations with 
DaVinci Resolve. 

For more information, please check the developer documentation found at 
Help > Documentation > Developer.

Support for Audio-Only TS Growing Files
Audio-only Transport Streams (TS) are now supported as Growing Files in DaVinci Resolve. 
This means the audio transport stream can still be accessed in a DaVinci Resolve bin, even as 
its being recorded live. 

Codec and IO
As in all DaVinci Resolve releases, there is additional codec and format support for commonly 
(and not so commonly) used file types.

Support for Blackmagic RAW 5.0 SDK.

Faster decodes for URSA Cine 12K LF and URSA Cine 17K 65 clips.

Support for decoding and encoding webp images.

12-bit support and custom quality controls for DNx.

Support for encoding H.264 and H.265 in MXF Op1A clips.

Support for decoding Samsung APV clips.
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Cut and Edit
The Cut and Edit pages in DaVinci Resolve 20.1 have improved keyframe behavior, as well as 
the ability to set up your own custom Viewer guidelines. In addition, several general usability 
enhancements were added.

Improved Keyframe Behavior
DaVinci Resolve 20.1 includes some significant refinements to the Keyframe behavior 
introduced in DaVinci Resolve 20. This includes:

•	 Improved easing behavior using multiple keyframes.

•	 More consistent easing for curves, keyframes, and inspector controls.

•	 Improved Curve Editor for active curves, ease, and locked parameters.

Adjust Curves from the Timeline 
Keyframes and Curves Tray
Curve editing returns to the timeline in DaVinci Resolve 20.1. By clicking on the Curves icon 
in the keyframe tray, you can now adjust the values and timings of a keyframe using the same 
keyframing controls found in the Keyframe Editor.

The Curves Editor can be accessed on the timeline 
by clicking on this icon in the keyframe tray.

The Curve Editor open in the timeline

Keyframes are Displayed Beyond Clip Edit Points
If you’ve set keyframes on a clip, and then subsequently make it shorter on the timeline, the 
keyframes that were “cut off” are still displayed in the Keyframe Editor. They were always still 
there and active in previous versions; now they are displayed as well.
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Set a Keyboard Shortcut to Switch 
Between Curve and Keyframe Views
You can use a keyboard shortcut to toggle between Curve an Keyframe views. 

1	 Go to DaVinci Resolve > Keyboard Customization.

2	 Under Commands, select All Commands.

3	 Type in “toggle keyframe” in the search box.

4	 Assign a keyboard shortcut for Toggle Keyframe/Curve 
for the Cut page, Edit page, or Keyframe Editor.

Curves Option to Disable Auto Zoom 
Graph Height for Custom Zoom
In the Curve Editor option menu, there is now a toggle to enable or disable Auto Zoom Graph 
Height. With this setting enabled (default), the height of the curve editor automatically adjusts 
based on the values of the active keyframes. When disabled, the graph height zoom becomes 
active and its range controlled by a horizontal slider, while a vertical window slider lets you 
navigate the entire graph height from top to bottom. This can be useful if you have multiple 
keyframed parameters showing on the graph whose range is exponentially larger or smaller 
than the others.

The Curve Editor with Auto Zoom Graph Height disabled. This activates the controls 
inside the red boxes, Graph Height Zoom (upper), and the window slider (right).
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Enhanced MultiText Features
DaVinci Resolve 20.1 has added some additional features to its MultiText titling effect, including 
styling options down to the individual character level, and support for indent, alignment, and 
paragraph styling as well.

Import CSV files as Column-Aligned MultiText Text Boxes
You can now import a Comma Separated Value (.csv) spreadsheet into MultiText and have it 
automatically formatted as columned aligned text. Once in MultiText, you can change the titles 
however you see fit. To do so, simply click on the Import CSV button in the Text tab of MultiText, 
then choose the .csv file to import.

A simple spreadsheet saved in .csv format 

The resulting .csv file brought into MultiText;  
each column is brought in as a separate text list item.

Smart Reframe Modes to  
Affect Pan Only, Tilt Only, or Both
There is now an additional Mode dropdown menu in the Smart Reframe tool to limit the 
AI reframing to a specific axis.

Auto: Smart Reframe will adjust the pan and tilt of a clip as it deems necessary 
to properly reframe the target.

Pan Only: Smart Reframe will adjust the pan (left and right) motion of the clip only.

Tilt Only: Smart Reframe will adjust the tilt (up and down) motion of the clip only.
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Custom Guides and Snapping in the Timeline Viewer
You can now create your own custom guides in the Edit page Timeline Viewer. This lets you 
fully customize and create specific geographic locations in the frame and then have the image 
snap to those locations in other operations. You can create Guides, which are colored lines 
that cross the frame horizontally or vertically, and Rulers, which provide measurement metrics 
along the edges of the frame. Both Guides and Rulers are overlay tools for adjusting your video 
position, and only show in the Viewer, not your final project output.

The Timeline Viewer with Guides and Rulers enabled

Both Guides and Rulers can be shown independently by clicking on their icon in the Ruler 
Guides section of the Viewer Guides dropdown menu on the Timeline Viewer. They can 
also be independently activated in the View > Rulers, and View > Guides menus.

The Ruler Guides section of 
the Viewer Guides dropdown
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To Show and Modify a Ruler:
1	 Activate the Ruler by choosing View > Rulers > On, or clicking on the Ruler icon in the 

Viewer Guides dropdown in the Timeline Viewer.

2	 Choose which metric you want the Ruler to use in View > Rulers, or by right-clicking on the 
Ruler in the Viewer.

Pixel: Shows the Ruler in number of pixels from the origin point (0,0) in the middle of the 
frame, using a standard x/y cartesian coordinate graph that reflects the Position field in the 
Video Inspector.

Percentage: Shows the Ruler in percentage distance from the origin point (0%, 0%) in the 
top-left of the frame. The top ruler runs from 0% at the left to 100% at the right, while the 
side ruler measures 0% from the top to 100% at the bottom. For example, a point at the 
exact center of the frame would be at (50%, 50%).

To Show and Create a Guide Line:
1	 Activate the Guides by choosing View > Guides > On, or clicking on the Guides icon in the 

Viewer Guides dropdown in the Timeline Viewer.

2	 Create a new guide by choosing View > Guides > Add Guide, or by right-clicking on the 
Ruler in the Viewer and selecting Add Guides.

3	 In the Add Guide dialog, choose the position and orientation you want the new guide to be, 
and click Add.

Position: Enter a value for where in the frame you want the guide line to intersect. You can 
also click and drag this line in the Viewer to position it by eye (a small popup will reveal the 
exact position value as you move it).

Orientation: Choose either a horizontal or vertical orientation for the line.

To Modify a Guide Line

•	 Click and Drag the line to any position in the Viewer. A small pop up window will 
appear to show you the exact position value.

•	 You can change the color of the guide lines for legibility by right-clicking in the Ruler 
and selecting a new color from the Guide Color context menu.

•	 You can delete a line by right-clicking on the line in the Viewer and choosing 
Remove Guide.

•	 You can change an existing line’s position and orientation by right-clicking on it in the 
Viewer and choosing Edit Guide.

•	 You can delete all, only horizontal, or only vertical lines, by choosing View > Guides > 
and selecting the appropriate lines to remove. You can also do this by right-clicking 
on the Ruler.

•	 Guides can be locked in place to avoid accidental movement by clicking on the small 
lock icon in the upper-left of the Ruler, or by choosing View > Guides > Lock Guides.
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Right-clicking on the Ruler opens a context menu,  
letting you adjust all parameters of the rulers and guide lines.

Snapping to Guide Lines

By default, when moving the clip inside the frame using the Transform Viewer controls, 
whenever the edge of the image gets near a guide line, it will automatically snap the 
image edge to it, turning the guide line purple, so you know that it is exactly placed. 
If you want to disable this behavior, simply hold down the option key while moving the 
image in the Viewer to bypass the snapping.

 
The guide lines turn purple when the edge of the image snaps to that location.
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Toggle Extents for Selected Safe Area Overlays
You can now toggle the extents safe area overlay on or off, in addition to the Action, 
Title, and Center overlays. You can access this features at View > Safe Area > Extents.

Create Subclip from Edit Timeline In/Out Range
You can now make a subclip from the active timeline in the Edit page. Simply set In and Out 
points where you want the subclip to begin and end, then right-click on the selected range 
at the bottom of the Timeline Viewer, and choose Create Subclip from the context menu. 
Alternatively, you can press Option-B.

This creates a new timeline with just the range chosen from the original timeline. It is named 
“<timeline name> Subclip” in the Media Pool to differentiate it from the original.

Options to Sync Media Pool Audio 
Using In, Out, and Marker
In addition to Timecode and Waveform, DaVinci Resolve 20.1 now allows you to auto sync audio 
clips in the Media Pool by In points, Out points, or by Marker. You can select these new options 
from the Synchronize Using dropdown menu in the AutoSync Audio dialog box.

Sync Audio for Stereoscopic 3D Videos
You can now AutoSync Audio for Stereoscopic 3D videos in the same way you do for 
2D video clips.

Menu Action to Move Playhead 
to Mouse Pointer Using the C Key
In the Edit page, you can instantly snap the playhead to wherever your pointer is on the timeline 
by pressing the “C” key on the keyboard. This lets you quickly move around the timeline without 
having to maneuver the mouse to click on the upper Timeline Ruler. 

You can also use a menu action: Playback > Go To > Mouse Pointer.

Menu Actions for Full Extent, Detailed, 
and Custom Zoom for Edit Timeline
In the Edit page, you now have menu actions for selecting Full Extent, Detailed, or Custom 
Zoom options. They can be found at View > Zoom. As these are now menu actions, they can 
more practically be assigned keyboard shortcuts in the Keyboard Customization dialog.

Timeline Tab Action to Load to Source Viewer
When using Stacked Timelines in the Edit page, you can now right-click on a tab and select 
Load Timeline to Source Viewer to load that timeline into the Source Viewer.
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Configurable Actions to Explicitly Enable or Disable Clips
There are now specific Enable and Disable clip actions that can be assigned to keyboard 
shortcuts in the Keyboard Customization  dialog. The enable/disable clip toggle shortcut is 
still “D” but assigning these specific actions prevents the issue of having disabled and enabled 
clips in the same selection simply swapping on/off states, rather than all being enabled 
or disabled.

1	 Go to DaVinci Resolve > Keyboard Customization.

2	 Under Commands, select Clip.

3	 Type in “able” in the search box.

4	 Assign a keyboard shortcut for Disable Clip and Enable Clip.

Audio and Video Only Insert Controls in the Source Viewer
In the Edit page, you can now persistently select Video and Audio, Video Only, and Audio Only 
inserts of a source clip from a dropdown menu under the Source Viewer.

The new persistent Video/Audio insert 
controls at the bottom of the Source Viewer

Improved Right to Left Language Handling in Transcriptions
If you’re transcribing using a language that reads right to left, DaVinci Resolve 20.1 has 
improved the automation’s handling of the text.
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Fusion
Fusion has received additional updates in DaVinci Resolve 20.1, including Magic Mask v2 and 
the Immersive Patcher tools. 

Support for Immersive Option 
in the Viewer 360 Views Menu
Fusion supports the decoding of Apple Immersive content in the 2D Viewer windows. 

To activate this, click the option menu in a Fusion Viewer, and select 
360° View > Immersive from the context menu.

Immersive Patcher [ImP]

The Immersive Patcher node

Immersive Patcher Introduction
The Immersive Patcher tool allows you to temporarily ‘undistort’ a section of an immersive clip 
to allow for easier tracking, painting, and compositing on a flat plane. Once finished, you can 
use a second Immersive Patcher to re-distort the immersive signal and integrate the newly 
composited elements into the scene.

Inputs
The Immersive Patcher node includes two inputs in the Node Editor.

Input: The orange input accepts an immersive or normal 2D output.

Metadata: The metadata input accepts metadata from another node.

Basic Node Setup
The Immersive Patcher is designed to work in pairs, essentially: 

	� You feed an immersive video clip into an Immersive Patcher node, and Undistort it into a 
normal image.

	� Adjust the Rotation and Angle of view to determine the area you want to modify.
	� Then use Fusion’s extensive toolset to composite and modify the image as normal.
	� Then use another Immersive Patcher node to Distort it back into an immersive video.
	� Then use a Merge node to join your changes back into the original immersive video clip.
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IMPORTANT: To maintain image integrity, it’s important that both Immersive Patchers 
have the same Rotation and Angle of View settings. The easiest way to achieve this is 
to copy the first Immersive Patcher, and paste it to create the second one.

Feeding an immersive video clip into an Immersive Patcher that undistorts the image, then adding a multipoly 
and transform operation, then distorting the image again with a second Immersive patcher before merging it in 
with the original immersive video clip 

Inspector

The Immersive Patcher controls

	� Mode: Two options let you choose to either Distort (convert the image from 2D to 
immersive video), or Undistort (convert immersive video into a 2D image) the input.

	� Rotation: Use these controls to rotate the immersive video until the area you want to 
modify is in the frame.

Angle of View: Use this control to adjust the angle of view shown in the VR headset.
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Magic Mask [MagM] v2 in Fusion
Magic Mask v2 is now the default in the Fusion Magic Mask tool. Its functionality is essentially 
the same as the Magic Mask v2 in the Color page, with some Fusion-specific interface changes. 
If you want to use the old Magic Mask for compatibility with older projects, you can do so by 
checking the Use Legacy Magic Mask checkbox at the bottom of the tool’s Inspector.

 

The Magic Mask node

Magic Mask Node Introduction
The Magic Mask palette uses the DaVinci AI Neural Engine to automagically create a mask to 
isolate one or more people or objects in the frame, guided by user-applied clicks to identify the 
subject for isolation. Masks can be generated for either an entire object, person, or for specific 
features of that person (their face, hair, arms, shoes, etc.). The following images show these two 
kinds of masks with Highlight enabled in the Viewer. A red onionskin overlay lets you see what 
Magic Mask is isolating.

(Left) Using Magic Mask to isolate just skin tones, (Right) Using Magic Mask to isolate just the apron. 
Note how the color of the apron and shirt are very close together, but Magic Mask understands the 
shape of the apron to generate the mask. 

While the masks generated by Magic Mask can often be good enough to use directly 
for making high quality isolated adjustments, it won’t always give perfect results. In 
these cases, the Matte Finesse controls let you make the resulting mask softer and 
looser as necessary to clear the edge of a difficult subject you’re isolating with the 
help of another mask generation technique, such as a qualifier key or window. For 
quick touch up work on a frame, you can also use the Paint tool to manually include or 
exclude regions of the mask. 

If you’re isolating specific features of a person, you can also mix and match what you’re 
isolating to create exactly the type of mask you require. In the above example, you 
might isolate the face, along with exposed skin on the torso and arms, to create a 
mask for creating an overall skin tone adjustment that doesn’t include the subject’s hair 
or clothes.
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This whole process is guided by clicks you make to identify the subject. In a typical workflow, 
you’ll make positive clicks (colored blue) over the person or feature you want to isolate. Then, 
if necessary, you can also make subtractive clicks (colored red) over parts of the image 
that are not the person or feature you’re isolating, to correct any problems you see in the 
generated mask.

Making Points in the Viewer
The Magic Mask tool works by placing points directly into the viewer. Once a point is drawn, the 
viewer will automatically show the mask you’ve created. You can draw multiple points to create 
a mask in an additive fashion and use negative points to remove areas from the mask. It is best 
to choose a frame to draw on where the object is completely in view and unobstructed.

	� To make a positive point to add an object to a mask: Load the Magic Mask node in a 
viewer, and left-click and make a point on the object you want to choose. Alternatively, you 
can change the Point mode to Add in the Inspector and left-click to make a new positive 
point. Positive points are colored blue.

	� To make a negative point to remove an object from a mask: Load the Magic Mask node in 
a viewer, and Option-left-click and drag to make a point on the object you want to remove. 
Alternatively, you can change the Point mode to Subtract in the Inspector and left-click to 
make a new negative point. Negative points are colored red.

	� To delete a point (or group of points) to remove them from the mask: Shift-drag around 
a point or group of points to select them (green), and press the delete key to remove 
them. Alternatively, you can change the Point mode to Select in the Inspector and left‑click 
and drag a selection window to select one or more points. Clicking the delete button 
removes them.

Making positive points will select areas of similar contrast and color, allowing you to 
link complex shapes together.

Making negative points removes areas from the object that you don’t want to isolate. 
This can be something simple, like removing the wheels of a car from a mask, or more 
complicated like removing specific books from a mask of a bookshelf.

Ideally, both positive and subtractive clicks should be centered on the part of the 
person or object you’re trying to add to the mask. Usually a simple point will correctly 
identify the object, or part of the object, you want to mask; you shouldn’t need to place 
multiple points on the same object unless it’s incredibly complex.

A single blue click on her back correctly masks her entire 
body, including arms and hair. Note that Magic Mask v2 
correctly differentiates her from her reflection in the mirror, 
even when they are overlapping.
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Inputs
The Magic Mask node includes four inputs in the Node Editor.

Input: The orange input accepts a 2D image that contains the luminance values you want to be 
keyed for transparency.

Garbage Matte: The gray garbage matte input accepts a mask shape created by polylines, 
basic primitive shapes, paint points, or bitmaps masks. Connecting a mask to this input causes 
areas of the image that fall within the matte to be made transparent. The garbage matte is 
applied directly to the Alpha channel of the image.

Solid Matte: The white solid matte input accepts a mask shape created by polylines, basic 
primitive shapes, paint points, or bitmaps masks. Connecting a mask to this input causes areas 
of the image that fall within the matte to be fully opaque.

Effect Mask: The optional blue input expects a mask shape created by polylines, basic primitive 
shapes, paint points, or bitmaps masks. Connecting a mask to this input limits the pixels where 
the luminance key occurs. An effects mask is applied to the tool after the tool is processed.

Basic Node Setup
The Magic Mask takes RGB inputs from other nodes and lets you isolate specific objects in the 
frame to use as a mask. Tracking the mask as it changes over time is built into the tool. You can 
then use the output of the Magic Mask into any mask input.

A Magic Mask node, feeding a matte to a Color Corrector 
connected to the foreground of a Merge node

Inspector

The Magic Mask Tracking tab
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Tracking Tab
You can think of each point you’ve placed as a persistent eyedropper that samples the 
image that overlaps it. The mask that results from all points’ collective analysis of the image is 
generated live over each frame of the clip. This means that if the camera or the subject moves, 
you need to motion track or otherwise adjust the position of each point to follow along with the 
motion, so the subject continues to be correctly identified. You also need to make sure that each 
point is able to analyze what it’s supposed to and turn off points that can’t for whatever reason.

Mode: Two options let you choose a tradeoff between quality and performance. Faster lets 
you generate a lower quality mask more quickly that’s suitable for garbage matting. Better 
generates a higher quality mask with more detail that’s more processor-intensive.

Point Mode: The main controls for adding and deleting points to define the mask.
	� Add Point: The positive eyedropper icon lets you select a point (blue) in the viewer that 

defines an area to include in the mask.
	� Subtract Point: The negative eyedropper icon lets you select a point (red) in the viewer 

that defines an area to exclude from the mask.
	� Select Points: Lets you select existing points in the viewer by dragging a bounding box 

around one or more points. Selected points are highlighted green.
	� Delete Point: Deletes any selected points.

Tracking Controls: These buttons control the tracking direction, from left to right:
	� Track Reverse: Continuously tracks from the current frame all the way to the beginning 

of the clip.
	� Track Reverse One Frame: Tracks one frame backwards and stops. Useful if you’re 

tracking frame-by-frame to watch the progress of a particularly complicated bit of motion. 
If something goes wrong, you can back up to the last frame where the point was able to 
properly track the subject, and drag the point to a better location using the pointer to make 
it follow the subject properly. If necessary, you can go a frame at a time, dragging the point 
to a better position every time it fails to follow the feature you’re using it to isolate.

	� Track Forward Then Reverse: Tracks from the current frame all the way to the end of the clip, 
then returns to the original tracking point and tracks backwards to the beginning of the clip.

	� Stop Tracking: Stops tracking in cases where there’s a problem with the track and you want 
to make a change.

	� Track Forward: Continuously tracks from the current frame all the way to the end of the clip.
	� Track Forward One Frame: Tracks one frame forward and stops. Useful if you’re 

tracking frame-by-frame to watch the progress of a particularly complicated bit of motion. 
If necessary, you can go a frame at a time, dragging the point to a better position every time 
it fails to follow the feature you’re using it to isolate.

Clear Points: These buttons remove all points from the selected range.
	� Current: Removes points from the frame under the playhead.
	� Range: Removes points from the selected render range.
	� All: Removes all points from the entire clip.

Go To Frame: These buttons snap the playhead to the selected frame, from left to right:
	� First Frame of Tracked Area: Moves the playhead to the first tracked frame of a range of 

tracked frames in preparation for tracking backwards if there are untracked frames at the 
beginning of the clip.

	� Reference Frame: Moves the playhead to the frame on which you initially drew the points.
	� Last Frame of Tracked Area: Moves the playhead to the last tracked frame of a range of 

tracked frames in preparation for tracking forwards if there are untracked frames at the end 
of the clip.
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Disk Cache: These buttons allow you to control what’s stored in the disk cache.
	� Regenerate All: Rebuilds the disk cache.
	� Clear: Deletes the frames in the current cache.

Reference Time: The Reference Time determines the frame where the initial points are drawn. 
It is also the time from which tracking begins. The reference frame cannot be changed once it 
has been set without destroying all pre-existing tracking information.

Processed Frames: Displays the range of frames that have already been tracked. Start is the 
earliest frame tracked and end is the last frame tracked. These fields are not user editable.

Post-Multiply Image

Select this option to cause the keyer to multiply the color channels of the image 
against the Alpha channel it creates for the image. This option is usually enabled 
and is on by default.

Deselect this checkbox and the image can no longer be considered premultiplied 
for purposes of merging it with other images. Use the Subtractive option of the 
Merge node instead of the Additive option.

For more information on these Merge node settings, see Chapter 35, 
“Composite Nodes,” in the Fusion Reference Manual or Chapter 95 in the 
DaVinci Resolve Reference Manual.

Matte Tab
The Matte tab refines the alpha of the key, combined with any solid and garbage masks 
connected to the node. When using the Matte tab, set the viewer to display the Alpha channel 
of Magic Mask’s final output.

Filter: Selects the Filter that is used when blurring the matte.
	� Box Blur: This option applies a Box Blur effect to the whole image. This method is faster 

than the Gaussian blur but produces a lower-quality result.
	� Bartlett: Bartlett applies a more subtle, anti-aliased blur filter.
	� Multi-Box: Multi-Box uses a box filter layered in multiple passes to approximate a Gaussian 

shape. With a moderate number of passes (e.g., four), a high-quality blur can be obtained, 
often faster than the Gaussian filter and without any ringing.

	� Gaussian: Gaussian applies a smooth, symmetrical blur filter, using a sophisticated 
constant-time Gaussian approximation algorithm.

	� Fast Gaussian: Gaussian applies a smooth, symmetrical blur filter, using a sophisticated 
constant-time Gaussian approximation algorithm. This mode is the default filter method. 

Blur: This blurs the edge of the matte using a standard, constant speed Gaussian blur. A value 
of zero results in a sharp, cutout-like hard edge. The higher the value, the more blur is applied 
to the matte.

Erode/Dilate: This shrinks or grows the matte. Eroding the matte reveals more of the 
foreground input, while dilating the matte reveals more of the background input. Values above 
0.0 dilate the matte and values below 0.0 erode it.

Gamma: This raises or lowers the values of the matte in the semitransparent areas. Higher 
values cause the gray areas to become more opaque, and lower values cause the gray areas to 
become more transparent. Completely black or white regions of the matte remain unaffected. 
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Threshold: Any value below the lower threshold becomes black or transparent in the matte. 
Any value above the upper threshold becomes white or opaque in the matte. All values within 
the range maintain their relative transparency values.

Restore Fringe: This restores the edge of the matte around the keyed subject. Often when 
keying, the edge of the subject where you have hair is clipped out. Restore Fringe brings back 
that edge while keeping the matte solid.

Invert Matte: When this checkbox is selected, the Alpha channel of the image is inverted, 
causing all transparent areas to be opaque and all opaque areas to be transparent.

Solid Matte

Solid mattes are mask nodes or images connected to the solid matte input on the 
node. The solid matte is applied directly to the Alpha channel of the image. Generally, 
solid mattes are used to hold out keying in areas you want to remain opaque, such as 
someone with blue eyes against a blue screen.

Enabling Invert inverts the solid matte before it is combined with the source alpha.

Garbage Matte

Garbage mattes are mask nodes or images connected to the Garbage Matte input on 
the node. The garbage matte is applied directly to the Alpha channel of the image. 
Generally, garbage mattes are used to remove unwanted elements that cannot be 
keyed, such as microphones and booms. They are also used to fill in areas that contain 
the color being keyed but that you wish to maintain.

Garbage mattes of different modes cannot be mixed within a single tool. A Matte 
Control node is often used after a Keyer node to add a garbage matte with the 
opposite effect of the matte applied to the keyer.

Enabling Invert inverts the garbage matte before it is combined with the source alpha.

Common Controls

Settings Tab
The Settings tab in the Inspector is also duplicated in other Matte nodes. These common 
controls are described in detail at the end of this chapter in “The Common Controls” section.

Caching Deep Composites to Disk
You can now cache deep compositions to disk to make working with complex, deep 
compositions less taxing on your computer. To do so, right-click on the node you want to cache, 
and select Cache to Disk, select a path to save the cache to, and press OK.

Downscale Clip Compositions to Timeline Resolution
If your computer is struggling with your Fusion comps, you can enable the Project Settings > 
Fusion > Downscale Timeline Resolution for Timeline Clip Compositions.

What this will do is automatically downscale your clips to the timeline resolution before 
processing. For example, this allows you to work with 4K original footage in an HD timeline and 
have only the HD-sized processing overhead.
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Improved DoD and RoI Support for 
Deep Image Compositing Tools
DaVinci 20.1 has expanded and improved support for Domain of Definition (DoD), and Region of 
Interest (RoI) in the Deep Image compositing tools.

Improvements for USD Renderer for Overscan
Domain Overscan and Overscan tools have been added to the Image tab in the USD Renderer.

Edit Individual Tool Controls From 
the Inspector Context Menu
By right-clicking in the Inspector and selecting Edit Control, you can bring up the Control Editor, 
letting you make adjustments to the parameters of that specific tool in the node tree.

The Fusion Edit Control dialog

Improved Shape Duplicate Tool with Style, 
Jitter, and Aligned Rotations
The sDuplicate tool has added Style, Copy Probability, Time Offset, Jitter, and Aligned Rotations 
parameters for increased flexibility in duplicating shapes.

Swizzler Improvements
The Swizzler tool has added abilities for layers to use Background Channels and create 
Alpha‑only multi-layer outputs.

Regular Expression-Based Selection in Cryptomatte
In the Cryptomatte tool, there is now an Expression box, where you can add regular 
expressions to select layers in the tool.
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Color
The Color page in DaVinci Resolve 20.1 has seen some minor Viewer interface changes and 
improved retention behaviors when copying versions or timelines.

Improved Color Viewer Safe Area Display Selection
The Color page Viewer now has the same graphical Safe Area selection tools as the Cut and 
Edit pages. The various safe area guidelines are accessible from the Safe Area dropdown list at 
the top of the Color page Viewer. Clicking on any of the menu items will overlay the safe area 
guides on top of the picture. Multiple guides can be selected at once. Clicking on the Safe Area 
icon toggles the visibility of the Safe Areas on or off.

The various Safe Area guidelines on the Color page Viewer.

Switch Timeline Resolution from the Color Viewer
The Color page Viewer now has the same timeline resolution switching interface as the Cut and 
Edit pages. Clicking on the Timeline Resolution icon will let you select a new timeline resolution 
on the fly. The default resolutions are Ultra HD, Full HD, Portrait, and Square. You can also 
select Custom Timeline Settings to modify all timeline parameters. 

You can select a new timeline resolution 
directly from the Color page Viewer
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Improved Cache Retention for 
Copied Versions and Timelines
The retention of Cache files while creating copied versions and timelines has been improved.

Improved Magic Mask Retention for 
Copied Versions and Timelines
The retention of Magic Mask selection and tracking while creating copied versions and 
timelines has been improved.

DCTL Support for ACES 2.0 Core
DCTLs now include support ACES 2.0.
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Resolve FX
DaVinci Resolve 20.1 introduces new ColorTone Diffuser and Split Tone effects, as well as 
improvements to Light Rays and Glow.

ColorTone Diffuser
The ColorTone Diffuser is an effect designed to mimic the use of a diffusion filter that is 
surrounded by a rectangle of user-controllable colored lights. Modifying the color and intensity 
of these lights scatters the light off the diffusion elements embedded in the glass filter, that is 
directly in the image path of the camera. This allows you to make specific artistic and creative 
looks difficult to achieve with post tools alone, until now.

The original image	 �The image with the ColorTone Diffuser 
“Teal Soft” preset

ColorTone Diffuser
	� Presets: Presents a set of ColorTone presets to try on your footage as starting points. 

The default is Clean Slate, which makes no changes and allows you to create your own 
custom look.

	� 3D LUT Compatible: Disables all controls that cannot be passed in a LUT.
	� Color Space Overrides: These controls allow you to change the input gammas and color 

spaces of the effect if you need to manually configure them for a display referred workflow. 
The default is “Use timeline,” which will match the color spaces you’ve selected in the Color 
Management section of the Project Settings.

Input Color Space: Sets the input color space; choose one from the drop-down menu.
Input Gamma: Sets the input gamma; choose one from the drop-down menu.

	� Diffusion: Spreads the bright areas out, diffusing into nearby parts of the frame.

Resolution: Set the amount of blur applied to the image to replicate the slight resolution 
loss of light coming through the filter.
Diffusion: Check this box to turn Diffusion on or off.
Amount: The strength of the diffusion effect.
Radius: The size of the area of diffusing.

	� Shadow Soft Clip: Protects the shadows from being affected by the ColorTone Diffuser. 
Anything under this level bypasses the filter.

Shadow Clip: Check this box to turn on or off Shadow Clipping. 
Threshold: Set the minimum black level for the ColorTone Diffuser to affect.
Softness: How gently the black level gets stopped at the threshold.
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	� Highlight Soft Clip: Protects the highlights from being affected by the ColorTone Diffuser. 
Anything above this level bypasses the filter.

Highlight Clip: Check this box to turn on or off Highlight Clipping. 
Threshold: Set the maximum bright level for the ColorTone Diffuser to affect.
Softness: How gently the bright level gets stopped at the threshold.

	� Tone Lights: These control the hue of the ring lights that is scattered off the diffusive 
elements in the filter.

Intensity: Controls the overall level of the tone light applied to the frame.
Bias Red/Green/Blue: The relative amount of a certain color in the Tone Light. These 
controls are content dependent and more visible in shadows, so there may not be as 
noticeable an effect in brighter footage.

	� Tone Light Falloff: Mimics the way that the light is dimmer at the edges of the filter and 
stronger in the middle. In reality it’s a vignette mask that determines the mapping of 
the effect.

Apply Falloff Mask: Check this box to turn the Tone Light Falloff on or off.
Preview Falloff Mask: Checking this box will bring up the vignette for the Falloff Mask in 
the viewer. This darker areas will have less of the effect, white more of the effect.
Size: Set the size of the center of the mask.
Softness: Sets the softness of the mask as you move away from its center.
Amount: How strongly the effects are affected by the mask.

The preview of a Falloff mask; the effect is 
stronger in the white areas of the mask.

	� Image Adjustments: Gives you basic exposure, contrast, and saturation controls. This lets 
you make these adjustments in the node, so everything is included in the LUT, and you 
don’t have to put an additional grade on top of the node.

Enable Adjustments: Check this box to enable the Image Adjustments.
Show Advanced Clipping Options: Checking this box will enable another set of shadow 
and highlight softclip controls that work the same as described above. These controls, 
though, are applied at the end of the plugin, not before. This can prevent blow outs from 
being adjusted by the original shadow and highlight softclip controls.
Exposure: Adjusts the Brightness/Gain.
Contrast: Adjusts the Contrast.
Saturation: Adjusts the Saturation.
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Split Tone Effect
The Split Tone effect lets you add color to shadows and highlights using an opposing hue 
angle. For example, adding orange to the highlights and teal to the shadows to get a more 
modern cinematic look.

The original image	� The Preview Influence checkbox shows 
you which split color will be added and where.

The final split-toned image

Split Tone
	� Split Tone Mode: Includes presets and a custom mode.

Natural: Designed to mimic the effect of film.
Strong: A more stylized intentional look.
Custom: Allows you to complete control over any two colors for the Split Tone.

	� Preview Influence: Shows where the split occurs using true colors.
	� Shadows (custom only): Controls the shadow side of the split.

Strength: The saturation for the dark regions of the image.
Hue: The color of the dark regions of the image.

	� Highlights (custom only): Controls the highlight side of the split.

Strength: The saturation for the bright regions of the image.
Hue: The color of the bright regions of the image.

	� Neutrals (custom only): Lets you protect your neutral (gray tone) regions of the image from 
the Split Tone effect.

Protect Neutrals: Check this box to toggle the Neutrals controls on or off.
Minimum Saturation: Regions below this saturation are preserved as gray.
Maximum Saturation: Regions above this saturation are affected by the Split Tone effect.
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	� Strength: How much of the split tone colors you add to the original image.
	� Pivot: Set the point where highlights and shadows diverge, setting the point 

where the color “splits”.
	� Hue Angle: The color of the split tone, measured by the angle on the vectorscope.
	� Color Space Overrides: These controls allow you to change the input and output gammas 

and color spaces of the effect if you need to manually configure them for a display referred 
workflow. The default is “Use timeline,” which will match the color spaces you’ve selected in 
the Color Management section of the Project Settings.

Input Color Space: Sets the input color space; choose one from the drop-down menu.
Input Gamma: Sets the input gamma; choose one from the drop-down menu.
Output Color Space: Sets the output color space; choose one from the drop-down menu.
Output Gamma: Sets the output gamma; choose one from the drop-down menu.
Output White Point: Sets the display white point. For creative purposes, you can choose 
one from the drop-down menu. D65 is the default white point.

Natural and Strong Split Tone Modes in Film Look Creator
The Natural and Strong Split Tone modes from the Split Tone effect have been added to the 
Film Look Creator effect under Split Tone.

Separate RGB sliders and Shimmer Controls in Light Rays
The Light Rays effect has been enhanced in DaVinci Resolve 20.1 with RGB Sliders and a new 
Shimmer control set.

Appearance

•	 Relative Length Red: How much the red glow spreads out relative to the other colors.

•	 Relative Length Green: How much the green glow spreads out relative to the 
other colors.

•	 Relative Length Blue: How much the blue glow spreads out relative to the other colors.

Shimmer 

Shimmer will add subtle variations in the light pattern cast by the rays.

•	 Add Shimmer: Check this box to turn on or off the Shimmer effect.

•	 Strength: Controls the amount of variation in the light patterns.

•	 Detail: Controls the relative detail of the variation; lower levels create finer details 
and higher level create larger details.

•	 Scale: Controls the size of the noise pattern.

•	 H vs. V Ratio: Controls the ratio of horizontal vs. vertical spread of the variations. 

•	 Evolution: How much should the noise pattern change.

•	 Seethe: How much to automatically evolve at each frame from the start.
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Secondary Glow Ability in Glow
The Glow effect now contains a Secondary Glow toolset. Essentially, this is a glow effect for 
your glow. This makes it possible for the inner and outer glows to be different colors for the 
same glow effect. For example, a red neon sign against a blue wall could have a bright red 
inner glow, with a blue toned secondary outer glow. The outside glow takes on more of the 
environment simulating a brighter blue wall illuminated by the sign, while the inner glow is bright 
red taking on the color of the neon tube.

Secondary Glow

•	 Add Secondary Glow: Check this box to turn on or off the Secondary Glow effect.

•	 Gain: How bright the secondary glow is.

•	 Spread: How much the secondary glow spreads out.

•	 Color Filter: The color of the Glow Halo.

Adding a secondary glow to the florescent tube along the  
blue tile wall to simulate the wall itself being illuminated by the light.

 
Just the glow from the above shot; the blue secondary 
glow on the outside was sampled from the wall color.
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Atmosphere Controls in Light Rays and Glow
A new Atmosphere control set has been added to the Light Rays and Glow effects. 
These controls are used to simulate how the light rays and glow would be seen through real 
atmospheric conditions, rather than just be generated on top of an image.

Atmosphere

•	 Add Atmosphere: Check this box to turn on or off the Atmosphere effect.

•	 Strength: Controls the amount of variation in the light patterns.

•	 Detail: Controls the relative detail of the variation; lower levels create finer details 
and higher level create larger details.

•	 Scale: Controls the size of the noise pattern.

•	 H vs. V Ratio: Controls the ratio of horizontal vs. vertical spread of the variations. 

•	 Evolution: How much should the noise pattern change.

•	 Seethe: How much to automatically evolve at each frame from the start.

Ability to Add Grain to Skin Smoothing 
Areas in Face Refinement
A new Grain toolset has been added to Face Refinement. Sometimes, when you use the Skin 
Smoothing controls the skin appears nicely smooth, but it unintentionally removes the natural 
grain of the video clip as well, making it look artificial. With the Grain toolset, you can add this 
grain pattern back in to match the overall original grain of the shot. 

Grain only affects the smoothed areas in the Face Refinement plugin, so it’s already 
pre‑qualified for you.

Grain

•	 Add Grain to Skin Areas: Check this box to turn on or off the Grain effect.

•	 Strength: Determines how much grain to add.

•	 Size: Determines the size of the grain.

•	 Softness: Determines how sharp or blurry the grain pattern is.

•	 Saturation: Determines how colorful the grains are.
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Fairlight
DaVinci Resolve 20.1 includes support for Apple Spatial Audio Format as well as other features 
and improvements

Support Apple Spatial Audio Format (Studio Version Only)
DaVinci Resolve Studio’s Apple Spatial Audio Format (ASAF) support lets you accurately 
position sound sources of any channel format in both the horizontal and vertical planes to 
create immersive multi-channel mixes for Apple’s Vision Pro video format.

This integration means you can use Fairlight’s 2D and 3D Spherical panning, as well as 
Fairlight Ambisonics effect plugins, metering, and compatible AU and VST plugins.

ASAF File Support
In addition to Ambisonic Scene formats from 1OA to 7OA, audio tracks can be of any format, 
ranging from mono to stereo and multi-channel immersive audio, which lets you easily create 
and utilize beds of any format to build complex immersive experiences.

Enabling ASAF
ASAF is enabled by going to Preferences > Video and Audio I/O and clicking the Apple Spatial 
Audio Format checkbox in the Immersive Audio section.

Setting Up an ASAF Mix
The depth of Apple Spatial Audio Format integration within DaVinci Resolve makes setting up 
an Apple Immersive mix as easy as adding an ASAF Master bus to your project and routing your 
audio tracks and busses to it.

Creating an ASAF Master bus
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To create your ASAF Master bus:
1	 Go to Fairlight > Bus Format.

2	 When the Bus Format dialog opens, either change the format of the existing Stereo bus to 
an ASAF Master or click the Add Bus button in the lower left.

3	 If you have chosen to create a new bus, you can rename it if you want to (e.g., ASAF), then 
select Apple Spatial Audio Format > ASAF Master from the corresponding dropdown in the 
Format column and click OK. 	

A new ASAF Master Bus channel strip with an Apple logo at the top of it is added to 
the Mixer, along with a corresponding track header on the timeline.

ASAF  
Master Bus 
channel strip

ASAF  
Master Bus  
track header

Sending Audio to the ASAF Master
When routing audio to the ASAF Master, the following factors must be taken into consideration:

An Ambisonic bus (ASAF Scene or native Ambisonic) routed to the ASAF Master becomes a 
Scene within the Master.

	� Only one Ambisonic bus can be routed to the ASAF Master. In other words, either an ASAF 
Scene bus or a native Ambisonic bus.

	� The new scene within the ASAF Master can accommodate any number of other Scenes 
being routed to it.

	� Up to 128 mono objects can be routed to Scene busses.
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Any non-Ambisonic bus routed directly to the ASAF Master becomes a static Channel Bed in 
the format of the source, for example, stereo, 5.1, or 7.1.4.

	� A maximum of 8 non-Ambisonic busses can be routed directly to the ASAF Master.
	� A bus can be turned into a Dynamic Object in the Track Index by changing the Type from 

Channels to Object.

Audio tracks of any format can be routed directly to the ASAF Master, as Dynamic Objects.

	� Up to 128 mono objects can be routed directly to the ASAF Master.
	� Stereo objects are comprised of two mono objects.

Panning
You can use the 2D, 3D Spherical, or Cartesian View Panners on each channel to position your 
sources in both the horizontal and vertical planes. You can use any channel-based format from 
mono to stereo to, for example, 7.1.2, and position them in the spherical sound field.

For more information about the 2D and 3D Panners, see Chapter 177, “Mixing in the 
Fairlight Page,” in the DaVinci Resolve Reference Manual.

Audio Inspector Controls
If you need to make more precise adjustments, selecting a track or bus and opening the 
Audio tab in the Inspector reveals a collection of additional controls.

Additional controls for making more precise adjustments to a track or bus (e.g., level, positional, 
and room reverb size) can be found on the Audio tab of the Inspector, as described below.

For more information about the Audio Tab, see Chapter 176, “The Fairlight Inspector,” 
in the DaVinci Resolve Reference Manual

ASAF Master Controls

Content Type 
The dropdown menus in this section let you define the following parameters:

	� Content Kind: This dropdown lets you select a description of the content deliverable in the 
ASAF Master. The available options are Movie or Music.

	� Monitor Mix Path: This lets you define the playback monitoring path for the audio signal. 
The choices are:
	� Virtual Reality
	� Virtual Reality + Speakers
	� Headphones
	� Headphones + Speakers
	� Speakers
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	� Reverb Preset: Lets you apply one of the available reverb settings to the audio signal. You 
can choose from:
	� Room Reverbs: Small, Medium, Large, or Large 2
	� Hall Reverbs: Medium or Large
	� Plate Reverb:
	� Chamber Reverbs: Medium or Large
	� Cathedral:

ASAF Master - Content Type section of the Audio Inspector

TIP: Clicking the icon in the upper-right corner opens the Space View plugin, which 
lets you view real-time positions and automated movements of audible sound sources. 
For more information, refer to the Space View section of this chapter.

Active Resources 
Active Resources provide a count of the audio resources in your ASAF mix, as described below:

Objects: The number of dynamic objects used in your current timeline.
The maximum number of dynamic objects is 128, in any audio format or combination of formats. 
However, if, for example, you route a 7.1 track to the ASAF Master, it will use 8 of the 128.

	� Scene Objects: The number of dynamic scene objects on the current timeline, which are 
routed to an ASAF Scene.
Scene Objects can be in any audio format, but the maximum number allowed in a 
project is 128.

	� Scenes: Indicates when an ASAF Scene (bus) is routed to the ASAF Master.
Although there is a limit of one ASAF Scene per project, any number of Scene Objects can 
be routed to an ASAF Scene.

	� Channels: The number of static channel Beds (busses) routed to the ASAF Master.
	� A project can include a maximum of 8 Beds.
	� Beds can be in mono, 2.0, LCR, Quad, 5.0, 5.1, 5.1.2, 5.1.4, 7.0, 7.1, 7.1.2, 7.1.4, 7.1.6, or 

9.1.6 format.

ASAF Master - Active Resources section of the Audio Inspector
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Head 
The parameters in this section control the position of the listener’s head. 

	� Head Yaw: The left-to-right rotation of the listener’s head, with a range of -180 ° to +180°.
	� Head Pitch: Controls the up-and-down movement of the listener’s head, as if looking up 

and down, with a range of -90 ° to +90°.
	� Head Roll: The tilting of the listener’s head side-to-side, from “one shoulder to the other,” 

with a range of -180 ° to +180°.
	� HRTF: When using compatible AirPods, this parameter lets you switch between the 

Personalized or the System default HRTF profiles.

ASAF Master - Head section of the Audio Inspector 

NOTE: The Yaw, Pitch, and Roll parameters automatically update according to the 
position of your head when using compatible AirPods or a head-tracker. 

Room Simulation 
The Room Simulation section lets you use the parameters described below to choose from 
a selection of simulated materials to “build” the walls, floor, and ceiling of a virtual room 
that you can apply to your ASAF Scene Objects, with the ability to adjust the room size and 
reflective quality. 

	� Size (X): This sets the room width with a range of 2 to 20 meters.
	� Size (Y): This determines the length of the room, with a range of 2 to 20 meters.
	� Size (Z): This sets the ceiling height, with a range of 2 to 20 meters.

ASAF Master - Room Simulation section of the Audio Inspector 
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	� Floor Material, Wall Material, and Ceiling Material: Each of these parameters offers the 
following selection of materials for their respective surfaces: 

ASAF Master - Room Simulation  
section of the Audio Inspector 

	� Absorption: Determines how reflective the room is.
	� Room RT60: This displays the amount of time the sound takes to decay by 60dB 

(decay time) after the audio signal goes silent.

World 
The Grid parameter determines the vertical position of the Room Simulation in relation to the 
listener, without changing the height of the audio object in question. This lets you effectively 
raise or lower the whole room while leaving the listener and the audio object or objects in the 
same location.

This is useful if, for example, you need to simulate a space with a high ceiling with the listener 
located closer to the floor.

ASAF Master - World section of the Audio Inspector 

Defaults 
These controls allow you to define the default panning configuration applied to all new 
audio tracks. 

	� Coordinate System: You can choose either the 3D Spherical or Cartesian panner 
for all new tracks.

	� Range: This control sets the default value of the Range parameter for the Panner, 
with a range of 1 to 10 meters. Setting the Range to 1m keeps panning in the room at unity. 
Larger values position objects farther away, making them sound quieter.

	� Set Global Defaults: Clicking this button applies the Coordinate System and Range to all 
newly created timelines.

ASAF Master - Defaults section of the Audio Inspector
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ASAF Object Controls

3D Panner 
This version of the 3D Panner offers an extended set of parameters for positioning an Audio 
Object, as described below.

TIP: Clicking the icon in the upper-right corner opens the 3D Panner plugin. 

For more information about the 3D Panner plugin, see Chapter 177, “Mixing in the 
Fairlight Page,” in the DaVinci Resolve Reference Manual.

3D Panner for an ASAF Object

	� Azimuth: Sets the horizontal angle (left to right) of the object around the listener, 
with a range of -180 ° to +180°.
This control is only visible when the channel’s Panner plugin in the Fairlight Mixer is 
set to 3D Spherical.

	� Elevation: Sets the vertical angle of the object above and below the listener (-90° to +90°).
This control is only visible when the channel’s Panner plugin in the Fairlight Mixer is 
set to 3D Spherical.

	� Radius: This is the distance between the object and the listener, from 0 to 10 meters 
in any direction.
This control is only visible when the channel’s Panner plugin in the Fairlight Mixer is set to 
3D Spherical.

This value, along with the Offset, is used by the ASAF renderer to simulate changes in 
distance by attenuating or raising the audio signal level. For example, an object set at 
1 meter away will play at unity gain, and at a distance of 10 meters, it will sound about 
20dB quieter.

When the Cartesian view is set on an ASAF Object, the Azimuth, Elevation, and Radius are 
replaced by X, Y, and Z parameters as described below:

X: Controls the Left/Right parameter of the Panner, with a range of -10m to +10m. 

Y: Controls the Front/Back parameter of the Panner, with a range of -10m to +10m.

Z: Controls the Down/UP parameter of the Panner, with a range of -10m to +10m.
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For more information about the Cartesian View, see Chapter 177 “Mixing in the 
Fairlight Page.”  in the DaVinci Resolve Reference Manual.

	� Width: Sets the object width, with a range of 0° to 180°.
	� Height: Sets the object height, with a range of 0° to 180°.
	� Directivity: Sets an object’s directivity pattern (radiation pattern), which defines how the 

audio is altered, depending on the orientation of the object relative to the listener. 
For example, if someone is speaking with their back turned to the listener, their voice will 
sound like a low-pass filter was applied to it.

	� Yaw: Sets the horizontal orientation of an object, with a range of -180 ° to +180°.
	� This setting will not affect an object when the Directivity parameter is bypassed.
	� Pitch: Sets the vertical orientation of an object, with a range of -90 ° to +90°.
	� This setting will not affect an object when the Directivity parameter is bypassed.
	� Follow Listener: When active, the object will face the listener, regardless of its location.
	� Headlock: When active, the position of an object remains fixed when the listener’s head 

moves. When Headlock is inactive, the perceived object location will change as the listener 
turns their head or moves.

NOTE: Headlock only affects binaural rendering. 

	� Externalize Binaural: This parameter is only available when Headlock is active.
	� When this parameter is active, HTRF will be used when the Binaural output is rendered, 

making the audio sound like it is outside of the listener’s head.
	� When Externalize Binaural is disabled, HTRF is not used in the rendering process, and the 

object will be panned between the listener’s ears.

Offsets 
The Radius Offset parameter adds up to 200 meters to the distance set by the Radius 
parameter in the 3D Panner. This control is only visible when the channel’s Panner plugin in the 
Fairlight mixer is set to 3D Spherical.

ASAF Objects – Offsets

If the 3D Panner is set to display the Cartesian View, this section will display the X, Y, and Z 
Offsets described below: 

	� X Offset: Sets the offset for the Left/Right parameter of the panner, 
with a range of -200 m to +200m.

	� Y Offset: Sets the offset for the Front/Back parameter of the panner, 
with a range of -200 m to +200m.

	� Z Offset: Sets the offset for the Down/UP parameter of the panner, 
with a range of -200m to +200m.
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Reverb
This reverb effect is activated by clicking the Reverb checkbox, located above the Mix control, 
which determines how much reverb is applied to the ASAF Object.

ASAF Objects – Reverb

NOTE: This Reverb section only affects ASAF Objects. 

Metadata
As an alternative to doing so in the Track Index, this section of the Audio Inspector lets you 
apply the correct metadata information to the object using the following settings:

	� Content Type: This dropdown menu lets you categorize the object as either Music and 
Effects or Interactive.

	� M & E Tag: If the content has been tagged as Music and Effects, you can use the 
options in this dropdown to further define the object—for example, Music, Effects, 
Dialogue, Narration, etc.

	� Interactivity: If the content was tagged as Interactive, you can select an option in this 
list to further define the object, such as Commentary or Audio Description.

	� Salience: Lets you assign a level of importance to the object audio to help the ASAF export 
encoder prioritize it in relation to other ASAF Objects in the project.

	� Language: You can use this dropdown to define the language for the content.
	� Post Reverb: When active, the object will be configured to allow Vision Pro to detect the 

room characteristics of the users’ listening environment and add a matching reverb setting 
to the audio.
Post Reverb is applied in addition to the reverb settings used by the ASAF Object Reverb 
mentioned above. However, it does not affect the output from the ASAF Renderer plugins.

 

ASAF Objects – Metadata 
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ASAF Channel Controls
The parameters listed below allow you to set the metadata for a Channel Bed:

	� Content Type: This dropdown menu lets you categorize the bed as either Music and 
Effects or Interactive.

	� M & E Tag: If the content has been tagged as Music and Effects, you can use the 
options in this dropdown to further define the bed—for example, Music, Effects, 
Dialogue, Narration, etc.

	� Interactivity: If the content was tagged as Interactive, you can select an option in this list to 
further define the bed, such as Commentary or Audio Description.

	� Salience: Lets you assign a level of importance to the audio.
	� Language: You can use this dropdown to define the language for the content.
	� Post Reverb: When active, the Channel Bed will be configured to allow Vision Pro to detect 

the room characteristics of the users’ listening environment and add a matching reverb 
setting to the audio.
Post Reverb does not affect the output from the ASAF Renderer plugins.

ASAF Channel – Metadata

ASAF Scene Controls

Gain 
When enabled by clicking the Gain Enable checkbox, this plugin increases or lowers the gain of 
the ASAF Scene based on the level set by the Gain control.

ASAF Scene – Gain Control 

Transform 
The Transform controls described below are used for making positional changes within an 
ASAF Scene.

ASAF Scene – Transform 
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	� Mirror Left/Right: Clicking this checkbox changes the positions of sounds, from left to right, 
by flipping the whole scene.

	� Mirror Up/Down: Filling in this checkbox inverts the vertical positioning of sound by 
vertically flipping the scene.

	� Mirror Front/Back: Clicking this checkbox results in a front-to-back flip of the entire scene, 
which reverses the spatial positions of sounds along the front–back axis.

	� Rotation Enable: Filling in the checkbox activates the Yaw, Pitch, and Roll parameters, and 
applies those settings based on their respective values.

	� Yaw: Turns the scene left or right around the vertical axis.
	� Pitch: Rotate the scene forwards or backwards around the horizontal axis.
	� Roll: Tilts or rolls the scene from side to side

Spatial Filter 

ASAF Scene – Spatial Filter

	� Enable: Clicking the Enable checkbox activates the plugin and modifies the scene 
according to the Base Gain and the settings in each of the four filters, which are controlled 
by their respective collection of filtering parameters:

	� Base Gain: Sets the overall gain applied by the plugin.
	� Filter Enable:  Activates the individual filter.
	� Filter Shape: Determines whether the spatial filtering shape is an ellipse or a rectangle.
	� Filter Azimuth: Sets the azimuth coordinate for the center of the individual spatial filter.
	� Filter Elevation: Sets the elevation coordinate for the center of the individual spatial filter.
	� Filter Width: Sets the width of the individual spatial filter shape in degrees.
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	� Filter Height: Sets the height of the individual spatial filter shape in degrees.
	� Filter Focal Gain: Sets the gain for the audio that lies within the individual filter’s 

spatial boundary.
This parameter is useful if you want to remove an undesirable sound coming from a specific 
location or direction. In this instance, you can set the filter’s position and spread controls to 
cover that area, and set the Base Gain to 1.0, and the Focal Gain to 0.0. 

Effects
Ambisonic-native Fairlight FX plugins, such as the Limiter, Channel Dynamics, and EQ, along 
with compatible Ambisonic-native third-party AU and VST effects.

Monitoring
Fairlight provides options that allow you to select the output monitoring source you want to 
hear, as well as the output format you want to hear it in.

To select the ASAF Master bus as your monitoring source, click the Bus Monitoring 
menu to the far right of the Transport control and select ASAF from the dropdown. 

ASAF Monitoring Source Selection

To select a monitoring format, click the dropdown next to the speaker output level 
control. You’ll notice various options, including  Binaural for monitoring on headphones.

Monitoring Output Format selection

Once you’ve selected a format, the corresponding decoder is automatically placed 
in the monitoring path, and the audio is routed to your Audio I/O and sent out to your 
speaker system.
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ASAF Binaural Monitoring with Head Tracking
If you’ve selected the Binaural option as your output format, you can also monitor your ASAF 
mix on headphones with support for Head Tracking for the full Apple Spatial Audio experience.

Enabling Head Tracking
Head tracking functionality can be activated by going to Preferences > Control Panels > 
Head Tracker. 

NOTE: Configuring these settings is only required when using a third-party head 
tracker, as opposed to compatible AirPods.  

Head Tracker preferences

This adds two buttons to the left of the Monitor Bus Source dropdown, immediately 
below the docked Video Monitor panel:

HT: Switches Head Tracking on and off.

CAL: Calibrates the current tracker direction as the “Front” or point of origin. This 
button is not required when using compatible AirPods and will not be visible, as the 
calibration happens automatically. 

Head Tracking Video Viewer Overlay
Binaural Head Tracking also lets you add an overlay to the video viewer for analyzing your mix 
against the picture, by clicking Headtracking Display > On, which adds an onscreen crosshair, 
indicating the current head (headphone) orientation. 

This submenu also includes a Show Torso option, which adds a head and torso to the 
video viewer that rotates as the head  tracking angles and positions change.

Head Tracking Video Viewer overlay 
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ASAF Metering Options

ASAF Loudness Standard
An Apple ASAF loudness standard is available for use in the Metering section of the Fairlight 
Monitoring Panel. To enable it, ensure this panel is viewable. If it is not, click the Meters button 
in the Interface toolbar, then select Apple ASAF from the  Loudness menu.

Selecting Apple ASAF from the Loudness menu in the Monitoring panel

Mixer and Track Header Meters 
Fairlight Ambisonic metering utilizes a single, composite bar-graph meter in the Mixer, Track 
header, and Meter panel. Unlike other audio formats, they don’t correlate to specific speaker 
positions or levels we would track visually to determine what is happening with the signal. 

Alternatively, you may want to use bar-graph meters that display Ambisonic signals as 
discrete, separate bus streams by choosing Fairlight > Immersive Audio > Ambisonics 
Channel Metering.  

Default Ambisonics metering (left) and 
Discrete Channel metering (right) 
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Monitoring Panel meters with Ambisonics Channel Metering enabled 

ASAF Rendering
Once you have set the Timeline Range you want to export, your ASAF mix can be exported 
as either an ASAF BWF or an APAC MP4 by going to the Fairlight menu > Immersive Audio > 
Export Master File, and selecting either Apple Spatial Audio Format BWF or Apple Spatial Audio 
Format MP4 from the Format dropdown, and clicking the Export button.

Space View
Space View is a 3D interactive workspace that lets you view your unmuted sound sources’ real-
time positions and automated movements.

You can open Space View by going to Fairlight > Immersive and selecting Space View.

NOTE: Only unmuted sources with a fader level greater than -70dB will be visible.

Space View Controls
The Space View offers the following control options, which, when used in conjunction with the 
track mute and solo buttons, offer very flexible options that let you focus on individual sources 
or groups of sources.

In the lower-right corner of the workspace, you’ll find four buttons that let you view your sound 
sources from different angles or perspectives.

You can freely rotate the workspace by holding down Command-Option-Shift while dragging it. 
If you want to get back to a default view, click one of the perspective buttons.
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Along the lower edge of the window, you’ll find the following checkboxes: 

Scene Mode: This dropdown is used for switching the Space View mode from Room to 
Spherical plane, as shown below.

Ambisonics Metering: This checkbox activates Ambisonics sonar-type metering when 
working on Ambisonic mixes.

Auto Zoom: When enabled, this function automatically zooms the view in or out, based 
on the overall proximity of the sound sources to the listening position depicted in the 
3D space.

Compact Meters: This option replaces the larger halo-style meters with 
smaller bar graphs.

Show Active Level Only: Clicking this option hides the names of silent sound sources.

Show Beds: This option reveals the labels and meters for ASAF Channel Beds that are 
feeding the ASAF Master. 

The options in the dropdown menu to the right of the checkboxes determine which 
objects appear in the virtual space:

Show Only Selected: Shows sources based on tracks you’ve selected in 
the Mixer or timeline.

Show Visible: Shows only the active audio sources for tracks that are not hidden.

Show All: All sound sources are visible and labeled. 

Room view of an Immersive Mix  
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Spherical Plane view of an Immersive Mix 

You can freely reposition sources in the 3D sound field according to your mouse 
movements (Left/Right and Forward/Backward):

•	 Holding down Command while moving your mouse forward and backward moves the 
sound source up and down in the sound field.

•	 Holding down Command while moving your mouse left and right moves the sound 
source left and right in the sound field.

All your changes can be automated (Touch and Pan) and saved. 

Half-Speed Timeline Playback
In addition to the other JKL keyboard shortcuts mentioned in Chapter 172, “Transport Controls, 
Timeline Navigation, and Markers,” Fairlight now supports half-speed playback via the key 
command Shift-K. 

Focus Mode Key Command
In addition to clicking the Focus Mode icon in the Fairlight toolbar, you can now use the key 
command W to switch the mouse cursor to Focus mode. 

For more information about the Fairlight Toolbar, see Chapter 170, “Using the Fairlight 
Page,” in the DaVinci Resolve Reference Manual
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AI Dialogue Matcher Control 
Applying a Dialogue Matcher Profile (Dialog Profile) to a Timeline clip adds a corresponding 
instance of the AI Dialogue Matcher to the Effects tab of the Inspector, with controls for 
adjusting the amount of Voice Isolation and a Dry/Wet mix control to help you match the 
ambient quality of the source material more accurately.

Dialog Matcher Controls in the Effects Inspector

For more information about the AI Dialogue Matcher, see Chapter 175, “ Editing Basics 
in the Fairlight Page,” in the DaVinci Resolve Reference Manual

32-bit Floating Point Recording
Fairlight now gives the ability to record 32-bit floating point audio. 

To enable this feature, go to Project Settings > Fairlight and place a check mark in the 
“Use 32-bit float recording” checkbox. 

Enabling 32-bit floating point recording
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Regenerate Timeline Clip Waveforms
If you find that the waveform is missing from a timeline clip, you recreate it by right-clicking the 
clip and selecting Clip Operations  > Regenerate Waveforms.

Clip contextual menu - Regnerate Waveforms

AI Audio Assistant Improvements
Applied Plugin View
AI Audio Assistant now gives you the option of switching between the default macro view and 
the full view of any plugin applied  during the mixing process by clicking the Change View 
button located to the right of the track name and effect slot number.

AI Audio Assistance Macro to Full UI View

Additional Improvements

•	 Increased speed of operation.

•	 Disabled tracks are now ignored during the mixing process.

Shift & Command Mixer Channel Selection
A collection of contiguous Mixer channels can now be selected by holding down the Shift key 
and clicking the channels at either end of the group.

You can select multiple non-contiguous channels by holding down the Command key while 
clicking each channel.
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Delete Audio Bus via Track Header
You can now delete busses by right-clicking the corresponding track header and selecting 
Delete Bus from the contextual menu. 

Granular Mouse-based Scrubbing
Holding down the Shift, Option, and Command keys while scrubbing with your mouse allows 
you to do so with more granularity. 

Miscellaneous Improvements
	� Audio waveforms are generated with greater accuracy while recording.
	� Quicker AI Audio Assistant analysis of shorter clips.
	� Fairlight Chain FX improvements 
	� Improved latency compensation.
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